Jump to content
EwinRacing Flash Series Gaming Chairs
svl7

Lenovo Y580 / Y480 'unlocked' BIOS versions

Recommended Posts

well dangit i dont even have a usb to use..my phone iphone wont let me use it as a usb drive at all....i just want to do this so i can use the dang card time now to hunt for a usb stik just to do use the card and maybe clock my memory to proper specs

USB drives are less than $10 and pretty handy to have.

Share this post


Link to post
Share on other sites

thank you svl7 I just installed the 8.01 bios and its working perfectly

Now I just need to figure out what all these options are for! :P

THANK YOU!

Share this post


Link to post
Share on other sites

Got my 104 error fixed, flashed like a pro. I still can't get my msata ssd in sata port 0 to be bootable(formats and stores data in windows 8 when booting off of HDD.) but in the very least I got numlock fixed. :D I bow to greatness.

Share this post


Link to post
Share on other sites

I have Bios 2.07 on my Lenovo y580, any idea how to unlock the Graphics card Clocks? :)

Share this post


Link to post
Share on other sites

Hi svl7,

I followed the instructions to the dot and now the computer is not booting up. I know that the bios works because the keyboard lights up and FN + spacebar key that controls the keyboard illumination works… I am not able to do anything else. I have tried an external monitor and resetting the cmos by removing all power and holding down the power button for 30 seconds. I am stuck and could really use your help.

Thanks,

Share this post


Link to post
Share on other sites
Hi svl7,

I followed the instructions to the dot and now the computer is not booting up. I know that the bios works because the keyboard lights up and FN + spacebar key that controls the keyboard illumination works… I am not able to do anything else. I have tried an external monitor and resetting the cmos by removing all power and holding down the power button for 30 seconds. I am stuck and could really use your help.

Thanks,

After about 50 attempts I was able to get the system to boot into dos and was able to restore the backup bios that I had created. For me the USB stick that was used had to be in the same USB port for the system to boot.

Share this post


Link to post
Share on other sites

I used FreeDOS to do the flash (prr.exe and fpt.exe) and surprisingly it worked fine. Also, the latest versions of Rufus already contain FreeDOS so no external files - it will just blank the drive, install freedos and then you can copy over the additional bios / flash files. Main plus of this method is no installs are required.

Also, holy crap I am not used to this many frames per second. It's almost uncomfortably smooth.

Share this post


Link to post
Share on other sites

Hello svl7,

Many thanks, Win 8 and 801 bios mod and working like a charm. Laptops are usually a let down in the bios but your mod makes my Y580 look like a desktop! I've read the entire thread and I'm being really cautious on changing anything. I wanted to mod for a reason I haven't seen. I just wanted to have higher fan speeds as I figured there was too much heat when gaming. Is there anything you know of that might cause trouble in the thermal settings?

Share this post


Link to post
Share on other sites
You can do it old-school and use a CD...

Well i dont know how to do that ..

Along with when i try to do a backup for my current bios of 8.01 it does not show up in the folder nor anywhere on my computer....

with the windows one at least..

unable to do the dos one because well i dont have a blank usb nor cd with dos bootable where i can put my own programs on it not that of stuff i dont know what it is....

Im not great at this just would like to use a 50 dollar peice of sillicon to get dual band that is all and clock memory...thats all icare for...not any software stuff pretty annoying that its a pain with everything i try to do

Share this post


Link to post
Share on other sites
Got my 104 error fixed, flashed like a pro. I still can't get my msata ssd in sata port 0 to be bootable(formats and stores data in windows 8 when booting off of HDD.) but in the very least I got numlock fixed. :D I bow to greatness.

You need to disconnect all storage cables except dvd/pendrive and ur ssd.

Share this post


Link to post
Share on other sites
First post revised, added modified v8.01 bios (unlocked, whitelist mod, 660m @ 1GHz core 3d :P).

Took me a while, but 'Error 28' when trying to flash is solved. Don't know what to do about 'Error 104' at the moment. I'm waiting for feedback, especially regarding the GPU mod.

All important things are described in the first post, I will here repeat the most important points:

Currently we can only flash the modified v8.01 BIOS, not the whole firmware image. Therefore I advise you to only flash the modified v8.01 when you're already on factory v8.01. While updating from 2.0x to the v8.01 might work, I can't guarantee success. The new bios comes with a different EC version, using the new bios with the old EC could lead to issues. If someone is going to test this, please keep us informed!!

In case Lenovo puts a new bios version on their support site, let me know. For 2.0x users I currently recommend only using the 2.0x mods. Once an official 8.0x update is available you can update to it and then flash the modified bios provided in the first post.

Bios flashed now, thanks a ton svl7! I now can use my 6205 and use my 5ghz N network. Works flawlessly.

Expect a beer soon for your hard work.

Share this post


Link to post
Share on other sites
Got my 104 error fixed, flashed like a pro. I still can't get my msata ssd in sata port 0 to be bootable(formats and stores data in windows 8 when booting off of HDD.) but in the very least I got numlock fixed. :D I bow to greatness.

I was able to do this in the original BIOS. All you need to do is under Boot you change Boot Mode from UEFI to Legacy Support. You also should change Boot Priority from UEFI First to Legacy First

- - - Updated - - -

svl7, any chance of an unlocked 2.07 BIOS with no whitelist for those still using Windows 7?

Svl7 already had this working a long time ago. Check the first post where it says ">> For users with a v2.0x BIOS: <<" Its very short and not half as complicated.

Share this post


Link to post
Share on other sites

Thanks for your work svl7 ! I'm so looking forward to flash it to use my 6300 card. By the way, could you please add a public link of the 8.01 bios? I still need several posts to download the attached file...

Share this post


Link to post
Share on other sites
svl7, any chance of an unlocked 2.07 BIOS with no whitelist for those still using Windows 7?

I need to fix the whitelist stuff in the 2.0x bios, there's one more thing I need to tweak. Will do when got my main system working again, my SSD died...

Bios flashed now, thanks a ton svl7! I now can use my 6205 and use my 5ghz N network. Works flawlessly.

Expect a beer soon for your hard work.

Sounds good, cheers! :D

Thanks for your work svl7 ! I'm so looking forward to flash it to use my 6300 card. By the way, could you please add a public link of the 8.01 bios? I still need several posts to download the attached file...

You're 'elite member', you have all the download rights already.

Share this post


Link to post
Share on other sites

Along with when i try to do a backup for my current bios of 8.01 it does not show up in the folder nor anywhere on my computer....

with the windows one at least..

unable to do the dos one because well i dont have a blank usb nor cd with dos bootable where i can put my own programs on it not that of stuff i dont know what it is....

You will need a USB drive or CD anyway, else you can't flash the BIOS. As for creating the backup with the Win tool, you need to run it in a cmd prompt with admin permissions, also some crappy AV software might block it's PCIe driver.

Is there anything you know of that might cause trouble in the thermal settings?

I don't think anything in the thermal settings will mess up, it might just not have any effect. But I don't have a Y580, I can't test anything myself.

After about 50 attempts I was able to get the system to boot into dos and was able to restore the backup bios that I had created. For me the USB stick that was used had to be in the same USB port for the system to boot.

Well, I'd say load the default settings in the stock bios, then do the whole procedure again (including backup, fixing etc).

Share this post


Link to post
Share on other sites

I found out that the Intel VGA BIOS in Y580 is outdated. I have a version 2137 but there's a new bios from January (version 2158) here with instructions how to install it. Is it possible to include this in modified bios?

Share this post


Link to post
Share on other sites

When I attempt to flash the V801Fix.rom file I get the following errors:

First in DOS I get:

PDR Region does not exist.

GBE REgion does not exist.

Then I get

Error 25: The host CPU does not have write access to the target flash area. To enable write access for this operation you must modify the descriptor settings to give host access to this region.

Share this post


Link to post
Share on other sites

First in DOS I get:

PDR Region does not exist.

GBE REgion does not exist.

Then I get

Error 25: The host CPU does not have write access to the target flash area. To enable write access for this operation you must modify the descriptor settings to give host access to this region.

The first two don't matter, and it's correct, those don't exist.

The second one however shouldn't occur. Run the tool with -i as parameter and post the output here. (I.e. run this and then post the content of the generated txt file):

fpt -i > info.txt

Share this post


Link to post
Share on other sites

I attempted to flash the v801fix.rom once again and i am running into the same bootup problems.

Here i the info from the info.txt file you requested:

Intel ® Flash Programming Tool. Version: 8.1.10.1286

Copyright © 2007 - 2012, Intel Corporation. All rights reserved.

Platform: Intel® HM76 Express Chipset

Reading HSFSTS register... Flash Descriptor: Valid

--- Flash Devices Found ---

EN25Q32B ID:0x1C3016 Size: 4096KB (32768Kb)

W25Q16BV ID:0xEF4015 Size: 2048KB (16384Kb)

--- Flash Image Information --

Signature: VALID

Number of Flash Components: 2

Component 1 - 4096KB (32768Kb)

Component 2 - 2048KB (16384Kb)

Regions:

Descriptor - Base: 0x000000, Limit: 0x000FFF

BIOS - Base: 0x180000, Limit: 0x5FFFFF

ME - Base: 0x001000, Limit: 0x17FFFF

GbE - Not present

PDR - Not present

Master Region Access:

CPU/BIOS - ID: 0x0000, Read: 0x0B, Write: 0x0A

ME - ID: 0x0000, Read: 0x0D, Write: 0x0C

GbE - ID: 0x0118, Read: 0x08, Write: 0x08

Total Accessable SPI Memory: 6144KB, Total Installed SPI Memory : 6144KB

FPT Operation Passed

Share this post


Link to post
Share on other sites

Does any1 have any ideas to overclock the 660m on 2.0x bios? Past the 135 mhz threshold? Thank you:)

Share this post


Link to post
Share on other sites

This is all okay, you have write access. Make sure you type the flash command correctly. Check the first post.

- - - Updated - - -

Does any1 have any ideas to overclock the 660m on 2.0x bios? Past the 135 mhz threshold? Thank you:)

I'll get to that once I have my main system is working again, will take a couple of days until I'm back to modding.

Share this post


Link to post
Share on other sites

Oh ok, thank you very much I didn't mean to trouble you. I thought it was something I could've done on my own without driving you up the wall:) Whether you get a fix out or not I hope ur system is up and running soon:)

I see that you have an m15x, I wanted to know if I do get it, is it easy (or do-able at least) to switch out the cpu and gpu?

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Similar Content

    • By Andrew2009
      Please could you check if it is possible to unlock my A17 BIOS? I have Alienware 17 R5(2013). 120 Ghz 3D. gtx 980 m. I want upgrade to 1070 but I have dark picture. Turns on but does not start with 1070. 980m-All good. What could it be?
    • By Aun
      I am trying to find unlocked bios for overclocking but i cannot find it from a few days please someone help in me. its for my alienware 17 r3 with 970m and i7 6700hq.
       
      my dumped gpu bios
       
      i would really appreciate your help!
       
      and btw rn i OCed thru msi after burner core clock +135 and memory clock +250.
       
      cpu gpuz pic
      gpu pic
       
    • By Klem
      In this thread you can post your requests for Lenovo G500 and G400 bios unlock.
      If someone wants upgrade Wi-Fi card and remove whitelist, or unlock hidden additional menus and settings in bios setup menu, then you can post your request in this thread.
       
      For prepare unlocked bios you should post your request here and then send me your file backup of bios via PM or upload it into any fileserver and send me the link.  For creating backup of bios use attached utility. Extract attached archive directly on the Desktop and run utility as Administrator (right click mouse, choice "Run as Administrator). Utility will create archive "results" directly on the Desktop. Send me this archive "results" via PM or upload it into any fileserver and send me the link.
      https://www.sendspace.com/file/mxoavw
      or
      http://www120.zippyshare.com/v/NC9WuxRI/file.html
    • By Klem
      In this thread you can post your requests for Lenovo G780.
      If someone wants upgrade Wi-Fi card and remove whitelist, or unlock hidden additional menus and settings in bios setup menu, in this case you can post your request in this thread.
       
      For prepare unlocked bios you can post your request in this thread, upload your file bios backup into any fileserver and post the download link. Or you can send me your file backup of bios via PM.  For creating backup of bios use attached utility. Extract attached archive directly on the Desktop and run Backup Utility as Administrator (right click mouse, choice "Run as Administrator"). Utility will create archive "results" directly on the Desktop. Send me this archive "results" via PM.
      https://www.sendspace.com/file/mxoavw
      or
      http://www120.zippyshare.com/v/NC9WuxRI/file.html
    • By Yomaster
      Hello, 
       
      some of my computer specs are as follows: 
      CPU: I9-9900k
      GPU: RTX 2070
      memory: 32 GB (forget the manufacturer/ clocks)
      Dsanke bios mod
       
       
       I recently bought a 1440p screen that is 120hz capable, but it does not allow me to select the 120hz option. I have checked numerous places and all of the websites say that this screen is 120hz enabled. I have the dsanke bios mod on my computer. I see people being able to use this screen's 120hz functionality, but I can't get it to work. Any suggestions? If you need any additional information about my laptop, I will be happy to provide info.
       
×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use. We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.