Jump to content

Lenovo Y400 / Y500 - unlocked BIOS / wlan whitelist mod


Recommended Posts

So like others how many posts or how many days do we have to wait to get promoted so we can download files. I know I just joined today ok. lol 

I am curious cause I need this bios so I can use my AC 7260 wifi card,

Edited by jgdiaz2167
Link to comment
Share on other sites

If you wanna get the downloads you need to watch the first message you receive it specifically says the following:


In summary:

  • New user account promotion system that views your level of quality activity on these forums over a span of 1 week with a minimum of 5 QUALITY posts. 
  • Once you have sufficient activity over this week, your account is flagged for moderator review. At that time you will get promoted as long as you had quality posts and didn't violate forum rules (e.g. spam posts, one liners, file begging, complaining etc.). Apart from a few odd members that break the aforementioned rules, almost everyone is guaranteed a promotion.
  • If you do not wish to wait for this promotion queue, you can simply opt for T|I Elite Membership to skip ahead and get your account promoted as long as the membership lasts. 
  • Attempting to circumvent the aforementioned rules may result in an infraction and/or ban. Please review our terms of service.
  • Thumbs Up 1
Link to comment
Share on other sites

svl7 - Awesome guide, I just unlocked my bios and I am now using my AC7260 wifi card!!!!! 

I sent you a small donation do you can buy a beer bro:  Confirmation number: 7FW44146E43741253

I was not able to flash my 650m video card, I keep getting an error that the bios name needs the proper extension even though the file has the proper .rom extension and I renamed the file 650m.rom so it is less than 8 characters. This is not a big deal as I do not intend to overclock the video cards.


Thanks for the excellent guide.

Link to comment
Share on other sites

Bummer about the wait, I guess it makes sense.

@Ex1Lee I am ssure that would not be allowed.

@jgdiaz2167 I am not sure, but weren`t you supposed to rename the rom file to be of 8 characters long? MS-DOS doesn`t work with file names larger.

Link to comment
Share on other sites

1 hour ago, crisdorya said:

Bummer about the wait, I guess it makes sense.

@Ex1Lee I am ssure that would not be allowed.

@jgdiaz2167 I am not sure, but weren`t you supposed to rename the rom file to be of 8 characters long? MS-DOS doesn`t work with file names larger.

No,  it  supposed to be less than 8 characters, dos will not recognize any names longer than 8 characters, it's an old dos limitation. I am an old dos expert which tells you that I am kinda old lol.

Link to comment
Share on other sites

FINALLYYY after a day and a half I got it to work. A couple notes to hopefully help along someone else:


  • Not all USB drives work, some just suck. I first tried a low budget thumb drive I had lying around and I could not boot into DOS via the drive, no matter what I tried. After that, I used another drive and it worked immediately. Go figure
  • For me, my computer would not boot past the Lenovo logo while the thumb drive was installed. I had to first boot into UEFI using F2, then when loaded I could insert the drive.


  • Though it may seem like common sense to most... the FPT_windows file should be used to make your backup(like the instructions suggest), but when you format the thumb drive per the directions, you have to remember that you formatted it for DOS so you need put the DOS version of FPT on your thumb drive. (dumb mistake I made and quickly fixed)
  • Additionally regarding the above: when you're using the DOS version of FPT(on your thumb drive), you'll need to grab the FPTparts file as well and if you had to use the special FPTparts file dealing with Error 104, don't forget to use that same FPTparts file on your thumb drive. (I'm assuming this matters, but feel free to correct me.
  • A step that's probably seen as common sense but not mentioned in the first post: once in UEFI bios and after inserting the thumb drive, you need to then navigate to the BOOT tab, change Boot Mode to Legacy Support, change Boot Priority to Legacy First, and make sure USB Boot is Enabled. After this you can hit F10 to save/exit and you will automatically boot into DOS on the thumb drive if everything went according to plan.


Much trial and error and hours of thinking I broke everything went into this process because some of the things mentioned above weren't mentioned in this thread. If most people know these things then COOL, I'm happy for you, but if not, I hope this can help someone who might be stuck and frustrated.




  • Thumbs Up 2
Link to comment
Share on other sites

Huge please help!
SLI is not included 650m.
Device Manager displays 2 vidiokarty.
Map 1 shows the Nvidiainspector Geforce 650m and all the features. 0 card only inscription Nvidea0.
The Nvidia Control Panel is displayed in the picture 2, but the list is only displayed near fiziks CPU and GF650 1.
Probyval different drivers when the transparencies or it does not turn on or freezes the control panel.
With the new driver 368.22 hangs when booting wines. on the "Welcome"
when loading all right without external cards.
Aida shows all the bios of 13 years, but the built-in card BIOS is normally writes 8/14/12 ?. firmware, and it was 2.02 and 2.04.
Bios sewn correctly. On the outside of the map sewn only under dos.
Nvflash of dos on the map №0 writes EEProm: Unknown, map №1 all as expected.
In theory, a built-in map works fine 3d mark 2006 13589 wrote balls.
Should Win 7x64.

Can anyone advise where to look and where to dig?
Link to comment
Share on other sites

I pierced from under DOS. Sew normal errors not write. (Probyval firmware 33, 3A, 3Aos, 33 ° C) where you can take the original bios?
If ultrabey pull the card is displayed in the Manager, only one card.
The maps show a different IRQ 16 and 17 for the second in the Device Manager.
In the nvidia control panel writes to one of the cards: IRQ: not used Bus: is not defined and zeros.
On older dryverah tries to turn and resets If still in Off. On the new 368.22 after installation and reboots the computer freezes at startup to "welcome." If you remove the card is loaded properly and running 3D mark.
Link to comment
Share on other sites

  • 2 weeks later...

Hey svl7,


I have a 650m SLI y500 and i wanted to know if it can use the same Bios fixer 2.0 that says the following (within the utility) to modify a fpt dump of my v2.02 bios?


Lenovo Y400 / Y500
 For BIOS version v2.04
 >> Drop your backup file here <<


It says including update for 2.02 & 2.03 users in the file name but i don't see separate bios fixers saying for v2.02 or v2.03.

Can the same be used? I actually made a mod of 2.02 with the v2.04 utility and flashed it without error. Now i want to know if i can proceed with using nvflash to flash the 650m ultrabay overclock mod (coz you mentioned ultrabay mod works only for v2.02 bios)?? Kindly reply as soon as you get time.


Thanks a lot,



UPDATE: Never mind...i grew impatient and tried it anyways...works fine.

Edited by jacobspeeds
Link to comment
Share on other sites

This video helped a lot, it goes in conjuction with what xxxdc5 mentioned about certain steps not being clear on the instructions page



as for the files, i was able to find a few links to those files individually on the some Asus and tech Chinese forums but was hesitant to try. Someone else can try them and report back here.

Link to comment
Share on other sites

I did not see that backup.bat either, but I managed to backup my bios by using the Dos version. 


BTW, does anyone have control on the fan speed on y400 after unlocking bios? I unlocked mine and set fan speed to 100%, but still could not make it run at full speed.

Link to comment
Share on other sites

Updated my Lenovo Y500 to the 2.04 mod. Installed a new WLAN Card AC7260.

Now i can't wake notebook from hibernate. Mouse move doesn't work. Pressing a key doesn't work.

Only by pressing the Power Button the notebook wakes up.

Is there somebody else with this problem?

Maybe the bios settings are wrong?

No matter what OS is installed. Fresh Windows 8.1 not working. Fresh Windows 10 not working.

So i Thing the problem is in the bios.

With old original 2.04 wake up from hibernate is working, but not from S5.

Any idea?

Link to comment
Share on other sites

On 6/21/2016 at 9:55 AM, Iron Lungs ☺ said:

I dont even have backup.BAT appearing :(


Whats the cause of that? 

if you use FTP64 make batch file with following command


FPTW64.exe -d biosbackup.bin -bios


or shift + right click on FPTw64 folder select Open command window here and use the same command

Link to comment
Share on other sites

After having a couple issues with my hard-drive this week, I wanted to see if i could upgrade my WiFi card. Doing a bit of googling, I find out about this bios white list. Of course I immediately check to see if there are workarounds and I find this site. So just want to thank svl7 for this topic, at this point I'm just waiting for the promotion system. I'm planning on getting the Intel AC 7260, however I'm just waiting to make sure I can modify the bios first.

Edited by DjSpammer
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...

Important Information

By using this site, you agree to our Terms of Use. We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.