Jump to content
EwinRacing Flash Series Gaming Chairs
svl7

Lenovo Y400 / Y500 - unlocked BIOS / wlan whitelist mod

Recommended Posts

:D Nice, just wanted to have a visual confirmation that all is there as intended, hehehe, did you notice the voltage slider? Use with care.

Cheers!

Share this post


Link to post
Share on other sites

Updated worked with ez but its showing 2.04 for bios verison and the ec verison showing 2.02 is thats normal right? Thanks again

Share this post


Link to post
Share on other sites

Hi,

My update went fine too (just flashed the latest, corrected v2.04 modded BIOS).

However, similar to another user a few pages back, I cannot flash version 80.07.9D.00.11 on my ultrabay GT750M card, using the latest nvflash utilities (either DOS or Windows).

It keeps saying 'ERROR: PCI Block corrupted - size mismatch'

The previous version 80.07.95.00.17 flashes just fine.

Seems quite weird to me, but not really a problem as the ultrabay card is functioning fine as it is (MODIFIED).

Greetings,

Auke

:D Nice, just wanted to have a visual confirmation that all is there as intended, hehehe, did you notice the voltage slider? Use with care.

Cheers!

Share this post


Link to post
Share on other sites
:D Nice, just wanted to have a visual confirmation that all is there as intended, hehehe, did you notice the voltage slider? Use with care.

Cheers!

Oh wow, so software overvolting can be done with the 2.04 BIOS? I'll flash it right away :P.

I can flash 2.04 from a modded 2.02 bios as long as I use the stock/official 2.02 backup to create the rom, right? Also, is this for 650m users?

***EDIT***

I can confirm that it works. Used the automated tool on the first page to flash the official bios version, then upgraded to 2.04 using the included mod tool. I can also confirm that you can use software to change the voltage! Awesome stuff svl7!

Share this post


Link to post
Share on other sites

Nice work svl7!

So is the addition of software voltage control the only difference between the 2.04 mod and previous versions, or are there other changes? How would someone with SLI unlock voltage control on the second GPU?

Now I'm just waiting for some overzealous individual turn the voltage slider to maximum and blow up their laptop LOL. As our favorite web-slinger used to say, with great power comes great responsibility​. :)

Also, for those who've already flashed, did you upgrade to 2.04 directly from 2.02 modded or did you have to flash back to 2.02 official first using either your backup or the leaked InsydeFlash? Did upgrading to 2.04 also update the EC version to 2.04, or is it still at 2.02? Is there any harm to having mismatched BIOS version and EC version?

Share this post


Link to post
Share on other sites
Nice work svl7!

So is the addition of software voltage control the only difference between the 2.04 mod and previous versions, or are there other changes? How would someone with SLI unlock voltage control on the second GPU?

Now I'm just waiting for some overzealous individual turn the voltage slider to maximum and blow up their laptop LOL. As our favorite web-slinger used to say, with great power comes great responsibility​. :)

Also, for those who've already flashed, did you upgrade to 2.04 directly from 2.02 modded or did you have to flash back to 2.02 official first using either your backup or the leaked InsydeFlash? Did upgrading to 2.04 also update the EC version to 2.04, or is it still at 2.02? Is there any harm to having mismatched BIOS version and EC version?

I flashed to the official 2.02 version using the easy flash tool included with the 2.02 file linked on the first page, then to 2.04 from that.

And as far as blowing up the laptop is concerned, nvidia inspector and .bat files are a bit clunky to use, but it seems that there's a real cap on the voltage level in the slider, and in what the system will allow th gpu to run at. Setting it above 1.15 volts results in the gpu being knocked down to 1.15v when on full load, no matter what. I'd attempt to see if there's a way to get around that limit, but messing with inspector and .bat files too much seems to result in the core cluck going up without the voltage increasing, rapidly sending the gpu into "good night" mode :P. I can't use msi afterburner to change the voltage either.

Share this post


Link to post
Share on other sites
Nice work svl7!

So is the addition of software voltage control the only difference between the 2.04 mod and previous versions, or are there other changes? How would someone with SLI unlock voltage control on the second GPU?

Now I'm just waiting for some overzealous individual turn the voltage slider to maximum and blow up their laptop LOL. As our favorite web-slinger used to say, with great power comes great responsibility​. :)

Also, for those who've already flashed, did you upgrade to 2.04 directly from 2.02 modded or did you have to flash back to 2.02 official first using either your backup or the leaked InsydeFlash? Did upgrading to 2.04 also update the EC version to 2.04, or is it still at 2.02? Is there any harm to having mismatched BIOS version and EC version?

You can extract the VBIOS from the BIOS using Phoenix Tool. The VBIOS is 152-159KB in size.

Flash the extracted VBIOS ;) Works flawlessly for me :)

If you want I can just upload them for you.

Share this post


Link to post
Share on other sites
I know 1.15v is a limit I reported before on my VBIOS mods. I am still looking to fix that.

Actually, I did some more fiddling arounf with .bat files, and now I can get the voltage to go up to 1.2v, constant P0 state. It absolutely will not go any higher than that using .bat files. Maybe the slider will let you inch it up a bit more... I dunno. I can only get the overclocks to work correctly when I use either the .bat or the sliders in nvidia inspector. Touching both of them always causes problems, lol.

Share this post


Link to post
Share on other sites

You mean to flash the ultrabay card?

You can extract the VBIOS from the BIOS using Phoenix Tool. The VBIOS is 152-159KB in size.

Flash the extracted VBIOS ;) Works flawlessly for me :)

If you want I can just upload them for you.

Share this post


Link to post
Share on other sites

Added the revised vbios to the first post, if you're an SLI user on the latest 2.04 mod I recommend flashing it.

  • Thumbs Up 1

Share this post


Link to post
Share on other sites

Hello threadnaught! And well uh. It appears I can't hit enter to start a new paragraph. OH WELL! I'm new to the forums and this is gonna look weird without any formatting so I'll try to keep it short and sweet. I have a Y500 with a single 650M and I'm interested in unlocking the BIOS for OC'ing or replacing this poop non dual band wireless card. I'm ALSO interested in getting a 650M Ultrabay, but I'm not even sure where to get those anymore. Quick question though. I've got Windows 7 installed on this Y500. Windows 8 is fine by me, but the guy I bought the laptop from disagreed haha. I noticed that in the instructions for flashing the BIOS, you mention that it contains the Windows 8 licenses, key, etc. I'm thinking this should still stay the same for Windows 7? It's a legitimate copy, and I'm just wondering if I can still used the BIOS files even with Windows 7. Thank you for any advice. Apologies for the Berlin wall of text.

Share this post


Link to post
Share on other sites
Added the revised vbios to the first post, if you're an SLI user on the latest 2.04 mod I recommend flashing it.

whats the difference

Share this post


Link to post
Share on other sites
Hello threadnaught! And well uh. It appears I can't hit enter to start a new paragraph. OH WELL! I'm new to the forums and this is gonna look weird without any formatting so I'll try to keep it short and sweet. I have a Y500 with a single 650M and I'm interested in unlocking the BIOS for OC'ing or replacing this poop non dual band wireless card. I'm ALSO interested in getting a 650M Ultrabay, but I'm not even sure where to get those anymore. Quick question though. I've got Windows 7 installed on this Y500. Windows 8 is fine by me, but the guy I bought the laptop from disagreed haha. I noticed that in the instructions for flashing the BIOS, you mention that it contains the Windows 8 licenses, key, etc. I'm thinking this should still stay the same for Windows 7? It's a legitimate copy, and I'm just wondering if I can still used the BIOS files even with Windows 7. Thank you for any advice. Apologies for the Berlin wall of text.

First please Enters a couple of times, that will help to read it.

But second Its no problem just follow the instructions and it will be fine ;)

Good luck!!

Share this post


Link to post
Share on other sites
Added the revised vbios to the first post, if you're an SLI user on the latest 2.04 mod I recommend flashing it.

Just tried to flash my 750m ultrabay and I keep getting this error any ideas this was on the newest nvflash on windows.. If I go thought dos I get error a newer version of nvflash is required.

Identifying EEPROM...

EEPROM ID (C2,2012) : MX MX25L2005 2.7-3.6V 2048Kx1S, page

ERROR: PCI Block corrupted - size mismatch

Share this post


Link to post
Share on other sites
Added the revised vbios to the first post, if you're an SLI user on the latest 2.04 mod I recommend flashing it.

Thanks! So I'm assuming this adds software voltage control to the Ultrabay GPU?

It's 90-100F every day here right now so I'll have to wait until winter to try my hand at overvolting, but this will definitely come in handy.

Just tried to flash my 750m ultrabay and I keep getting this error any ideas this was on the newest nvflash on windows.. If I go thought dos I get error a newer version of nvflash is required.

Identifying EEPROM...

EEPROM ID (C2,2012) : MX MX25L2005 2.7-3.6V 2048Kx1S, page

ERROR: PCI Block corrupted - size mismatch

Are you sure you have the latest version of DOS NVFLASH?

Share this post


Link to post
Share on other sites

Hm.

Like vito357si, I also get this error while trying to flash the ultrabay GT750M card:

ERROR: PCI Block corrupted - size mismatch

Have tried with both the latest versions of nvflash for DOS and Windows (v5.136 and v5.142 respectively).

The previous FW (80.07.95.00.17 - OC) flashes without problems, the new one does not :(

Greetings,

Auke

Added the revised vbios to the first post, if you're an SLI user on the latest 2.04 mod I recommend flashing it.

Share this post


Link to post
Share on other sites

Thank you sir! Yeah I've tried hitting enter, shift+enter, and even going to advanced reply but for whatever reason the cursor won't move. My formatting is destined to SUCK. Hmm, maybe its the browser. I'll switch that up. ANYway thanks again, might sound like a noobish question but I haven't flashed a BIOS before so I wanna cover all bases before ah, the main event. This is a great resource here, I'll be sure to post around! hopefully with more paragraph breaks :)

Share this post


Link to post
Share on other sites

Urm, I have a stock bios backup and when i flash it (similar how i flash the mod bios) the nvidia inspector still showed XX.XXX.XXX [MODIFIED] is there a work-around for this? or I need other bios tools to flash it? Because I need to send back to the service center for speaker repairs.

Thanks in Advance.

Share this post


Link to post
Share on other sites
Hm.

Like vito357si, I also get this error while trying to flash the ultrabay GT750M card:

ERROR: PCI Block corrupted - size mismatch

Have tried with both the latest versions of nvflash for DOS and Windows (v5.136 and v5.142 respectively).

The previous FW (80.07.95.00.17 - OC) flashes without problems, the new one does not :(

Not sure what's wrong, I'll take a look at it. You can try to force the flash with using -4 -5 -6, might allow you to flash.

Urm, I have a stock bios backup and when i flash it (similar how i flash the mod bios) the nvidia inspector still showed XX.XXX.XXX [MODIFIED] is there a work-around for this? or I need other bios tools to flash it? Because I need to send back to the service center for speaker repairs.

Reset your bios, go to the bios and load the default settings, if this doesn't help remove the coin cell battery if there's one.

  • Thumbs Up 1

Share this post


Link to post
Share on other sites

Load default settings doesn't help. guess left the remove coin cell option. (Just check n1smo pictures, I don't think I'm able to find CMOS battery in this unit). Should i flash the stock v2.02 provided on the OP?

Share this post


Link to post
Share on other sites

Hi,

Already tried that. The results is always the same I'm afraid...

Not sure what's wrong, I'll take a look at it. You can try to force the flash with using -4 -5 -6, might allow you to flash.

Reset your bios, go to the bios and load the default settings, if this doesn't help remove the coin cell battery if there's one.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Similar Content

    • By PepoJ
      Hello there!
      I am new on the forum. I'd need some help. I own a lenovo ideacentre t540-icb g, and i would need to unlock all the options in my bios, especially overclocking and thermal configuration. I tried with both amibcp and mmtool, but i didn't succeed (Error 18).
      I wonder if you could help me or give me some advice.
      Thanks in advance.
    • By thinkdad
      Hi,
       
      I need help in fixing my Thinkpad.

      I just got a T440p yesterday. It was working perfectly until the following:

      I reinstalled Windows and then I installed Vantage.

      I installed all the latest drivers.
      I also choose to install the bios update. The bios update ran in Windows and it asked me to restart. After restarting, the screen was blank. I tried powering it off and on and I saw the Thinkpad logo but after that the screen was blank.

      I tried powering on and off again and there's no Thinkpad logo now and the screen is just blank with the green power on. No sound, no nothing.


      Here's what I tried:
      Pressing the power button 10 times and then holding it for 30 seconds. Unplugged and battery is detachted Detached the CMOS battery and the reattached it Removed the ram, harddisk and optical disk drive. Attached the battery and inserted the charger. I turned it on and there was a couple of beeps Tried pressing FN+R and created a bootable USB I'd like to ask: How do I fix this? What do I need to do?
      Can I reflash the bios in some other way? Do I need to buy a new motherboard? Will this solve the issue? It's my first thinkpad and I'm really excited but I was bummed out that this happened. Can you please help me?

      Thanks in advance!
    • By pippocarlot
      Hello everyone! I am looking for an answer to a problem I cannot find a solution to ... I purchased an Amd wx 4150 MXM GPU module su e bay to upgrade my HP 8570W Mobile Workstation which is currently equipped with a Fire Pro M4000. Once the new GPU has been installed, the PC screen no longer turns on but works only with external monitors connected via the docking station. The same happens once the drivers are updated! If I put the old card back on, the integrated monitor starts working again ... How can I fix it?
    • By Swick1981
      Bios Release Version – v2.0.0
       

       
      Updated or Modded Items:
      A11 UNLOCKED BIOS FOR m18Xr2 (UNLOCKED BY SVL7 AND FULL CREDIT GOES TO HIM FOR UNLOCKING!)
      SVL7 Also created the PRR2.EXE tool that allows you to flash the new bios by unlocking it.  (FULL CREDIT GOES TO HIM FOR THAT FILE PRR2.EXE)
       
      Here are ALL the things I've added, modded, and enhanced on this bios -
      I've added FULL LEGACY SUPPORT ON THIS BIOS with ONE or TWO CARDS (SLI).  You can FINALLY use Win 7 OS on your machine and run the 900 series GPU's! 
      This is a MAJOR breakthrough!
       
      LEGACY SUPPORT Confirmed.  Works with 900 series GPu's in single OR SLI formation Updated the Intel RST Legacy to v12.9.0.2006 (Supports TRIM in RAID0 - CONFIRMED) Updated Intel RST UEFI to v12.9.0.2006 (Supports TRIM in RAID0 - CONFIRMED) Updated the ONBOARD Video Card for the HD3xxx to v2171 - FROM v2132 Updated ONBOARD Video Card for the HD4xxx to v2171 - FROM v2132 Updated the LAN Firmware & PXE Boot from 2.0.5.9 to v2.0.6.6 ADDED NvMe Support for m18xr2 ADDED M.2 support for m18xr2 Updated CPU Microcode to v29 for the 2900 CPU's Updated CPU Microcode to v1c for the 3900 CPU's Updated GOP Driver for Intel Sandy Bridge CPU Updated GOP Driver for Intel Ivy Bridge CPU Updated MAIN GOP Policy module for the m18xR2 Eliminated some code that wasn't used in the m18xR2 Updated CSM Module (v2) Streamline some coding to make mod(s) run a little more efficiently (v2) Added FPARTS.TXT to rar file in v2. (I had forgot to add it in v1) v2.5 to be released shortly.  I've updated a few more modules that I didn't realize could be updated.  (It's only 3 modules, but it's still an update!)   It should be released in about a week.  Hope this helps ya'll!  
      Instructions to flash:
      Use a flash drive to create a boot disk into dos Unzip ALL files into the root of the flash drive (flash.bat, r2final.bin, fpt.exe, flash.bat, prr2.exe, fparts.txt,m18r2.hdr, m18r2.hdr.bin, readmefirst.txt) BOOT INTO DOS – Note, that when you set the bios to legacy in order to boot into dos, you MAY have to reinstall OS!  (Just be prepared to reinstall no matter what) Once you boot into dos, run the file flash.bat It will unlock your bios (THANKS TO SVL7’s BIOS UNLOCKING TOOL – ALL CREDIT TO HIM FOR THIS TOOL!) Let it flash… Reboot your pc, and enjoy the MASSIVE updates!  
      Be on the lookout as I do plan to release newer version with more updates in the future.  However, it wont be for at least a few weeks as I'm now working on legacy support for the m17xR4 and several other systems.  So please be patient!
       
      ENJOY!
       
      Thread link for more information and discussion:
       
×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use. We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.