Jump to content

Recommended Posts

I don't think it will run on high settings, maybe medium settings max. Besides that, I don't think I even want to play that game on a small laptop haha :)

Share this post


Link to post
Share on other sites

BF4 on my laptop runs on High in campaign, its only stuttered and had FPS drops afew times. Online I have to play on Medium though.

Share this post


Link to post
Share on other sites

bf4 runs on my m14xr2 pretty well on med to semi high settings i normally set to med - medlow for competition

Share this post


Link to post
Share on other sites

i run bf4 on my laptop normally low to med low it can run higher but for comp purposes i dont bother

Share this post


Link to post
Share on other sites

anyone got trouble with m14x when full of dust got poor performance ( when cleaned back to normal )?

Share this post


Link to post
Share on other sites

I was running Rage and BF4 on my m14x but just did an upgrade to SSD and my Nvidia card wasn't being read upon initial fresh install of windows..Is working now, but getting Sata2 speeds and won't install games until I fix that first.

Share this post


Link to post
Share on other sites

Hey guys just picked up a m14xR1 and upgraded motherboard to a m14xR2... I have come from a m18xR2 and miss my extreme cpu. Wondering what a 3920xm or 3940xm will run like in it or am I wasting my money?

Sent from my SM-P600 using Tapatalk

Share this post


Link to post
Share on other sites
anyone got trouble with m14x when full of dust got poor performance ( when cleaned back to normal )?

Any computer/laptop is going to suffer performance problems if they get full of dust. The systems are designed to "throttle down" the CPU/GPU speed as the temperature rises (and hits a certain threshold). You should be cleaning your computer systems on a regular basis, especially a gaming rig, as the fans will normally run high and the system will run fairly warm. A regular cleaning with compressed air and occasional repasting will help your system run cooler and last longer.

Share this post


Link to post
Share on other sites

i wanna know as well if better processor will improove game performance.

Share this post


Link to post
Share on other sites
Nope, gpu plays a major part, not the cpu

And keeping the Nvidia drivers updated. :)

Share this post


Link to post
Share on other sites
I don't know how you can run crysis 3 on max settings with 30fps.

I have i7 2,20 GHZ , Nvidia GT555M 3GB and standard lcd 1366x768 and even if i overclock (without vmods just afterburner and standard bios) i get 15 fps avarage.(anti-aliasing - off)

I'm wondering the same thing. I play Starcraft II and I get low fps when the game gets intense. My Nvidia driver is up to date too.

Share this post


Link to post
Share on other sites

Currently having a lot of troubles with this "gaming" laptop. Doing research I found out many problems with this model, including the 67ºC GPU throttling which is a pain in the ass. Cant even play CSGO on lowest settings.

Share this post


Link to post
Share on other sites
And keeping the Nvidia drivers updated. :)

Not always the case. I have had few nvidia drivers over time where it has decreased fps in games such as csgo, league of legends.

Share this post


Link to post
Share on other sites

The latest version on my Nvidia GTX 765m card (344.48) is really making it glitchy, going back to Dell's Recommended 331.65 Driver.

Share this post


Link to post
Share on other sites

I went through all the drivers starting from 331.65 in order and got to 344.11 while still having everything work. The next update after this makes my graphics scrambled again. So far run all day without any issues.

Share this post


Link to post
Share on other sites

Anyone playing overwatch on m14x R1? I connect mine to a 1080p screen and could only get average of 25 fps. If any of you could get above 30 fps, what are your setting and did you guys OC?

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Similar Content

    • By learnfromit
      alienware 15 r2 970m with i7-6700hq vbios request so i can overclock and mess with voltage.

      BIOS version backup made with techpowerup GPU-z.

      GM204.rom
       
      or can someone re direct me to one already made that will work? all links i find are dead, thanks.

    • By Terriikk
      Hey guys, I have an Alienware m14x R2, and I have been trying to get access to the BIOS so that I can change the boot options (Everything is locked, I am unsure if someone set a password of if these are locked by default).I've tried updating the BIOS, and resetting the CMOS and nothing has changed this. Would anyone know if there are other options I can explore? Thank you. 
    • By danger007
      Well I am back, sort of.
       
      Reminder of Stats
      *Alienware M17x R4 (bought June 2012) w/ Intel i7 3720QM@2.6ghz (Ivy Bridge) including the igpu Intel 4000 HD series
      8GB Ram, 17 Inch, SoundBlaster software only Recon 3DI, and the normal stuff that comes with it
      *Graphics Card:  Originally shipped 660m, upgraded to 7970m, 7970m died early, with community help moved to MSI 4GB 680M (flashed to Dell thanks to @svl7) and installed I think 314.xx drivers with help from many (sorry can't remember everyone but notable was @J95), was running 7970m in whatever they called their hybrid drivers, the 680m is run in Optimus)
      *OS:  Windows 7 64bit Service Pack 1
      *Storage:  Msata 1tb Samsung 850 Evo, 2 Hitachi 1TB 7200 rpm 2.5" drives (yes I used all 3 GB or will)
       
      So what will you read.  What got me started on this project and then using all the resources on the net, from @J95 and legions of others I owe all credit for the project too.  Please note I take no credit, take no rights, this is simply something to help others out based on working with what has already been laid down for us.   Installing the latest Nvidia 417.67 mobile/notebook drivers for a 680m for Windows 7 Service Pack 1 on Alienware M17x R4
       
      When I got things up and running back in 2016/2017 with the noted people above I saw a new driver and with the STO game having a driver issue I upgraded to it.  Now I didn't notice anything wrong, the game worked and so paid no attention.  When I started to get unable to eject 680m error messages I thought great who got this, ejecting a gpu, wrong.  I then tried the uninstall Intel, Nvidia, use DDU in Safe Mode, disable AV/Firewall, disable driver enforcement, etc then reinstall intel, nvidia (removing certain folders) with the modified inf but now the game said it couldn't find any feature set and wouldn't let me play.  Finally removing the Nvidia drivers allowed at least the iGPU to run the game.  Used Unigine Heaven 4.0 to encounter more errors with Nvidia.
       
      I moved back to my msata install of windows 7 that I haven't had a chance to work on since 2017 (i know pathetic) that only had system drivers, expired Norton, and not yet registered/activation.  Seems fine.  Tried to run Heaven, same error.  Well after 3 days of trying to duplicate what I had been instructed to do, I finally sat down with a nice big bottle of Fiji Water (courtesy of lovely lady at the Oscars in almost every background pic) and decided I was determined to fix things.   I downloaded the 419.67, copied the nv_dispi.inf & nvdmi.inf to get to work.  After reading the content and using comparisons once again from the noted individuals and the legions of other, I had them modified and decided to give it a try on the clean win 7 install from 2 years ago.  After the uninstall, ddu, deleting folders, copying mod. inf to their directory (also included the change to setup.cfg - credit once again goes to individuals like @J95), gyrxiur, DeathAngel , creator of Notepad++, sora and many others) I was able to launch the Heaven 4.0 Benchmark.  So I am assuming that I have the new 419.67 working on my system.  I did a benchmark of the 680m in 419.67 with unigine Heaven 4 to go with the files I am posting.  Please note the bios was provided by I believe @svl7 (sorry if I got wrong person) and no overclocking of it other than what the changed vbios did.
       
      I am attaching below the following:
      Nvidia 419.67 modified inf and config - nvdmi.inf, nv_dispi.inf, setup.cfg (no credit to me all credit belongs to others)
      The Unigine benchmark results (txt file).
       
      Now the shortened legalize warning
      Please remember you are to take all risk when using modified inf files, I take no responsibility (no virus or other dildrus included) if they don't work with your GPU.  The usual.
       
      This was tested and used on Alienware M17x R4 running the last bios they released A12 or A13 and so it the system bios is not modified at all, the card is a MSI 680m 4Gb flashed vbios to Dell 680m 4GB, and installed in Windows 7 64bit Service Pack 1.  Hopefully if you have only a different card you can make any minor adjustments you need to.  
       
      Please let me know how they work.  I will also be reporting back on the reinstall on my other laptop install I use to play Neverwinter/ Star Trek Online - was suppose to be a temp solution till new install was finished, and if they worked on it as well.
      Alienware M17x R4 680m 419.67 Mod Inf and Setup and Heaven 4 Benchmark.zip
    • By Edrc
      Hello,
       
      I am new on this forum, so I am sorry if posting at the wrong place. It's been 2 weeks that I am searching how to make my GTX 980M 8GB working Inside my Alienware 17 R1 (June 2014, i7 4710MQ, 60 Herts Display, OPTIMUS and the GTX 880M Inside died.)
      After "quickly" looking some forums, I saw that a 980M would easily fit Inside … but maybe I was wrong.
       
      Hardware wasn't a problem. I've also could install drivers by modding the nvdmi or nvcvi. inf files. The card was recognied BUT :
      the clock speed is locked a 135 or 405 Mherts and fan is not runing when booted up.
      I tried to flash vBios with nvflash and some ROM I found on vBios collection … but no way to get this working properly.
       
      So, i'm coming here. I've seen many people talking about Prema or svl7 or other big boss in the place … but ? how ? where ? when ?
       
      Inside the peripherial manager I have this in remote acces path : PCI\VEN_10DE&DEV_1617&SUBSYS_05AA1028&REV_A1\4&D590A51&0&0008
      So I assume my GTX 980M card ID is 1617 and vendor and PC Model are 05AA 1028.
      But near the "Standard Microsoft Video Card" there is a yellow exclamation point and Inside details it says "this peripherial doesn't work properly" when no Nvidia drivers installed.
      I could find some vBios with 1617 (Asus) but black screen at boot up. Since laptop model where not the same .. probably.
      And I wasn't able to find 1617 with the existing 05AA 1028 … as the GTX 980M was not an option for my model. (AW 17 R1 2014 ,60Herts)
      I tried 353.60, 382.33 and 419.35 drivers. The latest one seems easier to install but longer.
       
      BIOS is A16 from Dell. And I am using Windows 10. Got a Dell 330W brick. 
       
      I saw a guy with the exact model as me, he gets a modded vBios especially for his configuration, then everything worked easily … but can't find the topic again
       
      I guess depending on the card info and the laptop model … a dedicated vBios is required … 
       
      So, If anyone here got some informations or any kind of help for me, it would be very nice.
       
      Thanks for reading and help.  
       
      PS: there are a lot of files, pictures and links that I can't see on this forum .. even after registration …. 
       
    • By Sleezy
      Troubleshooting Modified driver Installation. If you are able to successfully modify the .inf to install GPU driver but games still using dedicated graphics or crashing, this is how I got it to work. Also link to the instructions I used to modify the .inf (Credit to Yuki Rea Founder and Creator of null-src.com) That tutorial can be found here https://null-src.com/posts/nvidia-notebook-driver-inf-mod/post.php
       
       

      Soapbox - Gaming Laptop GPU Upgrade
×

Important Information

By using this site, you agree to our Terms of Use. We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.