Jump to content
svl7

Lenovo Y400 / Y500 - unlocked BIOS / wlan whitelist mod

Recommended Posts

svl7 awesome guide !! cant thank yu enough :):20_003::78:

could yu please tell me wat are the options in the bios tht has to be changed for enabling intel HD 4000 graphics ?

  • Thumbs Up 1

Share this post


Link to post
Share on other sites

im a bit confused about the bios versions.... Is v1.5 the same as v1.05 and v1.3 the same as v1.03?

Btw, great job Svl7

  • Thumbs Up 1

Share this post


Link to post
Share on other sites

I never called the bios v1.5 or v1.3 as far as I know... in the bios itself it says 1.05v, where did you see 1.5v?

  • Thumbs Up 1

Share this post


Link to post
Share on other sites

Earlier in the previous thread... I think it was someone else. Anyway, its good to know that there is only v1.0x. It just got me i bit confused..

Thanks

--

What is a whitelist exactly?

Is there any other card you can install thats "within" the whitelist? Or am i getting this all wrong?

  • Thumbs Up 1

Share this post


Link to post
Share on other sites

Well, there might be a v1.5 bios sometime in the future... I'm not familiar with Lenovo's naming scheme.

Whitelist is the opposite of a blacklist :D In the case of this system it is a list of hardware IDs of wlan cards which are accepted by the bios, if you try to boot the system with a different card it will show an error message at POST and refuse to boot. This mod circumvents this.

Share this post


Link to post
Share on other sites

Okey. Is there an actual list ? I mean is there other wlan card that we know are accepted?

Sorry for all the questions, and thanks

Share this post


Link to post
Share on other sites

Yeah there is, but it shouldn't matter since the check is now removed. All cards should work.

Share this post


Link to post
Share on other sites

@ svl7, I followed your guide and everything went smooth. I also installed a dual band WLAN card which works just fine. Thanx for your work!

  • Thumbs Up 2

Share this post


Link to post
Share on other sites

hello... I try to disperse the lenovo Y 500 GT650 SLI, but clock don't rise. how to correct it? thanks in advance... I am sorry for transfer

Share this post


Link to post
Share on other sites

Just flashed to the unlocked bios. Great instructions, everything went smoothly. Thanks svl7!!!

Share this post


Link to post
Share on other sites

Sir, kindly ask if this will work for v1.04 bios if I flash on top with v1.05 mod bios. TQ sir

attached bios backup for reference.

Sent from my GT-I9300 using Tapatalk 2

LENOVO-6BCN32WW(V1.04).zip

  • Thumbs Up 1

Share this post


Link to post
Share on other sites

Great job svl7! Got my laptop yesterday and installed the modified bios. No problems and i have never done anything like it before.

Share this post


Link to post
Share on other sites
Has anyone tried using the Intel Ultimate N 633ANHMW with the Y500?

No, but it should work because the Intel Centrino Ultimate-N 6300 is a commonly used card. If you want to use 3 instead of 2 connections you should buy an extra antenna.

Share this post


Link to post
Share on other sites

anyone with bios 6BCN32WW v1.04 flash with mod bios v1.05? working?

thks

Share this post


Link to post
Share on other sites
No, but it should work because the Intel Centrino Ultimate-N 6300 is a commonly used card. If you want to use 3 instead of 2 connections you should buy an extra antenna.

Thanks. I didn't realize replacing the adapter was going to be such an involved task.

Share this post


Link to post
Share on other sites
Thanks. I didn't realize replacing the adapter was going to be such an involved task.

It isn't you can also use two connections, or buy the Intel Centrino 6235. I assume you want 5GHz next to the 2,4GHz?

I have a Broadcom dual band card with Bluetooth installed on my Y500.

Share this post


Link to post
Share on other sites
It isn't you can also use two connections, or buy the Intel Centrino 6235. I assume you want 5GHz next to the 2,4GHz?

I have a Broadcom dual band card with Bluetooth installed on my Y500.

Yeah, I want dual band. I frequently move large amounts of data to/from a desktop and I want max throughput. I have no need for Bluetooth, so the lack of it on the 6300 isn't a problem. I'm just not sure if I'm up to the task of installing a third antenna inside the display and whether it's worth the trouble.

Share this post


Link to post
Share on other sites

The touchpad stuff is (in case it's software related) most likely in the EC. This method will only flash the bios, and as described in my guide, it's not necessarily a good idea to flash a modified which is a different version than your current bios, at least not when flashing this way. The EC isn't included and this might cause serious issues.

For going to a newer bios version I highly recommend waiting for an official bios update from Lenovo.

Share this post


Link to post
Share on other sites

Hi,

Can this method be used for IdeaPad Y400 as well? Thanks.

Updated: My Y400 has bios version v1.05 so I use the v1.05 file in the post to mod the bios. The modded bios works like a charm. I can now use Wifi Link 5100 AGN for the 5Ghz band. For those who are skeptical to try because your laptop is Y400 instead of Y500, just go ahead and follow the instruction of svl7 in this thread.

Good luck to all and thank you again svl7 for this great tool/instruction.

Share this post


Link to post
Share on other sites

This has been discussed, it's due to the motherboard design, leaving out the ability to use only the iGPU respectively only the dedicated GPU needs a more sophisticated mobo design, i.e. more expensive. Lenovo didn't put that ability in the Y500.

Share this post


Link to post
Share on other sites

Hi svl7, just wanted to thank you for wirting this tutorial and helping out the community~

Any idea on how to bypass the Error 104: The 2 SPI flash devices do not have compatible command sets?

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Similar Content

    • By Diky
      help me to unlock amd-v acer aspire one 725
      it's my vars file
      please..
      vars.rar
    • By Awesome14
      I found this: https://photonicsguy.ca/projects/t530
       
      It's a nice how to on altering the whitelist on the W530/T530 laptop.
    • By 9vul14
      Hey allI, I need help  with modding my BIOS. I was wondering if anyone could help me mod my BIOS to unlock the 'Advanced' tab which I don't have on my InsydeH20 F.52 Rev 5.0 Bios? Thanks so much and I look forward to your response! Laptop: HP Pavilion x360  ba109tx
       
      Specs: 
      i7-8550U
      Nvidia Geforce 940MX
      Intel(R) UHD Graphics 620
      12GB DDR4-2400 SODIMM RAM
      128GB SSD, 1TB HDD
       
      Laptop Product Page: https://support.hp.com/gb-en/document/c05650773
      Vanilla BIOS: https://support.hp.com/sg-en/drivers/selfservice/hp-pavilion-14-ba100-x360-convertible-pc/16851098/model/18161600
    • By Kunal Shrivastava
      Hi guys, I am the proud owner of a Clevo p775dm3-g notebook purchased from azom.systems (authorized Clevo reseller in India, Model rebranded as Azom Legion-17.3 inches). Here are my specs:

      Core i7 7700 (non-K version): undervolted by 110 mv and turbo boost disabled in BIOS- machine uses prema mod BIOS.
      GTX 1080: undervolted by 100 mv on all frequency steps using MSI afterburner voltage/frequency curve editor. clocks are untouched.
      16 GB DDR4: Cant remember clocks.
      1440p 120 Hz screen: No tinkering done to refresh rate.

      CPU has been delidded and repaste has been done on both CPU/GPU dies with gallium based TIM-Coolaboratory liquid ultra if I recall correctly.

      My issue is GPU hitting max temp limit of 90 degrees while playing DOOM and framerate drops from 110 avg to mid 60s-70s with horrible stuttering- this is thermal throttling for sure.

      System was running beautifully after repaste at 86 degrees max/ 77 degrees average at 100 percent fan speed. A month later I decided to see how much further I could push the system and ended up undervolting the CPU/GPU and RAM even further. The RAM undervolting part didnt work as well as I'd hoped, and I ended up resetting the BIOS to undo everything and reapply the previous setting (-110 for CPU with turbo boost disabled.) 

      I noticed that immediately after BIOS reset, both my CPU and GPU temps were 5-10 degrees higher even with the undervolt/underclock applied. Also, I think the fans were a bit louder before I reset the BIOS which leads me to believe that for some reason the fans are now capped at 80% max fan speed. There doesnt seem to be a fan speed selector in the BIOS or anywhere else so I cant say for sure whether this is a fan related issue or something else.Before the reset I could override the BIOS setting and set the fans to 100% by pressing fn+1, could I have done something to that setting after resetting the BIOS ? I dont think I have damaged the CPU or GPU as temps are holding fairly steady at 90-91 degrees and laptop doesn't shut down while gaming.

      If I have overlooked something or if anyone reading this has any solution help would be greatly appreciated.
      All settings/drivers/windows version/app version are exactly the same before and after BIOS reset.
    • By BAKED
      BAKED BIOS FOR TM, KM, DM, P6, P4 SERIES with most menus and options unlocked.
       
      THESE BIOS MODS ARE ONLY FOR PEOPLE WHO KNOW WHAT THEY ARE DOING!
       
       
       
      NEW:
      I'VE BEEN BUSY WITH SOME STUFF PLUS MY SYSTEM HASN'T BEEN WORKING FOR SOME TIME BUT I SHOULD BE ABLE TO CONTINUE MY WORK SOON 
       
      I'M CURRENTLY WORKING ON V3.0 WHICH WILL INCLUDE UPDATED UEFI DRIVERS, MICROCODE BIOS SCREEN SHOT SUPPORT AMISCE SUPPORT(For some models) PLUS MORE. 
      I'M ALSO WORKING ON MODS FOR OTHER MODELS TOO.
      ALL TM, KM AND DM SERIES ARE V2.0 AND NOW HAVE WINDOWS FLASHER INSTEAD, JUST EXTRACT AND RUN FLASH.BAT
       
      WARNING! BIOS FLASHING IS RISKY SO MAKE SURE YOU KNOW WHAT YOU'RE DOING BEFORE PROCEEDING. 
      FLASHING THE WRONG BIOS OR INTERRUPTING THE FLASHING PROCESS WILL BRICK YOUR SYSTEM! 
      USE AT YOUR OWN RISK!
       
      TM, KM AND DM SERIES
       
      P6 AND P4 SERIES
       
      INSTRUCTIONS
        IF YOU LIKE MY WORK FEEL FRE TO BUY ME A COFFEE   ENJOY!
×

Important Information

By using this site, you agree to our Terms of Use. We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.