Jump to content
EwinRacing Flash Series Gaming Chairs
J95

[Alienware - Clevo - MSI] Aftermarket Upgrades Driver Support - Modded INF

Recommended Posts

 

4 hours ago, Mr. Fox said:

I see you found it. I sent you a message with more detail. The INF is already modded for you. It's more of a mod than just your hardware ID. @J95 did some magic stuff to help stop the nonsense Alienware has developed a reputation for, and fixed some of NVIDIA's cancer crap. 

 

Sister @BigBr0ski was having troubles very similar to yours and this driver mod cured all of her woes, or so it seems. You might want to look into using this new unlocked BIOS. The stock locked BIOS is trash. I had it on my M18xR2 before I sold it to the guy that developed the new mod and a lot of people are very pleased with it.

 

 

 

I was wondering why you kept calling me sister, then I realized my profile was set to female, awkward lol.

 

but yes, this bad boy worked perfectly

Share this post


Link to post
Share on other sites

I removed my previous invidia drivers in safe mode using ddu. I was running peg with no Intel driver installed at all. After reboot windows comes to black screen and the restore point didn't save with previous working drivers. I am trying to see what's possible as I somehow need to install the drivers in safe mode but without signature verification and I'm not sure if that's possible. I'm guessing maybe installing Inteldriver in safe mode may let me boot to start over again though I wanted to avoid that. Windows is also set to never update video drivers in Windows 10 as per DDU. Any ideas other than what I stated above? 

Edited by momulah

Share this post


Link to post
Share on other sites
Guest
1 hour ago, BigBr0ski said:

 

 

I was wondering why you kept calling me sister, then I realized my profile was set to female, awkward lol.

 

but yes, this bad boy worked perfectly

LOL, yes. I looked at your profile and changed it from brother to sister, ha ha!! I thought your forum name was odd for a girl, but I have seen stranger things along those lines. I figured don't ask/don't tell would be the best approach. ;) Sorry for the mix up. 

Share this post


Link to post
Share on other sites
Guest
58 minutes ago, momulah said:

I removed my previous invidia drivers in safe mode using ddu. I was running peg with no Intel driver installed at all. After reboot windows comes to black screen and the restore point didn't save with previous working drivers. I am trying to see what's possible as I somehow need to install the drivers in safe mode but without signature verification and I'm not sure if that's possible. I'm guessing maybe installing Inteldriver in safe mode may let me boot to start over again though I wanted to avoid that. Windows is also set to never update video drivers in Windows 10 as per DDU. Any ideas other than what I stated above? 

You don't have a black screen in safe mode, correct? You could try running DDU in Safe Mode again. Or, install the NVIDIA driver in safe mode. Use the Legacy Advanced Boot menu and start the system in low resolution mode might work, too. If you haven't set Windows 8.1/10 to use the Legacy Advanced Boot menu you're doing it the harder / stupid Micro$haft way. Run the command below from an elevated (admin) command prompt and that will enable it so you can press F8 prior to Windows logon to see all the options like Windows 7.

 

bcdedit /set {default} bootmenupolicy legacy

 

 

 

Share this post


Link to post
Share on other sites

I ended up just refreshing PC which cleared up a few other issues so it was much needed. The problem I was having was I couldn't install nvidia drivers in safe mode due to not being able to disable driver protection prior to. Its cleared up.

Share this post


Link to post
Share on other sites

I have a GTX770M on Alienware M17xR2; I was installing 344 modded driver and new doom not run, Can I use this mod to run Doom???

 

Thanks

Edited by MondoJuan

Share this post


Link to post
Share on other sites

350.12 is in my opinion the best drivers even though a few post above seems otherwise. The 350.12 with V2 Prema mod is the only ones that dont drop severe frames during bench marking. I suggest if you are going to upgrade drivers use the 350.12 and flash V2 of Premas mod which works great on my M17xR4. The 368.25 keeps dropping frames during benchmarking which I attest to throttling even though I also flashed Premas V2 mod. I guess it depends on your rig. I am running on 980m so the card probably likes certain drivers best. I would start with my suggestion and the suggestion above with the 368.25 also to find the best which is probably the best start you're going to get. Oh and Doom on PC is terribly optimized with alot of crashed being reported including me with the steam version. Runs superd at Ultra then for no reasons just goes to desktop and crashes at random with no explanation. Reports are being made so hopefully they update it and we dont end up with another Batman Arkham conundrum. Hope this helps.

Edited by momulah

Share this post


Link to post
Share on other sites

@J95

 

Just installed 368.25 and ran Firestrike. I got the highest score ever for my M17xR4 :) http://www.3dmark.com/3dm/12889451

 

jBB7EhR.png

 

This is with a +225 Core / +400 Memory OC.

 

I did have to use the Hibernate trick in order to prevent throttling. I'm also using 330w PSU as I suspect my 240w may be causing throttling too but I'm not sure.

  • Thumbs Up 2

Share this post


Link to post
Share on other sites

@J95

Hey. I just followed your instructions for installing 368.25 on my M18xR2 with a single 980M (fantastic work on the guides btw!). 

Following your instructions I flashed Prema's vbios. My question is: is it absolutely necessary to use Prema's vbios for the new video drivers? As you know Prema's vbios has the card sit at a default voltage of 1.062, this is a bit of a problem for me since I only have a 240W power supply, and the current summer season + an unreliable AC puts my card at uncomfortably high temperatures with this voltage.

Edited by wuruochong

Share this post


Link to post
Share on other sites
On 7/2/2016 at 5:59 PM, ShatteredX said:

@J95

 

Just installed 368.25 and ran Firestrike. I got the highest score ever for my M17xR4 :) http://www.3dmark.com/3dm/12889451

 

jBB7EhR.png

 

This is with a +225 Core / +400 Memory OC.

 

I did have to use the Hibernate trick in order to prevent throttling. I'm also using 330w PSU as I suspect my 240w may be causing throttling too but I'm not sure.

OMG the Hibernate trick did work! Never know about this, you save my life! 

got over 19k graphic score with newer driver! never been so happy!

 

2016-07-03.png

Edited by twin snakes
  • Thumbs Up 1

Share this post


Link to post
Share on other sites

What is this "hibernate" trick?? i read there is throttling when you restart your pc or shut down. i always put my r2 in sleep mode i hardly ever shut if off.

is there any benefit from the new 368.39 driver that was released yesterday? i dont see any mods yet for that either.

Share this post


Link to post
Share on other sites

GeForce 368.69


    *Install drivers at your own risk* Windows 10 + GeForce Drivers are Killing Samsung and LG Notebook LCD Display Panels
      Uninstall both PrecisionX & MSI Afterburner (Keep RTSS) including screen overclocking tools *Still at risk*

 

       Requirements:

       Flash latest @Prema's v2 980M & 970M (Please consider donating to Prema)


  • Win10/8.1 'F8' Boot options 'Safe Mode' & 'Disable driver Signing'
    cmd (Admin)
bcdedit /set {default} bootmenupolicy legacy

 

        -> reboot -> F8 -> select 'Disable Driver Signature Enforcement' -> Install drivers

  • Run DDU "Clean & Shutdown (Safe Mode)
  • Extract driver using 7-Zip
  • Display.Driver folder,  copy/overwrite the proper .inf file
  • Extracted driver package >> delete the following folders as shown below (don't skip this step)  -> run setup.exe  

       >>> Keep these folders only <<<

368.39.PNG

 

 

 

    INF MOD v368.69

   

nv_dispi.inf (including nvdmi.inf) PEG/Dedicated All Models: M15x, M17x, AW17 R1, M18x, AW18 R1 (including Optimus/M17xR4) excluding AW 2015 - GTX 980 , 980M , 970M , 965M , 880M , 870M , 860M , 780M , 770M , 765M , 680M , 675MX , 670MX , 660M

 

nvcvi.inf: Optimus Alienware 17 / 05AA (only) GTX 980M - 970M - 965M

    

GeForce 368.69 Win 7/8.1


GeForce 368.69 Win10

 

Alienware

nv_dispi.inf_v368.69_Win7_8.1_PEG_Dedicated.zip

nvcvi.inf_v368.69_Win7_8.1_Optimus_Alienware_17.zip

 

nv_dispi.inf_v368.69_Win10_PEG_Dedicated.zip

nvcvi.inf_v368.69_Win10_Optimus_Alienware_17.zip

 

Clevo (non-Optimus)

nv_dispi.inf_v368.69_Win7_8.1_PEG_Dedicated_CLEVO.zip

nv_dispi.inf_v368.69_Win10_PEG_Dedicated_CLEVO.zip

 

 

900M Throttling workarounds:

M18xR2

Flash @Swick1981 [Bios Mod] M18xR2 - Legacy Support now Available 

M18xR2 980M workaround

 

@djcgeez2189

Hibernation method HERE and HERE

 

@MondoJuan please install using nv_dispi.inf above.

 

 

 

btn_donate_74x21.png

  • Thumbs Up 2

Share this post


Link to post
Share on other sites

@J95 I tried to install the new forceware but I always get " Installation failed " so I tried with 369.39 and it worked immediately so something must be wrong with new mod or something else 

I have Win 10 970M with Optimus ( do you think optimus is the problem ? )

How can i Help you to fix it ?

Share this post


Link to post
Share on other sites
35 minutes ago, HaloTechnology said:

@J95 I tried to install the new forceware but I always get " Installation failed " so I tried with 369.39 and it worked immediately so something must be wrong with new mod or something else 

I have Win 10 970M with Optimus ( do you think optimus is the problem ? )

How can i Help you to fix it ?

Device manager, please post HWIDs. Custom vBIOS?

Share this post


Link to post
Share on other sites

@J95HWID "PCI\VEN_10DE&DEV_13D8&SUBSYS_05AA1028&REV_A1
PCI\VEN_10DE&DEV_13D8&SUBSYS_05AA1028
PCI\VEN_10DE&DEV_13D8&CC_030000
PCI\VEN_10DE&DEV_13D8&CC_0300"

Hardware BIOS name "\_SB.PCI0.PEG0.PEGP"

not really but @Prema had to make a special bois for me because I had different Board ID 

Please let me know if you need more info 

Share this post


Link to post
Share on other sites

IDs are ok (nvcvi.inf), maybe you deleted the wrong folder(s) incl disabling DSE.

Share this post


Link to post
Share on other sites

Not really because when it didnt work I tried to install the older one and it worked without restart .

I tried with the folder with everything , like the screenshot + optimus and just like the screenshot nothing worked :( .

I feel is something related to windows but again the older one worked I must be done something wrong :? I am not sure what it is :(

Share this post


Link to post
Share on other sites

Then try using previous inf w/ current drivers. Anyone else having issues w/ AW17 Optimus 900M?

 

 

----------------------------Updated----------------------------

 

 

@_ALL if you are enjoying @Prema's  work, please consider making a contribution here.

 

 

Much appreciated!

 

Share this post


Link to post
Share on other sites

Sorry if this is a dumb question but I wanted to try out your drivers and have a M18Xr1 with 2 Clevo 780M's. Do I use the .INF from the Alienware or Clevo section?

 

Also do I need to set PEG in my bios or do those instructions just apply to the newer systems with the Optimus stuff?

Share this post


Link to post
Share on other sites

Just a little eye candy for those who are wanting the most out of there M18x R2 with 980m Sli.

 

 


http://www.3dmark.com/3dm11/11409376 - #1 Position.

Using Johnksss and Slv7's vbios with the its clocked +20/+400 and CPU@44x 10 VID. Here is a screen shot of the Intel XTU.

upload_2016-7-13_13-17-9.png

Needless to say I think this is about all it can run with the throttlestop set like this. Turned on of course

upload_2016-7-13_13-24-13.png 

Also you can no longer check the multiplier or it causes throttling on the 980 for some reason. And this is how I'm getting the scores. And if I get to 4.5ghz it will draw more than the 330w can handle.

  • Thumbs Up 3

Share this post


Link to post
Share on other sites

GeForce 368.81


    *Install drivers at your own risk* Windows 10 + GeForce Drivers are Killing Samsung and LG Notebook LCD Display Panels
      Uninstall both PrecisionX & MSI Afterburner (Keep RTSS) including screen overclocking tools *Still at risk*

 

       Requirements:

       Flash latest @Prema's v2 980M & 970M (Please consider donating to Prema)


  • Win10/8.1 'F8' Boot options 'Safe Mode' & 'Disable driver Signing'
    cmd (Admin)
bcdedit /set {default} bootmenupolicy legacy

 

        -> reboot -> F8 -> select 'Disable Driver Signature Enforcement' -> Install drivers

  • Run DDU "Clean & Shutdown (Safe Mode)
  • Extract driver using 7-Zip
  • Display.Driver folder,  copy/overwrite the proper .inf file
  • Extracted driver package >> delete the following folders as shown below (don't skip this step)  -> run setup.exe  

       >>> Keep these folders only <<<

368.39.PNG

 

 

 

    INF MOD v368.81

   

nv_dispi.inf (including nvdmi.inf) PEG/Dedicated All Models: M15x, M17x, AW17 R1, M18x, AW18 R1 (including Optimus/M17xR4) excluding AW 2015 - GTX 980 , 980M , 970M , 965M , 880M , 870M , 860M , 780M , 770M , 765M , 680M , 675MX , 670MX , 660M

 

nvcvi.inf: Optimus Alienware 17 / 05AA (only) GTX 980M - 970M - 965M

    

GeForce 368.81 Win 7/8.1


GeForce 368.81 Win10

 

 

Alienware Laptops

nv_dispi.inf_v368.81_Win7_8.1_PEG_Dedicated_Alienware.zip

nvcvi.inf_v368.81_Win7_8.1_Optimus_Alienware_17.zip

 

nv_dispi.inf_v368.81_Win10_PEG_Dedicated_Alienware.zip

nvcvi.inf_v368.81_Win10_Optimus_Alienware_17.zip

 

 

Clevo Laptops (non-Optimus)

nv_dispi.inf_v368.81_Win7_8.1_PEG_Dedicated_CLEVO.zip

nv_dispi.inf_v368.81_Win10_PEG_Dedicated_CLEVO.zip

 

 

 

900M Throttling workarounds:

M18xR2

Flash @Swick1981 [Bios Mod] M18xR2 - Legacy Support now Available 

M18xR2 980M workaround

 

Hibernation method HERE and HERE

 

 

@HaloTechnology  try nvcvi.inf above.

 

@SStratman nv_dispi.inf above (Alienware Laptops). Set PEG to enable SLI in NVCPL.

 

 

 

 

btn_donate_74x21.png

  • Thumbs Up 3

Share this post


Link to post
Share on other sites

@J95 Man you are awesome , It worked perfectly no problem and I didnt even use DDU for install I simply upgraded :frantics::frantics:

I should really do some benchmarks :logik:

Did some benchmarks I got 12306  in firestrike v1.1 720p <<<<<<<is that good ?

I got 7100 in 1080P


PS: something interesting I noticed that TDP usually before was around 35% but now it's only around 25% ( maybe the new vBIOS ?) ? although the Clock speed is full I dont think there is throttling ? what is a way to know if my card is throttling ?

Edited by HaloTechnology
  • Thumbs Up 1

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Similar Content

    • By Aun
      I am trying to find unlocked bios for overclocking but i cannot find it from a few days please someone help in me. its for my alienware 17 r3 with 970m and i7 6700hq.
       
      my dumped gpu bios
       
      i would really appreciate your help!
       
      and btw rn i OCed thru msi after burner core clock +135 and memory clock +250.
       
      cpu gpuz pic
      gpu pic
       
    • By Yomaster
      Hello, 
       
      some of my computer specs are as follows: 
      CPU: I9-9900k
      GPU: RTX 2070
      memory: 32 GB (forget the manufacturer/ clocks)
      Dsanke bios mod
       
       
       I recently bought a 1440p screen that is 120hz capable, but it does not allow me to select the 120hz option. I have checked numerous places and all of the websites say that this screen is 120hz enabled. I have the dsanke bios mod on my computer. I see people being able to use this screen's 120hz functionality, but I can't get it to work. Any suggestions? If you need any additional information about my laptop, I will be happy to provide info.
       
    • By Miyagi1007
      Hello guys so i bought a used alienware m17x r3 with hd 6870m on it, so when i was trying to boot well it goes to the windows 7 loading screen that says starting windows after that the screen turns white and goes to bsod saying atikmpag.sys
       
      also i attempt to switch my integrated gpu to my discrete card ( hd6870m)  and i wont switch at all 
       
      Responses are highly appreciated 
      Thank you in advance
    • By blancaster
      does anyone know why a vbios file  8mb in size for nvidia k80 , myu backup bios is only 256kb
    • By IveGotRoot
      I have recently upgraded my laptop(an M6800 firepro 6100) and replaced it with an GTX 980m. Nvidia says that the latest driver(461) supports my card but i can only install up to 388.13 Ive tried to mod it but i can't figure it out. I can run the latest linux driver tho
×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use. We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.