Jump to content
EwinRacing Flash Series Gaming Chairs
godfafa

Going to test clevo 980m in alienware m17x R4, m18x R2, AW17

Recommended Posts

So I bought the GTX 970M from Eurocom and have been going nuts with getting it to work in my Alienware M17Xr3. Upgraded from a dead GTX 580m that would overheat.

First frustrating part was that there is no information in the world of the internet on the pad placement for either the GTX 970M or GTX 980M. .. (end rant)

Basically when I turn the M17xr3 on, it gets like 1 bar on the bios bootup and I can't enter F2 to get into the bios. It just restarts. At first it was making a solid 5 beeps sequence over and over and after a power drain it boots to the alienware boot screen and just goes into infinite reset loop. Thoughts?

Share this post


Link to post
Share on other sites
So I bought the GTX 970M from Eurocom and have been going nuts with getting it to work in my Alienware M17Xr3. Upgraded from a dead GTX 580m that would overheat.

First frustrating part was that there is no information in the world of the internet on the pad placement for either the GTX 970M or GTX 980M. .. (end rant)

Basically when I turn the M17xr3 on, it gets like 1 bar on the bios bootup and I can't enter F2 to get into the bios. It just restarts. At first it was making a solid 5 beeps sequence over and over and after a power drain it boots to the alienware boot screen and just goes into infinite reset loop. Thoughts?

Is it a 120hz display? Not that I can offer any help yet except it should boot if the iGPU is active, but may still need another fix (vbios?). Something seriously wrong with the boot microcode on these cards...

Nobody knows for sure what the issue with the 980m is yet so you will have to hold tight to see what solutions appear.

As for the pad layout, I looked at a 980m pic and the component layout and sizes were identical to the 680m/780m (at least by eye).

Share this post


Link to post
Share on other sites
So I bought the GTX 970M from Eurocom and have been going nuts with getting it to work in my Alienware M17Xr3. Upgraded from a dead GTX 580m that would overheat.

First frustrating part was that there is no information in the world of the internet on the pad placement for either the GTX 970M or GTX 980M. .. (end rant)

Basically when I turn the M17xr3 on, it gets like 1 bar on the bios bootup and I can't enter F2 to get into the bios. It just restarts. At first it was making a solid 5 beeps sequence over and over and after a power drain it boots to the alienware boot screen and just goes into infinite reset loop. Thoughts?

Dang, not GTX 970M too:/

What card/vbios is it? Clevo? MSI? Aorus? Asus? You should try hunting down vbios from other OEMs (that match VRAM amount) and perhaps try (at your own risk).

According to Dell, 5 beeps means CMOS battery failure which I guess you fixed with the power drain.

I have no idea why it goes in an infinite loop. Are you running none Optimus Mode or Optimus mode? People have problems using non Optimus mode with 980M but it works with Optimus. Same with 970M I assume?

Share this post


Link to post
Share on other sites
Is it a 120hz display? Not that I can offer any help yet except it should boot if the iGPU is active, but may still need another fix (vbios?). Something seriously wrong with the boot microcode on these cards...

Nobody knows for sure what the issue with the 980m is yet so you will have to hold tight to see what solutions appear.

As for the pad layout, I looked at a 980m pic and the component layout and sizes were identical to the 680m/780m (at least by eye).

Pad layout is slightly different for the 980M in comparison to the 680M/780M - there's an extra inductor (the big grey quite tall square things at the top of the card), so those need considering when padding up if changing from a Kepler.

Pity about hearing the problems alienwareliam is having with the 970M in the R3, if I was him I'd flash svl7's 'A12 Unlocked BIOS with Sata Tweak' (the one I use), and then try different BIOS configurations in terms of IGD enabled or disabled, etc, to try and find something that works. The 'A12 Unlocked BIOS with Sata Tweak' has extra functions that might help him install it. (P.S. this post is more directed at alienwareliam - I know you know this stuff already MickyD after knowing you from notebookreview forums!).

Ah, of course, I missed that part of the post, he can't even get into the BIOS configuration screen. Hmm, I'd double check padding up was done properly and not applying uneven pressure which could be warping the card. Then I'd re-seat the card in the PCIe slot, maybe using a can of compressed air to blow out any dust that might be in the slot. That would hopefully rule out any physical problems associated with the card & it's interface.

I might also try removing the 970M, flashing the A12 unlocked BIOS I mentioned before - then try different IGD settings, etc, before replacing the 970M and trying to boot. Perhaps the correct settings need to be applied into the BIOS before installing the 970M and booting up. (The settings in the BIOS screens I think would need to be messed with are PEG/SG, and IGD enabled / IGD disabled). Given what we have heard so far about BIOS settings for the 980M then I would try:

1) SG + IGD enabled (IGD is in the Advanced Video Configuration Menu)

2) PEG + IGD disabled

The above Number 1 is effectively Optimus enabled. Number 2 is Optimus disabled, and just using the NVidia GPU directly.

  • Thumbs Up 1

Share this post


Link to post
Share on other sites

@ robbo, yeah since the thread was AW thought I'd chime in ;).

One thing I know for sure is the unlocked bios is dangerous on a 120hz machine. Activate the iGPU and you've bricked it. Been there, done that on my R3 :(.

I'm not even sure a modded vbios is going to help. The base VGA compatibility code is failing for some reason meaning that an iGPU is needed to get past POST. Whether that code is in the vbios or on-chip (generic pre-programed for basic compatibility required at POST) I have no idea...

Share this post


Link to post
Share on other sites
@ robbo, yeah since the thread was AW thought I'd chime in ;).

One thing I know for sure is the unlocked bios is dangerous on a 120hz machine. Activate the iGPU and you've bricked it. Been there, done that on my R3 :(.

I'm not even sure a modded vbios is going to help. The base VGA compatibility code is failing for some reason meaning that an iGPU is needed to get past POST. Whether that code is in the vbios or on-chip (generic pre-programed for basic compatibility required at POST) I have no idea...

Yes, good point, definitely need to be careful with the BIOS settings when you're running a 120Hz screen to avoid bricking! :-)

Share this post


Link to post
Share on other sites

So I guess that this is it huh?

No light at the end of the tunnel. No chinese nor english forum posting any successful upgrade to 980M/970M in any Alienware machines.

This is sad. Real sad.

Alienware must be proud of themselves blocking their owners from upgrading the GPUs. Not much use of a MXM port then.

Share this post


Link to post
Share on other sites

I am getting a maddening lack SUPPORT dell :livid: would like to thank you for your cooperation Alien:52_002:It's time for Clevo gtx980M with a desktop CPU :Banane44:Generally, Dell showed the true face and nothing itself does not make the suffering of the faithful users:72:

Share this post


Link to post
Share on other sites

Me:

"From the lack of updates from you guys in almost a week, I understand it isnt exactly a cakewalk to upgrade Alienware 18 with 970M/980M"

A well known company:

"Nope - this is going to take some time to find a solution"

So yeah looks like we are doomed. If only SVL was here and could give it a go. There are two companies working tirelessly on getting the Alienware notebooks to work with 980M to be able to sell a notebooks and hardware, and since nobody have managed to fix it at this time, I'm thinking there are some serious blockage somewhere in the systems that blocks them from working. :(

Share this post


Link to post
Share on other sites
What card/vbios is it? Clevo? MSI? Aorus? Asus?

Aorus gpu's(SLI) are embedded on the board while Asus have their own world of MXM boards which is not compatible with the famous nb's like AW,Clevo/Sager, and MSI.

Share this post


Link to post
Share on other sites
Me:

"From the lack of updates from you guys in almost a week, I understand it isnt exactly a cakewalk to upgrade Alienware 18 with 970M/980M"

A well known company:

"Nope - this is going to take some time to find a solution"

So yeah looks like we are doomed. If only SVL was here and could give it a go. There are two companies working tirelessly on getting the Alienware notebooks to work with 980M to be able to sell a notebooks and hardware, and since nobody have managed to fix it at this time, I'm thinking there are some serious blockage somewhere in the systems that blocks them from working. :(

I don't see why Alienware would be any different from any other manufacturer, I don't see what could be blocking it, unless it's a restriction that Alienware have put into their BIOS that's not allowing an upgrade to 900 series.

Alienware will for definite offer the 900 series, but when that's another story - it can only be in their benefit to do it now rather than later! They're dropping the ball!

Share this post


Link to post
Share on other sites
I don't see why Alienware would be any different from any other manufacturer, I don't see what could be blocking it, unless it's a restriction that Alienware have put into their BIOS that's not allowing an upgrade to 900 series.

Alienware will for definite offer the 900 series, but when that's another story - it can only be in their benefit to do it now rather than later! They're dropping the ball!

problem will be solved as they come out unless the card Della gtx980M:)

I had the same situation before with the Clevo card Gtx780M :livid:

then I got a card Della gtx780M and immediately complete plug@play :angel:

Only now the question is how many will wait until the new year or better ?

Share this post


Link to post
Share on other sites
I don't see why Alienware would be any different from any other manufacturer, I don't see what could be blocking it, unless it's a restriction that Alienware have put into their BIOS that's not allowing an upgrade to 900 series.

Alienware will for definite offer the 900 series, but when that's another story - it can only be in their benefit to do it now rather than later! They're dropping the ball!

Two years ago, I failed to upgrade my m17x R3 with clevo 7970m.

You maybe right but how the world can dell block maxwell when maxwell wasn't even released.

I think there is something in vbios not bios.

NVIDIA GeForce GTX 970M video card benchmark result - Intel Core i7-4710HQ,Alienware 0146Q8

This is a recent 970m 3gb (board-type) Dell bench result.

I think they are doing something :)

Share this post


Link to post
Share on other sites
Two years ago, I failed to upgrade my m17x R3 with clevo 7970m.

You maybe right but how the world can dell block maxwell when maxwell wasn't even released.

I think there is something in vbios not bios.

NVIDIA GeForce GTX 970M video card benchmark result - Intel Core i7-4710HQ,Alienware 0146Q8

This is a recent 970m 3gb (board-type) Dell bench result.

I think they are doing something :)

Good news! :-)

Share this post


Link to post
Share on other sites

This is sad. I just upgraded my MSI GT60 (780m version) with a Clevo 970m 6GB card. Plug and play after a tiny mod to my existing heatsink. Which vbios version do you have?

  • Thumbs Up 1

Share this post


Link to post
Share on other sites
Two years ago, I failed to upgrade my m17x R3 with clevo 7970m.

You maybe right but how the world can dell block maxwell when maxwell wasn't even released.

I think there is something in vbios not bios.

NVIDIA GeForce GTX 970M video card benchmark result - Intel Core i7-4710HQ,Alienware 0146Q8

This is a recent 970m 3gb (board-type) Dell bench result.

I think they are doing something :)

October 20th. Seen it a dozen times before.

That notebook (AW17?) and AW13 are the only one thats leaked. Makes you wonder if AW14 and AW18 truly are killed. :/

Share this post


Link to post
Share on other sites
Two years ago, I failed to upgrade my m17x R3 with clevo 7970m.

You maybe right but how the world can dell block maxwell when maxwell wasn't even released.

I think there is something in vbios not bios.

NVIDIA GeForce GTX 970M video card benchmark result - Intel Core i7-4710HQ,Alienware 0146Q8

This is a recent 970m 3gb (board-type) Dell bench result.

I think they are doing something :)

Still that dreadful Intel iGPU is present :(. Seriously though has anyone tried 3D Vision on an 980M non-Alienware machine? The official nVIDIA site for 980M doesn't even list 3D Vision 2 as a feature :(. I'm only after 120Hz, no need for 3D to be honest. Headaches all too soon.

Share this post


Link to post
Share on other sites
Still that dreadful Intel iGPU is present :(. Seriously though has anyone tried 3D Vision on an 980M non-Alienware machine? The official nVIDIA site for 980M doesn't even list 3D Vision 2 as a feature :(. I'm only after 120Hz, no need for 3D to be honest. Headaches all too soon.
Intrigued man :). Do you get headaches with NV 3D?

Like a lot of people I tried 3D TV, a complete failure IMO. Headaches, my brain seemed to be working too hard to assemble the 3D into perspective. Got the 120hz on the basis of seeing the superior display and was surprised at how well the 3D (at a decent refresh rate and dual images not split screen) works. Love it in open world games :D.

Share this post


Link to post
Share on other sites
does 2013 Alienware 17 has optimus? i mean, what do you think? can it run 980m, 970m? no 120hz and no 3d here. thanks!

There is a Chinese guy who used a Clevo 980M inside his AW17 and he was only semi successful. The card works like it should with Optimus On, but not the other mode with Optimus Off.

I don't see why Alienware would be any different from any other manufacturer, I don't see what could be blocking it, unless it's a restriction that Alienware have put into their BIOS that's not allowing an upgrade to 900 series.

Alienware will for definite offer the 900 series, but when that's another story - it can only be in their benefit to do it now rather than later! They're dropping the ball!

I really don't understand either. Some people are saying GTX 780M was the same and they had to wait for Dell vbios. That's gonna take a looooong time. Probably 2015 :/

I wish SVL or Prema could help

Share this post


Link to post
Share on other sites

Ok...Im curious to see if it will boot this way. I only skimmed this thread right now so not sure of all has been said or not been said.

On the m18x r2.

1 start with pulling all gpus and booting to an unlocked bios.

2: set graphics to SG.

3 Shut down laptop.

4: installed master gpu only.

5 try to boot from there.

you do not need to have the laptop fully put back together for this.

Right now all im looking for is to see if it will boot to windows and show the 980M in windows as a second gpu. If it doesn't work...You may need to wait for a dell version....maybe.

Share this post


Link to post
Share on other sites
Ok...Im curious to see if it will boot this way. I only skimmed this thread right now so not sure of all has been said or not been said.

On the m18x r2.

1 start with pulling all gpus and booting to an unlocked bios.

2: set graphics to SG.

3 Shut down laptop.

4: installed master gpu only.

5 try to boot from there.

you do not need to have the laptop fully put back together for this.

Right now all im looking for is to see if it will boot to windows and show the 980M in windows as a second gpu. If it doesn't work...You may need to wait for a dell version....maybe.

I think Peter at the NBR needs your help. He bought 2 980M for his M18x R2 and it is not working.

Share this post


Link to post
Share on other sites
Ok...Im curious to see if it will boot this way. I only skimmed this thread right now so not sure of all has been said or not been said.

On the m18x r2.

1 start with pulling all gpus and booting to an unlocked bios.

2: set graphics to SG.

3 Shut down laptop.

4: installed master gpu only.

5 try to boot from there.

you do not need to have the laptop fully put back together for this.

Right now all im looking for is to see if it will boot to windows and show the 980M in windows as a second gpu. If it doesn't work...You may need to wait for a dell version....maybe.

That's how I nvflashed in m17x r4. So I think it should work. The method you suggested was not tested in m18x r2 but I think that will allow m18x r2 act as optimus. So it should work.

- - - Updated - - -

I think Peter at the NBR needs your help. He bought 2 980M for his M18x R2 and it is not working.

Too bad he didnt read my post b4 buying two 980m. There is no way right now to make it work as sli. Only optimus makes it work. Try what Johnksss suggested. That method makes 18r2 run as optimus.

Share this post


Link to post
Share on other sites

SLI and Optimus? O_o

Edit: Oh you are just using one GPU to see if that method makes it boot up properly? Then what? :)

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×

Important Information

By using this site, you agree to our Terms of Use. We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.