Jump to content
EwinRacing Flash Series Gaming Chairs
J95

[Alienware - Clevo - MSI] Aftermarket Upgrades Driver Support - Modded INF

Recommended Posts

Do you still need Prema vBios with this driver? Prema website doesn't seem to work. Anybody know how to get a copy?

Edited by G.R.A.M.P.S.
Sorry, wrong thread. Thanks anyway.

Share this post


Link to post
Share on other sites

Geforce Game Ready Driver v. 388.00 launched

 Driver works just fine in any Alienware machine with GTX 980M installed, no modding needed again.

it seems that all Nvidia drivers from now on will compatible  with "980M/Alienware", modding time is over guys:cupcake:

 

Game Ready
Provides the optimal gaming experience for Destiny 2 and Assassin’s Creed Origins

 

http://www.nvidia.com.br/content/DriverDownload-March2009/confirmation.php?url=/Windows/388.00/388.00-notebook-win10-64bit-international-whql.exe&lang=br&type=geforcem

Edited by Tulius

Share this post


Link to post
Share on other sites

Yeah and what about 880M and Alienware M18xR1? Im pretty sure it still needs the mod. By the way we are modding desktop drivers, not notebook.

 

Waiting for someone to mod 388. 

Edited by Ezio21

Share this post


Link to post
Share on other sites
17 minutes ago, Ezio21 said:

Yeah and what about 880M and Alienware M18xR1? Im pretty sure it still needs the mod. By the way we are modding desktop drivers, not notebook.

 

Waiting for someone to mod 388. 

Humm, you're right I tested it in my M18XR1 with 780M and it didn't work, so we still need mods for 780 and 880M GPUs.

Btw J95 sometimes used notebook version driver to do mods too( aka drver 382.19). I dont see any significant changes in my 3DMark results between notebook and desktop drivers so I use whatever is available. 

Share this post


Link to post
Share on other sites

Ah, didn't know. I thought he always used desktop ones.

 

Im using 382.19 right now :D

 

I tested M18xR1 and still does not work without mod. Ehh stupid Nvidia could just add compatibility INF like they did with 980M.

Edited by Ezio21

Share this post


Link to post
Share on other sites

Hope this is the right thread, but I am seeking for help. I have a Dell M6700 with a GTX970m - when modding INF files I always go for the "nvdmi.inf" one and learned that I need to trick the driver to think my laptop is an Alienware. Got some driver issues now and I'm looking for someone to help mi specify which sections of the INF need to be modded and how - how do you know which sections apply to your machines (it might be easier with Alienwares than it is with a Dell Presicion)?

 

Now that I've browsed through the latest posts here I am somehow confused - was I supposed to mod DESKTOP drivers all that time? Cause I've been doing that with mobile ones for the past couple of months...

Share this post


Link to post
Share on other sites

Okay, it seems I had to do it myself.

 

Attaching modified 388.10 nv_dispi.inf

 

Added compatibility 880M - Alienware M18xR1 048F

nv_dispi.zip

 

Driver link - http://international.download.nvidia.com/Windows/388.10/388.10-desktop-notebook-win10-64bit-international.hf.exe

 

Hotfix 388.10 includes kepler fix for Wolfenstein 2

Edited by Ezio21

Share this post


Link to post
Share on other sites

qrp.png

 

Anyone can upload P151EM + 970M inf mod?

 

this laptop is optimus model.

 

i used laptopvideo2go's inf mod but that didnt worked for me. only using integrated GPU :(

Share this post


Link to post
Share on other sites

Hello, I am looking for the lastest driver for my M15X clevo 970M 6g on windows 10. Can any one send me one? My email address is 82912709@qq.com. Thank you in advance!

Share this post


Link to post
Share on other sites
On 2017/9/23 at 9:08 PM, Tulius said:

I'm uploading new mod file drivers for Alienware win10
 PEG and Optimus mod files(Optimus not tested):


GeForce driver 385.69

 

Game Ready

Provides the optimal gaming experience for Project Cars 2, Call of Duty: WWII open beta, Total War: WARHAMMER II, Forza Motorsport 7, EVE: Valkyrie – Warzone, FIFA 18, Raiders of the Broken Planet, and Star Wars Battlefront 2 open beta

Game ready VR
Provides the optimal gaming experience for EVE: Valkyrie – Warzone and From Other Suns open beta

 

Alienware:


nv_dispi.inf (including nvdmi.inf) PEG/Dedicated All Models

nvcvi.inf: Optimus Alienware 17 / 05AA (only) GTX 980M - 970M - 965M

nv_dispi.inf_v385.69_Win10_PEG_Dedicated_Alienware.zip

nvcvi.inf_v385.69_Win10_Optimus_Alienware_17.zip

 

GeForce 385.69 Win10

Hello. I got problem with my clevo 970m 6g on M15x. I have tried these inf, but none of them is working for it. the hardware ID is 13D8 02A2.

Share this post


Link to post
Share on other sites
On 2017/10/27 at 6:41 PM, Ezio21 said:

Okay, it seems I had to do it myself.

 

Attaching modified 388.10 nv_dispi.inf

 

Added compatibility 880M - Alienware M18xR1 048F

nv_dispi.zip

 

Driver link - http://international.download.nvidia.com/Windows/388.10/388.10-desktop-notebook-win10-64bit-international.hf.exe

 

Hotfix 388.10 includes kepler fix for Wolfenstein 2

Would you mind teach me how to add it? Thank you in advance! I am using Clevo 970M on my AW M15X. The hardware ID is as below

image.png.7c39b8fbe24b58bacf9dab50b5adb1af.png

Share this post


Link to post
Share on other sites

Sorry I didn't see your reply. Im not online here often.

 

  • Download new stock drivers and unpack it.
  • Download old stock drivers and unpack it
  • Download modified INF file for your clevo for old drivers from this thread
  • Use something like WinMerge to see differences between these old stock INF files and modified INF for your laptop
  • You will now see which parts are required for your card to be supported
  • Make same changes in new stock drivers INF file and install it.

 

  • Thumbs Up 1

Share this post


Link to post
Share on other sites

Hey guys would anybody be able to do a modded 385.69 (or latest stable ones) inf for a gtx 880m win 7 64bit? 

Edited by ashtaroth02

Share this post


Link to post
Share on other sites

So far I get the gist of the inf. File modification. Anyone here have direct experience with the Dell M6800 and install a 970/980 and what exactly I need to alter to software wise to get it to accept the card fully.

Share this post


Link to post
Share on other sites

This thread is still going decently strong. 

 

I haven't tried the 390.xx drivers yet. 

 

Last drive I was using I think is 388.xx but I did find issues on occasion, but I think it was windows update related, seems there was as few hotfixes and updates that would reset these drivers again , even AFTER the creative update. 

Share this post


Link to post
Share on other sites

@J95 if your still on here or around or anyone else who can help me, I have a alienware m18xr2 with a gtx980m recently installed I have the as unlocked bis and running the driver 345.20 by Mr fox. And I can't seem to get any other drivers to work at all. I'd like to update them. Do I require premas vbios? Where can I get them? I'm at a loss here I've tried everything I can find to update/mod drivers and every time it installs I get a black screen that flashes blocks of bad colour's like a broken screen but if I revert to 345.20 everything works fine again. Some help would be greatly appreciated if more info is required let me know. Also I'm using Windows 7 with the unlocked bios

Edited by NODice
Wrong thread just realized sorry help would still be apprecited tho

Share this post


Link to post
Share on other sites

I modified another driver, if anyone wants it Im sharing.

 

390.77 - Added compatibility for M18xR1 - GTX 880M. I used section for M18xR2 so there shouldn't be any issues.

 

@NODice You require newer vBIOS as I remember.

 

 

nvdmi.7z

Edited by Ezio21
  • Thumbs Up 1

Share this post


Link to post
Share on other sites

Would anyone be able to help with modding both nv_dispi.inf  and  nvdmi.inf  files, for the 780m GTX for m18x R1?

 

it would be highly appreciated :)

Share this post


Link to post
Share on other sites
16 hours ago, ahmadmud said:

Would anyone be able to help with modding both nv_dispi.inf  and  nvdmi.inf  files, for the 780m GTX for m18x R1?

 

it would be highly appreciated :)

The attached files tell you what you need to do to mod the two files for PEG/ Dedicated, get into the practice as there is nobody consistently doing .inf mods here anymore.

I have modded 391.01 following those instructions successfully however I hold no responsibility if it doesn't work on your machine as I've not checked for compatibility beyond my own, but let us know if it goes fine.

The instructions were created from older modded files using the method @Ezio21 suggested. So thank you @Ezio21.

 

Please note you still need to follow the whole string of instructions for installing modded drivers as previously outlined by @J95
But in short:

0) Make sure you have a copy of your last working driver ready to reinstall if anything goes wrong.

 

1) Download driver "XXX.XX-notebook-win10-64bit-international-whql" and unzip using your preferred compression software.

2) Make a copy of the nv_dispi.inf and nvdmi.inf from Display.Driver into a folder for modding them. Make a backup of the originals too.

3) Follow attached instructions to modify those files.

4) Replace the two files within Display.Driver

5) Delete all folders other than: 373.06.PNG

6) Restart (Shift + Restart on Win10) in safe mode.

7) Use DDU to uninstall old driver in full

8) Restart (Shift + Restart on Win10) and Disable Driver Signature Enforcement.

9) Install from setup.exe

10) Hope that you did everything right.

 

Once again the attached instructions worked for me. Hopefully they work for you.

 

 

NVDISPI INSTRUCTIONS.pdf

NVDMI INSTRUCTIONS.pdf

  • Thumbs Up 2

Share this post


Link to post
Share on other sites

Thank you dearly for this comprehensive response, much appreciated!!

 

By the way, I am using Windows 7, 64bit. So I understand I would have to d ownload driver "XXX.XX-notebook-win7-64bit-international-whql" , but otherwise same instructions right?

 

I will try this now. cheers

Share this post


Link to post
Share on other sites
18 minutes ago, ahmadmud said:

Thank you dearly for this comprehensive response, much appreciated!!

 

By the way, I am using Windows 7, 64bit. So I understand I would have to d ownload driver "XXX.XX-notebook-win7-64bit-international-whql" , but otherwise same instructions right?

 

I will try this now. cheers

That would be correct. Also disabling driver signing is an F8 on boot thing. Good luck

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Similar Content

    • By BAKED
      BAKED BIOS FOR TM, KM, DM, P6, P4 SERIES WITH MOST MENUS AND OPTIONS UNLOCKED PLUS OTHER MODIFICATIONS
       
      NEW:
      I HAVEN'T BEEN ACTIVE IN A WHILE BUT I MIGHT FIND SOME TIME SOON TO WORK ON AND RELEASE NEW MODS.
      I STARTED WORKING ON V3.0 A WHILE BACK WHICH WILL INCLUDE UPDATED UEFI DRIVERS, MICROCODE, BIOS SCREEN SHOT SUPPORT AMISCE SUPPORT(For some models) PLUS MORE. 
      ALL TM, KM AND DM SERIES ARE V2.0 AND NOW HAVE WINDOWS FLASHER INSTEAD, JUST EXTRACT AND RUN FLASH.BAT
      WARNING! BIOS FLASHING IS RISKY SO MAKE SURE YOU KNOW WHAT YOU'RE DOING BEFORE PROCEEDING. 
      FLASHING THE WRONG BIOS OR INTERRUPTING THE FLASHING PROCESS WILL BRICK YOUR SYSTEM! 
      USE AT YOUR OWN RISK!
      TM, KM AND DM SERIES
      P6 AND P4 SERIES
      INSTRUCTIONS
       
    • By qamar198
      Hello Everyone,

      I am trying my Sager NP 9377 to get to work but to no avail. NO POST, NO DISPLAY.
      in short>> powering on laptop causes fans to run at full speed after 10(cpu only) + 10 (now both cpu+gpu) with Caps Lock + Num Lock + Scroll Lock LEDs blinking, continuous 1 second beep, repeats for one minute with 1 second in between, then laptop shuts down.

      IN DETAIL
      System Specs are i7 4810mq 8gb gtx 880m SLI variant (though my laptop has other GPU Slot empty so only singular 880m running) 120 Hz display.

      The Problem
      > if i take out the battery and plug in AC only, the power light comes on ORANGE
      if both battery is connected, then i have both power and battery light ORANGE
      and if only battery is connected then of course laptop is waiting for me to press the power button
      but in all 3 cases the following happens
      > Pressing the power button brings laptop to some signs of life, power LED turns green, both the CPU and GPU fans have a very quick jerk but does not spin., keyboard lights up with Blue Backlight (dont know if this is relevant or not), HDD activity light starts to blink showing HDD access maybe (even when hdd is removed)
      > Display remains blank (i dont even sense the display backlight being on)
      > HDD activity light sometimes goes off after only 1-2 seconds, sometimes shows rapid blinking/activity for 4-5 seconds
      > both fans remain off (i removed back cover to check this)
      > after about 10 seconds or so, the CPU fan spins up (speed is normal, just like when using the laptop in IDLE)
      > after 10 more seconds have passed, the CPU fan seems to be turning off for a split second then both the CPU and GPU fan turn on full speed with a lot of noise.
      > Caps Lock, Num Lock and Scroll Lock LEDs all blink together with single beep for about 1 second, repeats beep with 1 second in between.
      > goes on for about 1 minute then laptop shuts down.
      > forcing the fans to spin down using FN+1 key makes them spin back up to full speed after a split second (dont even know why i tried this one -_-)

      What I Have Tried So Far
      > EC and Bios Reset (take out battery, disconnect AC Adapter, disconnect CMOS Battery, Press Power Button for upto 30 seconds)
      > Change Ram and check all available slots
      change/remove HDD
      > Repaste CPU/GPU and clean out fans
      > Checked GPU...... Flashed the 880m in this Sager with MSI vBios and tested it in a MSI Gt70 2PC i have, gpu ran fine, tested with FurMark, AC Odessey, Ghost Recon Wildlands for over an hour (unfortunately the cooling in my MSI is not good enough it already runs hot, and this 880m causes thermal throttling as well as power limit throttling sometimes). Reflash 880m with original Clevo vBios and put back into the Sager, still no boot, same results as before.
      > Checked the CPU..........checked the 4810mq in the MSI GT 70 which worked fine, as well as tried the 4810mq from the MSI in the Sager, still no boot.
      > Suspected bad GPU fan connection......therefore forced both fans to full speed as soon as i press power button (using FN+1 Keys) and both fans turn on full speed, same results.
      > tried charging the battery to the max before turning on on battery only, same results.

      >>------- The laptop has had some random shutdowns in the past too during gaming but would turn back on fine after waiting for 10 mins or so, then i sold it to some guy who brought it back to me the next day saying that it just turned off during gaming and wont turn back on, i returned his money, did all the troubleshooting above to no avail. then i finally put it aside to wait until i get some other system in which i can test the CPU and GPU.
      Then one day i turned it on (after leaving it untouched for a couple months), same results as above, i decided to try once without battery and it Freakin Turned ON!!!, used it for a couple days without battery, played a few games (thermal throttling was observed here and there), but then this happened again and this time it seems permanent . And now i have not only repeated all the steps above but this time also checked the CPU and GPU in the MSI GT70 too. ------------<<


      Some Observations
      > touching the CPU heat pipes feels warm, but the GPU heat pipes are colder (GPU never even booted?). dont know if this is normal or not.
      > i replaced one of the capacitors near the CPU once, but i did use the laptop for quite a while after that without any issues.
      > my Idle temps were always below 40c for both CPU and GPU, so an overheat warning as soon as laptop is powered on seems unlikely (false overheat warning?, but GPU does not even seem to be detected/ booted as heat pipes remain cold to touch), also i repasted the CPU and GPU multiple times.
      > The guy who sold me the laptop told me that the power adapter was originally a Dell, and it was modified to use with this Sager by replacing the cable with a 4-Pin one from a Toshiba (same pinout as the Sager), but then again i have used this laptop for quite a while on the same adapter.
      > From day 1 of having this laptop, some keys on the keyboard (w, s, t, c and numpad 4) did not work 99% of the time. pressing really hard on any one of them sometimes made ALL of them work for a while. any thoughts on this issue?? (even if its unrelated).

      So what seems to be the issue here?
      GPU not detected ?, False temperature alert?, Bad fan?.
      Any help towards resolving this will be greatly appreciated.
      Thanks in advance .
    • By BasedKnight
      I recently purchased a replacement 980M (Clevo model) for my P770DM-G after the original died, however, after installing the card the laptop doesn't boot. I only get a black screen, and after a couple minutes the fans spin to max before shutting down, which is the same thing that happens when I try to boot it without any gpu at all. I've tried the reset procedure, unplugging, removing battery, and removing CMOS, to no avail. It does beep before shutting down (I counted 22 times exactly). Anyone have any insight as to what the problem is?
    • By Brian
      Following the release of NVIDIAs new 436.02 driver which I mentioned in an earlier article here, I've decided to make a quick and dirty video showing off NVIDIAs new Sharpen filter which is part of their Game Filter feature. It works with the most popular APIs including DX 9, 11, 12 and Vulkan and can be set on a per-game basis with granular settings of 0-100 unlike AMDs RIS which is limited to Navi and lacks DX 11 support.
       
       

      View full article
    • By Brian
      Following the release of NVIDIAs new 436.02 driver which I mentioned in an earlier article here, I've decided to make a quick and dirty video showing off NVIDIAs new Sharpen filter which is part of their Game Filter feature. It works with the most popular APIs including DX 9, 11, 12 and Vulkan and can be set on a per-game basis with granular settings of 0-100 unlike AMDs RIS which is limited to Navi and lacks DX 11 support.
       
       
×

Important Information

By using this site, you agree to our Terms of Use. We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.