Jump to content
EwinRacing Flash Series Gaming Chairs
J95

[Alienware - Clevo - MSI] Aftermarket Upgrades Driver Support - Modded INF

Recommended Posts

4 hours ago, weztek said:

are you installing optimus or non-optimus?

I didn't know there was a choice for the M18xR2.

 

Homer

Share this post


Link to post
Share on other sites
On 7/12/2017 at 9:55 PM, MOCKBA said:

Hello ppl! Need some help here....

 

Alienware 17 R5(BIOS 14) with Upgraded Video to GTX 980m 8GB(13D7 05AA1028)

Card gets detected and windows boots no problems. Intel card is there and drivers are installed.

Windows 7 or 10 after installing modded drivers i get bsod after reboot(Page Fault in Non Paged Area)

 

Please help :(

Nobody can help me at all ?!

Share this post


Link to post
Share on other sites

Aw m15x bios A09, windows 10 with gtx 770m
I can't install nvidia driver :(
Please help me

Edited by Mòe

Share this post


Link to post
Share on other sites
On 2017/5/23 at 7:17 PM, J95 said:

 

   GeForce Hotfix driver 382.33

 

      Game Ready
       •Provides the optimal gaming experience for Tekken 7 and Star Trek Bridge Crew.


      *Install drivers at your own risk* Windows 10 + GeForce Drivers are Killing Samsung and LG Notebook LCD Display Panels
       Uninstall PrecisionX, including screen overclocking tools. Instead, keep MSI Afterburner's RTSS for monitoring purposes.

 

       900M Requirements:

       Flash latest @Prema's v2 980M & 970M (Please consider donating to Prema)

  •  
  • Win10/8.1 'F8' Boot options 'Safe Mode' & 'Disable driver Signing'
    cmd (Admin)

bcdedit /set {default} bootmenupolicy legacy

 

        -> reboot -> F8 -> select 'Disable Driver Signature Enforcement' -> Install drivers

  • Run DDU "Clean & Shutdown (Safe Mode)
  • Extract driver using 7-Zip
  • Display.Driver folder,  copy/overwrite the proper .inf file(s).
  • Extracted driver package >> delete the folders as shown below (don't skip this step)  -> run setup.exe  

       >>> Keep these folders only <<<

373.06.PNG

 

 

    INF MOD v382.33


Alienware: nv_dispi.inf (including nvdmi.inf) PEG/Dedicated All Models: M15x, M17x, AW17 R1, M18x, AW18 R1 (including Optimus/M17xR4) excluding AW 2015 - GTX 980 , 980M , 970M , 965M , 880M , 870M , 860M , 780M , 770M , 765M , 680M , 675MX , 670MX , 660M.

Clevo & MSI non-Optimus models: nv_dispi.inf (including nvcvi.inf & nvmii.inf )

 


nvcvi.inf: Optimus Alienware 17 / 05AA (only) GTX 980M - 970M - 965M

nvcvi.inf: Clevo P170EM / P150EM *Optimus* 980M - 970M

  

    GeForce 382.33 Win7/8.1

    GeForce 382.33 Win10

 

 

Alienware

nv_dispi.inf_v382.33_Win7_8.1_PEG_Dedicated_Alienware.zip

nvcvi.inf_v382.33_Win7_8.1_Optimus_Alienware_17.zip

 

nv_dispi.inf_v382.33_Win10_PEG_Dedicated_Alienware.zip

nvcvi.inf_v382.33_Win10_Optimus_Alienware_17.zip

 

Clevo & MSI Laptops (non-Optimus)

nv_dispi.inf_v382.33_Win7_8.1_PEG_Dedicated_CLEVO_MSI.zip

nv_dispi.inf_v382.33_Win10_PEG_Dedicated_CLEVO_MSI.zip

 

 

AW 900M Throttling workarounds:

M18xR2

First, flash @Swick1981 [Bios Mod] M18xR2 - Legacy Support now Available 

M18xR2 980M workaround

 

Hibernation method HERE and HERE

 

 

Please use the SEARCH function to see if your question has been answered/posted already.

 

https://www.techinferno.com/index.php?/announcement/4-user-account-promotion-rules-read-before-posting/

 

@82280zx that's a common issue with Nv latest drivers, try to found out if officially supported Alienware's 900M are also affected. If so, report it on GF forums as being an AW 2015 issue.

dude, 384.76 was released. Is it worth upgrade? Now I'm using 382.33 on my M18x R2 with dual 980M SLi.

Edited by wowmui
  • Thumbs Up 1

Share this post


Link to post
Share on other sites

Can someone tell me the corresponding ID for a 780M GTX ? The old and the new to remplace. Thx

Share this post


Link to post
Share on other sites

I've been struggling with updating drivers after installing windows 10 (m17xr3 680m) either it corrupts and I can't modify the file properly, or it just fails after 10% install ??? At first the newest drivers downloaded - but wouldn't display to my monitor. Now I just can't get drivers installed period. What the hell is going wrong? I've tried nvdmi / nv_dispi / nvam I've disabled driver signing I've updated am I missing something like damn java ? What is it. Days of this ugh any insight would help. Just reformatted as well

Share this post


Link to post
Share on other sites
On 5/23/2017 at 4:17 AM, J95 said:

 

   GeForce Hotfix driver 382.33

 

      Game Ready
       •Provides the optimal gaming experience for Tekken 7 and Star Trek Bridge Crew.


      *Install drivers at your own risk* Windows 10 + GeForce Drivers are Killing Samsung and LG Notebook LCD Display Panels
       Uninstall PrecisionX, including screen overclocking tools. Instead, keep MSI Afterburner's RTSS for monitoring purposes.

 

       900M Requirements:

       Flash latest @Prema's v2 980M & 970M (Please consider donating to Prema)

  •  
  • Win10/8.1 'F8' Boot options 'Safe Mode' & 'Disable driver Signing'
    cmd (Admin)

bcdedit /set {default} bootmenupolicy legacy

 

        -> reboot -> F8 -> select 'Disable Driver Signature Enforcement' -> Install drivers

  • Run DDU "Clean & Shutdown (Safe Mode)
  • Extract driver using 7-Zip
  • Display.Driver folder,  copy/overwrite the proper .inf file(s).
  • Extracted driver package >> delete the folders as shown below (don't skip this step)  -> run setup.exe  

       >>> Keep these folders only <<<

373.06.PNG

 

 

    INF MOD v382.33


Alienware: nv_dispi.inf (including nvdmi.inf) PEG/Dedicated All Models: M15x, M17x, AW17 R1, M18x, AW18 R1 (including Optimus/M17xR4) excluding AW 2015 - GTX 980 , 980M , 970M , 965M , 880M , 870M , 860M , 780M , 770M , 765M , 680M , 675MX , 670MX , 660M.

Clevo & MSI non-Optimus models: nv_dispi.inf (including nvcvi.inf & nvmii.inf )

 


nvcvi.inf: Optimus Alienware 17 / 05AA (only) GTX 980M - 970M - 965M

nvcvi.inf: Clevo P170EM / P150EM *Optimus* 980M - 970M

  

    GeForce 382.33 Win7/8.1

    GeForce 382.33 Win10

 

 

Alienware

nv_dispi.inf_v382.33_Win7_8.1_PEG_Dedicated_Alienware.zip

nvcvi.inf_v382.33_Win7_8.1_Optimus_Alienware_17.zip

 

nv_dispi.inf_v382.33_Win10_PEG_Dedicated_Alienware.zip

nvcvi.inf_v382.33_Win10_Optimus_Alienware_17.zip

 

Clevo & MSI Laptops (non-Optimus)

nv_dispi.inf_v382.33_Win7_8.1_PEG_Dedicated_CLEVO_MSI.zip

nv_dispi.inf_v382.33_Win10_PEG_Dedicated_CLEVO_MSI.zip

 

 

AW 900M Throttling workarounds:

M18xR2

First, flash @Swick1981 [Bios Mod] M18xR2 - Legacy Support now Available 

M18xR2 980M workaround

 

Hibernation method HERE and HERE

 

 

Please use the SEARCH function to see if your question has been answered/posted already.

 

https://www.techinferno.com/index.php?/announcement/4-user-account-promotion-rules-read-before-posting/

 

@82280zx that's a common issue with Nv latest drivers, try to found out if officially supported Alienware's 900M are also affected. If so, report it on GF forums as being an AW 2015 issue.

 

@J95 I found a post in the nvidia forums that I read and tried out and apparently it worked :D. I was able to install 382.33 without the black screen problem, Microsoft admitted that the Anniversary update had caused corruption on some machines it was distributed to and was later fixed, I re downloaded Windows 10 on a thumb drive with all the latest updates and reloaded my machine to have success with the latest driver from you :D thank you again for helping us out!

 

Edited by 82280zx
Double posted, sorry about that.

Share this post


Link to post
Share on other sites
On 8/4/2017 at 1:13 AM, Leo14 said:

I've been struggling with updating drivers after installing windows 10 (m17xr3 680m) either it corrupts and I can't modify the file properly, or it just fails after 10% install ??? At first the newest drivers downloaded - but wouldn't display to my monitor. Now I just can't get drivers installed period. What the hell is going wrong? I've tried nvdmi / nv_dispi / nvam I've disabled driver signing I've updated am I missing something like damn java ? What is it. Days of this ugh any insight would help. Just reformatted as well

 

So i had several issues at times getting my AW17 R3 to update effectively, i would make sure you run DDU in safe mode only first before running anything.  Then follow the instructions from the top (you can also do all the safe mode commands just before using DDU uninstaller.  I was merely suggesting in my previous sentence to do a complete uninstall first step to remove any possible corrupted files prior to the install steps) While in safemode start with (after you have run DDU (complete uninstall and shutdown), complete the command prompt line, and when u restart make sure to get to the boot menu for disable driver signing line, so that when it boots after that you do the install using 7-zip.  Extract files using 7-zip only if you just execute from the file (which opens the geforce installer, it will always fail.  I had many issues with this until i used 7-zip to extract and copy nvdimi files into the drivers folder as specified in the instructions). Sorry for the long winded response, but make sure you do the disable driver signing directly prior to installation of the drivers, if your system restarts for any reason after that step it will also always fail.  So basically the last step prior to installing the files, it start after disable driver signing.  Hope this helps, windows 10 is a pain for getting restarts to safe mode, i had several issues with that more than anything.  

Edited by Diffuse
Added content

Share this post


Link to post
Share on other sites

@J95 Thank you for all the modded .inf.
You'be been pretty quiet lately, are you retiring from modding  .inf for the community or simply working on only major driver releases?

Share this post


Link to post
Share on other sites

If anyone here interested I uploading this for Alienware win10 only:

 

GeForce driver 384.94

Game Ready
Provides the optimal gaming experience for LawBreakers, ARK: Survival Evolved, Fortnite Early Access, Dark and Light, and Hellblade: Senua’s Sacrifice

Game Ready VR
Provides the optimal gaming experience for EVE: Valkyrie’s “Ultra” graphics update

Alienware: nv_dispi.inf (including nvdmi.inf) PEG/Dedicated All Models: M15x, M17x, AW17 R1, M18x, AW18 R1 (including Optimus/M17xR4)

 

 

nv_dispi.inf_v384.94_Win10_PEG_Dedicated_Alienware.zip

  • Thumbs Up 1

Share this post


Link to post
Share on other sites
On 2017/8/9 at 9:34 AM, Tulius said:

If anyone here interested I uploading this for Alienware win10 only:

 

GeForce driver 384.94

Game Ready
Provides the optimal gaming experience for LawBreakers, ARK: Survival Evolved, Fortnite Early Access, Dark and Light, and Hellblade: Senua’s Sacrifice

Game Ready VR
Provides the optimal gaming experience for EVE: Valkyrie’s “Ultra” graphics update


Alienware: nv_dispi.inf (including nvdmi.inf) PEG/Dedicated All Models: M15x, M17x, AW17 R1, M18x, AW18 R1 (including Optimus/M17xR4)

 

 

nv_dispi.inf_v384.94_Win10_PEG_Dedicated_Alienware.zip

Thanks. Ready to try this out!

Share this post


Link to post
Share on other sites
On 8/9/2017 at 2:34 AM, Tulius said:

 

Does anyone have the nv_dispi.inf_v384.94_Win8.1 64bit dedicated Alienware file please 

 

Thanks in advance

 

Ian

On 8/9/2017 at 2:34 AM, Tulius said:

If anyone here interested I uploading this for Alienware win10 only:

 

GeForce driver 384.94

Game Ready
Provides the optimal gaming experience for LawBreakers, ARK: Survival Evolved, Fortnite Early Access, Dark and Light, and Hellblade: Senua’s Sacrifice

Game Ready VR
Provides the optimal gaming experience for EVE: Valkyrie’s “Ultra” graphics update


Alienware: nv_dispi.inf (including nvdmi.inf) PEG/Dedicated All Models: M15x, M17x, AW17 R1, M18x, AW18 R1 (including Optimus/M17xR4)

 

 

nv_dispi.inf_v384.94_Win10_PEG_Dedicated_Alienware.zip

 

2 minutes ago, Ianc said:

Does anyone have the nv_dispi.inf_v384.94_Win8.1 64bit dedicated Alienware file please 

 

Thanks in advance

 

Ian

 

Edited by Ianc

Share this post


Link to post
Share on other sites

Again now I'm uploading new mod drivers for Alienware win10:
 
GeForce driver 385.41

Game Ready
Provides the optimal gaming experience for Destiny 2 PC Open Beta, PlayerUnknown’s Battlegrounds, ARK: Survival Evolved, F1 2017, Pro Evolution Soccer 2018, and Quake Champions Early Access.

Alienware: nv_dispi.inf (including nvdmi.inf) PEG/Dedicated All Models: M15x, M17x, AW17 R1, M18x, AW18 R1 (including Optimus/M17xR4).

 

 

nv_dispi.inf_v385.41_Win10_PEG_Dedicated_Alienware.zip

Share this post


Link to post
Share on other sites

Hello there, I really need some help.
After installing any of the drivers from here I always get black screens while in game.

I tried: 378.49, 378.92 and latest 385.41.

I always use DDU for a clean uninstall before trying new drivers and obviously install them after DSE. I tried the modded infs provided here and also tried after modding myself (but with mine I get black screen also when installing the drivers so I stopped using my modded infs, even though I followed the guide).

 

My setup is:
AW 17 R5 (Win 10 - PEG Dedicated Mode) with upgrade to GTX 1070 (PCI\VEN_10DE&DEV_1BE1&SUBSYS_05AE1028)

I have to say that it was working great on drivers 378.49 BEFORE the latest Windows 10 Creators Update. After the Win update my gpu card was detected as "unkown" in Device Manager and I reinstalled same drivers (378.49). After that I had black screens so I successfully did a rollback to previous-Win Update and I blocked the Win10 Creators Update.
Now the problem is I still meet the black screens and can't find any driver to work properly.

Also, this is the error found in the Event log: nvlddmkm stopped responding and has successfully recovered

Edited by AndreBLJ

Share this post


Link to post
Share on other sites
2 hours ago, AndreBLJ said:

Hello there, I really need some help.
After installing any of the drivers from here I always get black screens while in game.

I tried: 378.49, 378.92 and latest 385.41.

I always use DDU for a clean uninstall before trying new drivers and obviously install them after DSE. I tried the modded infs provided here and also tried after modding myself (but with mine I get black screen also when installing the drivers so I stopped using my modded infs, even though I followed the guide).

 

My setup is:
AW 17 R5 (Win 10 - PEG Dedicated Mode) with upgrade to GTX 1070 (PCI\VEN_10DE&DEV_1BE1&SUBSYS_05AE1028)

I have to say that it was working great on drivers 378.49 BEFORE the latest Windows 10 Creators Update. After the Win update my gpu card was detected as "unkown" in Device Manager and I reinstalled same drivers (378.49). After that I had black screens so I successfully did a rollback to previous-Win Update and I blocked the Win10 Creators Update.
Now the problem is I still meet the black screens and can't find any driver to work properly.

Also, this is the error found in the Event log: nvlddmkm stopped responding and has successfully recovered

 

Check to see the card is installed properly and is not damaged, or "burnt' anywhere.

check under the card too. Maybe when placing it back, play with it a bit, and take notice if the fit is 100% as good as it needs to be, check angles to see if things are lined up and are flat and parallel.

 

Lets just assume your panel is still working and not this other random black panel weirdness we had a few years ago...

 

Now if the card is fine....

 

make sure you are in dedicated mode and using a 120Hz panel and not trying to run the card on Optimus through the HD Intel graphics switchable graphics technology.

 

If your running on the Switcheable tech, then your success in running  the card depends on support in the HD intel graphics, the chipset, the AWCC and MEI being up to date as well as having the right NVidia driver installed too. Most the time the HD intel graphics from official sites has no support for pascal, and Windows update does not usually include the one with Pascal support (least last i checked) and manually downloading the latest versions sometimes do not even install so it's tricky. 

 

If unsure, any HD graphics from after last year should be fine. 

 

On the dedicated front, to switch to dedicated mode, you will need a digital panel like the eDP display - lets say you have that.

Then you need to install windows, go through it as usual - you might not be able to get the Creative update - for some reason.

once in windows make sure to have the OSD and AWCC installed and chipset before attempting to install the modified driver. Best to just do the graphics last actually, even after the sound card. Rebooting many times until everything is updated - except the anniversary update. 

 

To install the driver when it comes time, you will need to disabled DSE and run the setup as admin on the modified drivers.

If you can find your harwdare ID might be a recent driver here for you : http://downloads.eurocom.com/support/drivers/upgradeyourlaptop/Alienware/

 

in worst case use the one I gave you originally or send me an email and I'll send you what I got. 

Share this post


Link to post
Share on other sites

I have a GT70-0NC and a GTX1060 that I've been working with Woodzstack on. Can get a modified nVidia driver to install, but cannot seem to get the Intel HD 4000 driver to install without crashing and resetting the laptop.

 

Have tried installing the Intel driver before installing the 1060 or removing the 1060 and installing the Intel driver, which works, but upon installing the 1060, the laptop will just crash/reset on Windows boot.

 

Currently, the 1060 is installed with the modified nVidia driver, but the nVidia control panel doesn't show any screens attached to the card and the Intel card is just showing as the "Microsoft Basic Display Adapter" in Device Manager. The 1060 also doesn't detect any external screens I've attached.

 

 I've seen a few others with similar setups that have gotten a 3rd gen i7 laptop with the Hd 4000 graphics working with a 1060 and seemingly had little trouble. Not sure what is holding my setup from working. 

 

Any thoughts/ideas on getting the Intel HD 4000 driver and Optimus working with the 1060? Thanks!

 

 

 

Share this post


Link to post
Share on other sites

Hi, I have an Alienware 17 2013 with gtx 980m installed. (382.33 nvidia drivers) I know that its old but the source I was getting them from stop updating.) I searched the forums but couldn't find anything. When i try to use hdmi i can't display above 1080p resolution connected to my 4k tv. I can create a custom resolution of 2560x1440 but its annoying with the Windows  10 popup that keeps going off saying 1920x1080 is best resolution... So i was wondering if anyone knows if it can display full 4k or is there some kind of workaround?

 

Edited by KaoS
Add more information

Share this post


Link to post
Share on other sites
On 8/26/2017 at 9:33 PM, Tulius said:

Again now I'm uploading new mod drivers for Alienware win10:
 
GeForce driver 385.41

Game Ready
Provides the optimal gaming experience for Destiny 2 PC Open Beta, PlayerUnknown’s Battlegrounds, ARK: Survival Evolved, F1 2017, Pro Evolution Soccer 2018, and Quake Champions Early Access.

Alienware: nv_dispi.inf (including nvdmi.inf) PEG/Dedicated All Models: M15x, M17x, AW17 R1, M18x, AW18 R1 (including Optimus/M17xR4).

 

 

nv_dispi.inf_v385.41_Win10_PEG_Dedicated_Alienware.zip

which file is for the Optimus version ?

Share this post


Link to post
Share on other sites
4 hours ago, HaloTechnology said:

which file is for the Optimus version ?

Sorry this file is dedicated for PEG(no optimus) version.

Share this post


Link to post
Share on other sites
1 minute ago, HaloTechnology said:

will that's a shame :( thanks anyway man what happened to @J95

Why did you use Optimus anyway? Would'n be better if you change to PEG in BIOS to fully utilizes your GPU? I think the only reason to utilize Optimus if you put the new 10 Nvidia series(1050, 1060 and 1070) in some nom eDP Alienware panels.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Similar Content

    • By Aun
      I am trying to find unlocked bios for overclocking but i cannot find it from a few days please someone help in me. its for my alienware 17 r3 with 970m and i7 6700hq.
       
      my dumped gpu bios
       
      i would really appreciate your help!
       
      and btw rn i OCed thru msi after burner core clock +135 and memory clock +250.
       
      cpu gpuz pic
      gpu pic
       
    • By Yomaster
      Hello, 
       
      some of my computer specs are as follows: 
      CPU: I9-9900k
      GPU: RTX 2070
      memory: 32 GB (forget the manufacturer/ clocks)
      Dsanke bios mod
       
       
       I recently bought a 1440p screen that is 120hz capable, but it does not allow me to select the 120hz option. I have checked numerous places and all of the websites say that this screen is 120hz enabled. I have the dsanke bios mod on my computer. I see people being able to use this screen's 120hz functionality, but I can't get it to work. Any suggestions? If you need any additional information about my laptop, I will be happy to provide info.
       
    • By Miyagi1007
      Hello guys so i bought a used alienware m17x r3 with hd 6870m on it, so when i was trying to boot well it goes to the windows 7 loading screen that says starting windows after that the screen turns white and goes to bsod saying atikmpag.sys
       
      also i attempt to switch my integrated gpu to my discrete card ( hd6870m)  and i wont switch at all 
       
      Responses are highly appreciated 
      Thank you in advance
    • By blancaster
      does anyone know why a vbios file  8mb in size for nvidia k80 , myu backup bios is only 256kb
    • By IveGotRoot
      I have recently upgraded my laptop(an M6800 firepro 6100) and replaced it with an GTX 980m. Nvidia says that the latest driver(461) supports my card but i can only install up to 388.13 Ive tried to mod it but i can't figure it out. I can run the latest linux driver tho
×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use. We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.