Jump to content
EwinRacing Flash Series Gaming Chairs
Lucas114846

Error 43 with NVidia 372.90 and newer drivers -> Use 372.70

Recommended Posts

I managed to get the new drivers working on my system, might or might not work for you guys : 

 

Went into the BIOS and disabled - Advanced Error reporting for the PCIe slot i had my GTX 1080 connected to.

 

Spoiler

SkelOS9.jpg9s2lwSw.jpg

 

 

 

Also not sure if this is possible with every BIOS or not. Since i dont quite have the standard issue Prema BIOS.

Edited by bloodhawk

Share this post


Link to post
Share on other sites
4 hours ago, bloodhawk said:

I managed to get the new drivers working on my system, might or might not work for you guys : 

 

Went into the BIOS and disabled - Advanced Error reporting for the PCIe slot i had my GTX 1080 connected to.

 

  Reveal hidden contents

 

Also not sure if this is possible with every BIOS or not. Since i dont quite have the standard issue Prema BIOS.

 

Great investigation.  Rightly so, if don't have such a BIOS setting then the problem persists with newer NVidia drivers.

 

Can you disable ASPM in your power profile using pic below  (PCI Express -> Link State Power Management -> off ), re-enable ASPM in the BIOS and see if this power profile setting gives an equivalent fix?

 

ASPM-PCIE.png

Share this post


Link to post
Share on other sites
58 minutes ago, Tech Inferno Fan said:

 

Great investigation.  Rightly so, if don't have such a BIOS setting then the problem persists with newer NVidia drivers.

 

Can you disable ASPM in your power profile using pic below  (PCI Express -> Link State Power Management -> off ), re-enable ASPM in the BIOS and see if this power profile setting gives an equivalent fix?

 

ASPM-PCIE.png

 

Ill give that a shot. But i have ASPM disabled everywhere in my BIOS. Do you think ASPM might be causing this? I have it disabled in my power profiles as well. 

Never quite used it in a long time, since it caused some issues for me, a while back.

It was a total brain fart while doing something else in the BIOS, figured since the system says the card is reporting problems, just make the card NOT report those problems :P

Edited by bloodhawk

Share this post


Link to post
Share on other sites
1 minute ago, bloodhawk said:

Ill give that a shot. But i have ASPM disabled everywhere in my BIOS. Do you ASPM might be causing this?

 

Yes, per previous message pls disable ASPM in power profile and enable it in BIOS to see if this is a fix for users without extensive BIOS options like you have. Based on your previous comments, it appears ASPM is causing error 43 in the newest NViDia drivers.

  • Thumbs Up 1

Share this post


Link to post
Share on other sites
11 minutes ago, Tech Inferno Fan said:

 

Yes, per previous message pls disable ASPM in power profile and enable it in BIOS to see if this is a fix for users without extensive BIOS options like you have. Based on your previous comments, it appears ASPM is causing error 43 in the newest NViDia drivers.

 

That didnt help. 

I set Advanced error reporting back to Enabled and Enabled ASPM as well, along with double checking if its enabled in the power profile as. With the drivers installed and working, there was no change and things were normal, but if i reinstalled the drivers, it would result in a code 43. I had to disable Advanced error reporting again in order for the drivers to install and then i could do whatever i please. Enabling or disabling either of the settings didnt cause any issues or changes, after a successful installation.

My best guess is that the driver checks for something during the install? 

 

One thing i did observe was, when  the driver was being installed with Advanced Error reporting turned off, the black screen that we get during the installation was way longer than it normally takes, and after which everything went normally. 

  • Thumbs Up 2

Share this post


Link to post
Share on other sites
55 minutes ago, bloodhawk said:

 

That didnt help. 

I set Advanced error reporting back to Enabled and Enabled ASPM as well, along with double checking if its enabled in the power profile as. With the drivers installed and working, there was no change and things were normal, but if i reinstalled the drivers, it would result in a code 43. I had to disable Advanced error reporting again in order for the drivers to install and then i could do whatever i please. Enabling or disabling either of the settings didnt cause any issues or changes, after a successful installation.

My best guess is that the driver checks for something during the install? 

 

One thing i did observe was, when  the driver was being installed with Advanced Error reporting turned off, the black screen that we get during the installation was way longer than it normally takes, and after which everything went normally. 

Same result here

I dont have ASPM option in bios and i only disable it in power profile, and it's not working.

Share this post


Link to post
Share on other sites

Would it be possible to disable ASPM before install, and reactivate it after, using something along the lines of pciutils/setpci (aka in software via a kernel driver)? Or is that what Windows is already doing when you disable it in the Power settings?

 

Edit: @Tech Inferno Fan Is this something that could be added to eGPU setup? (disabling ASPM or L1 Error Reporting). Thanks!

Edited by rbut

Share this post


Link to post
Share on other sites

I ‘'ve following the instruction in this thread and finally got error 43 on my GTX 1060, and my external monitor got nothing but black. How could I solve this problem?

 

(P.S) I reinstall my windows so the environment is very clean.无标题.png

Share this post


Link to post
Share on other sites
On ‎2016‎-‎10‎-‎24 at 10:45 AM, rbut said:

Would it be possible to disable ASPM before install, and reactivate it after, using something along the lines of pciutils/setpci (aka in software via a kernel driver)? Or is that what Windows is already doing when you disable it in the Power settings?

 

Edit: @Tech Inferno Fan Is this something that could be added to eGPU setup? (disabling ASPM or L1 Error Reporting). Thanks!

 

If it's possible to have that option in eGPU setup that would be awesome, the power profile change didn't work for me either.

 

Update: The new Nvidia driver 375.63 still gives code 43... 372.70 or below continues to work fine

Edited by Slickback

Share this post


Link to post
Share on other sites
12 hours ago, victorios said:

Look at Code 43 Section may be this will help you too

Sadly This did not work. This might be specific to those who purchased a MBP with a dedicated gpu. Upon Disabling the internal screen and rebooting once I install the newest driver update the internal defaults again with no way to set it back the way it was.

 

 

On 10/23/2016 at 10:50 PM, Tech Inferno Fan said:

 

Yes, per previous message pls disable ASPM in power profile and enable it in BIOS to see if this is a fix for users without extensive BIOS options like you have. Based on your previous comments, it appears ASPM is causing error 43 in the newest NViDia drivers.

Do you know of a way to disable ASPM on a Mac? Windows in bootcamp generally defaults with the power profile part. I assume That is the only way since there is no BIOS setting within MBP

Share this post


Link to post
Share on other sites

I have created an account here just to explain that isn't Macbook-only related.. It concerns every PC in general..

I have a GTX 1060 3Gb and an Asus S551LB that I have modded the BIOS by myself to unlock all the menus along with the hard to unlock chipset menu, and have successfully managed to disable all the cards except the PCIE (the eGPU ofc) card, but that hasn't fixed it.. the only solution which worked was this 372.70 driver which worked perfectly fine, disabling all the PCIe ASPM related features in BIOS did not fix this for me nor when installing the driver too.. seems like Nvidia has introduced some changes that actually break something which they could actually fix if we protest and report in their forums in masses, write emails or whatever works.. (I am getting some interruptions from time to time for unknown reasons like black screen for a second)

 

Thank you for the driver hint btw, that's an awesome solution cuz I thought I had faulty devices.

 

Has anyone tested the latest 28th of October driver release?

Edited by GTANAdam

Share this post


Link to post
Share on other sites
1 hour ago, GTANAdam said:

I have created an account here just to explain that isn't Macbook-only related.. It concerns every PC in general..

I have a GTX 1060 3Gb and an Asus S551LB that I have modded the BIOS by myself to unlock all the menus along with the hard to unlock chipset menu, and have successfully managed to disable all the cards except the PCIE (the eGPU ofc) card, but that hasn't fixed it.. the only solution which worked was this 372.70 driver which worked perfectly fine, disabling all the PCIe ASPM related features in BIOS did not fix this for me nor when installing the driver too.. seems like Nvidia has introduced some changes that actually break something which they could actually fix if we protest and report in their forums in masses, write emails or whatever works.. (I am getting some interruptions from time to time for unknown reasons like black screen for a second)

 

Thank you for the driver hint btw, that's an awesome solution cuz I thought I had faulty devices.

 

Has anyone tested the latest 28th of October driver release?

 

Yeah the latest driver is working as well, after i disabled the Advanced Error Reporting.

Were you able to unlock that option as well ? 

 

Instead of ASPM try and check if there is something called "Advanced Error Reporting" or similar under the PCIe settings for the port your eGPU is connected to. Because is the only think that worked for me. ASPM didn't do anything.

 

The black screen could either be :

 

- Unstable link.

- Insufficient power.

- In sufficient Bandwidth, when other ports are being used.

 

Here is a thread i created on their drivers forum :

 

https://forums.geforce.com/default/topic/970339/geforce-drivers/372-90-373-06-drivers-preventing-use-of-gpus-compute-cards-over-m-2-ngff-mpcie-/

Edited by bloodhawk

Share this post


Link to post
Share on other sites
4 hours ago, mrchrister said:

Are we stuck an old driver for now?

Unless one of these troubleshooting steps others have posted works for you then yes. Currently I have not found a way to get passed it either.

Share this post


Link to post
Share on other sites
36 minutes ago, bloodhawk said:

 

Yeah the latest driver is working as well, after i disabled the Advanced Error Reporting.

Were you able to unlock that option as well ? 

 

Instead of ASPM try and check if there is something called "Advanced Error Reporting" or similar under the PCIe settings for the port your eGPU is connected to. Because is the only think that worked for me. ASPM didn't do anything.

 

The black screen could either be :

 

- Unstable link.

- Insufficient power.

- In sufficient Bandwidth, when other ports are being used.

 

Here is a thread i created on their drivers forum :

 

https://forums.geforce.com/default/topic/970339/geforce-drivers/372-90-373-06-drivers-preventing-use-of-gpus-compute-cards-over-m-2-ngff-mpcie-/

 

You should consider joining us on fixing this driver issue as you can see not everyone is able to access the Advanced BIOS options, I am sure it's a driver related problem that can be easily fixed. 

I am planning on investigating this problem and making a modded version of Nvidia's drivers for the GTX 1060 eGPU folks like myself.

But first, we need to inform Nvidia on this matter, they could easily fix it since they're the ones developing it.

 

Update: Oh, I've just checked the link you've posted, It's great that someone has informed them about this.. everyone should support it so it could be fixed asap.

Edited by GTANAdam
  • Thumbs Up 1

Share this post


Link to post
Share on other sites
2 hours ago, bloodhawk said:

 

Yeah the latest driver is working as well, after i disabled the Advanced Error Reporting.

Were you able to unlock that option as well ? 

 

Instead of ASPM try and check if there is something called "Advanced Error Reporting" or similar under the PCIe settings for the port your eGPU is connected to. Because is the only think that worked for me. ASPM didn't do anything.

 

The black screen could either be :

 

- Unstable link.

- Insufficient power.

- In sufficient Bandwidth, when other ports are being used.

 

Here is a thread i created on their drivers forum :

 

https://forums.geforce.com/default/topic/970339/geforce-drivers/372-90-373-06-drivers-preventing-use-of-gpus-compute-cards-over-m-2-ngff-mpcie-/

 

@bloodhawk Can you please clarify on your solution. If you disable AER, then install the drivers, then reboot and immediately enable AER, then boot into windows for the first time, does it work?

 

Or is one reboot of windows with AER disabled required?

Share this post


Link to post
Share on other sites

What I actually noticed, he had Hotplug option enabled which I had disabled when I disabled all L1 substates, gotta try that out as it could be just it.

theoretically, it could be that nvidia tries to reset the device when installing but the system does not respond correctly due to protection it has against hot plugging in PCIe.. could be it but I am not sure.

Edited by GTANAdam

Share this post


Link to post
Share on other sites
1 hour ago, rbut said:

 

@bloodhawk Can you please clarify on your solution. If you disable AER, then install the drivers, then reboot and immediately enable AER, then boot into windows for the first time, does it work?

 

Or is one reboot of windows with AER disabled required?

Yeap, after the driver installs, toggling AER doesn't do anything. At least until the next update. 

1 hour ago, GTANAdam said:

What I actually noticed, he had Hotplug option enabled which I had disabled when I disabled all L1 substates, gotta try that out as it could be just it.

theoretically, it could be that nvidia tries to reset the device when installing but the system does not respond correctly due to protection it has against hot plugging in PCIe.. could be it but I am not sure.

That actually makes sense, ill give it a shot with hot plugging disabled. 

I have never had ASPM enabled btw. 

 

Edited by bloodhawk

Share this post


Link to post
Share on other sites

I'd like to confirm my theory earlier concerning the Code 43 device error.

Seems like the newer nvidia drivers are trying to reset the graphics device while installing but such feature called "Hotplugging" is not safe on laptops so the BIOS actually partially disables the device to avoid further conflict.

 

So the solution is enabling "Hotplug" in the PCIe settings in BIOS.

For those who are not able to access the advanced options, You will either have to wait for Nvidia to fix it or actually install a custom BIOS (This is dangerous).

  • Thumbs Up 2

Share this post


Link to post
Share on other sites

@Tech Inferno Fan @GTANAdam

 

So here are my findings in relation to AER and Hot Plug using the latest drivers 375.70 :

 

  • AER - Enabled + Hot Plug Enabled - NO CODE 43 / ERRORS
  • AER Disabled + Hot Plug Enabled  - NO CODE 43 / ERRORS
  • AER Disabled + Hot Plug Disabled - CODE 43
  • AER Enabled + Hot Plug Disabled - CODE 43

So AER doesn't seem to the culprit here, its Hot Plugging. This would lead me to believe they are trying to optimize hot plugging of eGPU's. Since it seems to work 8 out of 10 times when i plug in my GPU over TB3.

 

So if you guys have the Hot Plug option in your option in your BIOS for PCIe ports, maybe that will help. Or if @Tech Inferno Fan can implement it in his setup. 

 

Props to @GTANAdam for noticing the Hot Plug being enabled. 

Share this post


Link to post
Share on other sites

Great work @GTANAdam and @bloodhawk.

 

I did read somewhere that Microsoft implemented Hot Plug for Thunderbolt 3 in Windows 10, so maybe that's why it works for you bloodhawk?

 

For us Thunderbolt 1-2 users though, it may be dependent on the age of our machines? For Apple users, their website states:

 

Quote


Thunderbolt devices are "hot pluggable," or usable without a restart, in some cases. Windows 8 or 8.1 on all 2014 and later Mac computers support hot plug.

 

 

So my Late 2013 rMBP seems out of luck? :( Is anyone with a 2014+ Mac able to install the drivers?

 

I'm guessing playing with the PCI-E Slot Capabilities registers (to enable Hot Plug) is out of the question as it needs to be supported by the BIOS?

 

The only other option is to try and stop the installer from restarting the card somehow?

  • Thumbs Up 1

Share this post


Link to post
Share on other sites
7 minutes ago, rbut said:

Great work @GTANAdam and @bloodhawk.

 

I did read somewhere that Microsoft implemented Hot Plug for Thunderbolt 3 in Windows 10, so maybe that's why it works for you bloodhawk?

 

For us Thunderbolt 1-2 users though, it may be dependent on the age of our machines? For Apple users, their website states:

 

 

So my Late 2013 rMBP seems out of luck? :( Is anyone with a 2014+ Mac able to install the drivers?

 

I'm guessing playing with the PCI-E Slot Capabilities registers (to enable Hot Plug) is out of the question as it needs to be supported by the BIOS?

 

The only other option is to try and stop the installer from restarting the card somehow?

 

Over TB3, each and every driver works no matter what.

Over M.2 the latest drivers work only with HotPlug enabled. 

 

 

Share this post


Link to post
Share on other sites
2 hours ago, bloodhawk said:

 

So if you guys have the Hot Plug option in your option in your BIOS for PCIe ports, maybe that will help. Or if @Tech Inferno Fan can implement it in his setup. 

 

Props to @GTANAdam for noticing the Hot Plug being enabled. 

 

@bloodhawk, @GTANAdam, great troubleshooting in getting to the bottom of this.

 

Unfortunately the PCIe port hotplug bits are read and write-once (R/WO), so we can't change them after the BIOS has set them as shown from Intel's datasheet extract below. I've also confirmed these are write-once by attempting PCI writes to the register and seeing it doesn't change.

 

Registry hack to disable hotplug checking?

 

@Nautis1100 noted at here that NVidia added two new registry - SurpriseRemovalSupport and EnableRunTimePowerManagement to enable hotplugging. Can you guys install 372.90, search for those strings and see if removing/disabling those options fixes error 43??

 

Petition a NVidia fix

 

If get no joy with registry hack and sticking with 372.70 isn't an option then next easiest path to pursue is to petition NVidia to disable the hotplug checking code that is causing error 43 in their 372.90 and newer drivers.

 

hotplug.png

Share this post


Link to post
Share on other sites

workaround: Bypassing driver version checking for say BF1 which wants 372.90 or newer

 

From https://forums.geforce.com/default/topic/970339/geforce-drivers/372-90-373-06-drivers-preventing-use-of-gpus-compute-cards-over-m-2-ngff-mpcie-/post/4998890/#4998890 :

Quote
AaronZaBaron said:
KORDAEMUL said:One sad thing is that BF1 needs the latest driver... I cannot play this eventhough Pre-order.
Yes you can.
https://forums.geforce.com/default/topic/962633/pc-games/bypassing-the-driver-version-check-of-a-game-/post/4967359/#4967359

 

  • Thumbs Up 1

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Similar Content

    • By Bullfrog098
      Hi, just a quick question what would be the best EGPU adapter, because i see the really expensive ones but then you have the 400$ dollar one that Lowspecgamer used. Which do you guys recommend ?
    • By Arman
      Hello! My name is Arman! I from Armenia, and sorry for my English!
      I have iMac Late 2013 with Intel core i5, 8Gb, NVIDIA GeForce GT 750M 1024 Mb. I have Boot Camp installation on my iMac (now i have 7 Windows, but i can update it to 10 or 8 Windows) 
      I  discover that there is an Akitio 2, wich can use with iMac 2013 for productivity increase. I want to use akitio 2 with GTX 1050 ti 4Gb, but i dont know how it is intalling on iMac?
      Who can write for me the process of installation ALL equipment (akitio 2 + GTX 1050 ti + imac)? What i must to do? I talking about from the very beginning to the very end. 
      PLEASE everyone, help me. You are my last chance !!!!

    • By deltha
      Hello,
       
      I am using on a MacBook Pro (Retina, 15-inch, Mid 2015) 2,2 GHz Intel Core i7 with Intel Iris Pro 1536 MB, Akitio TB2, a water-cooled Nvidia 1080 TI using the driver Nvidia Web Driver 378.05.05.15f01
      OS: macOS Sierra v10.12.5 Script: automate-egpu.sh
       
      I would like to ask you : is there any chance to overclock it on macOS?

      Components:
      V-tubler
      Thermaltake C 1000 coolant
      2x luna 12 red + led band
      Radiator EK Water Blocks EK-CoolStream SE 240 (Slim Dual)
      Pacific PT40-D5 Reservoir/Pump Combo 250
      Akitio Thunder 2 pcie expansion
      Plexiglass, acrylic, plastic isolation, screws
      Water cooling fittings, pipes, hard tubing, without actually bending the tubing
      Lian Li PW-PCI-E38-1 Riser PCIe x16 3.0, 380mm, flexibil, High Speed, EMI Shielding + powered
      Openframe case Thermaltake Core P1
      RM650 gold PSU+Paperclip
      Graphic card:
      Zotac water cooled 1080 TI Fe (Zotac 1080 TI FE + Separate mount of Titan X nickel waterblock)

    • By MacFreekDotKext
      I am running Windows build 16193 (Redstone 3) on a portable SSD as Windows to go. And macOS Sierra 10.12.4.
      Windows to Go was created using EasyUEFI's wintousb program.
      I have previously used Windows 8.1 to success and 10 which needed DSDT override. 
       
      This is a guide on how i get Windows 16193 working successfully with RX 480:
      1. Leave Thunderbolt cable unplugged from Mac before turning it on.
      2. Press option to load Windows to go Portable SSD Windows 10 16193 build.
      3. Enter DIY eGPU Setup 1.35 with iGPU connected only. Configure it as:
      Press 3 to enter Menu based setup PCI Compaction 》 Legacy mode checked 》 Closeunusedbridges checked 》 ignore none 》 Endpoint 》 56.25GB-36bit 》 Run compact 》 iGPU 》 force iGPU to 32-bit Chainload mbr Select Windows 10  from OS selection menu As soon as the Windows logo comes up hotplug eGPU. When OS is about to load up, change display output to Displayport.  
      Voila!
      Every time you want this do be done automatically, reboot into DIY eGPU  Setup 1.35 and hit ENTER (or allow 10s countdown to do it for you) on the default option 2 "automated startup via startup.bat".
       
      The Setup:
       
      1. Use paperclip trick to get PSU turned on without motherboard.
      2. Two molex connectors from psu to rocketstor 6361a molex connections. To give power to 6361a motherboard.
      3. 8 Pin pcie connectors to GPU. And chassis bent to fit RX 480.
      4. Modified back of chassis to allow Displayport connection into GPU while GPU can be screwed firm into chassis.
       
      Rocking games such as Far Cry 4 @ 4k high settings! 
      Using AMD Crimson WHQL 17.2.1.
       
       
    • By SimoLoveApple
      Hi all, I have a macbook pro 15 inch retina mid-2015.
      I joined a Aikitio thunder2 with a graphics card GTX 1070 but there are problems with the internal monitor of my macbook.
      first of all we will list the specific to this topic.
      my macbook is equipped with two graphics cards, an integrated and a dedicated, integrated is an intel iris pro graphics while one dedicated is an amd radeon r9 m370x 2 GB gddr5, and obviously the eGPU GTX 1070.
      the problem is that with the external monitor connected via hdmi to egpu doesn't show any problem while using the internal monitor that should take the video signal from the thunderbolt has lagged.
      Mafia 3 with settings on external monitor turn 54 fps while on internal monitor turn 9 fps!!!
      i have windows 10 on bootcamp.
      There is not much difference and it occurs to me that the problem is the thunderbolt.
      members of tech hell please help me!
×

Important Information

By using this site, you agree to our Terms of Use. We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.