Jump to content
EwinRacing Flash Series Gaming Chairs
svl7

Lenovo Y410p / Y510p - unlocked BIOS / wlan whitelist mod / vbios mod

Recommended Posts

How to recover from soft brick Y510p, caused by changing Offset voltage in Unlocked BIOS.

 

As first step you need to remove back cover, disconnect Battery, and CMOS battery, unplug all RAM modules.
Then do Power Flee by pressing power button 20 secs or so.

Then connect AC, Power on, it will bootloop cos no ram installed.
- in one of the shutdown in-between bootloop , quickly connect CMOS battery connector back in its place. Let it reboot,
- it will shutdown again cos still no ram installed,
- after another shutdown ( still in-between bootloop ) quickly connect/insert 1 ram modules to its placed.
Then after next reboot it should back to life to enter Setup Mode. Then you could load Default Settings and restart or shutdown to connect battery and another ram modules, if you had 2 slots installed.


I hope this could help users experiencing soft brick after changing OFFSET VOLTAGE settings in bios setup menu.
NOTE: Do not change voltage ( undervolt ) in Inside BIOS! Only do it by Intel XTU.

Edited by Klem
  • Thumbs Up 1

Share this post


Link to post
Share on other sites

@Klem I'll try this in a while, but where is the CMOS battery connector?, isn't the battery just soldered on the motherboard?

Edited by CYGNUX

Share this post


Link to post
Share on other sites
1 minute ago, CYGNUX said:

@Klem I'll try this in a while, but where is the CMOS battery connector?, isn't the battery just soldered on the motherboard?

As first step you can try without disconnected CMOS battery. But if it doesn't work, then disconnect/desolder CMOS battery and try again.

Share this post


Link to post
Share on other sites
46 minutes ago, Klem said:

As first step you can try without disconnected CMOS battery. But if it doesn't work, then disconnect/desolder CMOS battery and try again.

Thanks, I'll try that then, but I'll not desolder the CMOS battery if it doesn't work as I don't have the tools or the skills to do that, and people already did that with no luck, as posted here:

https://forums.lenovo.com/t5/Lenovo-P-Y-and-Z-series/Y510P-Y410P-Undervolted-bricked-FIX/td-p/3272854

 

EDIT: IT LIVES!

@Klem I followed your instructions (without the CMOS step) and it worked!, I don't have words to thank you, please send me a bitcoin wallet or paypal email through MP so I can send you a small donation, you deserve it.

I really think it should be a warning on the main post and your steps to unbrick the laptop because I didn't find any way to unbrick the laptop on the whole Internet.

 

:thumbsup:

 

Edited by CYGNUX

Share this post


Link to post
Share on other sites

I have problem with HP USB Disk Format Tool when i want to format disk with 98 win files. Showing me ,,failed to format device''. I tested it on 3 pendrives and 2 computers. Ealier all works fine but after one year sth is wrong. What can i do?

Share this post


Link to post
Share on other sites
3 minutes ago, Pro100zsnd said:

 What can i do?

You can use the Rufus program, instead HP USB Disk Format Tool.

Share this post


Link to post
Share on other sites

Rufus Works! Second problem i have with backuped bios cuz when i want to drop backuped bios on the program biosfixer 2.0 i have error-invalid input file. Make sure its a proper dump of Bios version v3.05. Its v3.05...

Share this post


Link to post
Share on other sites

This may be a bit off from the thread, but I was disappointed to see that I have to be an active member on the forum and promoted to download the file? That's a bit frustrating, especially since I upgraded my y510p to Win10 and it'll just stop recognizing my wireless card at random (the stock card doesn't have a Win10 Driver). I'm mostly just looking to get rid of that whitelist though I did upgrade my bios to v3.5 (just to get that out of the way). Any alternate downloads for your mod or should I just wait to get out of "pre-promotion"?

Share this post


Link to post
Share on other sites

Hi,

 

Please, can somebody confirm Intel Wireless-AC 7260 7260HMW 802.11AC Dual Band BT4.0 PCIe Half Mini Wifi Card link 

http://www.ebay.com/itm/190897053836 

 

wireless card working with Lenovo Y510p ?

 

I read this forum, but I'm not 100% sure.

 

Thanks. 

Edited by Rasto

Share this post


Link to post
Share on other sites
On 28.01.2017 at 9:37 PM, Pro100zsnd said:

I have problem with HP USB Disk Format Tool when i want to format disk with 98 win files. Showing me ,,failed to format device''. I tested it on 3 pendrives and 2 computers. Ealier all works fine but after one year sth is wrong. What can i do?

I have the same problem.

 

On 28.01.2017 at 9:43 PM, Klem said:

You can use the Rufus program, instead HP USB Disk Format Tool.

In HP USB Flash Disk is written: "Create a DOS startup disk using system files located at:" and it's a folder. But in Rufus there are only "FreeDOS, ISO Image and DD Image." If I create ISO with "win98_files" folder (using DaemonTools), Rufus writes "This image is either non-bootable, or it uses a boot or compression method that isn't supported by Rufus". Or I just should create a bootable disk using FreeDOS?

 So how should I use Rufus?

21131_Ink_LI.jpg

Edited by sypchik

Share this post


Link to post
Share on other sites
On 29.01.2017 at 1:41 AM, Spiderach said:

This may be a bit off from the thread, but I was disappointed to see that I have to be an active member on the forum and promoted to download the file? That's a bit frustrating, especially since I upgraded my y510p to Win10 and it'll just stop recognizing my wireless card at random (the stock card doesn't have a Win10 Driver). I'm mostly just looking to get rid of that whitelist though I did upgrade my bios to v3.5 (just to get that out of the way). Any alternate downloads for your mod or should I just wait to get out of "pre-promotion"?

Here it is: https://1drv.ms/u/s!As-ULvSQI7cmo1baQqJytwGTxJbH

I had the same problem, and found this zip somewhere.

Edited by sypchik

Share this post


Link to post
Share on other sites

Nevermind I figured everything out!

Edited by Mageosnsu

Share this post


Link to post
Share on other sites

I have the Idepad Y510P model and I’d like to apply the BIOS mode in order to be able to change the problematic Wireless NIC.  The laptop came with Win 8.1 installed.  Will the new BIOS mod have any effect on the win8.1 Product Key hidden in the BIOS?

Thanks.

Edited by Huncenk

Share this post


Link to post
Share on other sites
On 2/7/2017 at 6:13 AM, Rasto said:

Hi,

 

Please, can somebody confirm Intel Wireless-AC 7260 7260HMW 802.11AC Dual Band BT4.0 PCIe Half Mini Wifi Card link 

http://www.ebay.com/itm/190897053836 

 

wireless card working with Lenovo Y510p ?

 

I read this forum, but I'm not 100% sure.

 

Thanks. 

 

I think pifive posted success regarding your question on this tread on January 16, 2015.

Quote: “….I have now my modified BIOS on my y510p laptop with the new7260HMW wireless AC card flying like an eagle….”

I am trying to do the same thing.  Good luck for you!

 

Share this post


Link to post
Share on other sites

So, I have been dealing with Bios issues for awhile now.

I have been getting errors 201 and 280 with FPTWT

 

Error 201: "cannot be run on the current platform.
Please contact your vendor."

 

Error 280: "Failed to disable write protection for the BIOS space!"

 

so I used FPT_Backup_95 instead and was able to get a .bin file however it also gave me error 26. 

 

Error 26: "The host CPU does not have read access to the target flash area. To enable read access for this operation you must modify the descriptor settings to give host access to this region."

 

So with the .bin file I got with FPT_Backup_95, I put it into the bios-fixer and it gave me no errors and I got a v305mod.bin without any problems. I'm just concerned that if I use the .bin I could brick my Y510p because of a problem with the .bin file because of error 26.

Anyone solutions?

If I uploaded my .bin file is it possible for someone to look at it and verify that it is not corrupt?

Share this post


Link to post
Share on other sites

Thanks for posting all this! I was wondering if the download link to the drivers is broken? TechInferno is throwing an error when I try to hit download.

 

 

Share this post


Link to post
Share on other sites

Who knows why I can't download the files?

May anyone upload the files into a netdisk or mailbox and share them to me?

Share this post


Link to post
Share on other sites

Hey guys Im new to the Y510P but ive been learning allot about this heap in past couple of days. The unlocked bios/ vbios is exactly what I'm after. How would I go about downloading the software on this forum. I don't seem to have the correct permissions. Thanks.

Share this post


Link to post
Share on other sites

If I don’t have and do not plan to have a secondary Graphics card installed, do I still have to utilize the vBios flash?  All what I have is the Intel and nVidia combo graphics that came with the laptop. 

Model: Y510P,

BIOS: 74CN44WW(V3.05)

Thank you.

Share this post


Link to post
Share on other sites

I have the driver version 17.13.12.1 / 2014-12-16 for the Wireless-N 7260.  This driver (from Lenovo)  helps me to stay online without interruptions.  Speed varies, but for now it is OK as a temporary solution.  I can’t wait to flash the BIOS and install a new wireless card.

My System: IdePad Y510P

BIOS: 74CN44WW(V3.05)

OS:  Windows 8.1 (64-bit)

Intel(R) Wireless-N 7260

 

Edited by Huncenk

Share this post


Link to post
Share on other sites

Guys when i try to backup the bios i get  "Error 200: Invalid parameter value specified by user. Use -? option to see help."

when i execute the Backup file it opens and close instantly and i don't get any backup.bin file  ...

any help or solution please ?

 

Share this post


Link to post
Share on other sites
15 hours ago, Taher_Kh said:

Guys when i try to backup the bios i get  "Error 200: Invalid parameter value specified by user. Use -? option to see help."

when i execute the Backup file it opens and close instantly and i don't get any backup.bin file  ...

any help or solution please ?

 

 

Bro,

 

I'm having the exact issue, what i did is that

1. right click on the .exe file and set tick run as admin and also compatible mode as win8

2. restart

3. try again. Voila.

 

At least that worked for me. help that help

Share this post


Link to post
Share on other sites

@bcc1911 

thx for the help but this didn't help me :( 

i still getting the same error "Error 200: Invalid parameter value specified by user. Use -? option to see help."  
anyone has another solution please ?

Share this post


Link to post
Share on other sites

Guys I seem to have bios v3.08 currently. Do I have to (and is it possible to) downgrade to v3.05 first in order to install this mod?

Also I cant download the files for some reason. Any mirror?

Edited by niankaki

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Similar Content

    • By Krak
      Hi everyone, I have a problem. I need to unlock the bios settings because I only have basic functions and I need to increase the memory of VRam. Sorry if I posted a post not in this topic.
    • By Klem
      In this thread you can post your requests for Lenovo ThinkPad X240.
      If someone wants upgrade Wi-Fi card and remove whitelist, or unlock hidden advanced menus and settings in bios setup menu, or upgrade to new display (with brightness control), then you can post your request in this thread.
      Important!
      For creating your personal bios dump and to flash your bios mod, you must use any SPI programmer  (like CH341A programmer) and a SOIC8/SOP8 test clip!
       
      Just dump your Bios using any SPI programmer  (like CH341A programmer) and a SOIC8/SOP8 test clip, then post it in this thread or upload it to any fileserver and send me the link.
       
       

      CH341A programmer:
      https://www.ebay.com/itm/USB-Programmer-CH341A-Series-Burner-Chip-24-EEPROM-BIOS-Writer-25-SPI-Flash-AU/153117073868?epid=577511738&hash=item23a67d21cc:g:XKEAAOSw5UdbW-iL
       
      https://www.amazon.com/Parts-tower-CH341A-Programmer-Software/dp/B01FVVHCVC/ref=sr_1_4?ie=UTF8&qid=1522179315&sr=8-4&keywords=ch341a&dpID=51BO7eGgO5L&preST=_SY300_QL70_&dpSrc=srch
       
      SOIC8/SOP8 test clip:
      https://www.ebay.com/itm/Soic8-Sop8-Flash-Chip-Ic-Test-Clips-Socket-Adpter-Bios-24-25-93-Programmer/201414947737?hash=item2ee5443399:g:up8AAOSw1Fda8qkt
       
      https://www.amazon.ca/MAUSAN-Socket-Adapter-150MIL-205MIL/dp/B06ZYSNJF3/ref=pd_sbs_21_3?_encoding=UTF8&psc=1&refRID=XM79QJWGED6B4K2VEZDJ
       
      How to use it:
       
      Also, you can search on YouTube a lot of guide for CH341a.
    • By spiderthink
      Hi,
      I am looking to remove the bios wifi whitelist restriction for a Lenovo G700 version 7ACN89WW . This is version 3.07
      I have used a programmer to read direclly from bios chip but it has failed. Is there any other method available to remove bios restriction from this laptop?
       
       
       
    • By AMV
      Hello to all big format laptop users!
      I`ll try to make it as short as possible. I have the Alienware M18X R1 for about 7years, i think. It was a problematic machine all the time. But during warranty period local support fixed everything super fast and free of charge :). I even upgraded from gtx 580m sli to gtc 780m sli. And made primary hdd samsung evo ssd. Unlocked Bios. Power brick i changed 3 times by now. Battery once. And 6moths ago one of the long time ago installed 780m died ( started with artifacts on screen then refused to boot windows). Replaced that and was as happy as ever. The machine kept working stable and i pushed all i could get from it in reasonably modern titles. Even tried RDR2 on default settings, gave me 17fps :). Not sure if SLI is supported for that game. The point is it was running fine for last 6 months.
      What happened:  Gaming as usual, room temp 23C. After around 2hr suddenly black screen. The laptop switched off by itself.
      What i check: First checked power brick. Green light off. Unplug from wall and laptop. After plugging in wall green light back on. Connect laptop light off.
      Next: Tried take out battery, unplug. And hold the PWR button for 1 min. Try to start on battery - nothing. Plug in - green light off again.
      Later: after some googling found that need to try to remove video cards. Done that. OK Nice! Plug in power and it starts as nothing happened on the integrated intel video.
      Found out that i one of the video cards is plugged in that triggers the power brick to trip. (the original upgrade 780m from years ago). 
      Start with GPU: Insert the other one in its slot. Systems start. But immediately i notice there`s no video drivers. OK i think reinstalling and job done. Drivers reinstalled, asked for restart. After restart nothing. Still no driver.
      Windows device manager: This is bogging me. it shows that i have 670M instead of 780m. Windows gives Code 43 Error.
      BIOS: I go into bios just to find that that it has reverted back to A05 (hows that possible?). And its so limited that i cant even choose witch video card to use. But it detects nVidia GFX.
      How to get at least my single 780M to be working?! Update bios again to unlocked? Did this event fry Vbios on my other card maybe?
      System: m18x R1
      SLI gtx 780m
      Unlocked bios (before event)
      nvidia driver 443.x(or there about)
      Win: 7, 64bit
×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use. We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.