Jump to content
EwinRacing Flash Series Gaming Chairs
svl7

Lenovo Y580 / Y480 'unlocked' BIOS versions

Recommended Posts

Looking forward to grabbing a wireless-ac7260 and giving this a go with my y580.

 

Thanks for all your hard work!

Share this post


Link to post
Share on other sites

I don't see why they have these requirements for downloading a file. All it's going to do is piss people off. I guess I'm off to make 4 more shitposts and wait a week to download a file.

  • Thumbs Up 2

Share this post


Link to post
Share on other sites

You're all going to have to accept the fact that you're basically going to have pay the $6 membership fee to have access to these files. I paid the price and it was completely worth it given the amount of time and headaches that were saved.

 

I got the Intel 7260 AC card here: https://www.amazon.com/gp/product/B00MY9S692/ref=oh_aui_detailpage_o01_s00?ie=UTF8&psc=1

 

I have a Y580. My bios version was v2.07. 

 

I downloaded the file named "[Y580][Y480]-'unlocked_BIOS'_660mGHzEdition_WhitelistMod.zip"

 

I got the error about the version not being newer than the current one I have, so I followed these directions:

  • Open platform.ini in notepad.
  • Find the line number 3: "SwitchString=ACEN DCEN CPVER:[1] FHRST RESSEN"
  • Change the "RESSEN" to "RESSDIS"
  • Save the file then launch InsydeFlash.exe.

Done.

Enjoy your new Wi-Fi card.

Edited by schmoofer

Share this post


Link to post
Share on other sites
On 12.10.2016 at 8:43 AM, schmoofer said:

You're all going to have to accept the fact that you're basically going to have pay the $6 membership fee to have access to these files. I paid the price and it was completely worth it given the amount of time and headaches that were saved.

 

I got the Intel 7260 AC card here: https://www.amazon.com/gp/product/B00MY9S692/ref=oh_aui_detailpage_o01_s00?ie=UTF8&psc=1

 

I have a Y580. My bios version was v2.07. 

 

I downloaded the file named "[Y580][Y480]-'unlocked_BIOS'_660mGHzEdition_WhitelistMod.zip"

 

I got the error about the version not being newer than the current one I have, so I followed these directions:

  • Open platform.ini in notepad.
  • Find the line number 3: "SwitchString=ACEN DCEN CPVER:[1] FHRST RESSEN"
  • Change the "RESSEN" to "RESSDIS"
  • Save the file then launch InsydeFlash.exe.

Done.

Enjoy your new Wi-Fi card.

It is reality so easy as written by schmoofer. Okay when you get the f.....g screw out witch one has mounted skew.  Also without to drill round about 5 minutes.

I have also use the AC7260 and V2.07. All files you needed are in "[Y580][Y480]-'unlocked_BIOS'_660mGHzEdition_WhitelistMod.zip" (when u get it). Included antennas working well.

Thx to the community.

Share this post


Link to post
Share on other sites

Somewhere on the Internet I found out that there is also a BIOS which removes the blacklist on other LCD-Panels?
Sadly there were no links. Does this bios do it also?

Share this post


Link to post
Share on other sites

I'm rather pissed, I've been reading and the instructions have been edited to actually make no sense, I even paid for the shtupid monthly crap to get the files but I'm stuck...

Share this post


Link to post
Share on other sites
On 12/08/2014 at 8:28 PM, blowntaha said:

How to setup an eGPU with Y580:

 

  1. Buy/get a PE4L-PM060A adaptor, GPU, and an appropirate PSU which is able to provide steady 12V/16A (or you can use two PSUs if your PSU can provide it but not at a steady rate.).
  2. Although not necessary, go ahead and download svl7's unlocked BIOS here. When I was troubleshooting my setup to get it working, I reverted to stock BIOS thinking the problem lied there, but eventually upon random startups, it would be buggy, and sometimes take a while AFTER rebooting for the display to switch from the internal LCD to an external monitor. Unlocking it lets you change an option that the stock does not allow, it also lets you tweak some other settings which may improve CPU performance.
  3. Go into the BIOS, and under configuration, change SWITCHABLE GRAPHICS to UMA GRAPHICS.
    1.  
    2. If you've unlocked it, go to Advanced settings, then to Video settings, select PCI Graphics (or PCI express, ... I'm writing this from memory), then change primary display to Auto-selected. For some better CPU performance, go to the power tab, CPU settings, then disable C-States, disable MSR Lock, and set the last two settings to the maximum. You can do this by hitting f6/f5 (can't remember which) after highlighting the option. Hit F10 to save and exit. If you don't have Throttlestop 6.0 already, download it, start it, and go to TPL settings (which are now unlocked thanks to disabled MSR Lock), and change 26 to 56 for the time setting, then set the long and short TDP to however you see fit. I personally use 56 for long and 60 for short. Apply, OK. Uninstall your NVIDIA drivers (I recommend DDU) and Lenovo Power Management.
       
    3. Power down everything (duh) and plug the PE4L in the WiFi slot or the empty modem slot (WiFi slot is easier since you can screw it). Flip your laptop over so it is upright, making sure it's on a flat surface. Plug in your GPU and any necessary 6-pin cables from your PSU along with your SWEX. And last but not least the floppy molex, peripheral cable to 4 pin cable onto the PE4L adaptor itself. If you don't have SWEX, you can just grab a paperclip, cut it into a U shape, put one end on the green wire hole space thing on the 20/24 ping PSU power cable and the other end in any black one (there is a black wire right next to the green). Place electric tape over the exposed part of the paperclip to secure it.
      1. If by chance your PSU *should* be capable, but you are having issues (like me), you can use two PSUs by having the second PSU power the PE4L adapter using the floppy molex. Use a second SWEX if you have one, or do the paper clip method.

 

[*]Power up both PSUs (the GPU fan/s should be spinning), wait a second then turn on your y580, install drivers and enjoy.

 

 

I'll post pics later.

3DMARK11.

6111 seems to be my max, since I can't push the clocks further than 1084/3225 core/mem, but it's probably that I don't have a "proper" PSU and/or know the right voltage.

Here's a vantage score, I only ran it once since I don't use it very often.

Has anyone attempted this on a Y510P?

I've already bricked my laptop once and wasted a lot of time fixing it. I don't want to take another chance. I am already on the modified BIOS fw and I do see the options he mentions above, but I don't know if this can also be applied to the Y510P.

When I first bricked my laptop I had changed the PCI graphics to auto (like how he mentioned) and changed the delay time to 3000ms. But I'm not sure which setting had caused the brick since I changed both settings at the same time after reboot. I'm thinking of trying just changing the PCI settings to auto this time but I don't want to brick again. Can someone shed some light on this and tell me if it's a good idea to follow the above instructions or if changing the PCI settings is risky.

Thanks in advance.

Edited by Imrule
Added more info about my situation

Share this post


Link to post
Share on other sites

Thanks for all this work. I always thought modding the bios would be in a pain in this ass with this laptop (y580) and never considered anything past that. Out of curiousity I began to look into after 4 years and I found this site! Now to get enough posts to download the actual file...

Share this post


Link to post
Share on other sites

Guys, I set up hdd password in my bios and I just want to get rid of this password. I tryed a few things but couldn't fix it. Please help.

Share this post


Link to post
Share on other sites
On 01.12.2016 at 0:35 PM, cpzz said:

Guys, I set up hdd password in my bios and I just want to get rid of this password. I tryed a few things but couldn't fix it. Please help.

???

Share this post


Link to post
Share on other sites

Hi all,

 

Nice to see this thread is still alive - I saw blowntaha's post about Y580 eGPU - would the same go for a Y480 using EXP GDC Beast possibly?

And has anyone had success with Y480/580 using EXP GDC Beast and GTX 10XX series cards?

( I know this thread is not about that, but there is some discussion and wondering if this BIOS will benefit).

 

It seems this guy had no problem installing older GPU driver, then upgrading to latest without error 

 

 

 

Share this post


Link to post
Share on other sites
On 11/24/2016 at 2:28 AM, Imrule said:

Has anyone attempted this on a Y510P?

I've already bricked my laptop once and wasted a lot of time fixing it. I don't want to take another chance. I am already on the modified BIOS fw and I do see the options he mentions above, but I don't know if this can also be applied to the Y510P.

When I first bricked my laptop I had changed the PCI graphics to auto (like how he mentioned) and changed the delay time to 3000ms. But I'm not sure which setting had caused the brick since I changed both settings at the same time after reboot. I'm thinking of trying just changing the PCI settings to auto this time but I don't want to brick again. Can someone shed some light on this and tell me if it's a good idea to follow the above instructions or if changing the PCI settings is risky.

Thanks in advance.

I wrote that guide so that you would not run into any trouble under any circumstance (that I could think of). IME it was pretty much plug and play, aside from trying different mPCIe ports. and if I remember correctly, I think I maybe had to disable the iGPU in device manage

Share this post


Link to post
Share on other sites

I see mods for the 2.07 and the 8.01 BIOS version.  When was the unmodified 8.01 issued?  Even checking the Lenovo site, they still have only 2.07 (5DCM40WW) listed as the current BIOS.

Edited by kwm

Share this post


Link to post
Share on other sites

Alright so I have made it back to page 48 so far... still not sure about this but I decided to at least try a few things and see how they went... and apparently for me nothing works in Windows 10 (Yes I am selecting Run as Admin)  but when I go to backup the BIOS a CMD window opens and closes nothing happens. I found an alternative method to backup my BIOS using a Universial BIOS Backup but I Question if I can trust it... 
I couldn't run the HP USB Tool so I used Rufus and tried the version of Free Dos they provide and just seeing if it can see my BIOS when booted I get Error 103. I saw some mention of it but have not found the post so far. Basically it says it cannot find a supported device to flash. 

 

So at this point even if I pay for the modified files I cannot even backup and trust my bios nor flash it. I am hoping this is mainly due to Windows 10 but I am sure with all the other things you guys are working on in here (Graphics Card Pushes etc) that the information is hidden here somewhere but I don't know where yet. 

 

Also I saw mention of Insydeflash. Did someone come up with a way to bypass the DOS Flashing and get it done in Windows and I haven't stumbled across that post yet?

 

Thanks Everyone. 

 

Update:

So I decided to give this a try completely in DOS using my FreeDOS USB I made with Rufus. I made a Backup Folder without the Error 104 fix and one with. Without the Fix I got the 104 error but it saw the Flash Devices, with the fix it doesn't see the Flash devices and gives the 103 error. This makes me wonder if maybe the Fix is my issue since it suddenly cannot see the Flash Devices to even back them up (Which would also prevent flashing the fix obviously).

I guess we will see if this help's find a solution. 

DOS Test.jpg

Edited by Cross
Added more information

Share this post


Link to post
Share on other sites

edit: I accidentally posted this in the wrong forum. Sorry!

 

Spoiler

 

I think I bricked my laptop. I could update just fine, except I couldn't flash the EC. I saw a post which said that it wouldn't be a problem so I just rebooted and could get into bios. I changed the boot device priority to boot from my SSD instead of HDD. I looked at a lot of settings but other than an undervolt of 10mV, I didn't change anything. Now when I rebooted, I get a black screen and the keyboard backlight turns on. Otherwise it's just nothing. I don't think the laptop boots into windows, as just typing the password and pressing enter (the sequence which should get me into windows) does not make any sounds. Therefore I don't think it's just the screen.

 

So my summary is as follows:

1. Flashed modded 3.05, completed succesfully

2. Failed flashing of EC failed, and I just rebooted

3. Entered bios, changed boot device settings and an underclock of 10mV

4. Rebooted

5. Black screen, fan turns on and keyboard backlight turns on. Laptop responds to fn+space to change keyboard lighting and long-press of power button shuts down laptop. Laptop does not boot into windows.

 

I'm right now searching for a few guides on resetting the bios. I read a bit about the contacts behind the RAM which should do something, but I'm having trouble refinding those posts.

 

Any suggestions/quick fixes or things that I can check?

 

Thanks!

 

 

Edited by Blokmeister

Share this post


Link to post
Share on other sites
On 12.11.2016 at 1:43 PM, Kyuusaki said:

Somewhere on the Internet I found out that there is also a BIOS which removes the blacklist on other LCD-Panels?
Sadly there were no links. Does this bios do it also?

What is "blacklist on LCD-Panels"?

Share this post


Link to post
Share on other sites

Is there any possibility to disable GPU throttling with this modded bios? There's no info on 1st page.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Similar Content

    • By pippocarlot
      Hello everyone! I am looking for an answer to a problem I cannot find a solution to ... I purchased an Amd wx 4150 MXM GPU module su e bay to upgrade my HP 8570W Mobile Workstation which is currently equipped with a Fire Pro M4000. Once the new GPU has been installed, the PC screen no longer turns on but works only with external monitors connected via the docking station. The same happens once the drivers are updated! If I put the old card back on, the integrated monitor starts working again ... How can I fix it?
    • By Swick1981
      Bios Release Version – v2.0.0
       

       
      Updated or Modded Items:
      A11 UNLOCKED BIOS FOR m18Xr2 (UNLOCKED BY SVL7 AND FULL CREDIT GOES TO HIM FOR UNLOCKING!)
      SVL7 Also created the PRR2.EXE tool that allows you to flash the new bios by unlocking it.  (FULL CREDIT GOES TO HIM FOR THAT FILE PRR2.EXE)
       
      Here are ALL the things I've added, modded, and enhanced on this bios -
      I've added FULL LEGACY SUPPORT ON THIS BIOS with ONE or TWO CARDS (SLI).  You can FINALLY use Win 7 OS on your machine and run the 900 series GPU's! 
      This is a MAJOR breakthrough!
       
      LEGACY SUPPORT Confirmed.  Works with 900 series GPu's in single OR SLI formation Updated the Intel RST Legacy to v12.9.0.2006 (Supports TRIM in RAID0 - CONFIRMED) Updated Intel RST UEFI to v12.9.0.2006 (Supports TRIM in RAID0 - CONFIRMED) Updated the ONBOARD Video Card for the HD3xxx to v2171 - FROM v2132 Updated ONBOARD Video Card for the HD4xxx to v2171 - FROM v2132 Updated the LAN Firmware & PXE Boot from 2.0.5.9 to v2.0.6.6 ADDED NvMe Support for m18xr2 ADDED M.2 support for m18xr2 Updated CPU Microcode to v29 for the 2900 CPU's Updated CPU Microcode to v1c for the 3900 CPU's Updated GOP Driver for Intel Sandy Bridge CPU Updated GOP Driver for Intel Ivy Bridge CPU Updated MAIN GOP Policy module for the m18xR2 Eliminated some code that wasn't used in the m18xR2 Updated CSM Module (v2) Streamline some coding to make mod(s) run a little more efficiently (v2) Added FPARTS.TXT to rar file in v2. (I had forgot to add it in v1) v2.5 to be released shortly.  I've updated a few more modules that I didn't realize could be updated.  (It's only 3 modules, but it's still an update!)   It should be released in about a week.  Hope this helps ya'll!  
      Instructions to flash:
      Use a flash drive to create a boot disk into dos Unzip ALL files into the root of the flash drive (flash.bat, r2final.bin, fpt.exe, flash.bat, prr2.exe, fparts.txt,m18r2.hdr, m18r2.hdr.bin, readmefirst.txt) BOOT INTO DOS – Note, that when you set the bios to legacy in order to boot into dos, you MAY have to reinstall OS!  (Just be prepared to reinstall no matter what) Once you boot into dos, run the file flash.bat It will unlock your bios (THANKS TO SVL7’s BIOS UNLOCKING TOOL – ALL CREDIT TO HIM FOR THIS TOOL!) Let it flash… Reboot your pc, and enjoy the MASSIVE updates!  
      Be on the lookout as I do plan to release newer version with more updates in the future.  However, it wont be for at least a few weeks as I'm now working on legacy support for the m17xR4 and several other systems.  So please be patient!
       
      ENJOY!
       
      Thread link for more information and discussion:
       
    • By svl7
      NVIDIA 'Maxwell' VBIOS mods
       
       
      Here you find modified VBIOS versions for the mobile parts of the Nvidia 'Maxwell' series.
      The VBIOS versions in this post are tweaked for performance and versatility. You'll get almost complete control over the performance parameters of your GPU.
      List of available VBIOS mods:
       
      Nvidia GTX 970m - 'OC edition' rev0 - >> 6 GB Version << - modified by @johnksss & svl7 -> see attachments Nvidia GTX 980m - 'OC edition' rev0 - >> 8 GB Version << - modified by @johnksss & svl7 -> see attachments  
      Screenshot demonstrating the capabilities of the 970m versions:

      >> Read the instructions carefully before flashing! <<
      If anything is unclear after reading or if you have additional remarks, please post in the thread.
       
      Flashing:
       
      - Go to the device manager -> 'Display Adapters' -> chooser your GPU, right click on it and choose disable
      - Flash the VBIOS with mnvflash, a modified version of nvflash (see attachments). Here are detailed instructions for nvflash in case you aren't familiar with it.
      - After the flashing is done: Enable the GPU once again in the device manager.
      - Reboot
       
      Do NOT use driver 347.09, it's broken and useless and won't allow you to overclock, even with the stock firmware.
      Don't distribute the files hosted here outside of Tech|Inferno. Don't modify the files you download here.
       
      Donation link in case you want to buy me a beer

      Thanks and cheers!
    • By svl7
      Files contained in this archive:
      FTP-DOS.zip prr2.zip M18x R2 - BIOS A03 'unlocked.zip M18x R2 - BIOS A08 'unlocked.zip M18x_R2_-_BIOS_A08_-_[unlocked]_-_[IRST 11.0.6.1702].zip M18x_R2_BIOS_A03_-_[unlocked] - [IRST 11.6.0.1702].zip M18x_R2_BIOS_A09_-_[unlocked].zip [FPT]-M18x_R2_BIOS_A09_-_[unlocked].zip [FPT]-M18x_R2_BIOS_A10_-_[unlocked]_V2.zip M18x_R2_-_BIOS_A08_-_[unlocked].zip M18x_R2_BIOS_A03_-_[unlocked].zip  
      For information on how to use the files in this archive, see here:
       
       
      My donation link in case you want to buy me a beer
×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use. We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.