Jump to content
EwinRacing Flash Series Gaming Chairs
Sign in to follow this  
ikir

Apple Thunderbolt 3 -> Thunderbolt 2 adapter

Recommended Posts

Hi all! I will try as soon as possible new Apple Thunderbolt 3 to Thunderbolt 2 adapter they announced few hours ago. I really hope i can use my homemade Akitio eGPU with Nvidia 970GTX on my MacBook Pro 13" 2016 which i've ordered!

 

I will post here my result, do the same if you can try it sooner than me :P

 

http://www.apple.com/shop/product/MMEL2AM/A/thunderbolt-3-usb-c-to-thunderbolt-2-adapter?fnode=e09572c8ad662aab9372157e6c5dcb44a2b44e8e4960abe33ae51a78ac7c22dc5cb8482fc3bf74c8ef78faa5e3cc9bd0617e305f74aeb2ff79df0a8df9b311188dee46443435dbfc5beafe024c53a502fccecfedeba94a6629caf65f1a1f6e0f

 

 

It would be awesome if we would be able to use our TB2 eGPU without issues.

 

 

 

Edited by ikir
  • Thumbs Up 1

Share this post


Link to post
Share on other sites

Edit: Ignore my post, I see it's already possible.

Edited by rbut

Share this post


Link to post
Share on other sites

You can pick this up at apple stores now (dont order online still 1-2 weeks wait)

 

hoping someone can test this to see if it works.

 

I have a macbook pro retina mid 2012 and hoping i can use this with the either the node or new thunderbolt devices! 

  • Thumbs Up 1

Share this post


Link to post
Share on other sites

I'm following this, since probably I'm going to get a older gen second hand mbp. Would be nice to have the possibility to use the node on that with an adapter and have it ready for a future purchase of a mpb.

Share this post


Link to post
Share on other sites

Edit: Didn't see this thread. Hopefully this works!

Edited by Slovedon

Share this post


Link to post
Share on other sites

I've sold my eGPU, so I will not able to test it with my incoming MacBook Pro.

 

Now I must hope to see Akitio Node compatibility updated with Mac support!

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

  • Similar Content

    • By bigubig
      need to install other manufacturer wifi card
    • By juquinha
      Hi!

      So, i got a strange situation here. I have an old Asus ROG G751JM laptop connected to an old Samsung monitor (Model S20C301L) through a VGA connection.
      This monitor supports both DVI-D and VGA inputs, while my laptop can output through VGA, HDMI or Thunderbolt/Mini DIsplayport. I wanted to upgrade to digital signal, so i bought an Thunderbolt/Mini DIsplayport to DVI cable.
      At first, it was a nightmare. There was absolutely nothing i could do to get it to work. I spent hours troubleshooting, but the monitor just could not detect any signal, only VGA one. But then this happens.
      I was testing with only one connection at once and i got tired of plugging and unplugging the cables every time. So i had the idea to keep both cables plugged in and change the source detection in monitor's menu when i wanted to. So, with the TB/MiniDP cable already connected, i've then connected the VGA cable (while DVI was selected as input source). The display started flashing. After 2 seconds, voilà, it was working. And i was like, "what the f***???" I've then unplugged the VGA cable, signal lost. Plugged it again, got digital signal.
      Well, i'm happy that it's working now, but i simply don't understand what's happening here. Why is that i need both connections simultaneously to make it work? WIll that still happen if i use a HDMI to DVI cable?
      Fun fact: the image displays only after windows startup. So, if i want to enter BIOS setup for example, i need to switch back to VGA as input source.
      Sorry for my english.
       
      Update: Can't run games with It, i get bsod.
    • By Bullfrog098
      Hi, just a quick question what would be the best EGPU adapter, because i see the really expensive ones but then you have the 400$ dollar one that Lowspecgamer used. Which do you guys recommend ?
    • By Bos Maior
      Hey guys,
       
      This is a thread for sharing what you have learned about configuring a graphics card using Gerald's Y510p Ultrabay Graphics Adapter. It was created to make it easier for new users to find the information they need to successfully configure and use the adapter on their computer. I consulted Gerald before creating this thread.
       
      Please feel free to post information, insights and tips below.
       
      The Y510P Graphics Adapter
       
      What is it?
       
      The Y510P Graphics Adapter is a card which will allow you to use a full-length PCIe desktop graphics card with a Lenovo Y410p or Y510p laptop. It plugs into the device's Ultrabay. This is the swappable device bay which is, for instance, used for the second NVIDIA card in Y510P SLI configurations.

      Please be aware that the Y510P Graphics Adapter is currently only compatible with the Y410p and Y510p. It is not compatible, then, with the Y500 and other Lenovo or IBM laptops that feature an Ultrabay. The Y510P Graphics Adapter was developed by Gerald, a member of this forum.
       
       
      What it needs to run - hardware
       
      In addition to the Y410p/Y510p laptop itself, the Y510P Graphics Adapter requires a separate power supply unit (known also as a PSU) to provide the graphics card with electricity. An actual PCIe graphics card is, of course, also required.
       
      If you are going to use the power supply unit to power the Graphics Adapter and the graphics card plugged into it only, a 450-watt unit will likely suffice, at least for current graphics cards. While graphics cards manufacturers may advise you to obtain a more powerful PSU, this is because the PSU would normally also be used to power other components, such as the hard drive and CPU. Note that the Radeon RX Vega 64 and R9 Fury X are exceptions to this rule, as they have been shown to draw close to 500 watts of power when they are under a lot of strain.
       
      Please note that without further modifications only AMD graphics cards will work, due to checks that are carried out by the computer on startup. High_Voltage has made two mods which should allow you to use an NVDIA card with the Graphics Adapter: a BIOS mod and a hardware mod:
       
      * Thread on the BIOS mod: https://www.techinferno.com/index.php?/forums/topic/12014-lenovo-y410py510p-bios-mod-to-enable-nvidia-egpu-support/
      * Post on the hardware mod: https://www.techinferno.com/index.php?/forums/topic/9686-y510p-ultrabay-graphics-card/&do=findComment&comment=163854
       
      Please be aware that flashing your BIOS is potentially dangerous, even if the BIOS you are installing is an official version. To minimise the risks, always back up your data first and make sure that your laptop is fully charged and connected to the electrical grid before you start the flashing process.
       
      What it needs to run - software
       
      Three versions of the Y510P Graphics Adapter exist:
       
      * Version 1: this is the experimental version which Gerald originally posted about.
      * Version 2: this is the version that Gerald sold in 2016 and part of 2017. It requires BIOS version 2.07 and Windows 10 to function. Earlier BIOS versions may also work.
      * Version 3: this is the version Gerald is selling at the moment of writing. Thanks to a discovery first posted to the forums by user David 'Soap' Washington, it should work with any BIOS version, as long as one uses an AMD graphics card rather than an NVIDIA one. It may also work Windows 7, 8 and 8.1, in addition to Windows 10. I am currently using this version of the adapter with Windows 10, using BIOS version 3.08.
       
      Videos on installing and using the Y510P Graphics Adapter
       
      Note that these videos only illustrate the installation process and performance with AMD cards.
       
      * Installing the adapter:
       
      - By Tesla: a general introduction on Version 2 of the adapter and how to install it: https://www.youtube.com/watch?v=KL7muHXsAmI
      - By ManyStrongWords/Go'Vic Gaming: a video on installing Version 2 of the adapter: https://www.youtube.com/watch?v=4pviqwFRDn4
       
      * Gameplay/performance:
       
      - By Tesla: using an AMD RX 470 with the adapter: https://www.youtube.com/watch?v=SqdDeZ0UCgc
      - By me: using an AMD Vega 56 with the adapter: https://www.youtube.com/watch?v=PVbsib8eHRg&t=25s
       
      Other useful videos
       
      * Removing the Y510P Ultrabay, by Someone7089: https://www.youtube.com/watch?v=tYcVlaMV0Ig
       
       
      Example of a configuration using the adapter
       
      My own configuration consists of the following:
       
      * Lenovo Y510P with an Intel Core i7-4700MQ CPU, 16 GB RAM and an Intel SSD hard drive;
      * iiyama G-Master GB2888UHSU 4K monitor;
      * Gerald's Ultrabay Graphics Adapter, version 3;
      * AMD RX Vega 56 graphics card;
      * Corsair 450W PSU;
      * OS: Windows 10 Creators' Update.
       
      Below is an overview of the steps I had to take to get this configuration to run well on an existing Windows 10 Creators Update install. Note that when I installed a fresh copy of the Fall Creators Update, Windows automatically recognised my hardware, monitor included, and I did not have to disable the other graphics adapters. I do find I sometimes have to reinstall the graphics drivers, as updates in AMD' s driver package sometimes result in The Witcher 3 crashing when a cutscene is played.

      *****
       
      In order to get my configuration to run well on an existing Windows 10 Creators Update install, I had to do the following:
       
      * Run the monitor at its native resolution.
      * Install the appropriate driver for the monitor, instead of the generic one provided by Microsoft.
      * Disable both the NVIDIA GeForce GT 755M and the Intel HD Graphics 4600 display adapters in the device manager.

      Note 1: removing the drivers for your Intel and NVIDIA display adapters is unnecessary. It is also likely to be futile as, ultimately, Windows may reinstall the driver even if you disable automatic driver updates.
       
      Note 2: an HDMI connection with your monitor should work just fine without you disabling the Intel HD Graphics 4600. A Displayport connection, however, will probably only work as intended if you do disable the Intel display adapter. If you do not do this, Windows will completely duplicate the video output displayed on the internal monitor on the external monitor, including the internal monitor's resolution. Note that this is not the ordinary 'duplicate screens' feature as there is no way to disable it until the Intal graphics adapter is disabled.
       
      A Displayport connection is generally preferable since most Freesync-capable monitors do not support Freesync over HDMI. Also, AMD cards usually do not output colour depths over 8bpc over HDMI connections.
       
      Note 3: should you find that the backlighting of the internal monitor remains on even though only the external monitor is active, all you have to do is press the FN and F2 keys at the same time. This will switch off the internal monitor.
       
       
    • By High_Voltage
      In case you own a Lenovo Y410p or Y510p laptop, you might be interested in upgrading its performance by installing an external graphics card. Ultrabay eGPU adapter designed by @gerald was proven to be a convenient plug-and-play option to do exactly that. However, for a long time only an AMD-branded GPUs could be used due to limitations in the Lenovo's stock BIOS. The purpose of the modified firmware presented here is to expand the range of available GPUs by enabling Nvidia support on Gerald's Ultrabay eGPU adapter.
       
      Huge thanks to:
      @MWichni - For efficiently assisting me during the development of this mod. By flashing dozens of BIOS builds over the course of several weeks and thoroughly describing the effects observed (or the lack thereof), he enabled me to fully understand necessary parts in BIOS structure and come up with a final solution. @svl7 - Whose unlocked BIOS / Whitelist mod has served as a basis for this modification. His discovery of a security hole in V2.07 BIOS has provided us with a convenient BIOS flashing method that does not require a physical programmer. The Unlocked BIOS and WLAN whitelist mods originally designed by him are also implemented in this BIOS mod. @gerald - For designing the aforementioned adapter. Without it, all this work would make very little sense.  
      Key features:
      Resolves the "40-second reboot" issue normally encountered while using Nvidia graphics cards with Ultrabay eGPU adapter, thus allowing all Nvidia cards to be used. Based on the latest V3.08 BIOS. Includes Svl7's WLAN whitelist removal mod - for the convenience of aftermarket WLAN card users. Includes Svl7's BIOS debug menu mod - for the ease of experimentation with newly available features, e.g. attempting to use Nvidia Optimus to pass eGPU video back to laptop's display.  
      NB! Svl7's Debug Menu is not a toy! It contains a lot of options that are either not supported or partially supported by the hardware platform and/or can disturb its normal operation or prevent the PC from booting up at all. Any of the entries not originally present in the stock BIOS should be modified at your own risk!
       
      DISCLAIMER:
      ANY MODIFICATIONS YOU ARE APPLYING TO YOUR HARDWARE ARE PERFORMED AT YOUR OWN RISK! AUTHOR OF THIS MOD DOES NOT HOLD ANY LIABILITY FOR LOSS OR DAMAGE RELATED TO USING THIS SOFTWARE.
       
      Screenshots:
       
      Installation instructions:
       
      If things don't go right:
       
      Error 43:
      If you intend using the GTX10XX-series Nvidia card as the eGPU (which you probably do), you are very likely to encounter the infamous Error 43 in Windows Device Manager. This is a widely known issue in the eGPU community and is not related to this particular mod in any way. Following this guide thoroughly will in most cases resolve the Error 43 issue.
       
      Download:
      Get your copy here!
       
      P.S.:
      Version of this mod for Lenovo Y400/Y500 models is coming soon!
       
×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use. We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.