Jump to content
EwinRacing Flash Series Gaming Chairs
svl7

Lenovo Y410p / Y510p - unlocked BIOS / wlan whitelist mod / vbios mod

Recommended Posts

I'm not sure I'm following what's going on here correctly. I'm ordering this laptop later today with the intel 7260 card to get better wireless. Would I be able to do this with the BIOS fix to make SLI work in 8.1? Or are we still waiting for the fix for that?

Thanks!

Share this post


Link to post
Share on other sites

@dmgloden

Wow didn't notice that I guess because I didn't recheck it after the upgrade. Using OS X 10.9, and windows 8.1 pro the IGU appears disabled. I never usually only am able to detect it if the ultrabay card is out of the system. I imagine is could then potentially make use of Optimus in windows? I can't get OS X to do anything with the card even after it recognizes and loads the display -- well it won't enable QE CI. *sigh* at least everything seems to be working again in 8.1 ^_^

@theholyfork

The bios OS the laptop is independent of the VBIOS on the video cards. The bios of the system (CMOS) is restricted with a whitelist that prevents the installation of other wireless cards. The VBIOS is a component of the graphics system, and I believe for two nvidia cards to operate in SLI they need to be the same down to the VBIOS. I could easily be wrong, and the best cure for that is research. That's my understanding of the situation. Lenovo posted a fix for the VBIOS a while back, and the de-whitelisting mod is available here. You might be able to use the other card you ordered, I'm not aware of what adds are actually on the list other then the 2230. It's a great system if you just wanna run windows, before I upgraded I tried an install of windows 7, and after switching the HDD for the OCZ vertex 450, the "windows experience" jumped from 5.6 to 7.6 (CPU was the lowest scoring benchmark, not bad).

Haven't tried gentoo but ubuntu plays nice.

  • Thumbs Up 1

Share this post


Link to post
Share on other sites
@dmgloden

No worries! You IGU is by default, disabled! Windows runs on the first 750m card that you can't remove. If you're having an issue activating SLI there is an update in the lenovo forms where moderators in line with tech support first released the fix for windows 8.1. The issue is that when the new driver (anything newer than the release in sometime this last April) would break SLI functionality. After many complaints on the forum, they released new drivers and specifically -- this is Key -- a VBIOS update for the ultrabay 750m card which wasn't receiving the intended VBIOS update that apparently was already performed on the internal dedicated 750m. I don't understand how that works entirely, but for SLI to function I know the cards usually need to be the same so maybe the different VBIOS created an issue in windows 8.1.

Performing the steps listed on the site I was able to restore SLI with the ultrabay card in windows 8.1 pro. I'll edit try to get the link up here if you can't find it on their forums. A lot of people are having trouble with the fix, but it was pretty simple for me — I mean, you unzip a file, run a bat, and click y, then restart lol.

Sent from my iPad using Tapatalk

Seems to me like Windows runs on the IGU by default, and then you can choose which card to run 3D applications on. I'm on 8.1 as well.

Share this post


Link to post
Share on other sites

Has anyone changed any parameter in the modded BIOS? I've seen many things that I want to change but first I need to confirm if anything works without breaking something (I'm from Argentina and if I break somenthing bye bye notebook)

Share this post


Link to post
Share on other sites

I planning to buy the y510p From newegg. I will do the mod after I get the laptop, and I am wondering will a Killer wireless card work? I am new to this modding stuff.

Share this post


Link to post
Share on other sites
I planning to buy the y510p From newegg. I will do the mod after I get the laptop, and I am wondering will a Killer wireless card work? I am new to this modding stuff.

It should as long as it it's a two antenna card.

Share this post


Link to post
Share on other sites

I would agree.

I don't like how you cannot set everything from the NVIDIA Control Panel, but if you right-click the file/program you want to open/run, you can choose the GPU there.

I will say having your system run in the Intel IGPU does conserve battery, which is nice for when I am out n' about.

Share this post


Link to post
Share on other sites

Hi, I just bought this laptop as of today and managed to change the HDD for my SSD and fougth for the last couple of hours with EFI, Secureboot and drivers. I did notice that the Wifi card is pretty much the worst I have ever seen, and modding the BIOS seems like a very promising solution, however, I am stuck with the new BIOS 3.05

Two questions here :

1 - Where do you find the older bios versions? I have enabled the flashing of older version, so in theory I could just reflash an older one.

2 - svl7: modding theses BIOSes is truely amazing, how do you proceed and can I help in the development of the 3.05 mod?

Share this post


Link to post
Share on other sites
Sleep now works again!

The sleep problem with AC7260 and Bluetooth now seems to have been fixed, thanks to driver version 16.6.0. :-)

I installed the above new version but still having trouble with the sleep function, same old where it tries to go sleep, keyboard lights goes out, then came back on with a black screen, if I hit a key or move the mouse screen will be on right away to ask for login prompt.

I'm still running win 8 not 8.1 is that a factor?

Share this post


Link to post
Share on other sites

For all of you who are probably reading this thread after horrible disappointment of the Wifi card : I managed to fix all of my problem by downloading the new Windows 8.1 driver directly from the Intel website. Just before installing it, I uninstalled the current one in the device manager and proceeded to the installation.

Note that Windows update still thinks he is better than me, and wants to "update" my driver to the Windows 8 version, which was causing the disconnections in the first place. You can kill these notifications by right-clicking on the update in the Windows update and tell it to never notify you anymore for that specific update.

It has been working wonderfully for several hours now, including multiple torrent downloads at 30mbits/s. You still don't get the 5Ghz support nor the AC standard, but at least the standard N is decent.

Share this post


Link to post
Share on other sites
I'm still running win 8 not 8.1 is that a factor?

Yes when it comes to drivers, Windows 8.1 is very different than Window 8. That change in naming convention from Microsoft suggests an upgrade, but we should consider it as a different version of the OS, same as Vista and 7

Share this post


Link to post
Share on other sites

I just got my Y410P. Great machine. Touch pad is cheap though. Replaced the HDD with an SSD. Everything is great. Now I'm learning that I need to flash the BIOS just so I can upgrade my WiFi card. How ridiculous. What does Lenovo really think they are helping by preventing you from using different wireless cards?

Share this post


Link to post
Share on other sites

Hi,

Just received a y510p today. It has Windows 8, and I have an Intel 7260 card that has an IBM part number on it. Still, the y510p rejects it as unauthorized. The BIOS is 74CN44WW (version 3.05) dated 9/18/2013. The SMBIOS is 2.7. How can I get the machine to accept the 7260 card with this BIOS. Some of the earlier posts are a bit confusing.

Need help asap!

Thanks

Share this post


Link to post
Share on other sites

Could someone of you guys try to contact the Lenovo support and ask for a bios update?

On the support site they say this:

My machine encounters a specific problem, only BIOS update can fix it. What do i do next?

Please contact the Technical Support for further assistance.

Just tell them some story about your system is having a specific issue that doesn't occur on the system of your friend which is running bios 3.05 or something like this.

A bios update would be nice for most people here. I'd call them myself but I don't have any service tag or similar to feed to the telephone guys.

Share this post


Link to post
Share on other sites

Here is some more detail: the card has IBM FRU 0$T2eC16ZHJGsFFMlgNbf3BS%281d6oFNw%7E%7E60_57.JPG4w3814. The Broadcom $T2eC16Z,%21%29%21FIc4z7yg5BSIRjeuShQ%7E%7E60_57.JPGcard I tried which also did not work had the following part #04w3764, Attached are photos

Share this post


Link to post
Share on other sites
Could someone of you guys try to contact the Lenovo support and ask for a bios update?

On the support site they say this:

Just tell them some story about your system is having a specific issue that doesn't occur on the system of your friend which is running bios 3.05 or something like this.

A bios update would be nice for most people here. I'd call them myself but I don't have any service tag or similar to feed to the telephone guys.

Because of the restart issues ? i can do i was just wondering why.

Share this post


Link to post
Share on other sites
Cause I'm lazy and it is much easier to only mod one bios :D

I did not have any luck on the phone. Would appreciate help asap.

Share this post


Link to post
Share on other sites

How do I check the bios version? I want to removed the white list but I'm not sure if my Bios version one of the ones supported in your first post.

Share this post


Link to post
Share on other sites

How do I check what bios version I have? I want to remove the whitelist and install the intel 7260AC wireless card, but I'm not sure if my bios is one of the versions listed in the first post.

Share this post


Link to post
Share on other sites
How do I check what bios version I have? I want to remove the whitelist and install the intel 7260AC wireless card, but I'm not sure if my bios is one of the versions listed in the first post.

It's telling you that in the bios

Share this post


Link to post
Share on other sites
Cause I'm lazy and it is much easier to only mod one bios :D

I called the danish division, and they there not really helpfull the said i should send it in for rma so no luck here :(

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Similar Content

    • By mssfss
      hi,
       
      I need a help to remove whitelist from bios to install my new wlan.
       
      model :lenovo g405 
       
      thanks.
       
       
      https://www.sendspace.com/file/7gvm11
    • By bunk42
      I have a Lenovo Thinkcenter Edge92z  type3396 model c7u.  I need to whitelist wirelesss card... BIOS Version/Date LENOVO 9XKT25AUS, 4/16/2013
       
      bios backup: https://drive.google.com/file/d/1ObnGVJGIsknhgs1WM3710sUlTCk7xen-/view?usp=sharing
       
      Thanks in advance
    • By bunk42
      I have a Lenovo thinkcenter edge92z type3396 model c7u need to whitelist wirelesss card... BIOS Version/Date LENOVO 9XKT25AUS, 4/16/2013 bios backup: https://drive.google.com/file/d/1ObnGVJGIsknhgs1WM3710sUlTCk7xen-/view?usp=sharing    
    • By blaz_evic
      Hello

      I upgraded my old laptop with i7-3632qm and its working fine, temps are ok but he wont boost. Lenovo g500s could be bought with i7-3632qm and it had same cooling as was 2020m so i dont think cooling is problem. Can i bios unlock? I cant acces advanced settings in bios. i need help

      thanks
×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use. We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.