Jump to content
EwinRacing Flash Series Gaming Chairs
J95

[Alienware - Clevo - MSI] Aftermarket Upgrades Driver Support - Modded INF

Recommended Posts

after reading threw some of the posts I see that the alienwares seem I have to modify a different inf file. I was modifying the .nvdim one that I got from other forums not the one I see you guys talking about on this thread. could this be my problem with getting the drivers to install??

hi friend, I've been through a lot in my alienware ... you need to modify the "nvdmi.inf" it is the KEY to get ... go and success!

Share this post


Link to post
Share on other sites
hi friend, I've been through a lot in my alienware ... you need to modify the "nvdmi.inf" it is the KEY to get ... go and success!

hello Fergus, thanks for responding. the problem im having is all the new drivers I download from all the sights to include eurocom don't have the nvdmi.inf, they only have a nvdmi, with no .inf at the end of the file. I have done two other laptops an older m17x r2 that I yanked out the 260's and put a 680m in, and my old m17x r3 that the gtx 580m went bad so I replaced it with a 880m, and those drivers have the nvdmi.inf file and I modded those and they work great. getting ready to pull my hair our!!!

Share this post


Link to post
Share on other sites
hello Fergus, thanks for responding. the problem im having is all the new drivers I download from all the sights to include eurocom don't have the nvdmi.inf, they only have a nvdmi, with no .inf at the end of the file. I have done two other laptops an older m17x r2 that I yanked out the 260's and put a 680m in, and my old m17x r3 that the gtx 580m went bad so I replaced it with a 880m, and those drivers have the nvdmi.inf file and I modded those and they work great. getting ready to pull my hair our!!!

Right... even the coming of Eurocom drivers I've already made the changes and functioned good ... sorry the question but you allowed to view the extent of common files?because HAVE to be the nvdmi.inf or nvdm.inf that are key to the alienware ...

The old drives are nvdm.inf and current nvdmi.inf ... I know it was a basic question, but that no extension would be useless file ... check if the extensions are actually released on Tools / Folder Options / View common extensions ... to finding strange that ...

Share this post


Link to post
Share on other sites
    This is a GeForce Hot Fix driver, version 358.59 that addresses the following issues:

  • G-Sync Windowed mode & full-screen performance issue
  • Undocumented bug fixes...

    *Install drivers at your own risk* Windows 10 + Official 353.62 Drivers are Killing Samsung and LG Notebook LCD Display Panels



  • Win8.1 'F8' Boot options 'Safe Mode' & 'Disable driver Signing'

    cmd (Admin)
    bcdedit /set {default} bootmenupolicy legacy
    -> reboot -> F8 -> select 'Disable Driver Signature Enforcement' -> Install drivers.



  • Extract driver using [url=http://www.7-zip.org]7-Zip
  • [/url]
  • Display.Driver folder -> copy/overwrite the proper .inf file
  • Extracted driver package -> run setup.exe

    INF MOD v358.59

    nv_dispi.inf (including nvdmi.inf) PEG/Dedicated All Models: M15x, M17x, AW17 R1, M18x, AW18 R1 (including Optimus/M17xR4) excluding AW 2015 - GTX 980M , 970M , 965M , 880M , 870M , 860M , 780M , 770M , 765M , 680M , 675MX , 670MX , 660M
    


    nvcvi.inf: Optimus Alienware 17 / 05AA (only) GTX 980M - 970M - 965M
    




GeForce 358.59 HF

Share this post


Link to post
Share on other sites
Quote

Why is the nvdmi.inf being included for the dedicated mode?

Sent from my HTC One using Tapatalk



Because the ID of the Alienware machines are not inserted in many of today's drives ... at least with the GTX780 NO nvdmi.inf I had my ID ... by manually entering all the drives worked ... can not be the case with colleague above, but I'm trying to give the solution that I managed ...

- - - Updated - - -



Quote

  • This is a GeForce Hot Fix driver, version 358.59 that addresses the following issues:
  • G-Sync Windowed mode & full-screen performance issue
  • Undocumented bug fixes...

    *Install drivers at your own risk* Windows 10 + Official 353.62 Drivers are Killing Samsung and LG Notebook LCD Display Panels
  • Win8.1 'F8' Boot options 'Safe Mode' & 'Disable driver Signing'

    cmd (Admin)
    bcdedit /set {default} bootmenupolicy legacy
    -> reboot -> F8 -> select 'Disable Driver Signature Enforcement' -> Install drivers.
  • Extract driver using 7-Zip
  • Display.Driver folder -> copy/overwrite the proper .inf file
  • Extracted driver package -> run setup.exe

    INF MOD v358.59

    nv_dispi.inf (including nvdmi.inf) PEG/Dedicated All Models: M15x, M17x, AW17 R1, M18x, AW18 R1 (including Optimus/M17xR4) excluding AW 2015 - GTX 980M , 970M , 965M , 880M , 870M , 860M , 780M , 770M , 765M , 680M , 675MX , 670MX , 660M
    


    nvcvi.inf: Optimus Alienware 17 / 05AA (only) GTX 980M - 970M - 965M
    


GeForce 358.59 HF



Could you give me a help with my gtx 780m? I am using overclocked to control the temperature, there is a better way to achieve this?
  • Thumbs Up 1

Share this post


Link to post
Share on other sites
Because the ID of the Alienware machines are not inserted in many of today's drives ... at least with the GTX780 NO nvdmi.inf I had my ID ... by manually entering all the drives worked ... can not be the case with colleague above, but I'm trying to give the solution that I managed ...

- - - Updated - - -

Could you give me a help with my gtx 780m? I am using overclocked to control the temperature, there is a better way to achieve this?

Fergus for the love of god, don't overclock... You are increasing temps.. How many times to tell you?

Also when are you getting Gelid GC Extreme?

Sent from my LG-H811 using Tapatalk

Share this post


Link to post
Share on other sites
Fergus for the love of god, don't overclock... You are increasing temps.. How many times to tell you?

Also when are you getting Gelid GC Extreme?

Sent from my LG-H811 using Tapatalk

hi Tom*, nice if someone at least tell me the correct procedure I thank you ... I'm not using it over to improve capacity but limit the max temperature that my GPU can use ... I am using so far the AS5 folder decreased by more than 20C temp ... if I do not use my temperature go to over 94C, with overclock down to 60C ... is it wrong this? if you answer yes, I stop immediately, I'm using VBIOS unlocked by slv7 ... need info on how to control my Temp... this single solution for me so far ... grateful for the help!

Share this post


Link to post
Share on other sites

Now I now all about display dying out but can anybody tell me , I am running now Win 10 AW17 with 353.50 and its been running fine for more then 2 months ? can I update to a newer one ?

Share this post


Link to post
Share on other sites
Now I now all about display dying out but can anybody tell me , I am running now Win 10 AW17 with 353.50 and its been running fine for more then 2 months ? can I update to a newer one ?

Same here...any news?

Share this post


Link to post
Share on other sites
Quote

hi Tom*, nice if someone at least tell me the correct procedure I thank you ... I'm not using it over to improve capacity but limit the max temperature that my GPU can use ... I am using so far the AS5 folder decreased by more than 20C temp ... if I do not use my temperature go to over 94C, with overclock down to 60C ... is it wrong this? if you answer yes, I stop immediately, I'm using VBIOS unlocked by slv7 ... need info on how to control my Temp... this single solution for me so far ... grateful for the help!

Please use the search function...Thermal Pad Placement [url]http://forum.techinferno.com/alienware-m17x-aw-17/3702-m17x-r3-gpu-upgrade-gtx-780m-23.html#post71956[/url]

Quote

Now I now all about display dying out but can anybody tell me , I am running now Win 10 AW17 with 353.50 and its been running fine for more then 2 months ? can I update to a newer one ?

Uninstall PrecisionX & MSI Afterburner (Keep RTSS)...time wasted looking for non-existent rootkits. Nvidia...fixing their mess silently...until then, I'm not uploading any win10 mods.



- - - Updated - - -



GeForce 358.70 Dev



    Fixes (over 356.04):

  • Updated driver support for GameWorks VR SDK, adding notebook support, VR SLI enhancements, and bug fixes.



    *Install drivers at your own risk* Windows 10 + GeForce Drivers are Killing Samsung and LG Notebook LCD Display Panels



  • Win8.1 'F8' Boot options 'Safe Mode' & 'Disable driver Signing'

    cmd (Admin)
    bcdedit /set {default} bootmenupolicy legacy
    -> reboot -> F8 -> select 'Disable Driver Signature Enforcement' -> Install drivers.



  • Extract driver using [url=http://www.7-zip.org]7-Zip
  • [/url]
  • Display.Driver folder -> copy/overwrite the proper .inf file
  • Extracted driver package -> run setup.exe

    INF MOD v358.70

    nv_dispi.inf (including nvdmi.inf) PEG/Dedicated All Models: M15x, M17x, AW17 R1, M18x, AW18 R1 (including Optimus/M17xR4) excluding AW 2015 - GTX 980M , 970M , 965M , 880M , 870M , 860M , 780M , 770M , 765M , 680M , 675MX , 670MX , 660M
    


    nvcvi.inf: Optimus Alienware 17 / 05AA (only) GTX 980M - 970M - 965M
    




    GeForce 358.70 Dev

Share this post


Link to post
Share on other sites

J95 what's the secret of Geforce 353.06 PEG MOD Throttling fix drivers? Why the results cannot be replicated in newer drivers like these 358.70 Dev drivers? I'm installing all new drivers with only the recommended directories and using the P0 - P1 switching procedure but even so some throttle occurs when 980M SLI reaches above 95% gpu utilization but that don't happens when using old 353.06 mod drivers.

Share this post


Link to post
Share on other sites
J95 what's the secret of Geforce 353.06 PEG MOD Throttling fix drivers? Why the results cannot be replicated in newer drivers like these 358.70 Dev drivers? I'm installing all new drivers with only the recommended directories and using the P0 - P1 switching procedure but even so some throttle occurs when 980M SLI reaches above 95% gpu utilization but that don't happens when using old 353.06 mod drivers.

Try this new mod...included CUDA 7.5 and updated game profiles. I haven't had time to test...

@kenny27

@juang1985


    Uninstall PrecisionX & MSI Afterburner (Keep RTSS)
  • DDU "Clean & Shutdown"
  • Disable DSE
  • Display.Driver folder -> copy/overwrite nv_dispui.inf.
  • NV Inspector P0/P1 matching.

    PEG/Dedicated All Models: M15x, M17x, AW17 R1, M18x, AW18 R1 (including Optimus/M17xR4) excluding [S]AW[/S] 2015 - GTX 980M , 970M , 965M , 880M , 870M , 860M , 780M , 770M , 765M , 680M , 675MX , 670MX , 660M


    GeForce 353.90 PEG MOD

nv_dispui.inf_v353.90_Win7_8.1_PEG_MOD.zip

Share this post


Link to post
Share on other sites

Thanks J95, I will test it and a few days I will post the results with this new modded driver. Btw I'm using default 980M Clevo BIOS in M18X-R2, its working better for me than prema bios(tested both Clevo and AW modded vBios) but I know that is intended for Alienware 18 not for M18X.

  • Thumbs Up 1

Share this post


Link to post
Share on other sites
Thanks J95, I will test it and a few days I will post the results with this new modded driver. Btw I'm using default 980M Clevo BIOS in M18X-R2, its working better for me than prema bios(tested both Clevo and AW modded vBios) but I know that is intended for Alienware 18 not for M18X.

If it still throttles then I'll need to start from scratch...355.xx major changes (logging...next INF checksum...hopefully not).

Try first Prema's v1.1 -> v1.1.1 including stock v84.04.22.00.12 (SLI) & v84.04.22.00.10 (Single) NV Inspector P0/P1 matching.

- - - Updated - - -

We still need stock vbios 3D voltage & ASIC readings, please post results here.

ng6ue4J.png


---------------------------
Checksum information
---------------------------
Name: Clevo_Stock_84.04.22.00.12.rom
Size: 185344 bytes (0 MB)

SHA1: 8D8A4F36C8A667E7670FCDBA4A3FE5C8829A342E

---------------------------
Checksum information
---------------------------
Name: Clevo_Stock_84.04.22.00.10.rom
Size: 185344 bytes (0 MB)

SHA1: D85DBDDE1B82DFFCB93B60650CA69B65D13113DA

UEFI NVFLASH_WIN_5.218_x64 (password premamod.com)

Clevo_Stock_980M_v84.04.22.00.12.rom.zip

Clevo_Stock_980M_v84.04.22.00.10.rom.zip

Share this post


Link to post
Share on other sites

post-12287-14495001017707_thumb.jpg

stock vbios 3D voltage & ASIC reading stock v84.04.22.00.12 (SLI)

GPU 0

post-12287-14495001018024_thumb.jpg

GPU1 much better asic points (tested playing Ryse at 2x supersampling)

post-12287-14495001018383_thumb.jpg

As you can see in GPU1 sensors, while I was playing Ryse there was some kind of throttle but this time a little different from before, if the gpu level utilization is below 95% there is no throttle at all but enabling supersampling 2x in this game and GPU utilization goes up to 99% level the throttle occurs and at some seconds and goes away and goes back again

post-12287-14495001019162_thumb.jpg

I think this driver is very good compared to others because almost no game pushes beyond 95% utilization anyway.

Update: In The Witcher 3 the same occurs, you can play normally till there is too much is happening at screen at once (like a battle with many soldiers or beasts) and gpu utilization goes up to 96%, the throttle occurs again and goes back to normal when gpu is not taxed too much in game. Btw Witcher 3 with all on ultra and physx on 1920x1080

Later I'll post results with prema bios.

post-12287-14495001018658_thumb.jpg

  • Thumbs Up 1

Share this post


Link to post
Share on other sites

@Tulius avoid supersampling/downsampling...DSR, single GPU NV throttling free mods v350.12, v353.00, v353.06 & @Prema's vbios mod v1.1, P0/P1 max settings...99% GPU utilization without any throttling, enabling DSR introduces throttling no matter what settings I used.

Share this post


Link to post
Share on other sites
@Tulius avoid supersampling/downsampling...DSR, single GPU NV throttling free mods v350.12, v353.00, v353.06 & @Prema's vbios mod v1.1, P0/P1 max settings...99% GPU utilization without any throttling, enabling DSR introduces throttling no matter what settings I used.

Ok, in some games like Ryse and Sniper Elite III there's an in game 1.5x and 2x supersampling that simulates 3840x2160 resolution, DSR is off in Nvidia control panel and I'm not using any overclock at all in gpu avoiding to tax the PSU. I know that single GPU is fine but I'm trying to find the sweet spot for a SLI config I hope its possible but maybe thats not happening with a single 330w PSU.

Btw I testing Prema bios 1.1.1...

post-12287-14495001021822_thumb.jpg

This is the result testing 3dMark Fire Strike performance... there's some throttle now and I'm using the default Fire Strike test not the extreme or advanced, that's not happening with default Clevo bios

post-12287-14495001022166_thumb.jpg

With Witcher 3 the throttle starts when gpu utilization goes beyond 95% all ultra, phyx on, 1920x1080 res, below 91% there's no throttle

post-12287-14495001022363_thumb.jpg

Ryse now throttles with default 1080p res without any supersampling in some crowdy scenes

In less demanding games its all ok, no throttle at all - Sniper Elite III maxed out 1920x1080 in game option supersampling 1.5x

post-12287-14495001022961_thumb.jpg

I'll go back to Clevo BIOS to see if the results are sustained...

Ps. what's the use for Asic values and why shall I uninstall MSI Afterburner ? I know for a fact that PrecisionX & MSI Afterburner may crippling screens in Windows 10 but I'm using Windows 8.1 right now without any problems.

Share this post


Link to post
Share on other sites

just so I can understand for sure what im reading on this post I literaly have to manually add the .inf file to the driver so the alien can use the driver? since all the new drivers do not include the required nvdi.inf file needed by alien. is this correct? I gave up here for a sec and put the old gtx 880's in just so I can play and now the 880's don't want to work properly. did a clean windows install of 10 pro and went back to windows 7 as well still having the same issue. the laptop lets me load the NVidia driver then after reboot looses one of the gpus and can only see one. grrrrrrrrrrrrrrrr, getting ready to loose my mind lol. if what I asked earlier is true I will attempt the gtx 980m sli upgrade again since I paid for the gpus and realy want to use them over the 880's seeing as how now they wont even work. madness I tell you, just pure madness I just want to playyyy!!! lol.

Share this post


Link to post
Share on other sites

hey guys do these modified inf files and drivers work for windows 10? I am going to attempt this upgrade again tonight since it seems my gtx 880m's don't want to work anymore since I went to uefi bios and windows 10. I bought a full version of 10 pro 64 just for this upgrade. so anyway are these viable drivers I can use with 10? thanks for the help. I will make a sig with my systems in the mean time trying to upgrade my alien 18, 4810mq, 32 gb ripjaw, 120 msata ssd mushkin, 2x 1tb Seagate xlt's hybrids in raid 0, and hopfully gtx 980m's sli. all drives formatted to gpt and bios set to uefi. so fingers crossed I guess. paid a mint for this 980m sli kit would hate not to use them at this point.

Share this post


Link to post
Share on other sites

@All

Nvidia pulled v358.70 (no explanation whatsoever), please install v358.59

I'll go back to Clevo BIOS to see if the results are sustained...

Ps. what's the use for Asic values and why shall I uninstall MSI Afterburner ? I know for a fact that PrecisionX & MSI Afterburner may crippling screens in Windows 10 but I'm using Windows 8.1 right now without any problems.

Fine tuning new vBIOS... before installing any driver you must uninstall PrecisionX, as a precaution do the same w/ MSI Afterburner and keep RTSS 'Show own Statistics'/HWiNFO OSD, EDID bug affects Win8.1 too.

Any new results using stock vbios?

hey guys do these modified inf files and drivers work for windows 10? I am going to attempt this upgrade again tonight since it seems my gtx 880m's don't want to work anymore since I went to uefi bios and windows 10. I bought a full version of 10 pro 64 just for this upgrade. so anyway are these viable drivers I can use with 10? thanks for the help. I will make a sig with my systems in the mean time trying to upgrade my alien 18, 4810mq, 32 gb ripjaw, 120 msata ssd mushkin, 2x 1tb Seagate xlt's hybrids in raid 0, and hopfully gtx 980m's sli. all drives formatted to gpt and bios set to uefi. so fingers crossed I guess. paid a mint for this 980m sli kit would hate not to use them at this point.

Windows 10 + GeForce Drivers are Killing Samsung and LG Notebook LCD Display Panels

Uninstall PrecisionX & MSI Afterburner (Keep RTSS) Nvidia...fixing their mess silently...until then, I'm not uploading any win10 mods.

Share this post


Link to post
Share on other sites
@All

Fine tuning new vBIOS... before installing any driver you must uninstall PrecisionX, as a precaution do the same w/ MSI Afterburner and keep RTSS 'Show own Statistics'/HWiNFO OSD, EDID bug affects Win8.1 too.

Any new results using stock vbios?

:64: It seems I was wrong about vBIOS differencies because Clevo vBIOS was acting exact the same as Prema's... I Redo the driver install again using DDU and uninstalling Precision X and now the games don't throttle anymore like the first day installation... it's like the Nvidia drivers has some kind of time expiration of working just fine and then another day it throttle again...

Now I'll test the old 353.06 PEG MOD pushing it the harder I can get just to be sure about its qualities.

- just wait... is there someone who lost a LCD panel using the latest nvidia drivers and PrecisionX in Windows 8.1? Maybe my EDID is already corrupted but its working ok for awhile, no 8 beeps error here.

Share this post


Link to post
Share on other sites
:64: It seems I was wrong about vBIOS differencies because Clevo vBIOS was acting exact the same as Prema's... I Redo the driver install again using DDU and uninstalling Precision X and now the games don't throttle anymore like the first day installation... it's like the Nvidia drivers has some kind of time expiration of working just fine and then another day it throttle again...

Now I'll test the old 353.06 PEG MOD pushing it the harder I can get just to be sure about its qualities.

@Tulius please install v353.00 instead, v353.06 is too messed up/workaround.

  • Uninstall PrecisionX & MSI Afterburner (Keep RTSS)
  • Flash @Prema's CLEVO_8GB_GTX980M_OC_PM_v1.1.1 (please consider donating to Prema)
  • DDU "Clean & Shutdown"
  • Disable DSE
    cmd (Admin)
    bcdedit /set {default} bootmenupolicy legacy


    -> reboot -> F8 -> select 'Disable Driver Signature Enforcement'.

  • Extract driver package using 7-Zip -> GeForce 353.00 PEG MOD <-
  • Display.Driver folder -> copy/overwrite nv_dispi.inf -> Run setup.exe -> don't reboot yet <-
  • NV Inspector -> Driver Profile Settings -> Import User Defined Profiles -> Import (replace) all driver profiles (Nvidia text format) -> Full_Profiles_3_v353.00.txt
    cWsgPhg.png
  • NV Inspector -> restore current profile to Nvidia defaults -> reboot
    ZWIgKXR.png
  • Open NVCPL -> Manage 3D settings -> Set High Performance etc...
  • NV Inspector -> P0/P1 matching -> Copy nvidiaInspector folder + included batch files to C:\ root directory ( Single/980M_Single_GPU_NVI...zip or SLI/980M_SLI_NVI....zip)
    Stock 1127/2505 P0/P1 or 1127/2705 P0/P1 (vram OCing - check stability)
    zS4PoDH.png
  • Task scheduler -> import task .xml -> one task at a time...:D or disable current task or edit task/Actions (System tasks/hidden command prompt window).
    02kvNwv.png

Update:

Full_Profiles_4_v353.00.txt (no need to reinstall drivers) GeForce 353.00 PEG MOD

Full_profiles_v353.00.zip

  • Thumbs Up 1

Share this post


Link to post
Share on other sites

  • Open NVCPL -> Manage 3D settings -> set all settings to default by clicking "Restore" -> Change resolution -> Refresh rate 60Hz -> Close NVCPL.

That piece of the process make me remember that I'm currently using a Benq 120hz gamer monitor as a main screen for my M18X-R2... its that a problem? Two displays but actually only display 2 is on to sucessfull achieve 120hz frequency, but I can use the Alienware monitor for this test sake...

  • Uninstall PrecisionX & MSI Afterburner (Keep RTSS)

With just RTSS installed without MSI Afterburner, the on-screen statistics display don't work, I have to reinstall Afterburner afterward the new driver installation because I use it like a tool to measure gpu performance.

Edit: Thanks for the info, I'm all set now

  • Thumbs Up 1

Share this post


Link to post
Share on other sites
  • Open NVCPL -> Manage 3D settings -> set all settings to default by clicking "Restore" -> Change resolution -> Refresh rate 60Hz -> Close NVCPL.

That piece of the process make me remember that I'm currently using a Benq 120hz gamer monitor as a main screen for my M18X-R2... its that a problem? Two displays but actually only display 2 is on to sucessfull achieve 120hz frequency..

Updated instructions & profiles...set 120Hz instead.

With just RTSS installed without MSI Afterburner, the on-screen statistics display don't work, I have to reinstall Afterburner afterward the new driver installation because I use it like a tool to measure gpu performance.

@Tulius RTSS + HWiNFO

post-3012-14495001024813_thumb.png

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Similar Content

    • By -GP
      I got a msi ge60 2pf Apache pro & its specs :
       
      Processor-i7 4710MQ
      Ram-16GB 
      VGA- GTX 860M 2GB Maxwell 
       
      Could anyone tell me the best overclock that I could use on this GPU?
      Please keep in mind that the voltage cannot be changed as this is a laptop
       
      Thank you
    • By OnaStack100
      I have a p150sm which has a seemingly dead 780m due to a perpetual error 43 which came after a big BSOD about 6 months ago. I upgraded the laptop to a 980m and modded the inf files. The upgrade was perfectly fine for a week. One day, i left the laptop and something related to sleep or power may have caused the laptop to shut off. Since then, the laptop with the 980m won't boot. I tried many things like resetting cmos, taking out the hardware and putting it back in, and resetting bios, and buying a 230W adapter. Nothing worked. The laptop works fine with the old dead 780m in there, but now when the 980m is in there, holding the power button generates a green light flash and then the power LED goes back to orange. No sounds, maybe one tick, and that's it. What is left to try?
    • By DragonRai
      After the most recent Windows 10 update, my Clevo Control Centre has stopped working properly. When I try to change the fan speed nothing happens and this is causing my laptop to overheat when playing certain games. This has happened before but using malware bytes seemed to work; that was a free trial so I no longer have access to this. 
      Please can someone help? I'm at my wits end with this.
       
×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use. We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.