Jump to content

Y510p Ultrabay Graphics card


Recommended Posts

I try to do it but I can not download the file package, and it seems to me that AWDFLASH which I found did not work properly or its wrong version 

Edited by STYXMHE
Link to comment
Share on other sites



thats step by step what I get

IMG_0852 [107236].JPG

IMG_0853 [107238].JPG

IMG_0854 [107240].JPG

and when I type the name of the bios is not happening nothing but flashes inscription please wait but absolutely nothing happens for a long time

Link to comment
Share on other sites

Update on the RX 480 DONT BUY THE REFERENCE MODEL AS IT WONT WORK FOR THIS ADAPTOR. It works in the adapter and everything until the card goes under load and dies because it cannot get enough power through the PCI-E slot (you can google for more info on this issue). I'm going to be returning my reference card and wait for an aftermarket version with two 6 pins or one 8 pin so the power draw  through the PCI-E is less. 


@STYXMHE I guess wait a week until you get promoted to a user and can download those files or look through the posts and see if there is an alternate download. I should have a tutorial put together by then.

Edited by ManyStrongWords
Link to comment
Share on other sites

MAJOR CHANGE to setup: Just Run the 2.07 EXE 






Extra: Also make sure to uninstall drivers for video cards as you switch them them out. Not the 750m drives but I went from a 6670 to the RX 480 and needed to wipe them.


Gerald you can remove your uploaded bios as I was just trying 2.07 with Windows 7 which does not work. I just now tried 2.07 with Windows 10 and it works with the setup for 2.07 being much easier.


Edited by ManyStrongWords
Link to comment
Share on other sites

I have grabbed two old graphic cards from a friend (MSI GT430 4GB) and GT520 just for testing.

Getting a black screen on both of them. and laptop keeps rebooting every ~30secs

Tried with (BIOS 2.04 EC 3.05) and (2.07EC/BIOS).

the result is the same. Does it have anything to do with the fact i have Windows 10 UEFI? do I have to install it as legacy?

Link to comment
Share on other sites

Have you checked the BIOS settings?

I have uploaded them a few comments before.


ManyStrongWords got the adapter under Win10 running. No idea if UEFI or not. But I guess this is not the reason for your issue.


Link to comment
Share on other sites

i matched the bios and the settings, windows doesnt seem to boot at all with those gpus. and yes no startup sounds :/

It could be bcoz of those gpus are old and they use pcie 2.0 interface, or it has to do with UEFI(but i doubt it).

im gonna try couple more scenarios and let you guys know.

Link to comment
Share on other sites

  • Brian pinned this topic

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...

Important Information

By using this site, you agree to our Terms of Use. We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.