Jump to content

[M14x R2] [M17x R4] [M18x R2] - UEFI fast boot / secure boot GPU issues *SOLVED*


Recommended Posts


User with any of the M14x R2 / M17x R4 / M18x R2 notebooks with a current BIOS have reported issues when using the Secure Boot / Fast Boot options in combination with the dedicated Nvidia / AMD GPU.("Can't detect MXM card GOP driver" in case of the R4 / M18x R2)

The reason for this is simple - Dell never provided a vbios update which includes the necessary graphic drivers to make those feature work. The only UEFI compliant drivers in the system have been the ones of the Intel HD iGP.

A very big failure on Dell's side if you ask me, especially since this has been reported here and in other forums as well on the dell community site and it was said that people would look into this... absolutely nothing happened.Not that this really surprises me... looking at the latest BIOS releases and also at the behavior regarding release notes for such updates. Seems we need to look for the updates ourselves.

Anyway, Dell actually ships the very latest systems with updated vbios on the dedicated GPUs.

Attached to this post you can find a new vbios for the Nvidia GTX 680m, 660m as well as the AMD 7970m. Both include the required UEFI drivers, and should therefor fix this issue.

Thanks @Zyron for the 680m vbios.

I don't have a version for the 675m so far, so if anyone has an updated vbios for that card, please let me know or post it.

Flashing instructions for Nvidia: http://forum.techinferno.com/general-notebook-discussions/2166-%5Bguide%5D-nvidia-vbios-flashing.html

Flashing instructions for AMD: http://forum.techinferno.com/general-notebook-discussions/1738-%5Bguide%5D-amd-vbios-flashing.html

As for the M14x R2, a new, yet unreleased BIOS (A10) has made it's way to the web. You can find it here: http://forum.techinferno.com/alienware-m14x/2655-%5Bm14x-r2%5D-a10-bios-fixes-uefi-issues-nvidia-card.html

Check the third post. Also I took a quick look at it and wrote down the most important changes (post #4).

EDIT: M14x R2 BIOS A10 is now officially available on the Dell drivers site.


M14x R2-Dell GTX 660m -

M14x R2-Dell GTX 680m - 80.04.5B.00.02.zip

M14x R2-Dell 7970m -

M14x R2-Dell 675m - 70.24.4E.00.10.zip


M17x R4-Dell GTX 660m -

M17x R4-Dell GTX 680m - 80.04.5B.00.02.zip

M17x R4-Dell 7970m -

M17x R4-Dell 675m - 70.24.4E.00.10.zip


M18x R2-Dell GTX 660m -

M18x R2-Dell GTX 680m - 80.04.5B.00.02.zip

M18x R2-Dell 7970m -

M18x R2-Dell 675m - 70.24.4E.00.10.zip

  • Thumbs Up 19
Link to comment
Share on other sites

Thank you so much. Finally downloaded and flashed. Lets see what improvements I will get. I quick question though (if nobody minds): Will I have to reinstall the operating system if I use UEFI fast boot mode? Thank you once again for the wonderful work SLV7. Hope to see you soon on the other forum as well :)

Link to comment
Share on other sites

Thanks a bunch, a problem is probably any custom clocks we have on modded vbios files though right?

It's like this - if you want to make use of a customized vbios, you will need to enable legacy option roms, and therefore can't use any of the secure boot / fast boot features.

I only modified the legacy stuff, cause it doesn't make sense to go into modifying an uefi driver, it won't get loaded anyways if secure boot is on, and if secure boot is turned off you can simply use the legacy stuff.

Finally! Why doesn't dell post these on their site? Thanks for the files!

No idea, really, especially since I told the Dell reps ages ago that it's caused by the vbios. It seems that it's rather difficult for the Dell communitiy representatives to really reach out to the technicians, or people responsible for releasing updates on the Dell drivers site. Dell is a huge company, so I can imagine that this may be the problem, but there should be a way for them to react quicker, else it kinda defeats the great idea of having community reps online - especially if the community provides the updates to the masses faster than Dell.

The vbios files have been around for quite a while now, maybe [MENTION=4474]Alienware-L_Porras[/MENTION], [MENTION=4664]Alienware-Natalia_J[/MENTION] or any of the Dell reps could somehow try to speed up things, but I think they already did the best they can in their position, Dell is simply slow when it comes to providing updates to the masses.

Link to comment
Share on other sites

It's not at all surprising. Dell is a big company with lots of disparate divisions. It takes time for instructions and changes to migrate through a big company. Never mind that the web services guys probably don't work nights, weekends or holidays while the support side is a 24-hour shop.

Link to comment
Share on other sites

Hey svl7 thanks for replying :) Yes the HD is GPT (three 512GB SSDs raid 0) which I set legacy boot, then go in secure mode and it shows as a UEFI loader (might be the issue though?) Whenever I reboot though the machines does a quick on, quick off and quick on almost like the cards are not picked up and back to Ivy Bridge.

Link to comment
Share on other sites

Three 512GB SSDs in raid 0... now that's an awesome system! :D

It's kinda hard for me to figure out what's wrong, I never installed Win8 so far, and I don't have a similar system to check the bios settings in detail. I take it that you have disabled legacy option roms?

EDIT: I see you have fixed it by reinstalling everything.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...

Important Information

By using this site, you agree to our Terms of Use. We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.