Jump to content
EwinRacing Flash Series Gaming Chairs
ChillAlarm

m18x r2 GTX 980m upgrade

Recommended Posts

Hey all,

 

I'm going to be upgrading my m18x r2 from dual radeon hd 7970m's to a single gtx 980m. Ordering an upgrade kit today from here that should arrive in 3 days or so. 

I've taken it apart before but all parts are original thus far. I've noticed this is a pretty common topic here on TI but haven't found a straighforward guide. I'm planning to

document the upgrade as I go along to serve as that guide. My plan as it stands right now is this: Flash swick and SVL7's A11 unlocked BIOS, teardown and replace the cards

more or less following this guide, rebuild and check that I didn't screw anything up too terribly, and flash prema's vBIOS. As of now my next step is downloading the latest 

nvidia drivers and modifying them for my system following this guide, but if that doesn't work I may just revert to using j95's modded drivers

 

 

My specs are:

PC: Alienware m18x r2

OS: Windows 10 Home

CPU: Ivy Bridge Intel i7 3630QM

RAM: 12GB Dual Channel DDR3

HD: 1TB RAID 0

GPU: 7970m Crossfire (sadly dead)

BIOS: A11(stock)

 

 

For flashing the BIOS and vBIOS you have to create a bootable dos usb. I found a great guide for that here.

Edited by ChillAlarm

Share this post


Link to post
Share on other sites

 

I'm having a little trouble getting a hold of premas vBIOS so can anyone recommend an alternative?

Would this one from SVL7 work?

Share this post


Link to post
Share on other sites

 

A little more research done and now I'm beginning to doubt this whole complicated process.

From the forums here and here it seems like I don't need to jump through so many hoops.

Just update to A12 BIOS and pop in the card.

 

Can anyone confirm or deny this?

Share this post


Link to post
Share on other sites

You have an M18xR2 not Alienware 18, two different machines. 

 

You should get this BIOS:

 

 

Also, much cheaper to buy here:

 

http://www.ebay.com/itm/New-NVIDIA-GTX980M-Graphics-Card-8GB-GDDR5-256-Bit-MXM-3-0-GPU-Upgrade-/282591461768?hash=item41cbc38188:g:oHMAAOSwIjJZXvQ0

 

If I remember correctly, with the 980M , all you have to do is flash that BIOS. Turn off, swap cards and it should be good to go. I think the 7970m heatsink also works with 980M but don't remember. 

 

Share this post


Link to post
Share on other sites

@ssj92 Thanks for you quick response!

 

I've got that BIOS downloaded and ready to go as soon as my card comes in. Really I could do it today but don't have a reason to.

 

I read elsewhere that the heatsink should be good but I'll see. Planning to do the upgrade Sunday night.

 

Are you saying that I don't even need to mess with the vBIOS or modifying the drivers?

 

Share this post


Link to post
Share on other sites
33 minutes ago, ChillAlarm said:

@ssj92 Thanks for you quick response!

 

I've got that BIOS downloaded and ready to go as soon as my card comes in. Really I could do it today but don't have a reason to.

 

I read elsewhere that the heatsink should be good but I'll see. Planning to do the upgrade Sunday night.

 

Are you saying that I don't even need to mess with the vBIOS or modifying the drivers?

 

You will need to modify drivers everytime since this isn't an official configuration. If the card comes with a dell vBIOS, I would leave it as is and see how it performs before flashing it. 

Share this post


Link to post
Share on other sites

Hey all,

 

Did the upgrade last Sunday and everything went smoothly. Haven't flashed a modified vBIOS as of yet seeing as I haven't had any major issues thus far. 

All I've done is flashed the unlocked BIOS, installed the new card, and installed the modified driver. Pretty simple in hindsight, just seemed pretty daunting 

at first. 

 

Now my only issue is that I believe my display cable is damaged. That started before my last cards died. I suspect it's the cable because when on integrated graphics

the display works perfectly. But when switched to the discrete graphics the display is fuzzy. Just looks like there's a lot of static, but when connected to an external monitor

it works perfectly. But that's a problem for another day.

Share this post


Link to post
Share on other sites

So am I to understand that if you have the M18X R2 

On 03/08/2017 at 8:07 PM, ssj92 said:

You will need to modify drivers everytime since this isn't an official configuration. If the card comes with a dell vBIOS, I would leave it as is and see how it performs before flashing it. 

I'm literally after the same upgrade this guy is. have the same setup too but on Win 7 64bit. Just my BIOS is A12. Do I still need to move to the A11 unlocked BIO you talk about or does the A12 facilitate the 980m. 

Second question, do I need to buy a 980m with dell vBIOS or would one thats come out of an MSI machine work?

Edited by CryPlz

Share this post


Link to post
Share on other sites

Also does it matter if the 980m has g-sync or not. Is there a preference here?

Share this post


Link to post
Share on other sites

Hi Cryplz,

 

I would say the preference would be non g-sync. I have a 970m gsync and I only get a blank screen if I boot it PEG but it does work in SG / Optimus. Also worth noting latest NVidia hotfix driver now officially supports the 970m / 980m in the M18x R2 so no more driver modifying, but only standard cards not gsync ones.

 

Jon

  • Thumbs Up 1

Share this post


Link to post
Share on other sites

Thats good news, am I still looking at not getting a card unless it has come out of a dell machine? As ebay has 2 MSI 980m's that have been in msi laptops. Just worried about buying them and realising later that they dont work in an Alienware m18x r2 

Share this post


Link to post
Share on other sites

any advance on this? unsure whether to go ahead and get an MSI gtx980m, anyone fitted one of these to an M18X R2?

Edited by CryPlz

Share this post


Link to post
Share on other sites
On 21/10/2017 at 3:36 PM, javers said:

Hi Cryplz,

 

I would say the preference would be non g-sync. I have a 970m gsync and I only get a blank screen if I boot it PEG but it does work in SG / Optimus. Also worth noting latest NVidia hotfix driver now officially supports the 970m / 980m in the M18x R2 so no more driver modifying, but only standard cards not gsync ones.

 

Jon

is that SLI they support or just single gpu

 

Share this post


Link to post
Share on other sites

I know this post is old, but I just went from dual 675M to single 980M, I Have the A12 bios (I can't download on this site yet to get the unlocked A11).  I am getting 8 beeps. Is this because of the bios? I am running Windows 10 because I thought with Windows 8 and 10, the maxwell was supported on the R2. Do I need to reinstall the old card and wait to be able to download this BIOS? I have been waiting about a week to get promoted. I am impatient, but I am super excited to complete this upgrade. (Also put in a 1TB SSD!) Please help!!! haha! Thanks!

 

Edit: I now have this working, Thanks!

Edited by Losercore13
Got It working.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Similar Content

    • By Freddyicy
      I have spent a little time in the past few days looking around this site. I would love for someone to point me in the right direction to a forum that has information that could help me out with my problem.
       
      I have a:
       
      Alienware M17XR3 
      Windows 7 Home Premium 64-bit
      Intel I7-2820QM 2.3
      Bios InsydeH20 Version 1.0 A12
      NVIDIA GeForce GTX 460M
      (4x) 4 GB Ram
      samsung 2.5" 256 SSD (SATA3.0Gbps)
       
      It has been an amazing machine for the last 10+ years. Minor issues, nothing that an Alien Respawn could not fix, till now! On battery power it works just perfect.  Then I plug it in and it's all OK until I try to do anything, and then the screen goes white. The screen sometimes goes yellow, sometimes blue, but mostly white screen. It will do nothing until I do a hard reset (holding the power button till it turns off and turn it back on) with the power unplugged.  If the power is not unplugged then it will go through boot up to windows swirling dots then go white again. If I plug it in and do nothing I can charge it, unplug and continue what i was doing. I have tried a lot of solutions bouncing around the internet, and thought I was having a DC Jack connection issue (replaced the ac/dc power adapter, then the motherboard). I get a better connection now but with the same white screen result. I stumbled into this forum and I'm hoping to find solutions to my issues.  Then upgrade like so many others have.
       
      Any ideas, comments or suggestions welcome.
       
      Thank you in advance!
       
    • By Swick1981
      Bios Release Version – v2.0.0
       

       
      Updated or Modded Items:
      A11 UNLOCKED BIOS FOR m18Xr2 (UNLOCKED BY SVL7 AND FULL CREDIT GOES TO HIM FOR UNLOCKING!)
      SVL7 Also created the PRR2.EXE tool that allows you to flash the new bios by unlocking it.  (FULL CREDIT GOES TO HIM FOR THAT FILE PRR2.EXE)
       
      Here are ALL the things I've added, modded, and enhanced on this bios -
      I've added FULL LEGACY SUPPORT ON THIS BIOS with ONE or TWO CARDS (SLI).  You can FINALLY use Win 7 OS on your machine and run the 900 series GPU's! 
      This is a MAJOR breakthrough!
       
      LEGACY SUPPORT Confirmed.  Works with 900 series GPu's in single OR SLI formation Updated the Intel RST Legacy to v12.9.0.2006 (Supports TRIM in RAID0 - CONFIRMED) Updated Intel RST UEFI to v12.9.0.2006 (Supports TRIM in RAID0 - CONFIRMED) Updated the ONBOARD Video Card for the HD3xxx to v2171 - FROM v2132 Updated ONBOARD Video Card for the HD4xxx to v2171 - FROM v2132 Updated the LAN Firmware & PXE Boot from 2.0.5.9 to v2.0.6.6 ADDED NvMe Support for m18xr2 ADDED M.2 support for m18xr2 Updated CPU Microcode to v29 for the 2900 CPU's Updated CPU Microcode to v1c for the 3900 CPU's Updated GOP Driver for Intel Sandy Bridge CPU Updated GOP Driver for Intel Ivy Bridge CPU Updated MAIN GOP Policy module for the m18xR2 Eliminated some code that wasn't used in the m18xR2 Updated CSM Module (v2) Streamline some coding to make mod(s) run a little more efficiently (v2) Added FPARTS.TXT to rar file in v2. (I had forgot to add it in v1) v2.5 to be released shortly.  I've updated a few more modules that I didn't realize could be updated.  (It's only 3 modules, but it's still an update!)   It should be released in about a week.  Hope this helps ya'll!  
      Instructions to flash:
      Use a flash drive to create a boot disk into dos Unzip ALL files into the root of the flash drive (flash.bat, r2final.bin, fpt.exe, flash.bat, prr2.exe, fparts.txt,m18r2.hdr, m18r2.hdr.bin, readmefirst.txt) BOOT INTO DOS – Note, that when you set the bios to legacy in order to boot into dos, you MAY have to reinstall OS!  (Just be prepared to reinstall no matter what) Once you boot into dos, run the file flash.bat It will unlock your bios (THANKS TO SVL7’s BIOS UNLOCKING TOOL – ALL CREDIT TO HIM FOR THIS TOOL!) Let it flash… Reboot your pc, and enjoy the MASSIVE updates!  
      Be on the lookout as I do plan to release newer version with more updates in the future.  However, it wont be for at least a few weeks as I'm now working on legacy support for the m17xR4 and several other systems.  So please be patient!
       
      ENJOY!
       
      Thread link for more information and discussion:
       
    • By svl7
      Files contained in this archive:
      FTP-DOS.zip prr2.zip M18x R2 - BIOS A03 'unlocked.zip M18x R2 - BIOS A08 'unlocked.zip M18x_R2_-_BIOS_A08_-_[unlocked]_-_[IRST 11.0.6.1702].zip M18x_R2_BIOS_A03_-_[unlocked] - [IRST 11.6.0.1702].zip M18x_R2_BIOS_A09_-_[unlocked].zip [FPT]-M18x_R2_BIOS_A09_-_[unlocked].zip [FPT]-M18x_R2_BIOS_A10_-_[unlocked]_V2.zip M18x_R2_-_BIOS_A08_-_[unlocked].zip M18x_R2_BIOS_A03_-_[unlocked].zip  
      For information on how to use the files in this archive, see here:
       
       
      My donation link in case you want to buy me a beer
    • By Crustieraxe
      Hello Guys this is my first post here!
       
      So my original post was this:
       
      "I don't even know if any active forum is out there on this laptop and on this issue, but after installing my new DHCG2 LTN173HT02 120hz display, I am unable to boot up on it. I do have a modded bios which the video setting is set to PEG, and just about read every forum about this but have not found a solution. I have tried resetting the bios, made sure the cable is plugged into the Edp port, and have made sure I have an UFEI Windows installation and legacy mode is turned off. I don't know what else to do and if anyone could help it would mean alot to me! "
       
      The reason it was not booting up on a pure UEFI environment is because my 660m did not have the GOP compliant driver vbios. You would need this in order to boot up in a pure UEFI environment which at the time I didn't know, and my fix was to stick to legacy. Any card before the 660m will most likely require this if you need to boot up in a pure UEFI environment. If you do not have this vbios driver while it is set to UEFI and plug in the 120hz lcd, it will beep 8 times and you will be forced to plug back in the 60hz display to change it back to legacy.
       
      This was the vbios that I can say worked for me and had the GOP compliant driver for the 660m
       
      https://www.techpowerup.com/vgabios/144032/144032
       
      ------------------------------------------------------------------
       
      These are the steps to upgrade from a normal 1600x900 60hz display to a 1920x1080 3D 120hz Display which is needed if you want to update your graphics card to a more modern one.
       
      I am making this guide because I felt frustrated that for this awesome computer, there aren't really any post in 2020 to upgrade the LCD panel to the 3D 120hz one. And The older posts I scavaged through really helped me little in doing this upgrade.
       
      Anyways lets begin
       
       
      1) If you have a stock AMD graphics card, and are wanting to install the 120hz display, then your journey ends here and you will have to upgrade to an NVIDIA graphics card to do so. If you have an NVIDIA, you may continue
       
      1a) ( Only if upgrading to pascal graphics card )Your NVIDIA card Needs to have a GOP compliant vbios  or else it will not let you select the UEFI option on the bios. This is needed because you need to set a UEFI environment before upgrading to a 1060/1070 Since these cards don't support legacy mode. This means you will need to flash a vbios onto your card that will allow you to boot on a UEFI Environment. You will need to verify first wether your card has a GOP compliant vbios by searching up your vbios version in GPU-Z. If you have a 660m that doesn't have this, then here is the link to that vbios that does. https://www.techpowerup.com/vgabios/144032/144032 I think that all of the Nvida 6XXm are not GOP driver compliant and need this but do not quote me.
       
      2) On the 60hz display, I would start by making sure that you have windows 10 installed or reinstall with UEFI support as it is needed if you are installing a pascal graphics card. If you have legacy mode enabled, and are not planning to upgrade to a pascal graphics card and keeping your old Nvidia 6XXM, then disregard this and head on to step 5 (although I would recommend to read everything)
       
      3) turn the laptop off and boot into the bios. In order to boot into the bios, spam the F2 key while it is turning on.
       
      4) Once in the bios, go to the Boot menu, and make sure to Disable "Secure Boot", Make sure that importantly if you converted over to a UEFI installation of windows, UEFI mode is chosen (UEFI  Environment will be needed for a pascal graphic card and legacy will not be compatible) then again, if you are on a legacy installation of windows 10, disregard this if you don't want to upgrade to a pascal graphics card.
       
      5) we can now start looking at the 120hz display. I bought mine on ebay with this seller https://www.ebay.com/itm/New-Dell-Alienware-M17X-R4-17-3-FHD-WLED-3D-V-M-LCD-Screen-DP-N-DHCG2-GN36T/273644412867?hash=item3fb67a5fc3:g:9A0AAOSw5AhcP1pw:sc:USPSPriority!32720!US!-1 (Just in case the link goes bad, this was the listing name"Alienware M17X R4 17.3" FHD WLED 3D V M LCD Screen DP/N DHCG2 GN36T"  with the screen model being  LTN173HT02 and Dell part number GN36T )
       
      6) Since my listing came with the video cables, I did not have to go out and look for the video cable. If yours did not come with the cables, You will also NEED to get the video cable it is required. the Dell Part number is N392W. I cannot stress enough This video cable is required and the 60hz's video cable CANNOT be used with the 120hz one or else you will brick your computer from what I read.
       
      7) Once it comes In, we can start to take apart the computer to Install our new display. I watched this video to remove the old 60hz and install the 120hz panel 
       
       
       
      8) Before I would remove the whole 60hz lcd panel, I would first make sure that you can boot on the 120hz panel. Notice that there is one connecter with screws on both sides right next to where the 60hz screen connecter is. Make sure that you put the 120hz one with the connector where screws are. This is known as the Edp port and cannot be confused with the LVDS port. Again, you want to plug the new 120hz display into the EDP port and unplug the 60hz one.
       
      9) If the installation was done correctly, then you should have no problem booting with the screen. if it is giving you 8 beeps, then just plug in the 60hz display, and navigate back to the bios to make sure everything is in order and refer back to steps 2-3. If you happen to be an advanced user like me and went ahead and installed a modded bios, then on the 60hz display make sure that the video setting is set to PEG. I dont think this is necessary to have a modded bios since the bios automatically changes the video setting when the 120hz display is detected and should be a last resort option to install a modded bios. I got my modded A12 bios from a guy in this forum named klem for 10 US dollars thorough paypal. Shoot him a message in the forum below.
       
       
      10) Once the new LCD is tested and you know you can boot up with no problems, go ahead and finish removing the old 60hz LCD and proceed to finish installing the 120hz LCD. And you are done. 
       
      A couple of words from my personal experience: When I installed the 120hz display, and booted up windows on it, and turned the computer off, it refused to turn on for some weird reason. I don't know why it would turn on when the AC and battery where on. regardless of what this was, I fixed it by Reseting the CMOS. If you don't know how to do this, do a quick google search and after turning it on i got 5 beeps which i then turned the computer off, and then turned it back on which the computer just reset itself and when it turned back on I was able to boot up into windows.
       
      This is the forum that I was able to find about upgrading the graphics card to the 1060.
       
      Anyways I hope I at least helped someone transform their computer! In 2020!
       
       
×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use. We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.