Jump to content
EwinRacing Flash Series Gaming Chairs

Blackscreen/not Detected eGPU on Acer Aspire V3-772g

Recommended Posts

Hi Guys,


I hope I'm posting this in the right section and yes, I used Google, the search function and the troubleshooting guide.


I'm trying to get an eGPU setup up&running but I encountered some major problems.

First of all, here are the specs for the hardware:



Acer Aspire V3-772G

CPU: Intel Core i7-4702MQ, 2.2GHz - 3.2GHz boost

dGPU: Nvidia Geforce GTX 760m




PE4C-PM060A V3.0 (via mPIC-E)


PSU: Cooler Master B600 Ver.2 - 600W/+12V/PCI-E

GPU: MSI Geforce GTX 970 4G - 4GB vRAM


I don't really know where to start, so lets begin how everything is connected.


The Acer-Aspirve V3-772G has 2 mPCI-E Slots. Both were previously occupied (SSD MMC, and an Wifi-Bluetooth card in the half/small port). I tried the following steps on both mPCI-E slots without any changes.


For the first try, I just removed my WIFI card and connected the PE4C to my laptop. Next I inserted the new GPU and connected the power from the PSU (1x24p ATX directly from PSU to PE4C, 1x6pin and 1x8pin from the 6/8p output from PE4C to the graphics card).

On the first boot, nothing happened, the screen stayed black but the gpu-fans started spinning and the status-leds switchted to green, so I tried different troubleshooting steps.


  • Different boot-delay settings for the eGPU - made no difference, the screen stay always black (no signal) but it seemed to result in different fan-speeds on the gpu

My next steps seemed to work at first, because the GPU-fans started spinning really fast, without any crashes or "not working display". But in every case, neither the GPU or the PE4C could be detected by windows.

  • Turn eGPU ON when windows initializes
  • Turn eGPU ON after standby (booting with eGPU OFF)
  • Hot-Swap WIFI and eGPU (from standby - with and without wifi card on boot)

After this, I completly removed the nvidia drivers (for mobile) and deactivated the dGPU via device-manager and repeated the above steps (hot swapping...) but with the same results. Either it halts on boot with "no signal" or it doesnt get detected at all.


After further research, my next guess was that the dGPU messes with the eGPU on startup, so I bought eGPU Setup 1.30

  • After making a USB-Bootable drive, I booted the setup "with menu" 
  • First, I booted with the Wifi-Card, wich worked fine (detected) and gave me the pcie port, where my eGPU should be setup.
  • After this I continued with the previous steps (turn egpu on at boot, in menu, hotswapping...)
  • With each variant, (after disabling the dGPU) I tried to initialize , reset, deactivate/activate the correspondent pcie port - including different gen setups.

The result stayed the same as in Windows, the eGPU won't get detected in eGPU Setup 1.30 (the pciport shows nothing after his id -> pci3 1.2x:    )


Now I am out of ideas and wonder if I am just doing something completly wrong or the eGPU Adapter is simply not working with my laptop.


Of course I researched before buying the equipment... which should work fine with my laptop...

I also can refund my GPU (today or monday) but would prefer not to :)


I appreciate every helping hand, who can give me a clue how to fix this.


cheers, d00t3y



Share this post

Link to post
Share on other sites

similar thing happen to me, but I didn't buy the Setup 1.30 yet, and I hope I don't need to buy it because I already spent my whole month salaries, so please someone help us out, many thanks :)

Share this post

Link to post
Share on other sites

Yes the same things append to me.




I really like the idea of the eGPU so I decided to bought one.


My laptop: Asus x53sc

CPU: i5-2430M


iGPU: HD 3000

dGPU: Nvidia GT 520MX

OS: Windows 10/64bit


My eGPU setup: EXP GDC v8

eGPU: Nvidia GT9600 (for test if it works i'll buy the Nvidia GTX 950)

Power: 550W


My story:

  1. I bougth the EXP GDC v8.
  2. I connected all the cable correctly.
  3. Windows 10 started with no problem.
  4. I saw the eGPU in the Device manager.
  5. I downloaded the driver and installed it with out problem.
  6. But at the reboot the internal monitor was black and the eGPU doesn't have any output video.
  7. Now :(


What i try to do:

  1. I try to disable the dGPU form the device manager.
  2. I try to reinstall the GT 9600 driver.
  3. I try to follow: https://www.techinferno.com/index.php?/forums/topic/8947-mpcieec-egpu-troubleshooting-steps/
    1. I uninstalled clearly the Nvidia GPU driver and I cleaned the registry with DDU but the problem persist. (black screen)


Possible solution:

What is the problem? Where i do wrong?

Do you think that i need the Setup 1.30 SW?

The problem could be Win 10? Should i return to Win 7?

( Your help <3)


Share this post

Link to post
Share on other sites

If the delay switches does nothing and bios hangs on all settings then try to isolate PIN22 on the mpci connector and set the PERST delay switch to max. Hope this solves your issue. Btw if you are using this pin22 method never restart you computer, always do shutdown/power on.

For more info: 



Edited by Doink

Share this post

Link to post
Share on other sites

have you managed to get 970 gtx to work on your notebook??? i have the same notebook.im new to the egpu so any advice is welcome especially if you get that card working please share it with community.thanks :)

Share this post

Link to post
Share on other sites

Hi Guys,


sorry I was quite busy lately, but here is my final conculsio:


Unfortunaltey I didn't get it to work "in time" so I decided to cut my losses for purchasing the board and DIY eGPU Setup tool(although it's a mighty tool, it didn't make a difference in my case, because the problem, at least i think, was "on a level above") and refunded the gpu itself.


On 5.3.2016 at 6:51 PM, Doink said:

If the delay switches does nothing and bios hangs on all settings then try to isolate PIN22 on the mpci connector and set the PERST delay switch to max. Hope this solves your issue. Btw if you are using this pin22 method never restart you computer, always do shutdown/power on.

For more info: 



Thanks for your help, but unfortunatley I wasn't able to try this in time, but maybe this does the trick.


Another reason why I decided against it, and is clearly a problem of this specific board:

The mPCI-E adapter (especially the fixed/attached cable to the pcb) didn't quite fit in the notebook caseso the connectors sat at an angle and needed to be taped down. Also the backplate was a mess with this adapter as well, half open and not really stable and because it is right in the middle, the notebook easily tips over from left to right (of course I used an usb keyboard, but if you have a cat or some other pet...)


My last resort was to bend the cable right after the pcb connectors so that I could screw the hole thing down in the slot, but it made no difference (tried everything with this "setup" again").

In my oppinion, when you don't have an PCI-Card slot or some fancier thunderbolt stuff for "plug and play", this whole thing defeats the purpose of itself, because you have to screw/unscrew everything everytime you want to use your "mobile" notebook somewhere else - and i don't think you should stress your motherboard with this "heavy mechanical use".

On the other hand, you could use this to "retire" a notebook as an "desktop" with a fix spot at home - which is not really an option for me.


So here some stuff that I tried after my initial post, so you don't have to do it again (keep in mind, that this only applies to the same board and gpu)

- flashed insyde h20 v1.15 unlocked BIOS on my notebook

- tried different dGPU/PCI-E BIOS settings and/or deactivated them (then the whole procedure with hotplugging and all that stuff)

-I even tried to deactivate the whole iGPU and dGPU, which is of course a bad idea (I just wanted to try everything) because you can't see anymore ;)

-NOTE: before you try stuff like this, make sure to check the hotkeys for "set to default" and "save and exit" in you BIOS and how you can confirm this two options (just enter,left+enter, y/n,...) so you always can restore your BIOS settings to default, even when you deactivated the wrong thing and cant see anything. (it certainly doesn't help with anything, but can save your a**... in my case it was F9-Enter, F10-Enter)

-Different UEFI/Legacy settings with windows and linux (for DIY eGPU)


hope this helps, so you don't have to waste time and/or money


cheers d00t3y








Share this post

Link to post
Share on other sites

For those who may be interested - i got this laptop running with 750 GTX. Unlocked bios with EXP GDC.

Share this post

Link to post
Share on other sites

Sir please help where did you get the unlocked bios? 

I have an acer v3 772g

I7 4702mq 2.2Hz

750m geforce


I have a gtx 1080 on wxp gdc egpu


I needed to disable dpgu but cant see the advanced setting on bios


Please HELP me! 


I need to unlock the bios 1.15 insyde


Share this post

Link to post
Share on other sites
On 1/14/2017 at 11:45 PM, rzrwolf said:

Send me PM or your email, i will try to help

Error when trying to PM you so here is my issue. Kindly assist


Hi, I saw your post saying you'd found a fix for the acer egpu laptop. Kindly assist me

I have the gdc exp 8.4 and an nvidia 970. Laptop is the acer v3 571G with i5-3210m and dedicated nvidia 630m.

When connected, the gpu never appears on my device manager. It only appears very briefly on the diy 1.3 software screen and this only happens when i am trying to fit the cable into the mpcie slot. 

Share this post

Link to post
Share on other sites
On 1/15/2017 at 7:45 AM, rzrwolf said:

Send me PM or your email, i will try to help

Rzrwolf any change u could help me with obtaining the unlocked bois for acer aspire v3-772g gt 750m version

Share this post

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Similar Content

    • By mclarke2355
      I want to share the modded Bios I created for the Acer Aspire E5-572G notebook.
      The official bios 1.09 was used as a base.
      I'm offering three flavours: Microcode 01, Microcode 07 and Microcode 21.
      Microcode 21 is the latest available microcode, this is the Bios you want to use unless you want the special properties of the other microcodes.
      Microcode 07 is the latest microcode that allows using the full turbo clock speed on all cores (using single core turbo with all cores).
      Microcode 01 is the one you should take if you want to try this. I wasn't able to get it to work on mine (i5 4210m, HM86), but your mileage may vary.
      In case you want to always use an older microcode, I'm offering a script for windows that'll keep the OS from using a newer microcode (compatible with Windows Vista to Windows 10). Frequency and other things can be set up with ThrottleStop (use the latest version).
      I've also included an overclocking enabled ME firmware that should (hopefully) allow overclocking on the HM87 equipped notebooks.
      There are two flavours of this notebook available: Ones that use the HM87 chipset and others that use the HM86 chipset. Overclocking is only possible with HM87 as HM86 isn't capable of overclocking (tested it myself).
      Additionally I offer a collection of Bios, EC, ME and FD files of this device, in case anyone wants to experiment with these for a bit (EC Modding, etc.).
      I will update this bios in case there are newer parts available.
      Any feedback is welcome!

      -Advanced Bios Options unlocked (Advanced, Power tabs and additional options in the existing tabs)
      -Nvidia 840M/940M VBioses replaced with adapted 940MX VBios with unlocked TDP Limit, unlocked Boost Table and some OC (1306,5MHz GPU/1070MHz Memory - with general usability in mind) + all voltage sliders unlocked
      -Intel Management Engine: Updated to + All Locks Unlocked + Overclocking Enabled For HM87 Notebooks + PAVP (Protected Audio/Video Path) Enabled
      -Flash Descriptor unlocked
      -Microcode updated to version 21 (respectively downgraded to 07 and 01)
      -Intel GOP Driver updated to 5.5.1033
      -Intel VGA Bios updated to 1042
      -Intel RST OROMs updated to
      -Realtek Lan OROMs updated to 2.037/2.64
      -Applied a few useful BIOS patches by CodeRush (Unlock CPU Power Management Register (useful for Hackintosh Users)/Disable BIOS Lock/Disable SMI Lock)

      Flash procedure:
      1. Copy the BIOS file to an empty and with FAT16/32 formatted usb stick.
      2. Unplug the AC adapter.
      3. Remove the battery of the notebook - you can unlock the battery on the backside.
      4. Plug in the USB flash disk.
      5. Press and hold <Fn> and <Esc>, and then plug in the AC adapter while still holding <Fn> and <Esc>.
      6. Press the Power button. You can now stop holding <Fn> and <Esc>.
      7. The BIOS flash should now begin, the fans will spin up at max speed and the power led should blink. It should take between one to two minutes.
      8. After everything is done, you can reinsert the battery and go to the BIOS (F2). There you may want to change some settings (the BIOS flash erases all previously chosen settings).

      Recommended Bios settings:
      F12 Boot Menu ---> Enabled
      D2D Recovery ---> Disabled
      Boot Configuration: Numlock ---> On
      Thermal Configuration: Cpu Thermal Configuration: Bi-Directional PROCHOT# ---> Disabled
      Chipset Configuration: RTC Lock ---> Disabled
      Chipset Configuration: IFR Update ---> Disabled
      Chipset Configuration: BIOS Lock ---> Disabled
      ACPI Table/Features Control: TCO WatchDog Support ---> Enabled
      ACPI Table/Features Control: WatchDog ACPI Table ---> Enabled
      ACPI Table/Features Control: ACPI Memory Debug ---> Disabled
      ACPI Table/Features Control: PEP Graphics ---> Disabled
      Extended ICC: Use WatchDog Timer For ICC ---> Enabled
      Extended ICC: ICC Locks after EOP ---> All Unlocked
      User Access Level ---> Full
      Wake on LAN ---> Disabled
      Advanced CPU Control: xAPIC Mode ---> Enabled
      Advanced CPU Control: Package C-State Demotion ---> Enabled
      Advanced CPU Control: Package C-State Un-Demotion ---> Enabled
      Advanced CPU Control: ACPI 5.0 CPPC Support ---> Enabled
      Advanced CPU Control: ACPI 5.0 CPPC Platform SCI ---> Enabled
      Advanced CPU Control: Package Power Limit MSR Lock ---> Disabled
      Advanced CPU Control: Long Term Power Limit Override ---> Enabled
      Advanced CPU Control: Long Term Time Window ---> 128

      Module names (for replacement/update):
      GOP Driver: 7755CA7B-CA8F-43C5-889B-E1F59A93D575_256.ROM
      Intel RST: 382F560D-17A9-4887-BD9C-EB439C1CC482_1654.ROM and 501737AB-9D1A-4856-86D3-7F1287FA5A55_1781.ROM
      Intel VGA Bios: 8DFAE5D4-B50E-4C10-96E6-F2C266CACBB6_1743.ROM
      Nvidia 840M VBios: D336DBCB-33C1-4D15-A06F-C3FF405C6A68_1749.ROM
      Nvidia 940M VBios: C09F4207-D557-47D0-A4B5-1E4B6459E519_1761.ROM
      Realtek LAN: 0A33D14A-7B60-4C58-9194-DED0812F9B2B_1767.ROM and E8991F69-D813-4116-A2C2-61E304ECBD72_1533.ROM
      Intel Microcode (integrated in file): PADDING_2702.ROM
      Management Engine: Integrated in BIOS image, HEX Editor needed for replacement

                    -Donovan6000 for his very helpful guides and insights on Insyde bios modding
                    -Andy P whose PhoenixTool I used to replace the modules
                    -Plutomaniac for providing the used Intel ME firmware and the Intel ME System Tools to properly configure it for this notebook
                    -Ultrax5 from TechInferno for providing his OC enabled ME firmware for 8-series systems which I used as a reference to unlock the feature for this notebook
                    -SoniX for his Intel VGA Bios update guide and the OROM, Microcode and Intel VGA Bios database he maintains
                    -Pacman for sharing the latest Intel RST OROMs
                    -CodeRush for providing the included BIOS patches
                    -WerePug from overclock.net for providing the way to unlock the Nvidia VBIOS voltage sliders for editing in Maxwell II BIOS Tweaker
                    -The author of the Maxwell II BIOS Tweaker which I used for editing the Nvidia VBioses
                    -All the other people who shared the used OROMs/Microcodes/Firmwares/Useful Information etc.

                         -13.09.16: 1.09a - Initial release
                         -03.10.16: 1.09b:
                                                      Unlocked a few more options that I missed before - everything that can be unlocked should be available now
                                                      Overclocking enabled ME is now included by default (no disadvantages for HM86 notebooks)
                                                      Applied a few useful BIOS patches by CodeRush (Unlock CPU Power Management Register (useful for Hackintosh Users)/Disable BIOS Lock/Disable SMI Lock)
                         -22.10.16: 1.09c:
                                                      Changed Nvidia GPU idle voltage from 0,94V to a more correct value of 0,76V - thanks to Maison1 from win-raid.com for bringing this matter to my attention
                                                      Unlocked all sliders in the Nvidia VBIOSes for editing with Maxwell II BIOS Tweaker - thanks to WerePug from overclock.net for posting the way to do this

      Acer Aspire E5-572G - BIOS 1.09c - Microcode 01
      Acer Aspire E5-572G - BIOS 1.09c - Microcode 07
      Acer Aspire E5-572G - BIOS 1.09c - Microcode 21

      DeleteMicrocode Script for Windows
      Acer Aspire E5-572G BIOS-ME-EC-FD Collection
    • By EdMkn
      I am requesting your help. I have an Acer e5-523g, and  I have applied the method with h2ouve mentioned in this forum to activate the amd-v feature, and it worked. But everytime on two, when the system was shutting down, whether intentionally or low battery, the virtualization was going back to deactivate. And I always repeated the same process. Until one day: when I enter in the cmd, everytime I tap “h2ouve -gv vars.txt” or “h2ouve -sv vars_mod.txt” it shows sth like:
      Now parsing Variable Information...
      LoadDeviceDriver fail,
      GetLastError=0x2 Failed to get bios data!
      Fail to get Variable Information
      My problem is that I don’t really know what LoadDriverDevice means, and how to make it work

    • By Diky
      help me to unlock amd-v acer aspire one 725
      it's my vars file
    • By Solaire
      Hello everyone,
      some time by now I flashed a custom Vbios (thank you Klem) on an Acer Predator 15 G9-591 and I started doing some tests about how far I could go overclocking the gtx 970m without running too hot. With the voltage up to 1150mV and something like 300 additional MHz for the core clock, in the strongest stress condition for both Gpu and Cpu ( i7-6700hq undervolted), the Gpu reaches a max temp of 85C (with some 86 spikes but never more than that).
      Considering that soon I'm going to relid both Cpu and Gpu and clean everything in the internals (laptop is 4 years old) I think I'm going to have some additional heatroom.
      I've already tested some further overclocking and I noticed that even if the temperatures remains under 93C (which is just for testing purposes, but after relidding temps could be nicer) graphical glitches occur and after some time most games crash. But my question is, could it be because of lack of power supply? The laptop charger provides 180W 
      Could there be an increase in overclock margins with a 230W psu or something like that? (Obviously with the same 19.5V output)
      If anybody tried something like that on any laptop model, or knows the matter, I'd like to know
  • Create New...

Important Information

By using this site, you agree to our Terms of Use. We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.