Jump to content

Blackscreen/not Detected eGPU on Acer Aspire V3-772g


Recommended Posts

Hi Guys,


I hope I'm posting this in the right section and yes, I used Google, the search function and the troubleshooting guide.


I'm trying to get an eGPU setup up&running but I encountered some major problems.

First of all, here are the specs for the hardware:



Acer Aspire V3-772G

CPU: Intel Core i7-4702MQ, 2.2GHz - 3.2GHz boost

dGPU: Nvidia Geforce GTX 760m




PE4C-PM060A V3.0 (via mPIC-E)


PSU: Cooler Master B600 Ver.2 - 600W/+12V/PCI-E

GPU: MSI Geforce GTX 970 4G - 4GB vRAM


I don't really know where to start, so lets begin how everything is connected.


The Acer-Aspirve V3-772G has 2 mPCI-E Slots. Both were previously occupied (SSD MMC, and an Wifi-Bluetooth card in the half/small port). I tried the following steps on both mPCI-E slots without any changes.


For the first try, I just removed my WIFI card and connected the PE4C to my laptop. Next I inserted the new GPU and connected the power from the PSU (1x24p ATX directly from PSU to PE4C, 1x6pin and 1x8pin from the 6/8p output from PE4C to the graphics card).

On the first boot, nothing happened, the screen stayed black but the gpu-fans started spinning and the status-leds switchted to green, so I tried different troubleshooting steps.


  • Different boot-delay settings for the eGPU - made no difference, the screen stay always black (no signal) but it seemed to result in different fan-speeds on the gpu

My next steps seemed to work at first, because the GPU-fans started spinning really fast, without any crashes or "not working display". But in every case, neither the GPU or the PE4C could be detected by windows.

  • Turn eGPU ON when windows initializes
  • Turn eGPU ON after standby (booting with eGPU OFF)
  • Hot-Swap WIFI and eGPU (from standby - with and without wifi card on boot)

After this, I completly removed the nvidia drivers (for mobile) and deactivated the dGPU via device-manager and repeated the above steps (hot swapping...) but with the same results. Either it halts on boot with "no signal" or it doesnt get detected at all.


After further research, my next guess was that the dGPU messes with the eGPU on startup, so I bought eGPU Setup 1.30

  • After making a USB-Bootable drive, I booted the setup "with menu" 
  • First, I booted with the Wifi-Card, wich worked fine (detected) and gave me the pcie port, where my eGPU should be setup.
  • After this I continued with the previous steps (turn egpu on at boot, in menu, hotswapping...)
  • With each variant, (after disabling the dGPU) I tried to initialize , reset, deactivate/activate the correspondent pcie port - including different gen setups.

The result stayed the same as in Windows, the eGPU won't get detected in eGPU Setup 1.30 (the pciport shows nothing after his id -> pci3 1.2x:    )


Now I am out of ideas and wonder if I am just doing something completly wrong or the eGPU Adapter is simply not working with my laptop.


Of course I researched before buying the equipment... which should work fine with my laptop...

I also can refund my GPU (today or monday) but would prefer not to :)


I appreciate every helping hand, who can give me a clue how to fix this.


cheers, d00t3y



Link to comment
Share on other sites

similar thing happen to me, but I didn't buy the Setup 1.30 yet, and I hope I don't need to buy it because I already spent my whole month salaries, so please someone help us out, many thanks :)

Link to comment
Share on other sites

Yes the same things append to me.




I really like the idea of the eGPU so I decided to bought one.


My laptop: Asus x53sc

CPU: i5-2430M


iGPU: HD 3000

dGPU: Nvidia GT 520MX

OS: Windows 10/64bit


My eGPU setup: EXP GDC v8

eGPU: Nvidia GT9600 (for test if it works i'll buy the Nvidia GTX 950)

Power: 550W


My story:

  1. I bougth the EXP GDC v8.
  2. I connected all the cable correctly.
  3. Windows 10 started with no problem.
  4. I saw the eGPU in the Device manager.
  5. I downloaded the driver and installed it with out problem.
  6. But at the reboot the internal monitor was black and the eGPU doesn't have any output video.
  7. Now :(


What i try to do:

  1. I try to disable the dGPU form the device manager.
  2. I try to reinstall the GT 9600 driver.
  3. I try to follow: https://www.techinferno.com/index.php?/forums/topic/8947-mpcieec-egpu-troubleshooting-steps/
    1. I uninstalled clearly the Nvidia GPU driver and I cleaned the registry with DDU but the problem persist. (black screen)


Possible solution:

What is the problem? Where i do wrong?

Do you think that i need the Setup 1.30 SW?

The problem could be Win 10? Should i return to Win 7?

( Your help <3)


Link to comment
Share on other sites

If the delay switches does nothing and bios hangs on all settings then try to isolate PIN22 on the mpci connector and set the PERST delay switch to max. Hope this solves your issue. Btw if you are using this pin22 method never restart you computer, always do shutdown/power on.

For more info: 



Edited by Doink
Link to comment
Share on other sites

  • 2 weeks later...

Hi Guys,


sorry I was quite busy lately, but here is my final conculsio:


Unfortunaltey I didn't get it to work "in time" so I decided to cut my losses for purchasing the board and DIY eGPU Setup tool(although it's a mighty tool, it didn't make a difference in my case, because the problem, at least i think, was "on a level above") and refunded the gpu itself.


On 5.3.2016 at 6:51 PM, Doink said:

If the delay switches does nothing and bios hangs on all settings then try to isolate PIN22 on the mpci connector and set the PERST delay switch to max. Hope this solves your issue. Btw if you are using this pin22 method never restart you computer, always do shutdown/power on.

For more info: 



Thanks for your help, but unfortunatley I wasn't able to try this in time, but maybe this does the trick.


Another reason why I decided against it, and is clearly a problem of this specific board:

The mPCI-E adapter (especially the fixed/attached cable to the pcb) didn't quite fit in the notebook caseso the connectors sat at an angle and needed to be taped down. Also the backplate was a mess with this adapter as well, half open and not really stable and because it is right in the middle, the notebook easily tips over from left to right (of course I used an usb keyboard, but if you have a cat or some other pet...)


My last resort was to bend the cable right after the pcb connectors so that I could screw the hole thing down in the slot, but it made no difference (tried everything with this "setup" again").

In my oppinion, when you don't have an PCI-Card slot or some fancier thunderbolt stuff for "plug and play", this whole thing defeats the purpose of itself, because you have to screw/unscrew everything everytime you want to use your "mobile" notebook somewhere else - and i don't think you should stress your motherboard with this "heavy mechanical use".

On the other hand, you could use this to "retire" a notebook as an "desktop" with a fix spot at home - which is not really an option for me.


So here some stuff that I tried after my initial post, so you don't have to do it again (keep in mind, that this only applies to the same board and gpu)

- flashed insyde h20 v1.15 unlocked BIOS on my notebook

- tried different dGPU/PCI-E BIOS settings and/or deactivated them (then the whole procedure with hotplugging and all that stuff)

-I even tried to deactivate the whole iGPU and dGPU, which is of course a bad idea (I just wanted to try everything) because you can't see anymore ;)

-NOTE: before you try stuff like this, make sure to check the hotkeys for "set to default" and "save and exit" in you BIOS and how you can confirm this two options (just enter,left+enter, y/n,...) so you always can restore your BIOS settings to default, even when you deactivated the wrong thing and cant see anything. (it certainly doesn't help with anything, but can save your a**... in my case it was F9-Enter, F10-Enter)

-Different UEFI/Legacy settings with windows and linux (for DIY eGPU)


hope this helps, so you don't have to waste time and/or money


cheers d00t3y








Link to comment
Share on other sites

  • 9 months later...

Sir please help where did you get the unlocked bios? 

I have an acer v3 772g

I7 4702mq 2.2Hz

750m geforce


I have a gtx 1080 on wxp gdc egpu


I needed to disable dpgu but cant see the advanced setting on bios


Please HELP me! 


I need to unlock the bios 1.15 insyde


Link to comment
Share on other sites

  • 5 months later...
On 1/14/2017 at 11:45 PM, rzrwolf said:

Send me PM or your email, i will try to help

Error when trying to PM you so here is my issue. Kindly assist


Hi, I saw your post saying you'd found a fix for the acer egpu laptop. Kindly assist me

I have the gdc exp 8.4 and an nvidia 970. Laptop is the acer v3 571G with i5-3210m and dedicated nvidia 630m.

When connected, the gpu never appears on my device manager. It only appears very briefly on the diy 1.3 software screen and this only happens when i am trying to fit the cable into the mpcie slot. 

Link to comment
Share on other sites

  • 4 months later...
  • Create New...

Important Information

By using this site, you agree to our Terms of Use. We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.