Jump to content
EwinRacing Flash Series Gaming Chairs

Installing a Tesla P6 into a Laptop

Recommended Posts

Hello world...


I was wondering if anyone tried to install a tesla p6 mxm gpu in a laptop. I am looking to doing this - modification- not quite an upgrade  - because I will have to accept optimus - if it will work - nvidia states there is no optimus support, as well as no video output - but I am optimistic - i will try the flash a hex modified bios of a p5000 on it - via spi flasher and see if it will do the trick - the specs and the card itself seem to be identical... but I was just wondering if anyone did this before.


Share this post

Link to post
Share on other sites

TLDR: Use 1.8v flashing for Pascal GPUs


@bagster Please keep us informed on your endeavor. In the US we have Thanksgiving break coming, so hopefully that means tinkering time. I have seen [email protected] resellers advertise Tesla M6 and miner cards like P106M in Dells, HPs, and Clevos using optimus and the iGPU, so what you are attempting is not complete nonsense. IIRC, Pascal might require 1.8v clip flashing to bypass some encryption nonsense that you might encounter using a software flash method. USE 1.8 volts!!! There were reports of BIOS damage from improper flashing. The hardware ID may be physically unchanged even after the flash, so modification of the driver INF can be performed to recognize the card in Windows. Linux is more forgiving of hardware ID mismatch so you may want a linux installation as another option to verify the card is functional.

Share this post

Link to post
Share on other sites

Ok, so I have recieved the card, inspected every little solder pad and it seems that compared to the gtx 1070 mxm and the Quadro P5000m, there is a slight difference, meaning that some small ic chips are missing. Therefore if anyone should have a  high quality photo of the card, the lower part close to the mxm pins, front and back, where I could read the codes on the IC chips, that would be really helpfull.  I am getting a defective Clevo gtx 1070m next week, and might be able to identify some components but just want to double check.

Will keep you up to date.


Share this post

Link to post
Share on other sites

Hi there! 

Did you ever have any luck? 


If the pinouts are the same, and your laptop meets the voltage requirements then there's a good chance it will work. 

There is a link to the specs here:



There will be a difference in the board layout and presence of components on the pcb as this is a different gpu card module. 


As Drawkward has stated above, software would be the barrier. 

Share this post

Link to post
Share on other sites

Hello @Meoleo91,


Sorry for the delayed response. 
I did not try it on the alienware, but I got the chance to test it on a MSI gt72.
The good part is, that the laptop boots up.  the card is being recognized under linux as being a p6, and i can  install the drivers, but can't control the gpu and i get no nvidia crtl panel.
Under windows 10 it throws an error under device manager, but with a bit of modding of the inf file I kinda installed the quadro p5000m drivers, via nvclean install, i got the card to get halfway recognized under gpu z, but i can not enter the nvidia dispaly adapter settings or anything else, and optimus does not work.

I have to mention that I have not hard modded the card yet, because I do not seem to find a good quality picture of a quadro p5000m to see what are the missing components. and there are a few. I could solder them with no pb. but I need a bit of help from all other users.

I do not know if the gpu id  is hard modded on a chip level or on a components level, but I tend to belive that the missing components are the difference and the bios.
The Vbios on the tesla has 512K, and the one on the quadro only 256k.
I could, without an issue, flash the bios of the quadro on the tesla via spi programmer, but as long as I don't have the needed pictures, it would be in vain. 
So please, if you know any other useres that might have this card on hand and are willing to take some high quality photos of the lower part of it, front and back,  and send them to me I would much apreciate it.

Thank you for your help and interest in my small project, and sorry again for the late response.

Best Regards.

Share this post

Link to post
Share on other sites

I also have this graphics card nvidia Tesla P6 mxm 16gb got it off eBay for almost 300€’ I spotted a cut at the back of the card a line then plugged it in and got this psychedelic glitchy Colors no response from the system keyboard frozen then suddenly various shapes cubes started moving abouts  and no more than that ! After googling some info I’ve come to conclusion that u need to short the bios chip pins with tweezer both ends that got me actually to see hp screen and boot into system, before that I thought let’s try cause after first attempt I gave up put it away got refunded, as the seller apologised saying it’s their fault I was like ok fine thanx, so recently I thought let’s have another go, and after that knowing I get those glitches, I log into windows 10 out it to sleep, (my laptop: hp zbook 17 g2) removed my nvidia quadro m5000m while it’s sleeeping, and installed this one with the heat sink back fan cable plugged in and with a tweezer short the power pin and back straight to windows login screen, device manager- detected as Microsoft basic display adapter,install the driver asks for restart, so we know what happens then glitch again only no glitch if u hold the pins on bios chip! So quick boot up holding the pins and quickly install back the heat sink with fan on and screw all back nvlash —gpumode - -graphics done restart no more need to short the pin now driver installs no problem but no 3D or physx select in nvidia control panel and no wddm enabled that’s where I’m stuck! I accidentally decided to try that gpumode command out of all others that failed (nothing to lose) and it worked there the card has ko video output on lcd when I turned off hybrid mode in motherboard bios idk y but now if I can’t find how to enable 3D settings in nvidia control panel also in task manager the gpu won’t appear that’s wddm I know! If I can’t at least find a way to to enable 3D in nvcpl then I need to flash the bios as I also correctly closest match guessed would be p5000 very identical to this one by clocks and memory capacity despite having both gddr5 the p5000 is slightly higher clocked on gpu frequency than this P6 where I’m sure Tesla can take that speed easily ! I tried all possible and available bios files with 16gb unverified files from techpowerup gddr5 pcie filter of nvidia quadro P series and pascal named files all nvflash64 ID bypass version says gpu id mismatch ! That’s I wonder how to get passed that and convert this card at least to p5000 ffs ! Anyones suggestions welcome! 

Share this post

Link to post
Share on other sites

At least you got the drivers to install, I did not, the problem is that there are some missing components and bios differences from P6 to P5000  . The spi dump of the P6 vbios is almost 2 mb if I'm not mistaken. I did not find an spi flash dump of the P5K to compare them, but I do not belive that the vbios of the P6 allows direct 3D redering or at least it has to be switched on. 

It is a strange card, Nvidia took their time to block stuff out compared to the 980m and the M5KM. 

I was really eager to get some photos of thenmissing components on the P6 so that I may solder them on, but did not recieve nor have I found any. And I've searched all the sites that had pictures of the card, or that had it up for sale. 

I gave up and ended up selling the card.

Share this post

Link to post
Share on other sites

If you look into the p5000 and this Tesla P6 side by side you can see Tesla as you said got many bits unsoldered ! Now recently I tried to extract its original bios file and wanted to flash it back (who knows maybe it will do something but it’s aid your image got wrong IDs ims like huh how the fock so I had to edit them IDs with hex editor yet at launch with nvflash says no it’s still bitches about pci subsystem ids mismatch although 10DE-2255 was changed from 103C-0000 was it anyways mysterious wicked card my next move - I’ve found one man here in Gibraltar he runs mobile repair shop and such he solders stuff gonna buy P5000 bios chip and give him to solder that onto this Tesla P6 basically give flash 30£ for the job cheap again nothing to lose I shall inform you soon I also recently bought P4000 from eBay from china this one came with like 5 resistors or is it capacitors missing chopped off so I got this lad to responder them with few of old nv cards I got like gts430 1gb ddr3 mxm such I gave him so he can take them bits off them which ever is compatible still what happens even after is that windows 10-11 now running on (unsupported hw says Microsoft basic display adapter install restart - windows disabled device reported problems code 43 if you then disable and re enable it it will say ok no proba won’t show up in taskmgr and no nvcpl re flashed bios images from Lenovo and it’s original dell had to change IDs also says pci id mismatched using allow mismatch nvflash version so changed in hex ids flashed no change code43 wtf is it idk got refunded at least completely ! Got also Tesla m6 motherboard bios won’t detect its bios at all hp zbook 17 g2 ! I think that card is dead idk

Share this post

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Similar Content

    • By DoenerBoy123
      Hello guys 
      I've got a pretty weird problem with my M18x R2. I already searched the web but couldn't find an answer. A few days ago I changed some settings in the bios, if I remember correctly DMVT Pre-Allocated.
      After saving this setting the notebook refuses to even POST. I get no beep errors or anything. If I press the power button the system turns on, the leds turn on and then the system shuts itself off. I already reset the cmos, the IME, tested different configurations and so on. If I remove all the memory sticks I actually get the memory error code. At this point I'm pretty sure that the bios got corrupted for some reason when saving these mentioned settings. Did anyone had a similar problem and got a solution for this? I repaired lot's of notebook but never had an error like this...
      The Bios installed is the a15 unlocked.
    • By Swick1981
      Bios Release Version – v2.0.0

      Updated or Modded Items:
      SVL7 Also created the PRR2.EXE tool that allows you to flash the new bios by unlocking it.  (FULL CREDIT GOES TO HIM FOR THAT FILE PRR2.EXE)
      Here are ALL the things I've added, modded, and enhanced on this bios -
      I've added FULL LEGACY SUPPORT ON THIS BIOS with ONE or TWO CARDS (SLI).  You can FINALLY use Win 7 OS on your machine and run the 900 series GPU's! 
      This is a MAJOR breakthrough!
      LEGACY SUPPORT Confirmed.  Works with 900 series GPu's in single OR SLI formation Updated the Intel RST Legacy to v12.9.0.2006 (Supports TRIM in RAID0 - CONFIRMED) Updated Intel RST UEFI to v12.9.0.2006 (Supports TRIM in RAID0 - CONFIRMED) Updated the ONBOARD Video Card for the HD3xxx to v2171 - FROM v2132 Updated ONBOARD Video Card for the HD4xxx to v2171 - FROM v2132 Updated the LAN Firmware & PXE Boot from to v2.0.6.6 ADDED NvMe Support for m18xr2 ADDED M.2 support for m18xr2 Updated CPU Microcode to v29 for the 2900 CPU's Updated CPU Microcode to v1c for the 3900 CPU's Updated GOP Driver for Intel Sandy Bridge CPU Updated GOP Driver for Intel Ivy Bridge CPU Updated MAIN GOP Policy module for the m18xR2 Eliminated some code that wasn't used in the m18xR2 Updated CSM Module (v2) Streamline some coding to make mod(s) run a little more efficiently (v2) Added FPARTS.TXT to rar file in v2. (I had forgot to add it in v1) v2.5 to be released shortly.  I've updated a few more modules that I didn't realize could be updated.  (It's only 3 modules, but it's still an update!)   It should be released in about a week.  Hope this helps ya'll!  
      Instructions to flash:
      Use a flash drive to create a boot disk into dos Unzip ALL files into the root of the flash drive (flash.bat, r2final.bin, fpt.exe, flash.bat, prr2.exe, fparts.txt,m18r2.hdr, m18r2.hdr.bin, readmefirst.txt) BOOT INTO DOS – Note, that when you set the bios to legacy in order to boot into dos, you MAY have to reinstall OS!  (Just be prepared to reinstall no matter what) Once you boot into dos, run the file flash.bat It will unlock your bios (THANKS TO SVL7’s BIOS UNLOCKING TOOL – ALL CREDIT TO HIM FOR THIS TOOL!) Let it flash… Reboot your pc, and enjoy the MASSIVE updates!  
      Be on the lookout as I do plan to release newer version with more updates in the future.  However, it wont be for at least a few weeks as I'm now working on legacy support for the m17xR4 and several other systems.  So please be patient!
      Thread link for more information and discussion:
    • By Rommancen
      Hello everyone, I decided to replace the video card on my MSI gx680 with gtx770m, the video card came from a dell laptop, it did not get stuck: the vent was turned on full, but there was no picture at all, I took it to the service with a request to flash vbios from msi, flashed, nothing changed. Does it make sense to give it for repair or video cards from dell do not work on msi notebooks?
    • By Seolly
      I have several questions on upgrading my M18X R2.
      My rig's GPU is 680m and video ram is 2GB. It's a relic :p So I will change it to 980m.
      1. Is it working on windows 7? (If it works, legacy or UEFI mode?)
      2. Is 980m /w G-sync compatible with my rig? 
      3. Are there any compatibility issues with M18X R2 and Windows 10? 
      I tried to find useful information far as I can do, but my English ability sucks :S
      Guys, please help me!
    • By ServusFidelis
      My 675m showed lines all across the screen but did let me go into bios.  I decided to go ahead and upgrade to a 980m and finally got it in the mail.   
      I installed the carf and i now get 8 beeps.   So I reset the CMOS and still 8 beeps.      I’m now tearing it back down to put the 675m back in. (I’ll finish after work).   I have bios a12 currently.  
      What at exactly do I need to do?   
      Any my help would be greatly appreciated.   Will post on YouTube when and if I can get it to work with your help.  
  • Create New...

Important Information

By using this site, you agree to our Terms of Use. We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.