Jump to content
EwinRacing Flash Series Gaming Chairs
metatime

What's your experience with Lenovo customer service?

Recommended Posts

I bought a bluetooth mouse on sale about a year ago. It died a little over a month... so I called support and told them my situation. They sent me postage through my email and sent it back. I waited about 2 months and wanted to find out if I'm getting a replacement or not so I chatted with the CS rep. He was nice and said he'll find the status and let me know through email.

Well I don't like to pressure anyone or push anyone so I waited like a month for another status update. I chatted with a lady and she found out that nothing was really done besides a ticket was open and she said she'll send a status update to me through email.

So.... waited another 2 weeks this time... got another lady on chat and well... she wasn't helpful. Another month past (got caught up on some stuff) and started to get irritated. So I got another guy on chat and explained the situations, show him some of my past chats (I save most my chats) and he said can't give me a replacement but reimburse me....

So got busy with life and never seen anything reimbursed or anything. Those CS reps just keep making you go in circles over and over until eventually you give up.

Lesson, most are nice but you'll get no results. Anyone else have better results?

Share this post


Link to post
Share on other sites

I actually I just sent in my Y510p it only took 7 days from sending it in to getting it back, and they even upgraded my motherboard to one with a populated SSD slot.

But your situation sounds like what I went through with Motorola when they were "fixing" my Atrix 4G's digitizer. After 5 months of calling them and being told that it was being worked on, I finally spoke to someone helpful who informed me that they had scrapped my phone for parts months ago (even though I had been told a week prior that it was still being worked on) and that they couldn't do anything about it. Another two weeks of calling later and they finally agreed to send me a replacement. Three weeks later when it arrived, I opened the box and noticed that It was refurbished (they told me it would be new). Thinking nothing of it I powered it on, only to see that 50% of the LCD worked. Luckily when I explained my story to AT&T they agreed that it was unacceptable and gave me a new phone.

I have never trusted warranties ever since and was shocked when Lenovo fixed my laptop considering that It was my messing with a modded bios's that bricked it in the first place.

Share this post


Link to post
Share on other sites

I found the same of the mix from above. A week before my warranty ended, i broke my first Y510p. Lenovo kept it for about 8 days before sending it back to me and saying that the warranty had expired. When i filed the RMA claim, it was within it's warranty period, but by the time they received it, it had expired. I couldn't get them to agree to do the work, and the only issue was the SSD that came with mine, had failed and died. Becuase i didn't have the recovery partition anymore, i couldn't recover it without hassle and headache. I figured "If they'll fix it, i'll use it until i really need a new laptop"... but then i got another Lenovo anyways, due to the cost vs specs. Anything similar from anyone else was over 300 dollars more, so i decided that bad support vs saving 300 bucks was a good trade. I haven't had another issue aside from dead WIFI N card in my new laptop now (Bought it in May, not even a year old), and i don't feel like shipping it to them and using the warranty replacement to fix just a wifi card. Time to do it myself and flash the BIOS, and if it breaks, i'll send it in anyways, and claim i was updating the BIOS and it died. Either way, no risk, no harm, no loss, and saved a bit of cash.

Share this post


Link to post
Share on other sites

I've owned a Lenovo Y510p for 2 years now. My first battle with customer support was trying to figure out when they were going to ship my laptop. There site said 2 months which was unacceptable to me so i called. They couldn't give me an estimated time but said it would be much sooner than what their site says (then why does there site say that?). I was transferred twice because the first 2 people didn't know what they were doing. In the end, it ended up taking three months to arrive.

Second issue i had with them was trying to figure out if i could upgrade the wireless card, what a nightmare. Nobody could give me an answer. It's like they put their worst support staff on the phone first and then transfer you to someone who knows slightly more, and so on.

I'm satisfied with my y510p but hate Lenovo support. Also i wouldn't recommend the chat option if it's a complicated question because they send you generic answers that aren't the ones you're looking for.

Share this post


Link to post
Share on other sites

Mine was OK. I sent mine in for the manufacturers defect where the left hinge rips open. I got it repaired, but it was a hassle. They stated it was user caused, when it isn't. I had to have it escalated to Customer Service Management, who then made it a free repair. It was annoying, but at least it got fixed.

Share this post


Link to post
Share on other sites

International service is quite bad, let me tell you my story. I live in Mexico and decided to buy a Y510p as a gaming laptop, after using it for a while I found some problems with the trackpad and WiFi reception. Since the laptop was brand new I called customer support hoping that they would replace the defective parts. Upon calling repeatedly a guy with an accent from South America answered the phone and insisted I gave him my address, telephone, laptop serial number and several other things before even asking what my problem was. Troubleshooting with him was basically rebooting the laptop and hoping for the best, the guy clearly had no idea what he was doing.

To make matters worse the call ended abruptly and upon dialing again another south american guy answered and refused to help or reconnect me until I gave him all the info I had previously told the first guy. This second man essentially instructed me to clean with a dry cloth the trackpad to fix it getting stuck upon clicking, not responding and moving the mouse randomly and told me it was normal behavior of the laptop to drop the WiFi connection every 10 minutes.

It appears to me that they are told to find any excuse possible to not offer the free repairs the guarantee gives the user. I have no intention of contacting customer support again.

Share this post


Link to post
Share on other sites

I have a y400, inmediately my warranty expires, the laptop fail, no one in lenovo respond my claim, sad history.

Share this post


Link to post
Share on other sites

Got a Y510p last year, the screen were broken out from the box, contacted with Lenovo and the return process were pretty smooth and they also arrange to ship another one out with next day service.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Similar Content

    • By thinkdad
      Hi,
       
      I need help in fixing my Thinkpad.

      I just got a T440p yesterday. It was working perfectly until the following:

      I reinstalled Windows and then I installed Vantage.

      I installed all the latest drivers.
      I also choose to install the bios update. The bios update ran in Windows and it asked me to restart. After restarting, the screen was blank. I tried powering it off and on and I saw the Thinkpad logo but after that the screen was blank.

      I tried powering on and off again and there's no Thinkpad logo now and the screen is just blank with the green power on. No sound, no nothing.


      Here's what I tried:
      Pressing the power button 10 times and then holding it for 30 seconds. Unplugged and battery is detachted Detached the CMOS battery and the reattached it Removed the ram, harddisk and optical disk drive. Attached the battery and inserted the charger. I turned it on and there was a couple of beeps Tried pressing FN+R and created a bootable USB I'd like to ask: How do I fix this? What do I need to do?
      Can I reflash the bios in some other way? Do I need to buy a new motherboard? Will this solve the issue? It's my first thinkpad and I'm really excited but I was bummed out that this happened. Can you please help me?

      Thanks in advance!
    • By sam@83
      Hello !
      I tried a tutorial on the forum to remove the supervisor password on a X260 thinkpad but the winbond 25Q128FVPQ chip is not recognized with the programmer CH341A and ASprogramer (does not detect automatically and not manually). Plugged into the motherboard with a soic8.

      Can you help me with detection?
      Can I find the password with the software or do I have to write it?
       
      Thank you so much !!!
    • By Cubitci
      To install the unlocked bios, I prepared and booted a freedos usb. I start the installation by typing flash.bat but every time I get the following error: Error 28: Protected Range Registers are currently set by BIOS, preventing flash Access. Please contact the target System BIOS vendor for an option to disable Protected Range Registers.
      How can i solve this problem ?
    • By arifhsn
      https://www.sendspace.com/file/0zjk9f
       
      please help i can't access my g5070's advanced menu
    • By raqall
      Hi!

      I would love to have my BIOS modded to disable the wireless whitelist.
      I tried to do it myself (dump BIOS from chip, disassemble, locate the reference to the error message "Unauthorized Wireless network card is plugged in..." memory address and modify the condition in the binary file so not to "land" in the infinite loop) but I couldn't dig to anything meaningful I could easily change.

      Laptop: Lenovo ThinkPad S440 (TYPE 20BB-S00400)
      BIOS version: 73ET71WW (1.71)
      Original WiFi/BT card: Intel Wireless-N 7260 (7260HMW BN) (vendor: 0x8086, device: 0x08B2, subdevice: 0x4262)
      Target WiFi/BT card: Broadcom BCM94352HMB (I haven't received it yet, waiting for delivery)

      Manufacturer BIOS download: bootable ISO, updater for Windows
      My BIOS dump (using CH341A SPI Programmer under Linux): http://www.mediafire.com/file/mn0gfr9ext7yqrn/S440_73ET71WW.bin/file
       
      Thanks!
×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use. We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.