Jump to content
svl7

Acer Aspire V3-5xx series - BIOS mods for higher Nvidia GT640m clocks

Recommended Posts

yeah, hello guys!

my brother has got the Acer V3-571G. (i5-3210m, 8GB RAM, GT640m) so i told him that there is a nice vbios for the gt640m.

i flashed it for him...

and it works pretty well!!

Before: [ATTACH=CONFIG]6785[/ATTACH][ATTACH=CONFIG]6786[/ATTACH][ATTACH=CONFIG]6787[/ATTACH]

NVIDIA GeForce GT 640M video card benchmark result - Intel Core i5-3210M Processor,Acer VA50_HC_CR score: P1821 3DMarks

After: [ATTACH=CONFIG]6788[/ATTACH][ATTACH=CONFIG]6789[/ATTACH][ATTACH=CONFIG]6790[/ATTACH]

NVIDIA GeForce GT 640M video card benchmark result - Intel Core i5-3210M Processor,Acer VA50_HC_CR score: P2059 3DMarks (i only overclocked the memory of the GT640m to 1200mhz. the core ist the ''stock'' from the modded vBIOS)

games run much smoother now!

BIG THANKS AGAIN svl7, for the great work!!! :)

Could you list out the steps you took to flash the modified bios? For some reason, I'm always encountering errors. When running the flash tool, I get Error 200: Invalid parameter value specified by user. Use -? option to see help. I'm pretty new at this stuff, so it'd be great to get a step-by-step procedure for us non-techies heh.

It's great news that everything works fine for your brother though! I'm excited to hopefully get it running on mine.

Share this post


Link to post
Share on other sites

i'm sorry, but I think you should wait for the advice of an expert. ( @svl7 )

because i just downloaded this file Downloads and extractet it to the desktop.

closed all programs and runned the flash tool... and it works without any error:o

maybe your BIOS version is to new? what do you got for a BIOS installed?

Share this post


Link to post
Share on other sites
i'm sorry, but I think you should wait for the advice of an expert. ( @svl7 )

because i just downloaded this file Downloads and extractet it to the desktop.

closed all programs and runned the flash tool... and it works without any error:o

maybe your BIOS version is to new? what do you got for a BIOS installed?

I have version 2.13. So I found out the error, it's really weird:

Error 75: "fparts.txt" file not found.

The file seems to be there, I don't know why I'm getting that error. So as of now, I can't even make a dump of my bios. Here's my info.txt:

Intel ® Flash Programming Tool. Version: 8.0.10.1464

Copyright © 2007 - 2012, Intel Corporation. All rights reserved.

Platform: Intel® HM77 Express Chipset

Error 75: "fparts.txt" file not found.

Share this post


Link to post
Share on other sites

schranzmaster: tell your brother, grats. Yes, SLV7's bios seem to work great with I5s and I7s. However, there has been issues with the new UEFI/Windows 8 one to my knowledge.

Dustin: Fparts.txt should be in the compressed archive. It was there for me. Are you sure you uncompressed it properly?

Share this post


Link to post
Share on other sites

Hi guys, I've just recently bought the Acer v3-571G after finding out this thread and that I can overclock the GPU. My Acer came in with v1.08 of the BIOS and the version offered at the download sections states it's 1.07? If I'm not mistaken, didn't svl7? post a modified version of the new BIOS file, including the UEFI version for those with Windows 8?

Unless I'm missing something here, I can't seem to view any file other than the 1.07 one. Can anyone guide me?

Share this post


Link to post
Share on other sites
schranzmaster: tell your brother, grats. Yes, SLV7's bios seem to work great with I5s and I7s. However, there has been issues with the new UEFI/Windows 8 one to my knowledge.

Dustin: Fparts.txt should be in the compressed archive. It was there for me. Are you sure you uncompressed it properly?

I'm quite certain that I compressed the archive properly. I see fparts.txt right inside my Fptw64 folder.

EDIT: Actually, it works now. Must have been a path problem, so I just put all the files to the my System32 folder and it recognized it. Now, I can flash the modified bios for 2.13. Did anyone else try this yet and has it worked successfully? I just want to make sure that I don't brick my laptop :o.

schranzmaster: What version bios were you using? Are you using the Windows 7 version of this laptop?

Share this post


Link to post
Share on other sites

glad to hear you got it fixed. What version of windows are you running and how old is your laptop? Mine is 30 days old so I'm crossing my fingers for a reworked UEFI W8 new 2.1x BIOS one day. :)

Share this post


Link to post
Share on other sites
glad to hear you got it fixed. What version of windows are you running and how old is your laptop? Mine is 30 days old so I'm crossing my fingers for a reworked UEFI W8 new 2.1x BIOS one day. :)

I'm running Windows 8 64-bit, with Bios 2.13. My laptop is around fourth months old so it's still running beautifully. I can manage to get +135mhz on core and a bit on memory using MSI Afterburner.

Share this post


Link to post
Share on other sites
I'm running Windows 8 64-bit, with Bios 2.13. My laptop is around fourth months old so it's still running beautifully. I can manage to get +135mhz on core and a bit on memory using MSI Afterburner.

Yup. I can achieve 135core/275mem boosts via inspector. SVL7's BIOS can achieve higher core clocks (which is what you want since this is basically a underclocked GT650/660 IIRC).

Share this post


Link to post
Share on other sites
Yup. I can achieve 135core/275mem boosts via inspector. SVL7's BIOS can achieve higher core clocks (which is what you want since this is basically a underclocked GT650/660 IIRC).

Have you tried the modified vbios yet? I'm just waiting until someone confirms that it works with the Windows 8 version 2.13.

Share this post


Link to post
Share on other sites

I need to fix that v2.13. Might find time during the weekend.

  • Thumbs Up 1

Share this post


Link to post
Share on other sites
Have you tried the modified vbios yet? I'm just waiting until someone confirms that it works with the Windows 8 version 2.13.

I personally went about 90% into it. I stopped however after finding a few members bricking or having issues with Windows 8 and the UEFI. I am just holding out to see if SVL7 updates it with any progress.

SVL: awesome :D I know quite a few members that will be happy if your able to manage the pain in the ass W8 UEFI bios. However, since Linux developers can workaround the UEFI I'm hoping Windows 8 can too. Apples to oranges but still. Kudos as always

Share this post


Link to post
Share on other sites

Hi, i have acer v3-571g and bios from acer site 1.13. Is it safe to use this mod which u made?

Share this post


Link to post
Share on other sites

Hello. I am from Russia. Sorry in advance for spelling errors (Google Translate).

Hopefully soon svl7 will make a new unlocked bios for Acer v3 571g. Especially has released version 2.15. Many people in the Russian forums are waiting for updates from svl7. Good luck to you, svl7.

Share this post


Link to post
Share on other sites

Small question. Does this bios work as well for Aspire TimelinU m5-581tg ?

Share this post


Link to post
Share on other sites

I see there is undervolting edition listed, but there is no linkt to it. Maybe I could use it to stop throttling and increase the clocks just a bit.

Share this post


Link to post
Share on other sites

is this mod still updated ? can i use it on my new v3 571g with bios version 1.13?

Share this post


Link to post
Share on other sites

HAllo is there any new bios 2.15 modded for the new acer aspire v3 571G with nvidia GT 730M???????????????? we are waiting this modded bios !!! if it's not possible is there any solution to downgrade my bios to another modded one?????????????? help me please

Share this post


Link to post
Share on other sites

I know that perhaps no one is working more in this thread, but some time ago svl7 has created another interesting bios for our acer v3 with unlocked Advanced menu options (this). I wonder if you can unlock the advanced menu also in this version with modded VBIOS.

@svl7 I hope you can still make us happy.

Share this post


Link to post
Share on other sites

Hello guys,

unfortunately svl7 no longer work to new bios mod releases , so I set to work to compile a new bios release which has a VBIOS overclocked with the added functionality of the Advanced Menu

The modified version of the bios is the last available non-UEFI (1.13) for owners of Nvidia 640M.

The base frequency of the 640M is set to 708.5mhz for the core and 900MHz for the memory, in this way the GPU boost is disabled, the maximum overclock remains of + 405 mhz then 1114Mhz in max overclock. In addition, the advanced menu unlocks many interesting features, but unfortunately the fan control is still not working.

Unfortunately I was not able to turn off or change the GPU boost table, so even having built other bios with higher clock frequencies the GPU boost under load sets the frequency to 708.5 mhz making unusable the basic clock rate increases. This is what happens in the bios modded by svl7 with 810MHz of base core but only 708.5 MHz under load. This also limits our overclock to "only" 1114 mhz when, as already demonstrated, this gpu can safely withstand the 1200MHz on the core. .

Now the question, can I disable the GPU boost by editing VBIOS? Or is it possible to flash the VBIOS of a nvidia 650M (it has a 950Mhz of GPU boost) by replacing the module in the our bios Insyde?

post-4858-14494996139371_thumb.jpg

Edit:

I have taken the the VBIOS module of the nvidia 650M from dumping of acer V3 771G bios, which I find much more similar than the VBIOS of asus I've used before.

The two boards have a different device ID, I was able to change the code, using an editor, the tab 1303fd10 in 1303fd20 but I get a checksum error, and finally I could not replace the device id. I think this is fundamental to flash the VBIOS correctly because with a different ID card would not be recognized (in fact in the dump are more VBIOS for different VGA that the laptop can have like 630M, 640M or 730m). I'd like to know if there is a way to change this device ID to flash correctly (I hope) this VBIOS or if there is an alternative way to perform this procedure.

I already have a bios compiled with this 650M Vbios module, I have not tried this, but, without change the Device ID, do you think this can work?

On request I can post the link of the bios that I've modified: V3 571G Ver. 1.13 - 640M @ 708.5 / 900Mhz with OC unlocked + Advanced Menu unlocked

I hope that my speech was understandable.

Thanks in advance for your support @slv7 or anyone who wants to help me.

Edit 2.

Thanks anyway, although I have not received help, I managed to solve all my problems.

Now i have a Nvidia 640M@650M with the possibility of further overclocking unlocked (+405 mhz), the base frequency is 835mhz - (950mhz with GPU Boost) core / 900 mem, so I solved the old GPU boost problem set frequency at 708.5 MHz, and now i can also get into overclocking beyond the threshold of 1114mhz..

With this mod i have 2404P on 3dmark11 at stock frequency

Considering that I'm totally noob in the bios modding, I feel very satisfied with the result, It's really nice to have a 650M when you bought only a 640M :victorious:

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×

Important Information

By using this site, you agree to our Terms of Use. We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.