Jump to content
EwinRacing Flash Series Gaming Chairs
Sign in to follow this  
munbeo

P150EM + 970M driver update problem! (Might be serious)

Recommended Posts

I am freaked out right now, please help me. I am using Prema vBIOS 2.0 for my 970m and Prema mod BIOS and the 364.72 drivers and everything are just fine. However, after i install the latest driver, the 372.70 driver, my games stopped switching to my 970m. So I uninstalled the 372.70 driver with DDU and installed the older version, 364.72 but now my games still doesn't switch.  I tried updating the latest Intel driver to no avail! Is anyone having problems with the 372.70 driver like me? Is there away to force the card to work on a program or something to make sure that it is a driver/software problem, not my card dying on me? Thank you so much for your help!

 

EDIT 1: I was on Windows 10 Anniversary. Did a clean install of Windows 10 Anniversary, didn't work. Revert back to a clean install of Windows 10, didn't work. Did a clean install of Windows 7, didn't work. (Different drivers for different OS used) Like I am seriously don't know what might even be the issue right now. 

Edited by munbeo
Update

Share this post


Link to post
Share on other sites

Just like to post a quick update. I was tweaking around with the computer and when I ran dxdiag in the display tab, it shows that Direct Draw Acceleration, Direct3D, AGP Texture acceleration are all "Not available." Updating Intel Drivers doesn't help. Any help is greatly appreciated!

 

EDIT: Apparently, installing the NVIDIA driver will disable these three options for me. Anyone having the same issue? Thanks

Edited by munbeo
Update

Share this post


Link to post
Share on other sites

i just tried installing the newest nv driver with prema mod v3b and it doesn t work either, so no bf1 4 me :D

Share this post


Link to post
Share on other sites

 

10 hours ago, Khenglish said:

Can you open the Nvidia Control panel if you right click on the desktop?

 

Yes I can. I can even set the games to run on the Nvidia GPU when I run the game it doesn't use the 970M. May I ask what build are you on right now regarding drivers, bios and OS? Have you tried updating to Windows 10 Anniversary edition (IF YOU HAVEN'T, DO NOT). 

 

4 hours ago, chap said:

i just tried installing the newest nv driver with prema mod v3b and it doesn t work either, so no bf1 4 me :D

 

Wow, you have prema mod v3b? Do you have to inf mod to install drivers? What OS are you on? Windows 10 Anniversary?  

Share this post


Link to post
Share on other sites

If you have access to the Nvidia control panel that means the driver is running and you are not having hardware issues. If you were the driver would not run.

 

Download Nvidia Inspector. There is an option called "optimus shim" or something like that that you must make sure is enabled. If you can't find the option I will make a screenshot.

 

I can't get win10 to not run the frame rate limiter, so I am using win7.

Edited by Khenglish
  • Thumbs Up 1

Share this post


Link to post
Share on other sites
3 hours ago, Khenglish said:

There is an option called "optimus shim" or something like that that you must make sure is enabled. If you can't find the option I will make a screenshot.

I found the Shim Rendering Mode Options per application  for Optimus and it is currently at: "SHIM_RENDERING_OPTIONS_DEFAULT_RENDERING_MODE" 0x00000000. How do I enable it? Thanks

Share this post


Link to post
Share on other sites

You want the setting "Enable applications for optimus". Try setting it to "enable".

Edited by Khenglish
  • Thumbs Up 1

Share this post


Link to post
Share on other sites
13 hours ago, Khenglish said:

 

You want the setting "Enable applications for optimus". Try setting it to "enable".

 

I did it. I don't think it is working. I am switching back to windows 7 and going to try the same thing and see if it works. 

 

EDIT: I went back  to windows 7. Installed the correct driver and changed the optimus shim setting and it still doesn't work. This is extremely weird since going back to a previous version of Windows (Clean Install) is usually supposed to fix all the problems. Thank you for dedicating your time to help me.

Edited by munbeo
Update

Share this post


Link to post
Share on other sites

Can you think of anything I could do to fix this? I even re-flashed my BIOS and vBIOS to no-avail. 

Share this post


Link to post
Share on other sites

Hi

i have a similar problem but with a p170SM and a 980M , both with the latest prema Bios and vBios. 

 

I installed the 375.76 with a modded inf. Can access the nVidia settings, but the card is simply not starting in games or optimus is not working right.

 

If i start a game the small LED that shows the activity of the dgpu does not glow...

 

Had a 770M before that and this one was working fine. Also using windows10, clean install already done :/.

 

Share this post


Link to post
Share on other sites
On 2016. 10. 17. at 4:39 PM, Core or Feed said:

Are you sure its running on your integrated graphicscard and not on GTX 970m with hard underperformance?

 

No. Its not.

 

Exactly same thing is happening to me also.

 

I was also using TH2 Build of windows 10 with 364.72 driver.

tried to update RS1, and coz i did clean installed windows installed all drivers automatically.

than i noticed windows never uses 970M but Intel HD 4000 only.

 

im so fucking pain in ass.

what i tried is : 

- Tried to install latest driver with inf mod, but fails. gives code 43 error at device manager.

- Re-flashed vbios as prema's. code 43 is fixed but still windows doesnt use 970M.

- Tried to install old driver 353.xx,355.xx But still doesnt uses 970M.

- Re-installed windows to TH2 Build. still no go.

 

For fucks sake... What the hell is wrong with 970M?

What i tried to do is updating windows to latest build, but makes my ass pain so much.

 

Anyone can help me please?

 

Share this post


Link to post
Share on other sites

Any news on this issue, Im on p170em and I still suffer from this.

 

 

Edit:

Solved at least for now.

 

Edited by j3tstream

Share this post


Link to post
Share on other sites

Windows 10 and nVidia stopped support and close down the new driverssupport for your machine.

 

First you have to modify your new driver, nvidia does not more support older clevobooks with new graficadapters. Only machines support, who get the rare Prema V3 Bios Versions (only for high cash from Eurocom).

 

Modify

http://null-bin.blogspot.de/2015/08/how-to-modify-nvidia-notebook-driver.html

Second you have to instruct Win10 to accept your moddified drivers.

 

Deactivate Windoze checksystem

https://www.deskmodder.de/wiki/index.php/Treibersignatur_deaktivieren_Unsignierte_Treiber_installieren_Windows_10

That are the problems.

 

Sorry for my bad english

 

Here is a example mod file for the Clevo P370EM and a nVidia GTX970XM

 

image.jpeg.66c0d773ae12301d1c9048d09ee265d2.jpeg

 

 

 

nvcvi.rar

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use. We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.