Jump to content

[M17xR3] Upgrade from 460M to 765M success! I think.


Recommended Posts

Posting to share success on doing a replacement of the original 460M discrete to a 765M discrete purchased from Ebay. And to make sure I didn't skip any important steps, and maybe find out the best way to keep an eye on the health of the new card in case I did a lousy job with the thermal pads or damaged something.


Installed unlocked A12 BIOS

after restart:

uninstalled IDT audio package from control panel->programs->uninstall


Shut down, went to bios, disabled integrated HD audio. Set video from SG to PEG to disable integrated HD3000.

Convinced Win8.1 to reboot to safe mode (charm, Settings, change pc settings, update and recovery, recover, advanced startup, clicked restart now)

When it came up, did advanced, change startup settings. When the menu came up, selected safe mode.

Used "Display Driver Uninstall" v12.4 to fully remove Nvidia drivers and shut down (third option).

Disassembled laptop, removed old card.

removed heatsink from old card, cleaned up the old thermal paste, replaced pads that were falling off, added a pad or two to places that looked like they needed coverage.

On the new card, it didn't have the weird metal backplate over some of the video ram (that Dell helpfully hides a pad under). Put a pad on the new card's exposed vram, but left the new backplate/spreader (lacking the dell plate) on it instead of trying to remove the old one from the old card.

applied a bit of new paste to the new processor, put the heatsink back on (having to remove the captured screws that worked with the new card. Fortunately the person I bought the new card included mounting screws, pads of varying thickness, etc).

installed the new card, buttoned up the machine.

Booted cleanly to bios, making me feel very very happy.

Immediately shot myself in the foot by reenabling the internal HD audio (too soon!), which caused the first windows boot to freeze on a white screen.

Went back to bios, turned the HD audio back off, booted to windows.


Up, on windows basic display drivers. Yay!

Extracted the 334.89 whql drivers I'd pulled from Nvidia.

Used the inf modding guide (
) to make the following changes in the nv_dispi.inf in the display driver folder.

Added to the last section:



Added to the NTamd64.6.3 section (and the 64.6.2 and 64.6.1 sections, in case I had to roll back to Win8 or Win7):

%NVIDIA_DEV.11E1% = Section102, PCI\VEN_10DE&DEV_11E1

%NVIDIA_DEV.11E2% = Section102, PCI\VEN_10DE&DEV_11E2

Ran the driver install, which failed with a vague error message. Remember the excellent advice from here to turn testsigning on.

From admin cmd prompt, did bcdedit /set {current} testsigning on


Tried running the nvidia setup again. This time it completed successfully.


Turned testsigning off (bcdedit /set {current} testsigning off)



System now working on nvidia drivers, appears to be set! Now to turn the audio back on.

Shut down, went to bios, enabled HD audio.

booted into windows...white screen again.

Shut down, disabled HD audio, booted into windows. Tried to install Dell provided IDT. It balked. Tried to install IDT from Realtek. It took. When system restarted, went in to bios before windows finished rebooting, enabled HD audio, saved and finished the boot. 8.1 splash screen showed, login showed, I started typing in my password thinking I was finally done, when the screen went black and did not recover.

Sighed. Hard power off. Boot to bios, turn HD audio back on.


System seems happy with the video card, but I failed to get around the white screen lockup fully. With the HD audio enabled, I get to the login screen but lose all video within a few seconds. With it shut down, clean boots. Audio shut down pending me figuring out what I did wrong.

So the video card went without any major hitches, barring me doing something dumb with pads or goo. The audio is still disabled, but I'm going to go browsing for the posts on how to do that RIGHT and see where I went wrong.

What else do I need to do? What is the best way to monitor video card (and cpu) specifics (like temp) even if I'm not going into the advanced menus to overclock yet? I used to have some widgets to watch that, but 8/8.1 seems to have killed that concept, so what's the best low resource but workable thing to use on an older Alienware?

Much thanks to @J95, svl7, and everyone else who posts problems and solutions for others to research!



M17xR3, Nvidia 765M (2GB, video BIOS, 8GB RAM, i7 (2630@2GHz), Toshiba 256GB ssd boot, WD 1TB data drive, purchased 2011,

  • Thumbs Up 3
Link to comment
Share on other sites

Using Dell/Alienware OEM nvdmi.inf (1028) makes it even easier, CTRL+H -> Find What: 05AE Replace With: 0490 -> Replace All -> done (Windows all versions).

Audio try this http://forum.techinferno.com/alienware-m17x-aw-17/4829-780m-gtx-m17xr3-integrated-soundcard-working-again-no-more-usb-soundcard.html

Monitoring tools HWiNFO64 HWiNFO, HWiNFO32/64 - Download Download TechPowerUp GPU-Z v0.7.7 | techPowerUp

  • Thumbs Up 1
Link to comment
Share on other sites

I pulled it off on the Windows 8.1 install prior to the post hitting the forum.

Then went back to try to make it go on my windows 7 install, and it was a nightmare.

I used the post you referenced, tried it as written, then with many changes, and could get nowhere. Decided on a clean install (to separate my boot and application partitions while I was at it).

I did the 'clean install' method. And it still took the better part of a day to find a working combination.

I believe this worked:

Bios->disable HD audio

(PEG is enabled, everything else is the same as my win8 install, including AHCI instead of raid).

Fresh install of windows 7 pro x64

Installed all drivers, in this order (rebooting at every request):


Intel Management Engine Interface

Intel Rapid Storage technology

Wired ethernet driver

Wireless driver (from qualcomm site, now that bigfoot has been bought)

The install folder I made in the first post for Nvidia (334.89-notebook-win8-win7-64bit-international-whql) to install the 765 driver

Attempted install (with the hardware still disabled) of dell A01 audio driver (failed for 'no supported hardware detected')

bluetooth driver

media card reader

touchpad driver

AW OSD driver (onscreen display)

Renesas USB driver

Intel Wireless display

Freefall sensor

Intel INF update (probably totally unneeded)

Made a system restore point.

Rebooted. Enabled HD Audio in bios.

Booted to safe mode.

Installed dell A01 IDT software

Rebooted. Saw that damned white screen (though my login worked, and I could hear audio).

hard power off; boot to safe mode. Clean uninstall of nvidia driver (DDU 12.4 again). Restart.

boot to safe mode again.

Reinstall Dell A01 IDT software.

Reboot to normal Win7.

Allowed system screen to go white. heard windows starting sounds. Put my password in blind.

Watched for drive activity to drop off, and login sound to happen.

Tapped windows key, right arrow, return (blind shutdown request), allowed graceful shutdown.

Boot to safe mode. Install nvidia drivers from my custom folder. Reboot to normal windows 7.

This time it worked. It appeared I needed to get one clean start, not in safe mode, to have the audio drivers 'stick' enough to allow the nvidia install to go (and resolve whatever resource conflict forces the white screen). I include all the verbiage because I had poor luck (or something) on doing it from an already finished install trying to do a clean OS reinstall, and though the keyboard shortcuts (and the knowledge that if you've got a white screen but hear all the normal system sounds, you can use keyboard shortcuts to get a graceful shutdown).

(possible dupe. Didn't see the reply post, didn't see the 'being reviewed' window either. If so, please erase)

Link to comment
Share on other sites

Appears I might not be quite as successful as I thought.

Ran a citrix session, and locked the computer up with a grey screen after the remote system seemed to be loading fine.

And when I look at GPU-Z (thanks, btw!) I seem to be missing physx and cuda support (which I thought sure the 765M could do).

Here's my output:


Worse, that side's fan doesn't seem to be working. I looked at the graphs in Z after looking at a brief game session (to see if games were working) and noticed the temp was at 53, and the fan 100%, but I didn't hear much fan action. Checked with my hand and the CPU side fan was running but the video side was not and the vents were hot to the touch. Flipped it on its side, removed the base cover, and the fan supporting the video heatsink is not spinning at all. Wires look fine. Ideas?

Link to comment
Share on other sites

  • 10 months later...

I have an Aleinware m17x r2 with 2 Nvidia GTX 285m SLI, one burned out so i decided to upgrade. I went through the whole process folling your first post and now I'm stuck at the sound point. Leave it off in bios it works fine turn it on and it pretty much crashes. I wanted to know if you found a resolution for this and hopefully its not as painfull like it was to get the card to even work lol.

ok I got the card to finally work and intalled all drivers. The problem im getting now is when I turn back on the IDT in bios and when windows is loading with the flag it pretty much crashes. So i have no sound atm. Anyone have aquick fix?

Link to comment
Share on other sites

  • 2 years later...
On 2014-3-13 at 1:57 PM, Kephra said:


Installed unlocked A12 BIOS
after restart:
uninstalled IDT audio package from control panel->programs->uninstall
Shut down, went to bios, disabled integrated HD audio. Set video from SG to PEG to disable integrated HD3000.


Hello, i'm stuck on this part. i got alread disble hd audio, set video from SG to peg and put 765m on it. But i could even get on bios, just 8 beeps any idea? This 765M is fully working, was used on my m15 R2, on my m17x R2 and no on M17x R3. Never updated Vbios. 

@svl7 sorry about tag u, but this topic is so dead. And maybe u could help me 



i tryed motherboard reset, pushing powerbutton without power. And now I just got black screen, no beeps anymore. And i noticed this 765m Vbios are different from yours, 

this could be the problem ? 

Look that labe behind gpu, that is my vbios. 


Edited by azshalsa
Link to comment
Share on other sites

  • 2 weeks later...
  • 11 months later...
  • 4 months later...

Hey any new updates on the 765M upgrade? Looking to upgrade my 460m as well to something more.......better haha Also putting in a SSD as soon as i get it next week.

Oh and what OS did you end up with it working on? I would like to run Win 10 hopefully!

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...

Important Information

By using this site, you agree to our Terms of Use. We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.