Jump to content
EwinRacing Flash Series Gaming Chairs
bruxel

Speaker issues with M14X R1

Recommended Posts

Hello there new to the forums,

Recently started having some problems with the speakers on my R1.

The audio started sounding like some speakers and bass was missing.

Checking the levels on my playback devices, seems that the only one working now is the front speakers.

(which when turned all the ways down turns the audio off).

As the music plays, the bass and back speakers will fade in and cut out from time to time, while the front continues to play.

When i plug it into external speakers it sounds fine as far as i can tell, but then again it sounds fine coming out of just the front speakers..

Would this problem be hardware related or is there some configuration/driver that could be causing this.

Thanks.

Share this post


Link to post
Share on other sites

There is a "subwoofer" that breaks if you play your speakers at high volumes... I think mine broke within a week of use. Chances are this is your problem as it was with mine.

While cheap to repair buying off of Amazon (or anywhere else).. You need to take the whole computer apart to replace it, but if you can do it easily if you are comfortable taking your laptop apart.

Share this post


Link to post
Share on other sites

I'm having an issue with my subwoofer as well. Was it just a poor design/bad batch? I'd purchase a replacement but if it's just going to blow out again I suppose I'll just skip it.

Share this post


Link to post
Share on other sites

This Happened to me it was so annoying. I had to send it to them to fix it. And they did :)

Share this post


Link to post
Share on other sites

Make sure you have the drivers installed correctly. If you dont have the drivers sound wont come out of the subwoofer.

i have windows 8 and sometimes no sound came from the subwoofer, after restarting it the driver "reloaded" and sounded good.

Share this post


Link to post
Share on other sites

My subwoofer does work, just that it works like a normal speaker. Isn't it normal. I have never really noticed this until it blew a few weeks ago and I had to order some replacement part from aliexpress, around 18 bucks.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use. We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.