Jump to content
EwinRacing Flash Series Gaming Chairs

Recommended Posts

Dell just released a couple of new BIOS for their most recent AW systems. Thanks @Nemesis for the big news.

There's no change log available, so let us know how it goes and whether you notice any big differences.

Maybe if someone could make some screenshots in case there's any visible difference...

I attached the untouched BIOS, it can't be accessed through the official site at the moment.

NOTE: You might not be able to easily downgrade to something older than A08 anymore.

EDIT 2: A09 is not on the Dell site, but file is nowhere to be found. You might want to wait with updating until they release A09.

Here's the official link: Drivers and Downloads | Dell [united States]

M17x_R4 - BIOS A08.zip

Share this post

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Similar Content

    • By MicroAlex
      Hello guys,

      Having s bit of a headache with a latest upgrade. Essentially I took my friends Alienware M17X R4 for an upgrade as the 7970M has kicked the bucket. We have decided on the 970M as the best option for an upgrade at that point, so we proceeded hunting one down in Ireland. Eventually we have located one for a decent price, however it was noted that this 970M is a 3GB version and if I remember correctly it was originally listed as compatible with MSI and Clevo laptops. We decided to try our luck.

      So after removing AMD drivers with the cleaning tool, flashing back from A12 BIOS to an unlocked A11, installing the card and trying to boot I got 8 BEEP error on post. As a result took out the card, tried PEG mode, etc... eventually go the laptop to boot with a card installed under SG mode. Installed a test driver from Eurocom and it worked! 
      The card was running well in a benchmark and also Dead Space 3. However it is not detected properly by either AIDA64 or OCCT. MSI Afterburner on the other hand does see the card and reports values correctly. More important than that is the fact that nVidia Control Panel crashes when I try to grab the hardware information sometimes, and always when I am trying to add a .exe in 3D settings to override the iGPU. 

      If it wasnt for the nVidia control panel I would not even bother figure this issue out. So now I am wondering is it the vBIOS? If yes then is there any available for the 3GB version of 970M that would be compatible with AW R4?

      PS, the laptop is with a regular non 3D panel, runs at 1080p.
      MSI & Clevo compatible GTX 970M 3GB 
      Windows 7 64BIT
      GPU fan works
      Let me know if you need more details.

      Any help would be much appreciated as this is going beyond my level of knowledge. Thank you.

    • By svl7
      Dell recently posted a new BIOS for the M11x R3 on their support site - A05.
      Grab it here: M11x R3 - BIOS A05
      Release notes:
      Since that's only half the fun I also unlocked the hidden menus, see attachment.
      As always with modified BIOS - use at your own risk, don't change anything you aren't familiar with.
    • By svl7
      Dell has hidden a lot of options in the BIOS of the Alienware M17x R4, the modified BIOS versions here will show you all the hidden menus and allow you to further tweak your system and optimize its performance.
      Don't change anything you're not familiar with. There might be functions available which don't work on your system, so use this BIOS with care. It should only be used by advanced users.
      In case you mess up and your system refuses to boot after applying the changes you make, remove the AC adapter, battery and coin cell battery in order to clear the non-volatile ram of the BIOS. This should fix most issues.
      If you're on A05 or an earlier version, you can flash the modified bios by simply using the InsydeFlash utility provided with the official bios update on the Dell support site.
      However, once you're on a version newer than A05, things get a bit more complicated. There are two options then:
      - Method 1:
      Revert to stock A05 or earlier by using the Insyde USB bios recovery method, and then flash the modified bios by using the official tools (InsydeFlash).
      - Method 2 (recommended):
      Flash the modified Bios from DOS by using the FPT tool:
      NOTE: The flashing from DOS as described above will only update the BIOS, not the rest of the firmware. Therefore I strongly advise you to first flash the stock version of the bios you want by using the official update provided by Dell, and once that's done you can go ahead and flash the modified version of your bios by following the instructions above.
      Download links to the unlocked M17x R4 BIOS versions:
      M17x R4 - BIOS A05 [unlocked] M17x R4 - BIOS A08 [unlocked] - see attachment M17x R4 - BIOS A09 [unlocked] - see attachment M17x R4 - BIOS A10 [unlocked] - see attachment [FPT] M17x R4 - BIOS A10 [unlocked] - see attachment [FPT] M17x R4 - BIOS A11 [unlocked] - see attachment  
      Donation link, in case you want to buy me a beer
      Here some pictures of the menus (thanks a lot for the pics @deadbydawn!)

      I want to thank @widezu69 for testing !!
      It's hard to find users who are willing to risk their system in order to test a mod, I greatly appreciate this! Thank you!!
      Flash and use at your own risk. I don't take any responsibility for any possible damages on your system.
      The software which I provide here ('prr tool') comes with absolutely no warranty to the extent permitted by applicable law.

      [FPT] M17x R4 - BIOS A10 [unlocked].zip
    • By Commando784
      I've had this issue a while ago on my Alienware m17x R4 with 7970m and windows 7 Ultimate x64 and I've been trying to fix this since, but I've found a solution :DIt's probably more simple then you thought it would be :PBasically, what you do is you switch to iGPU Intel HD4000 first (FN+F7),then you have to install this audio driver (A01, 4/30/12, Creative Labs CT9570, Audio_Creative_W74_5NJ7K_A01-Setup_ZPE.exe), driver from their website,Switch back into dGPU again,there you go :DHope this helps
    • By shabe
      Well sometime ago I disable the integrated graphics using the unlocked A08 BIOS. However, yesterday for some reason I was going to re-enable it again and made a mistake in selecting the wrong option on the Video Setting setup page. After that my computer has been unable to boot up and I get a blank screen. I tried the BIOS recovery by placing a usb stick on the eSATA port with the file named PAR00X64.fd and I get usb activity, a lot of beeps after that and two reboots, however, i get back to the blank screen again. I tried using all the available video outputs (vga, hdmi, display port) and it was a no go. I could only managed to see the intel raid driver screen via hdmi but after that I get a blank screen. My issue is not hardware related, more of a software issue and if i could manage to revert the BIOS to the default settings everything would get back to normal. My PC is an m17xR3 running the unlocked A08. Any help would be greatly appreciated.
  • Create New...

Important Information

By using this site, you agree to our Terms of Use. We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.