Jump to content
Apologies for the spam Read more... ×

MicroAlex

Registered User (Pre-Promotion)
  • Content Count

    3
  • Joined

  • Last visited

Community Reputation

10 Semi Elite

About MicroAlex

  • Rank
    Junior Member
  • Birthday 11/27/1989
  1. Hello guys, Having s bit of a headache with a latest upgrade. Essentially I took my friends Alienware M17X R4 for an upgrade as the 7970M has kicked the bucket. We have decided on the 970M as the best option for an upgrade at that point, so we proceeded hunting one down in Ireland. Eventually we have located one for a decent price, however it was noted that this 970M is a 3GB version and if I remember correctly it was originally listed as compatible with MSI and Clevo laptops. We decided to try our luck. So after removing AMD drivers with the cleaning tool, flashing back from A12 BIOS to an unlocked A11, installing the card and trying to boot I got 8 BEEP error on post. As a result took out the card, tried PEG mode, etc... eventually go the laptop to boot with a card installed under SG mode. Installed a test driver from Eurocom and it worked! The card was running well in a benchmark and also Dead Space 3. However it is not detected properly by either AIDA64 or OCCT. MSI Afterburner on the other hand does see the card and reports values correctly. More important than that is the fact that nVidia Control Panel crashes when I try to grab the hardware information sometimes, and always when I am trying to add a .exe in 3D settings to override the iGPU. If it wasnt for the nVidia control panel I would not even bother figure this issue out. So now I am wondering is it the vBIOS? If yes then is there any available for the 3GB version of 970M that would be compatible with AW R4? PS, the laptop is with a regular non 3D panel, runs at 1080p. MSI & Clevo compatible GTX 970M 3GB Windows 7 64BIT GPU fan works Let me know if you need more details. Any help would be much appreciated as this is going beyond my level of knowledge. Thank you.
  2. Hey there lads, I am having some trouble with my upgrade decision. Essentially I have thought that just like with desktops I will be able to easily upgrade my laptops GPU... NOPE! This laptop was rocking a 560M previously, however I have decided to strap a M290X to it. I did manage to get it working by updating to the latest Alienware unlocked BIOS and tweaking some settings. My problems is that the GPU fan will not spin at all while the laptop is ON. Yes I can control it with a 3rd party software, however I prefer that the fans would work automatically as when you are not in Windows you are baking your laptop. The fan is not faulty as was tested by swapping with CPU fan. Also GPU fan spins with custom HWiNFO curve and while performing a BIOS flash as both of them ramp up to 100%. I also did notice that Aida64 reports 1RPM 35% fan speed. I hope all it needs is a small tweak. Personally I have played around with flashing VBIOS to desktop cards, making slight mods to them and messing with Asus N61JQ AMIBIOS to unlock hidden menus. Any suggestion on what could be modified, tweaked and so on for this to work properly? Feel free to request additional info. PS, if to be believed the M290X 4GB card is from a new Alienware 17 series laptop launched sometime in 2013. Bios signature also shows DELL in the description. I know I do not have the minimum requirements to post or contact svl7 for a Bios mod, but I am curious if it is possible to make it work properly to begin with. I have no problems in making a donation for the help as I know that time is money. Specs: Alienware M17X R3 BIOS A12 (unlocked) Intel i7-2670QM nVidia 560M (stock GPU) AMD R9 M290X (upgrade) 16GB DDR3 Stock power brick (also have a 330w brick) Thank you for your time.
×

Important Information

By using this site, you agree to our Terms of Use. We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.