Jump to content

Alienware m17x r3 with Dell r9 m290x(HD8970m)


Recommended Posts

I just got a Dell r9 m290x card for my m17x r3. I'm using the stock A12 BIOS. Had PEG set in the BIOS and on boot had a black screen. I cleared CMOS, most likely reverted back to SG and on boot had a black screen with 8 beeps.
I've seen people on here report that it is working for them. Do I need to use a different vBIOS? Or maybe the unlocked A12 BIOS with some settings changed?
Any help would be appreciated :)  Thanks.

Link to comment
Share on other sites

Another episode of "trying to do things that weren't meant to be done"...
I was wrong about it switching back to SG, it stayed on PEG.  I tried a few more things today and will just summarize from the beginning here:
I have an Alienware M17x R3 with an AMD HD6870M.  I got a Dell R9 M290X to replace the 6870.  BIOS was set to PEG upon starting procedure.
1) Swapped thermal solution to new card & installed new card
2) Powered on, got black screen
3) Powered off, removed CMOS battery
4) Powered back on, got black screen & 8 beeps
5) Powered off & on a few times, same results
6) CTRL+ALT+DEL, rebooted, same results
7) Removed new GPU
8) Booted fine with no discrete GPU
9) Checked BIOS, was still set to PEG
10) Set BIOS to SG
11) Reinstalled new GPU
12) New GPU shows in BIOS - ATI GFX
13) New GPU shows in Device Manager - AMD Radeon HD8970M
14) Intel GFX driver had a bang - Code 31 could not load drivers
15) Rebooted, same results
16) I'm using the Dell Intel driver - (it's old, but it allowed me to use HDMI-In with the old card)
17) Rebooted, now both cards have bangs
18) New card's driver says Code 12 cannot find enough free resources
19) Tried to auto update drivers, same results
20) Uninstalled both devices from Device Manager
21) Rebooted
22) Both showed up under Other Devices with no drivers
23) Reloaded drivers, Intel driver works, but same results with AMD driver
34) Had read somewhere that the integrated audio might interfere with some of these cards, so I tried disabling the onboad audio in BIOS, same results
35) Listed devices by connection in Device Manager, saw that AMD High Definition Audio Bus was on same controller, so tried uninstalling that, same results after reboot
36) Enabled show hidden devices in Device Manager, saw old 6800 series driver still there, but showing disconnected
37) Uninstalled old card's driver, rebooted, same results
38) Ran GPU-Z, shows vBIOS
39) GPU-Z did not show any sensor data
40) Ran HWInfo, shows GPU fan at 35%, but I have not seen the fan come on at all
38) Set back to PEG in BIOS
39) No black screen this time, was able to see the OpROM screen for RAID controller
40) Right after that, got corruption/artifacts on the screen (several vertical blue lines with some scrambled looking text)
Suspect the artifacts/corruption might be due to heat, since the fan does not seem to be working.  Will let it cool off and try again later.
Here's some info on the resource usage shown in Device Manager:
HD8970M - PCI bus 1, device 0, function 0
I/O - 0000000000006000-00000000000060FF
Memory - 00000000A0000000-00000000AFFFFFFF & 00000000C8400000-00000000C843FFFF
IRQ - (PCI) 0x00000007
Link to comment
Share on other sites

I let it cool down, since I thought heat might be causing the corruption on the screen.  And repositioned my external fan to help keep it cool.
Rebooted, still got corruption after the RAID opROM screen.
Remembered that I had been using a different charger for testing that had been causing an error on boot - not the factory charger yada-yada, press F1 to continue.  So I thought this might be that screen and pressed F1.  Yep, that worked and it started loading Windows.  All the following screens were ok.
In Windows, no driver was loaded and the device was listed under Other Devices.
I chose to reinstall the drivers.  It said drivers successfully installed.  But then went to the login screen (no reboot).  After logging back in, I noticed a message in the notification area saying the video driver had failed to start.  So I checked Device Manager.  But the driver was loaded and said it was started properly.  Perhaps that was from the first time and it had re-started since.
The GPU fan never did start turning, so I had to use HWInfo to control it manually.  This worked fine.
I tried a few apps and games, all went well.  I got awesome frame rates compared to the old card.
I think everything is going to work out ok with it, I only had a couple of concerns:
1) Once when I rebooted, I hit F2 to go to BIOS, the BIOS Information page was completely blank!  Bizarre, but only happened once, during early testing.
2) The fan not turning, although HWInfo manual control seems to work fine.
3) The scrambled screen on boot after the RAID opROM loads.  If there is an error, it will be unreadable.  However, if I switch back to SG, I should be able to read it.
4) My external monitor's resolution is reported a little shy of the max.  This is likely a driver problem and I will fiddle around with it later.
So the HD8970M / R9 M290X does work in an M17x R3.  Takes some effort & frustration, but works in the end :)
Link to comment
Share on other sites

  • 3 years later...

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...

Important Information

By using this site, you agree to our Terms of Use. We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.