Jump to content

Alienware m17x (2014) 8 beeps after bios flash


Recommended Posts

Hello everyone,


I've recently bought an Alienware 17 secondhand. Being the tinkerer I am the first thing I though of was getting an unlocked/custom bios.


While flashing the mod I saw Svl7's name, someone I used a custom bios from in the past for my clevo p170em, which worked flawlessly and I was really happy with. 


Now the bad parts starts and I'm starting to panic a bit. The readme from the moderator described two flashing methods, the first one to use a DOS usb and run flash.bat. I tried about 10 times but I always got error 28, which he said I had to ignore and try method 2. 

Method 2 was to rename the bios file to VAS00X64.FD, VAS00X64.bin, VAS00X64.rom,  put them on a fat 32 usb, disconnect battery and AC from the laptop, hold the end key, connect AC and press the power button then wait for a beep and release the end button. Here is where it first started going wrong, I held the end button for 15 minutes but I heard no beep. I tried a second time, same thing. Then I tried starting the laptop, it gave me a black screen with 2 grey lines in and it beeped 8 times. I searched a bit online and this is supposed to be a display issue? How can a display issue occur after a bios flash? I've come to this forum like I did with my clevo p170em in the hopes I'll get a reply and a fix, I've had a good experience with Svl7's mod before.


I hope someone can help me and thanks a lot in advance.


EDIT: I've tried several things so far, reset CMOS, tried to recovery flash stock a14 bios, took out gpu, took out display and nothing of these worked. However, there seems to be a second connector to plug in LVDS cable, right above the one where the original was plugged in. When I insert the LVDS cable into the second connector, I get no more beeps but display also doesn't turn on. When I connect an external monitor through hdmi, the external monitor turns on, flashes for one second and the laptop restarts. Any ideas?


EDIT 2: 

I somehow managed to get screen.
When I inserted my gpu again, with the LVDS cable into the EDP port and an external display, I get screen on my external monitor and I can use my laptop as normal again. I flashed original stock bios. So how do I fix my laptop screen now?

I narrowed it down a bit. I put LVDS cable in original port and I looked into bios and it said Integrated GPU: (none detected) which was very strange to me, I have never disabled it before. So after booting into OS I looked into device manager and HD 4600 was missing. It was just gone. So I pressed FN + F5, it asked me if I wanted to enable integrated gpu, I said yes and laptop restarted. Then it was the same issue again, black screen (backlight does turn on) with 2 grey lines. So any ideas? How do i re-enable HD 4600?

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...

Important Information

By using this site, you agree to our Terms of Use. We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.