Jump to content

M17x r3 Mods/Fix/Random

Recommended Posts

Hey guys, 


I have an Alienware m17x R3. i bought it as scrap. but currently working. i have this issues with this device. i hope you guys can help me out with this.




The device is charging when its turned off. and when its on (on) state, when i plug in the charger it turns off the light in the charger port.

solutions that i have tried: changed the charger and battery, flashed the bios.


change a capacitor near charging port. 


after all of the solutions i tried. i have found one thing to be suspicious about. The device charges normally even on (on) state and doesn't kill the light in the chargers port. if i dont install the driver of the GPU 680m Dell 2gb. 

can anyone help me with his matter? thank you

Link to comment
Share on other sites

  • 1 year later...
  • 2 years later...

With the BIOS a8 unlocked and installed gtx 880m / stock gtx 560m /, his laptop should start about a minute after pressing the start button and the picture is in four rows with low resolution.  Is it a defective video card or do you need a12 bios?

Link to comment
Share on other sites

  • Create New...

Important Information

By using this site, you agree to our Terms of Use. We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.