Brian

ATi/AMD 5870M Vbios Flash

32 posts in this topic

NOTE: Dell has released the official vbios + flasher which I would recommend using if you do not want to do a manual dos flash: ftp://ftp.us.dell.com/video/R281544.exe

------------------------------------------

THE FOLLOWING IS THE DOS METHOD OF FLASHING THE NEW 5870M VBIOS INDIVIDUALLY ON EACH VIDEO CARD. THIS MINIMIZES THE RISK OF BRICKING YOUR VIDEO CARDS:

Important points to note before updating the 5870m beta vbios:

1) This VBIOS is ONLY for the 5870 cards and works with single or crossfire confingurations. There is currently no update needed for the 4870 cards.

2) This VBIOS will flash your card to the latest revision.

3) You MUST load the 8.763 video driver stack BEFORE flashing your VBIOS. If you flash before you load the newer video drivers, the result will be endless BSODs. Safe mode or VGA mode will work around this… Once you have the new VBIOS, you can’t use the 8.6xx driver stack any more.

4) It is recommended you download and install the 10.8a Crossfire Applications Profile along with the Dell 8.763 driver release.

By using the manual dos flashing method rather than flashing within Windows, you reduce the risk of bricking your cards. Furthermore, you will now have the ability to revert back to the old shipping vbios should you desire.

Step 1: Download all the following files as they will be needed throughout this guide.

1. Download the HP USB Key Utility: HP USB Disk Storage Format Tool - v2.1.8 Download - EXTREME Overclocking

2. Download the Windows 98 system files: Windows 98 System Files Download - EXTREME Overclocking

3. Download Atiflash files: techPowerUp! :: Download ATIFlash 3.79

4. Download the new Dell beta vbios files from here: Dell 5870m beta vbios

Step 2: Creating a Bootable USB Drive to Flash to GPU

1. Install the HP USB Key Utility

2. Launch the HP USB Key Utility and do the following:

- Insert your USB thumb drive.

- Select File system as "FAT32"

- Select Format Option as "Create a DOS bootable Disk..."

- Checkmark the box that says, "Quick Format"

- Locate the directory you extracted the Win98 files.

- Format the USB key using the the Win98 files.

3. Copy the extracted files from the DellBetaVbios.rar file onto your usb key.

Step 3: Flashing Your GPU's vBios to the new beta vBios

1. Make sure your usb is plugged in and system is on AC power.

2. Reboot.

3. Press F12 at the Alienware Logo screen.

4. Select "Boot from USB"

5. At the Command Prompt, type in "atiflash -p 0 dellb0.rom” (without the quotes) to flash the master card. Then after it has been flashed, type, “atiflash –p 1 dellb1.rom” (without the quotes) to flash the secondary/slave card. Once the flash process has completed, you may remove the USB key and reboot

Share this post


Link to post
Share on other sites

Hey Brian,

Nice guide. I'd just add a little note - when I did the above (it was few months ago when it was released), using Dell's flash software, it didn't want to work with my 8GB USB drive. It complained about it being > 4GB, so made a bootable DVD for flashing VBIOS. Probably a minor thing, but just FYI.

Share this post


Link to post
Share on other sites

I use an 8gb flash usb drive almost daily lately to reflash

Share this post


Link to post
Share on other sites

Sup guys! Came over from notebook review thought id ask for some knowledge dropped on me. I recently ordered 2 new 5870's for my M17x-R2 to upgrade from my 4870's now dell offerd free home tech to install but im quite worried that hes going to mess my perfectly working computer up if i let him. So the question is. Should i let him do it or is there plenty of info like a step by step guide online for me to do this? also once there installed what steps do i have to take to make sure there working perfectly.

Share this post


Link to post
Share on other sites

whew those guides are in depth haha i really want to do those thermal pad/paste upgrades too see to make it run much cooler but ill have to wait on that haha the 2 new GPU's werent super cheap lol.

Share this post


Link to post
Share on other sites

Unreal by the way I think it works on greater than 4gb drive as long as you format it the way that was posted with the HP format tool.

Share this post


Link to post
Share on other sites

hey guys so the installation worked perfect but i cant for the life of me figure out how to get the vbios off the dell website keeps starting up the download manager but never downloads anyting the master card came with the correct bios but the slave is sitting at the 20.19 so any help would be great!

Edit- Also i tried brians auto flash from dell but it tells me i do not have the 5870's installed the device manager says i have 2 5800 series so not sure what the problem is also i did a vantage run and got P15564 which seems right.

Edited by Zeratual

Share this post


Link to post
Share on other sites

I had similar trouble, I hate using Internet Explorer most of the time, but in this case you may need to use Internet Explorer instead of alternate browser. If downloading using browsers dowload manager than try updating the browser your using, check java version, update flash player and try again after a restart... could be one of those became outdated... I use Filehippo update checker it's free and it does a good job at telling you what you need an update to according to what you have installed. I set it not to start when the system does... but on my mom's system and girlfriends system since I help them on computer I have it start and check for new versions of software at every start.

Share this post


Link to post
Share on other sites

I think the problem on the Dell website is it asks you once whether you want to download with the browser or using their moronic download manager. Like me, you've fallen for another one of their classic pranks (BAZINGA!).

Clear the Dell cookies in the browser and try to download again.

P.S. Thanks for the update on > 4GB drives. I burned the DVD anyway - I think that was the second time in last 2 years I actually used the optical drive on M17x. :) First time was to copy Win install on USB key. :D

Share this post


Link to post
Share on other sites

Unreal under certain formatting options there can be a limit to 4gb and also certain manufacturers don't use the same standards.. So it's very possible you ran into one of those... It may have worked on my 8gb usb flash drive but may not be the case for the next person.

Share this post


Link to post
Share on other sites

ok internet explorer worked but its still giving me the error that i do not have ati 5870's. Again the Device manager is saying ther 5800 series?

Share this post


Link to post
Share on other sites

Don't worry about that. You can check it's 5870 in GPU-Z. I think it says "5800 series" in my Device manager too.

Share this post


Link to post
Share on other sites

ok then i so should i just follow brians method for the manual usb flash? since the auto flash will not work ?

Edited by Zeratual

Share this post


Link to post
Share on other sites

That would work just fine using Brians method... Did you burn the iso (cd image) onto cd and booted computer from it? That I believe is the instructions for the Dell vbios installer. I have it burned myself and have used Brian's method too, both work well.

Share this post


Link to post
Share on other sites

still getting micro stuttering in DA2 cant for the life of me figure it out

Share this post


Link to post
Share on other sites

Try VSYNC on or off, the opposite what you tried so far and or try RadeonPro. You can set a specific set of graphic settings for DA2 and find which ones improve performance for that particular game.

Share this post


Link to post
Share on other sites

Would anyone here happen to have the old 5870 VBIOS by any chance?

Share this post


Link to post
Share on other sites

M17x 5870m Vbios Version

Can anyone tell me what the updated vbios version for the 5870m is from Dell? I have had so many laptops replaced I don't remember if I flashed this one or not. Big waste of time if I already did it.

I have version 012.020.000.027.037640 according to gpu-z.

Share this post


Link to post
Share on other sites

This is what mine says

post-3-14494987990318_thumb.png

So yeah you have the latest one

Share this post


Link to post
Share on other sites

Hello ,

I joined this forum to just post this problem . I have tried to do the dell method but its saying I need 5870s to do this...which I do. So I decided to do the manual flash. I got it about 90% complete. Just when in the command prompt I do what is said and I get this error. " Exiting do to Signal SIGILL " Followed by about 20 lines of error codes.

Help ?

Share this post


Link to post
Share on other sites

A bit strange if I can give some advice it would be try to redownload all the required files for the manual flash maybe from another computer and set the USB drive back up again with the hp format tool. just start at the beginning again and see if the error is because of a corrupt file or block on you USB drive.

Share this post


Link to post
Share on other sites

Probably dell sent you the A00 version, whitch is a bit dodgy. I have sent a few pair A00 back to dell, with the engineer who bought them. As soon i see the label A00 dint even took my lappy apart. they did it 2x with me. Dell just try get rid of the old stock.

The best, contact dell and SEND IT BACK!!!

Hello ,

I joined this forum to just post this problem . I have tried to do the dell method but its saying I need 5870s to do this...which I do. So I decided to do the manual flash. I got it about 90% complete. Just when in the command prompt I do what is said and I get this error. " Exiting do to Signal SIGILL " Followed by about 20 lines of error codes.

Help ?

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.