Jump to content
EwinRacing Flash Series Gaming Chairs
TheGrreatGatsby

[GUIDE] Make new 2015 MBPr's with AMD GPU Compatible with an e-GPU [PROVISIONAL]

Recommended Posts

THIS IS A PROVISIONAL GUIDE THAT IS INCOMPLETE, CHANGES ARE BEING MADE CONSTANTLY, USE AT YOUR OWN RISK

After about 3-4 days of researching, I'm confident enough to start a provisional guide for 2015 Edition Macbook Pro Retinas both 13" and 15" that have dedicated AMD GPUs instead of nVidia GPU's. A few people have stated that it is impossible to use an eGPU with the new 2015 Macbook's but I believe this is simply not true. After chatting with 2 different Apple engineers at a Genius Bar, I was told that no changes were made to the new 2015 line of Macbook's that would effect the application of a eGPU build, and that it's highly possible to do so. With this in mind I decided to continue with my project and was able to do some extensive research on what parts I would need and what I would need to do with the software. The hardware remains the same, meaning there's nothing extra you should buy, that you would not have bought if you were building an eGPU for any other Macbook. The software, from what I can see is where it gets tricky but I'll get to that later.

First off I purchased these:

Power Supply - Used to power parts.

GPU/Graphics Card - The thing that's going to play Star Wars Battlefront on High Settings at 60 FPS (hopefully)

Akitio Case - Used to make GPU thunderbolt Compatible. (You're connecting your thunderbolt cable to this, as GPU's don't have thunderbolt ports).

Barrel Plug - Used to attach Dell DA-2 Power supply to Akitio Case and GPU.

Super HD Drawing of how the Connections look like

Imgur

You set up the Hardware like you would any eGPU build.

1. Connect Graphics Card to Akitio Case.

2. Connect barrel plugs 8-pin PCIe end to the Dell DA-2's 8-pin plug.

3. Connect one of the 6 pin PCIe plugs coming from the Barrel into the Graphics Card

4. Connect the Barrel to the Akitio case in order to power the case.

5. You have now powered the GPU and the Akitio case.

6. Your hardware is ready.

Now onto the provisional software guide:

The software is currently being worked on until my eGPU parts come in to test if it actually works (thus this being a provisional guide)

(Requirements: Windows 8.1)

At first I thought that the software would be just like any other Apple e-GPU project. Meaning, connect eGPU, install drivers etc. However, the new 2015 line of MBPr's that have dedicated GPU's (dGPU), use AMD rather than nVidia. What this means is that you can no longer use nVidia's Optimus technology in order to connect the eGPU to the new Macbooks with dedicated GPU's. What Optimus does is if it detects that there are 2 nVidia cards connected to the device (the one in the Macbook and the eGPU), it switches to the one with the most power, which would be the eGPU, automatically disabling the default dGPU for you. This allows someone with a 2014 Macbook that has a dedicated GPU, to use the internal LCD screen (the Macbook screen). This is not the case with the new MBPr's with AMD dGPU's. So now, we have to figure out a way to disable the default AMD dGPU and enable the Intel iGPU, which should allow you too use the eGPU for the internal monitor.

The problem is that device manager doesn't show the Intel iGPU by default, as that's the way Bootcamp is optimized. It is explained in more detail in the thread below. If you have one of the new 2015 MBPr's with a dGPU and you were to go into device manager on Windows, you would only see the AMD dGPU. You wouldn't see the Intel iGPU.

In order to solve this issue I looked at THIS thread. This thread basically solved the whole problem, thanks to users @ah- for providing the file that makes it so device manager shows Intel's iGPU (Intel Iris Pro 5200).

The instructions for device manager to show your iGPU are as follows: (Huge thanks to @juniordiscart , wouldn't be able to do this without him)

1. Install reFIND via Windows.

2. Reboot your computer, you should now see a new boot screen. You will see this every time you boot up from now on. Boot back into Windows.

3. Download THIS file and place it on your desktop.

4. Open up Command Prompt, run as administrator.

5. (Thanks to @juniordiscart for the clear and concise instruction)

Enter the following commands:

mountvol S: /S

This will mount the EFI partition in Windows and assign it the drive letter S. You won't be able to see it appear in "My Computer" however, it remains hidden.

S:

cd EFI

dir

Check the output after these commands. If you see a directory for refind, then you have refind installed and you can proceed with the next set of commands. Otherwise, make sure you follow the installation instructions for rEFInd for Windows onthis link: The rEFInd Boot Manager: Installing rEFInd

xcopy /E C:\Users\YOURUSERNAME\Desktop\apple_set_os.efi S:\EFI\custom\

This last one copies the efi file to the custom folder of the EFI partition. Make sure you get all of the "\" right and that your path to your apple_set_os.efi file is correct. It should ask you to create any custom directory if you don't have one already.

6. Now that you've done the hard part, when you reboot you should be brought to the reFIND boot screen and there should be a new option called something like "apple_set_os.efi". Open this up.

7. It should flash the screen quickly and bring you back to the reFIND boot screen. (If it opens up and stays on the screen for more then a minute, shut off your computer and try again)

8. Boot to Windows.

9. Check device manager. Your Intel iGPU should now show up.

Congrats you've done the hard part! Now install your Intel Drivers ( https://downloadcenter.intel.com/ ) BUT WAIT------

While installing your Intel drivers your screen will flash black and most likely freeze up. Let it sit like that for a couple of minutes or so and shut down your computer by holding the power button till it turns off.

Turn it back on, and REPEAT STEPS 6-7 above. Every time you shut down your computer you have to first start up the "apple_set" efi file, then start Windows. Or else your iGPU won't show.

Now you have the latest Intel drivers. Disable your dGPU in Device Manager (right click it, disable), your Macbook should auto switch to the Intel iGPU.

Personally, all of the above worked great for me. I was able to disable the dGPU and use my iGPU. The speed at which the 2880 resolution screen ran was evidence enough that it worked. Now, we wait :50_002:

Since my parts haven't come in yet I'm not able to see if connecting the eGPU will allow me to use the Mac's internal display, but they should be here soon so I'll update as soon as I get them.

(To be continued.....)

Edit: If anyone can explain to me what error 12 is and how it occurs please do :). Thanks!

  • Thumbs Up 3

Share this post


Link to post
Share on other sites

Hi, I have several questions.

I currently own the 2015 MBPr, is it possible to set up a titan x as egpu?

With the egpu system, will I be able to disconnect and connect frequently?

Do I have to go through the lengthy process each time I connect to the egpu?

thx.

Share this post


Link to post
Share on other sites

Yes it is possible to set up a titan x as an egpu. However, the card itself is really big so you're gonna have to leave the Akitio case open.

Yes you will be able to disconnect and reconnect frequently.

No you don't have to go through the lengthy process each time you connect the egpu. All you have to do is open up the apple_set_efi in refind, then boot up windows every time you shut down or restart your computer.

Share this post


Link to post
Share on other sites

Can you give me a list of things I have to buy for setting up a titan X. What power supply I need. What kind of connecting cords? Thanks again.

Do you have yours working now?

Share this post


Link to post
Share on other sites

NVidia Titan X 12G

RM750 PSU

AkiTiO Thunder2 PCIe Box

Im not sure if I can make the molex-to-barrel adapter bymyself. Is there one that I can just buy?

Do I need anything else?

Share this post


Link to post
Share on other sites
NVidia Titan X 12G

RM750 PSU

AkiTiO Thunder2 PCIe Box

Im not sure if I can make the molex-to-barrel adapter bymyself. Is there one that I can just buy?

Do I need anything else?

Well you can buy a barrel plug with screw terminals, that should be easy ;)

Are you aware that you will have to bend open the case to fit in the card and that it can't be covered buy the outer case?!

Also you need sth to start the PSU (paper clip trick or adapter).

  • Thumbs Up 1

Share this post


Link to post
Share on other sites

Any updates TheGrreatGatsby? I have the same Model as you and i'd love to add eGPU to my setup. Great work so far getting iGPU active in device manager

Share this post


Link to post
Share on other sites
Any updates TheGrreatGatsby? I have the same Model as you and i'd love to add eGPU to my setup. Great work so far getting iGPU active in device manager

Hi Svcti, TheGrreatGatsby has another thread in the Apple Implementation Guide also which is more up to date:

http://forum.techinferno.com/implementation-guides-apple/10489-2015-15-mbp-radeon-r9-m370x-gtx970%4016gbps-tb2-akitio-thunder2-win8-1-%5Bgatsby%5D.html

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Similar Content

    • By Tech Inferno Fan
      We've had a stack of recurring questions from with problems getting a mPCIe eGPU working. This includes GPU-Z not reporting no clock details, error 10/43 or even not being detected at all. Overall it's more troublesome getting mPCIe working than say expresscard or Thunderbolt.
       
      Here's some common problems and some troubleshooting steps to correct them.
       
      Getting a black bootup screen, resolving error 10/43 or ACPI_BIOS_ERROR win bootup messages
       
      Here the BIOS doesn't know what to do when it sees an eGPU. So the solution is to not let the BIOS see it. Do that by setting the delays on the eGPU adapter (CTD/PTD - EXP GDC or CLKRUN/PERST# on PE4L/PE4C). Boot with eGPU adapter in the wifi slot into Setup 1.30 or Windows. Is the eGPU detected?
       
      I'll add that should error 43 continue AND you have a NVidia dGPU as well as NVidia eGPU then it's likely because of having the mobile NVidia and desktop NVidia drivers loaded simultaneously. Proceed to uninstall ALL your NVidia drivers, use "DDU" to clean NVidia registry entries and do a 'clean' install of the latest NVidia desktop driver.
       
      mPCIe port that hosted the wifi card disappears when connecting an eGPU in it's place
       
      Use the Setup1.30 PCIe Ports->enable to enable the missing port.
       
      eGPU does not get detected
       
      Overcome mPCIe whitelisting by booting with the wifi card and then hotswapping in the eGPU. That way the BIOS will enable the mPCIe port to work.
       
      1. Boot with wifi card into Windows, sleep system, swap wifi card for mPCIe eGPU adapter and ensure eGPU is powered on, resume system. Do a device manager scan in Windows. Is the eGPU detected?
       
      2. Boot with wifi card into Setup 1.30 *carefully* hotplug the eGPU adapter in place of wifi card. Hit F5 to rescan the PCIe bus. Is the eGPU detected?
       
      If this enables detection then avoid this tedious hotswapping by seeking a unwhitelisted modified BIOS for your system OR test the Setup 1.30's PCI ports->undo_whitesting feature.
       
      eGPU still not detected - set the PSU to be permanently on
       
      The latest EXP GDC and BPlus eGPU adapters try to manage the PSU to only power on after they detect a signal. This can cause a race condition where the eGPU isn't ready to go when the CLKRUN signal is asserted.
       
      Avoid this by jumpering the PSU so it's permanently on rather than being managed. Depending on the PSU you are using refer to the following doco on how to do that:
       
      http://forum.techinferno.com/enclosures-adapters/8441-%5Bguide%5D-switching-atx-psu-using-paperclip-trick-swex.html
      http://forum.techinferno.com/enclosures-adapters/9426-220w-dell-da-2-ac-adapter-discussion.html
       
      eGPU still not detected - a non-standard mPCIe implementation by your vendor?
       
      PERST# mPCIe pin 22 may need to be isolated due to a non-standard implementation by your notebook vendor: http://forum.techinferno.com/enclosures-adapters/10812-pe4x-series-understanding-clkreq-perst-delay.html#post142689
       
      eGPU still not detected - faulty hardware?
       
      If you still don't get detection then test the video card and eGPU adapter in another machine to confirm neither is faulty.
       
      NVidia driver stops responding
       
      EXP GDC, PE4H 2.4 and PE4L 1.5 all use a socketted cable and therefore are not true Gen2 compatible device. This error indicates there was transmissions errors.
       
      The solution is either to get a better Gen2-compliant eGPU adapter such as PE4C V3.0 or PE4L 2.1b (both with soldered cable), or downgrade your link from Gen2 to Gen1 using BIOS options or Setup 1.30
       
      Other troubleshooting help resources?
       
      See DIY eGPU Troubleshooting FAQ.
       
    • By ReverseEffect
      3dMark11 Performance Preset Benchmark: http://www.3dmark.com/3dm11/11262792
       
      Required items:
      1.) Lenovo u310 (I have a Core i3 - Ivy Bridge, 8GB RAM)
      2.) 65CN99WW unwhitelisted.
      3.) eGPU (I used a EVGA GTX 750 Ti from another computer I had).
      4.) EXP GDC mPCIe Edition adapter (got from eBay - banggood seller).
      5.) ATX power supply (I used a 600W PSU from another computer I had).
      6.) USB wireless.
      7.) External monitor, keyboard, and mouse.
       
      Steps:
      1.) Obtain and install a unwhitelisted BIOS. If you are unable to obtain a unwhitelist BIOS, I think it might be possible to bypass it with Tech Inferno Fan's Setup 1.x (may need confirmation as I haven't used it myself yet.)
      2.) Shutdown computer and remove all USB devices, ethernet cables, power cables, card reader cards.
      3.) Remove mPCIe wireless card and detach antennas.
       
       
      4.) Attach EXP GDC external mPCIe cable to the former wireless slot and screw down.
       
       
      5.) Attach HDMI end of the mPCIe cable adapter to the EXP GDC device.
       
       
      6.) Attach graphics card to the EXP GDC device (I moved my laptop off the desk and onto the side shelf to make room on the desk for the monitor/keyboard/mouse).
       
       
      7.) Using the power cable adapters that came with the EXP GDC device, I hooked in my ATX power supply's 20 pin and CPU 4 pin cables. Then hooked the other end (8 pin) into the EXP GDC device. My EVGA 750 Ti also required that I use an additional PCIe power cable (6 pin) in the top of the card.
       
       
       
       
       
      8.) Then I attached my misc devices (HDMI monitor, USB keyboard/mouse/wireless adapter), and hooked in my PSU and powered it on (below is image of final product, also moved HDMI cable out of the way).
       

       
      9.) Power on your computer and let it install the standard VGA drivers and then install your drivers (I didn't have to go in the BIOS for any graphics settings, which it doesn't have anyways, nor did I have to disable iGPU in Device Manager before the card was added).
       
      Extra Info:
      I found that most games will play on med settings with about 45 FPS with this particular card.
      BDO: Upscale on - Anti Aliasing on - SSAO off - med settings.
      Skyrim: Med-High settings.
      Fallout 4: Med settings.
       
      (EDIT 5/19/2016) > Images added.
       
    • By TheLoser1124
      Hello, A couple of days ago I got a new GPU but when I installed it into my computer I was unable to use it but now I know why. When checking the device manger I went into the events tab of my GPU when I went to view all events, I noticed an error it said " event 411 kernel PnP " and It also said Problem Status: 0xC01E0438. I believe this is why my GPU hasn't been working on my PC. If you know how to fix this problem or have info on how to fix this problem that would be greatly appreciated. I'm also using a EVGA NVIDIA GeForce GTX 1660.
    • By TheLoser1124
      I'm having a problem where my PC is saying my eGPU is not usable, its detected in the Device Manager and it doesn't have the yellow triangle next to it. I cant use it games and the Nvidia Control Panel doesn't recognize it either. I'm using a EVGA NVIDIA Geforce GTX 1660. I'm using windows 10 and I tried DDU and reinstalling them and now I cant access the nvidia control panel. The GPU is not recognize on any other apps and I went on *********** and was unable to find my answer, Any help on how to fix this problem would be greatly appreciated.
    • By Radstark
      Title sums it up.
       
      TL;DR: we have a Clevo that runs a desktop CPU, one with those huge 82 Wh batteries. We remove the GPU and let it use the CPU's integrated graphics. How much time for the battery to go from 100 to 0? Is it comparable to an ultrabook's?
       
      I'm theorizing a mobile set with a static eGPU and an upgradable CPU. Given a hypothetical user that needs fast processing on the go and long battery life while retaining very high degrees of mobility, but at home wants a powerful machine to run most games, I guess that would be their best bet. It would surely be more convenient to keep everything in the same disk. And even though the thing would be quite heavy to carry around, changing CPU would be more cost-efficient than changing an entire laptop. (Not sure if I'm right here, and also I'm not sure whether the motherboard in a Clevo would be replaceable when the new CPU needs a different socket, which is another reason why I'm asking here.)
       
      If my above guesses aren't correct, then an ultrabook with Thunderbolt and without a dedicated GPU would be a better choice. If they are, then we would be carrying more weight in exchange of a more cost-efficient setup, which I think would be a fair tradeoff.
       
      Also I am aware of the heating problems that these laptops suffer from, at least compared to a desktop setup. Would they be solved by moving the GPU out of the chassis, and instead plugging it with an eGPU dock via Thunderbolt port?
       
      What do you think? Is it doable? If not, why?
×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use. We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.