Jump to content
EwinRacing Flash Series Gaming Chairs
GetFound

Alienware Warranty & Return Issues

Recommended Posts

perfect glad you got them to actually do work lol.

Share this post


Link to post
Share on other sites

@DanXbix, I foresee a new laptop in your future! The 285's arent just out of stock, they were discontinued due to overheating. An early welcome to the M18x... Be firm and polite and you will be taken care of!

Share this post


Link to post
Share on other sites
@DanXbix , I foresee a new laptop in your future! The 285's arent just out of stock, they were discontinued due to overheating. An early welcome to the M18x... Be firm and polite and you will be taken care of!

I can confirm this as my M18x i have now was an exchange on an R2 system under warranty...

Share this post


Link to post
Share on other sites

Hey all thanks :) my m17xr2 is already a replacement if they don't fix by Monday i will push for it. This is the first problem i have had with this unit. My old XPS m1730 had about 10 repairs before replacement to the m17xr2.

How does the RGB vs 18x LCD Compare? What was wrong with your m17xr2 mw86?

update: The service tech is replacing parts now they have sent 5870m x2, MB, Fans & Heatsink. Cards are refurbished as expected so will see if this fixes it.

Edited by DanXbix

Share this post


Link to post
Share on other sites

The 5870's are great cards! Push the system after the work with at least a 3dmark run... Honestly for the work I do and the games I play, I dont miss the RGB like I thought I would. The M18x's wled is still a great screen, even out of the box.

I started with an M1730, loved it, was a beautiful laptop. Until the video card overheated to the point the didnt shutdown and the heat warped the case and finally the whole system froze. (was it a bad sign that I ordered it in April 2009 and Dell discontinued the laptop in May 2009???)

Then I got an M17x R1 pretty well maxed out. That was a turd, 2 replaced in 2 months.

Then I got an M17x R2 and Loooooved it. Then 3 months and the first one died, 2 weeks in second one died, and 3rd one lasted 6 months. All different issues.

Now I have the M18x in my sig and this thing is a BEAST! I still would have been happy to if they would have just fixed my R2, but this thing is sweet. I really like the jump to sandy bridge. (-:

Good luck with the work, either option in good working order and you should be a happy camper!

Share this post


Link to post
Share on other sites

Thanks :) well i have tested machine a little last night and the 5870m are great cards however they a getting hot (85c) and CPU is idling at 60c and crossfire keeps dropping out (clocks on GPU2 stay @ 300mhz) Getting restarts while playing a game (no BSOD) for 10mins & also in benchmarks. I asked the service rep if had had worked on one of these machines before and guess what he said no. I had to guide him through pulling it apart haha when he put the machine back together he first taped the xfire cable to the mb (not ontop of the metal casing) I have email tech support "unresolved technical issue escalation" and stated nicely i want it fixed or replaced. Hopefully someone will ring today.

Share this post


Link to post
Share on other sites

Just loaded up Black Ops and laptop sitting on desk (back up a little) game started got to the very first shooting bit and laptop powers off! tried a second time and again powers off. does this sound like faulty cards? CPU, Motherboard??

Share this post


Link to post
Share on other sites

Does the light of the PSU stays on when the shutdown happens?

Share this post


Link to post
Share on other sites

When the PSU is tripping it indicates that there's a shortcut in the system, at least for a while, or that the PSU is dying...

Since this only seems to happen when you start a game I guess it's the PSU, the power draw raises when you start the game, this might cause it to trip. Do you have another adapter for testing purposes?

Share this post


Link to post
Share on other sites

unfortunately no :( this is driving me mad :disturbed: i haven't heard from dell either and not sure if i should wait or ring again.

Share this post


Link to post
Share on other sites

Yeah, if your system is still covered by warranty just call them. (Don't send them an email, takes too long until you get a response)

Share this post


Link to post
Share on other sites

covered until end of 2013 :) so glad i extended warranty talk about timing. this unit is a new build and only 8months old. Love the RGB screen!!

Share this post


Link to post
Share on other sites

So an update i got a response back from the email from ANZ_Escalation Rep. He said "we are not able to offer you a replacement or refund since this system is already close to 1 year old" umm you have before i have emailed him back asking for brand new cards or replacement. They have automatically organized another repair. I also rang dell tech support but they said as it has only been repaired once they can only send out parts again. I said a previous rep told me there is no ETA on cards and they are on backorder (also he confirmed 285m SLI are not made anymore hence upgrade) said he would check on date and give me a call. I stated this was a replacement and original was fixed 8+times. Have also tweeted to @dellcares but not sure if that will help as i'm in AUS. Do i need to accept another repair? how many before they replace if not fixed?

Share this post


Link to post
Share on other sites

I know that the situation out of the US is a bit tricky. Dell Israel didn't agree to give me a replacement after 3 tries at fixing my R2 as well. I had to agree for the laptop to be sent to their lab (even though i paid premium for on site service). I guess it really depends on how much you press and if you're lucky enough to get a rep that is willing to help.

Good luck!

Share this post


Link to post
Share on other sites

I will be refusing depo service as I did will old system. They have created another service no without telling me. Replacing CPU, Motherboard, 1x GPU (a 285m which I was told they cant get anymore) fan & heatsinks. They said Monday service tech will ring. I will get service done and refuse GPU as I have 5870m in there one of which is faulty. The rep last night said after that they can put in a request for replacement as I have had all parts replaced. Currently when the laptop is idling the screen goes all garbled, freezes and fans max.

Gpu 1 hit 110c omg!

Edited by DanXbix

Share this post


Link to post
Share on other sites
I will be refusing depo service as I did will old system. They have created another service no without telling me. Replacing CPU, Motherboard, 1x GPU (a 285m which I was told they cant get anymore) fan & heatsinks. They said Monday service tech will ring. I will get service done and refuse GPU as I have 5870m in there one of which is faulty. The rep last night said after that they can put in a request for replacement as I have had all parts replaced. Currently when the laptop is idling the screen goes all garbled, freezes and fans max.

Gpu 1 hit 110c omg!

Hang in there it took them a lot of time to finally put everything through for replacement but your probs warrant it for sure.

Share this post


Link to post
Share on other sites

I hope you guys don't mind me ranting lol. I contacted Tech support for the 10th time last night making sure i ring them every few days. Basically the guy from ANZ_Unresolved Issues has dispatched another service with the 285m GTX sli cards and as i found out again last night NO ETA.

The Rep last night said the ANZ_Unresolved guy has made it a candidate for replacement i think pending repairs (which the 285mGTX won't arrive)??? They keep telling me different things but i have logged everything. I have now emailed the rep and awaiting reply but not holding my breath.

ARghh!!!!! lol

Edited by DanXbix

Share this post


Link to post
Share on other sites
I hope you guys don't mind me ranting lol. I contacted Tech support for the 10th time last night making sure i ring them every few days. Basically the guy from ANZ_Unresolved Issues has dispatched another service with the 285m GTX sli cards and as i found out again last night NO ETA.

The Rep last night said the ANZ_Unresolved guy has made it a candidate for replacement i think pending repairs (which the 285mGTX won't arrive)??? They keep telling me different things but i have logged everything. I have now emailed the rep and awaiting reply but not holding my breath.

ARghh!!!!! lol

Your situation mirrors mine and probably others. Hang in there grass hopper lol... keep up what your doing its the only way to get anywhere...

Share this post


Link to post
Share on other sites

They just rang 5mins ago to say the parts are on backorder 3days lol yeah right haha Another email & call to tech support arghhh!!!

rang tech support again lol and the rep is saying if they request replacement it will get rejected as only 1 maybe 2 services have been done. he stated it had to be 3 of the same problem.

Anyone had their replacement replaced with only 1 or two services?

Edited by DanXbix

Share this post


Link to post
Share on other sites

So a small update. My rep emailed me after everything and is stating there is a hold up with the parts at aus customs. He has started they are putting nvidia cards back in there to eliminate the issue reoccurring. I email him politely stating that I was upgraded to 5870m xfire because of stock issues and we are back to square one.

Update 10th Nov - Still no parts (perhaps there is no more 285m SLI dell)

Update - service replaced all parts to find the same problem now replacement pending approval.

Edited by DanXbix

Share this post


Link to post
Share on other sites

Not sure about finance teams involvement, but the manager approval is instant. What may take a day or 2 is generating the specs for the replacement. My last replacement was all done in one long phone call, he didnt hang up until I approved the specs. Feel free to call back knowing that getting your specs is possible, some techs are just lazy...

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use. We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.