Jump to content
EwinRacing Flash Series Gaming Chairs
San Pedro

8970m problems in my m17x R3

Recommended Posts

Alright, I installed 8970m in alienware m17x r3 last night. I started up went into the BIOS and disabled the IGP and set the display to PEG. I restarted and got 6 beeps. Disappointed to say the least. However, I persevered (maybe not what my wife would say) and cleared CMOS, which allowed me to reenable my IGP and set the display back to SG.

So, I then could go back into Windows and the card is detected by HWinfo and device manager, but when I install a driver and restart windows I see nothing on the display though windows loads up, and I can sign in.

I tried to output to my TV via HDMI and VGA, but neither worked. Later today, time pending, I will try a monitor via VGA, but I highly doubt it will work.

So, it seems like I don't have the right vbios? Any other ideas or suggestions?

Thank you everyone.

Share this post


Link to post
Share on other sites

I hope he can. I searched high and low for people using the 8970s in Alienwares, but there wasn't much... There were a couple people who said they did, but disappeared with giving details. Anyway, I'm trying to be optimistic, it'll be a pain in the butt to ship back, etc.. etc..., but life goes on.

[uPDATE]

After trying a couple different vbios, eurocom sent me one that worked. I was dreading 6 beeps after disabling the IGP, but much to my relief I booted into windows.

The vbios that worked for me is hbr44618.001

Look for that one if you're putting a 4gb 8970m into an R3.

Share this post


Link to post
Share on other sites

Hi all,

I try to install one HD8970m to my Alienware 17x-R3, but i have some problems like [MENTION=17268]San Pedro[/MENTION](It is the same card edition HD8970m with 4GB RAM).

I use the A12 bios from Dell.

The first time, i choose the SG option from bios. The system boot normally (from integrated Intel Vga) and find the new device. Then i install the drivers and the system reboot. After that, when it load windows 7, the screen become black. I understand that the system work fine, because i hear the sounds from windows and i can close the system normally, from the keyboard keys.

When i select, from bios the PEG option, the system start with horizontal color flickering lines over the screen. Windows work fine, except that you can not understand nothing because of this distortion of the screen.

Unfortunately my vbios is HBR44618.001 and as it seem, that does not work for me.

Anyone has an idea?

Share this post


Link to post
Share on other sites

If I remember right, I was able to get into Windows (using SG) even after trying to install AMD drivers with the HBR44618.001. With the other two vbios I was getting black screen when going into windows. With PEG selected I didn't have any problems (except my VGA out doesn't work). Also, I never experienced any color flickering lines or distortion on the screen through the whole process. It may be a problem with the card.

Another thing you may want to try is unlocked A10 or A12 bios.

Good luck.

Share this post


Link to post
Share on other sites

It is very possible that there is a problem with the card.

I speak with the support of Eurocom and they create an RMA, so i can send the card back to them.

When i have news i' ll inform you about this.

Share this post


Link to post
Share on other sites

I forgot to post here, what happen with the case of my card.

Eurocom change my problematic card, with a new one.

Now my allienware work like a charm, with my new 8970m graphic card.

Share this post


Link to post
Share on other sites

I have my M17xR4 but cannot installed the display driver, and if installed the screen goes blank and shows nothing...I need help please.....

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Similar Content

    • By Henrik9979
      Okay here is what's going. I have a alienware m18x r1 running an amd 8970m, I wanted to upgrade it to crossfire but I could see a 8970m was more expensive than a r9 m290x
      So I decided to buy a r9 m290x and see if I could make it work in my alienware and also run crossfire.
      Even though many shops refused to sell me one because the didn't think it would work in an alienware m18x r1 only in the r2.
       
      Here is the whole process.
       
      19/08/17 23:15
      No post bios showing when booting, so impossible to enter bios menu, but can boot into windows 10 with no problems.
       
      19/08/17 23:20
      Because I haven't deleted the old AMD 8970m the r9 m290x shows as a 8970m with no problems.
       
      19/08/17 23:34
      First performance test was a success. The r9 m290x changed p-state normally. The gpu fan start spinning normally. But because of no thermal paste, the test lasted 20 seconds because the temperature raised fast.
       
      20/08/17 00:00
      Created a backup of the vbios version
      015.032.000.004.044450
       
      20/08/17 00:10
      Flashed a new clevo vbios version 015.032.000.003.044465
      Caused the card to be corrupted and resulted the 8 beep code.
       
      20/08/17 00:35
      Finally managed to flash the back and return the graphics card to its original state.

      20/08/17 00:50
      Flashed a new dell vbios version 015.046.000.014.045579
      No change in behavior
       
      20/08/17 01:07
      After trying multiple vbios with no luck I finally found one.
      Dell vbios Version 015.041.000.000.044966
      Brings back the post bios screen and I can now enter the bios menu through the r9 m290x.
      Note: This vbios reduce the cards performance from 900 mhz to 850 mhz
       
      20/08/17 01:21
      After more testing I found one that is working with no limits.
      Clevo vbios version
      015.036.000.005.044618
      Brings back the post bios screen and I can now enter the bios menu through the r9 m290x.
      This will be the vbios I will keep at the moment.

      20/08/17 01:56
      I completely uninstalled the previous driver and installed the newest driver. The graphics card is recognized as a 8970m but works normal.

      21/08/17 20:15
      I have inserted my old 8970m in the secondary slot and will start testing crossfire.
       
      21/08/17 21:45
      I have found out that the fan for the secondary fan did not spin. The is a cable that have felt out. I will fix it now.

      21/08/17 22:00
      In my try to test crossfire compatibility, I installed the newest AMD driver 17.7.2 but as soon it installed the driver for the secondary card it caused black screen. Only booting the computer in safe mode brings the screen back.

      21/08/17 23:02
      After many frustrating hours I finally managed to get crossfire working with the r9 m290x as the primary card and my old 8970m as the secondary.
      I have flashed the same vbios on both cards so the r9 m290x shows up I device manager as a 8970m.
       
      I first installed AMD driver version 16.2.1
       
      Then installed AMD driver version 16.6.1 in order to play battlefield

      21/08/17 23:20
      First test run in battlefield 1

      21/08/17 23:40
      Battlefield 1 is flickering bad, this can maybe be solved with a new patch or driver.
      Other games I have tried is working perfect with crossfire on.


      Now what I would like to try is somehow force the r9 m290x driver to be installed and see if it will make it possible to run the latest AMD driver without getting a blackscreen.
       
      I have tried to edit the .inf file like you would do with nvidia but no luck.
      I have also tried to figure out how to edit the device id in the vbios, but I find it too complex.
    • By Klem
      Klem's_vbios_DELL_GTX880M_80.04.F5.00.07_UNLOCKED.rar
      For 8Gb card.
      1. Unlocked Nvidia core limit +135 MHz.
      2. Unlocked core voltage adjustments.
      3. Unlocked Power Limit.
      4. Unlocked Power adjustment by software (for example with Nvidia Inspector).
      5. Increased Power Limit and Power Target.
      6. Enabled some additional tweaks.
       
      If you liked my mod, you can buy me some beer:   https://www.buymeacoffee.com/ekushukovZ
    • By Noxco
      Hello to all can you help me change the graphics card?
      Alienware m17x r4
       i7 3610qm
      quadro k4100m
      display 120hz 3d
      bios a15
      trying to install 980m but not getting 5 or 8 beeps removed the battery and reset the bios. disabled legacy and secure boot in settings windows 10 gpt uefi
      help how to be?
    • By Guardian241
      So I just received a 980m in the post and after installing it I was greeted by multiple system crashes on my Alienware m17xr4 and was unable to install new drivers.

      Is there a step in the intallation process I missed? A bios setting I was supposed to change? The laptop is already set to UEFI mode in preperation for this and upon putting the old 680m back in the system it now works again. I have heard that I need to change INI files to install drivers but I expected it to at least function without large bugs such as these. Do you think that this GPU is faulty or have I done something wrong?
       
      Thanks for any help you can give.
       
      - M
×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use. We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.