Jump to content
EwinRacing Flash Series Gaming Chairs
Aikei

MSI GX70 CPU Overclocking - Possible?

Recommended Posts

Hi Gx60 Owners,

Kenglish's Method Gives the GX60/70 A great boost so in order to simplify the method for beginners I've Described the entire process with one Image, Enjoy!

[ATTACH=CONFIG]9378[/ATTACH]

hi could you re post it please I can't see it, it says I don't have wrights to see it or im trying to edit some one profile :)

would really appreciate it, I have a MSI GX70 with A10 5750m

Share this post


Link to post
Share on other sites

I to am stuck with the bar-edit part... windows 8.1 on my gx70 and it doesn't seem to make the writes

Share this post


Link to post
Share on other sites

Hi. I locked my CPU on 3.2 and now i have problems with laptop. It hangs. I did fresh windows install but it didn't help i can't change CPU back to it's original state. It still shows 3.2 in overdrive.... can someone tell me what's going on ?

Share this post


Link to post
Share on other sites
Hi. I locked my CPU on 3.2 and now i have problems with laptop. It hangs. I did fresh windows install but it didn't help i can't change CPU back to it's original state. It still shows 3.2 in overdrive.... can someone tell me what's going on ?

Changes in bar-edit are always reset on restart. The cpu will report max speed at idle if you set your windows power management to max performance even without using bar-edit.

I think what happened is you accidentally disabled pb1 leaving just pb0 enabled. This does not work and results in a crash, and I think you were very unlucky and this crash corrupted windows.

- - - Updated - - -

I to am stuck with the bar-edit part... windows 8.1 on my gx70 and it doesn't seem to make the writes

It worked for me on win8 so I would expect 8.1 to work as well.

- - - Updated - - -

do you have any guide on how to lock the cpu to 3.4 to 3.5 instead of 3.2 to 3.5?

thanks.

This is not possible.

- - - Updated - - -

hi could you re post it please I can't see it, it says I don't have wrights to see it or im trying to edit some one profile :)

would really appreciate it, I have a MSI GX70 with A10 5750m

You need more posts to see his image.

  • Thumbs Up 1

Share this post


Link to post
Share on other sites
Guest

@Khenglish - tried to send you a PM but your Inbox is full. The M18xR1/R2 CPU fan is 1.2cm thick, 8.5cm side-to-side and 8.7cm from the air outlet to the opposite edge of the housing.

Share this post


Link to post
Share on other sites

So from what @Khenglish is saying the Baredit needs to be run each startup maybe not from hibernation. Do you guys activate this with a batch file or just manually each time you want the extra frames in your favourite FPS?

Share this post


Link to post
Share on other sites

I do it manually. I tried running a .com file is dos written in assembly, but it didn't work. I do not know how to get ring0 access in windows or linux to write a proper tool.

Share this post


Link to post
Share on other sites
Hi Gx60 Owners,

Kenglish's Method Gives the GX60/70 A great boost so in order to simplify the method for beginners I've Described the entire process with one Image, Enjoy!

[ATTACH=CONFIG]9378[/ATTACH]

I am trying to do this, but I am having a little trouble... If I change the 0x0A8 (30, 31 bits) to 0, no problem occures. But when I change the 0x0DC bits (9th and 10ts), my system just freezes. Is it okay? Should I wait few minutes before it takes any effect?

I tried to do this in different order (first 0x0A8 and then 0x0DC) but it always freezes after the 0x0DC change. I have also tried to slightly increase voltage before making theese changes, but it always just freezes.

Any suggestion? :)

Share this post


Link to post
Share on other sites
I am trying to do this, but I am having a little trouble... If I change the 0x0A8 (30, 31 bits) to 0, no problem occures. But when I change the 0x0DC bits (9th and 10ts), my system just freezes. Is it okay? Should I wait few minutes before it takes any effect?

I tried to do this in different order (first 0x0A8 and then 0x0DC) but it always freezes after the 0x0DC change. I have also tried to slightly increase voltage before making theese changes, but it always just freezes.

Any suggestion? :)

1. Make sure that you are not accidentally clearing bit 8 locking to Pb0 that will cause a lock up.

2. The effects happen instantly so if your computer locked up most likely you cleared the wrong bits.

3. Do not ovrervolt that will only cause more problems. Try an undervolt to decrease heat.

Share this post


Link to post
Share on other sites
I am trying to do this, but I am having a little trouble... If I change the 0x0A8 (30, 31 bits) to 0, no problem occures. But when I change the 0x0DC bits (9th and 10ts), my system just freezes. Is it okay? Should I wait few minutes before it takes any effect?

I tried to do this in different order (first 0x0A8 and then 0x0DC) but it always freezes after the 0x0DC change. I have also tried to slightly increase voltage before making theese changes, but it always just freezes.

Any suggestion? :)

Everything is instantaneous so waiting will not help. Is this trinity or richland?

Try "counting down" on bits 10 through 8 of 0xDC and tell me when it crashes. For example, default is 111. Try 110, then 101, 100, 011, and lastly 010. By counting down we are disabling state 1 at a time. What I say to do in my guide is 001 for just hardware P-states 0 (PB0) and 1 (PB1) to be active. 000 leaves just hardware P-state 0 (PB0) active, which works for no one. Maybe your BIOS requires more active P-states. Whatever your final stable result is, set bits 31 through 29 of 0xA8 equal to bits 10 through 8 of 0xDC to make PB0 work again.

Share this post


Link to post
Share on other sites
Everything is instantaneous so waiting will not help. Is this trinity or richland?

Try "counting down" on bits 10 through 8 of 0xDC and tell me when it crashes. For example, default is 111. Try 110, then 101, 100, 011, and lastly 010. By counting down we are disabling state 1 at a time. What I say to do in my guide is 001 for just hardware P-states 0 (PB0) and 1 (PB1) to be active. 000 leaves just hardware P-state 0 (PB0) active, which works for no one. Maybe your BIOS requires more active P-states. Whatever your final stable result is, set bits 31 through 29 of 0xA8 equal to bits 10 through 8 of 0xDC to make PB0 work again.

Well.... yesterday I have tried it couple times again and I have finally managed to get this working.

I tried almost everything, but this one way works for me, I dont know why, but it does.

And by the way, I actually cleared the correct bits, the problem isn't here.

First, I restart my computer. If I don't restart it and clear that bits, my laptop freezes.

Then I open-up AMD overdrive. In the Clock/Voltage tab click "Turbo Core Control" and make sure its enabled.

If I haven't restarted my computer, the "Turbo Core Control" option would be grey and not available to click/activate.

Then I click the green sphere at the top of the AMD OD GUI, then red circle around it appears. After it my clock finally go over the 2,5 GHz.

...but it still randomly drops between 2,4 and 3,5.

If I do all of these steps, I am able to change those bits without any freeze and its finally locked on 3,5. (Its actually 2 cores on 3,2 and 2 cores on 3,5... no idea why as well ->according to AMD OD)

I don't get it, why does it work this way.

Now, with slightly OCed 8970HD, I can finally run BF3 on ultra at 45-65 FPS!! Yay! Other games run much better too of course.

Thanks again @Khenglish for your guide and all the others caring about people like me! :)

Share this post


Link to post
Share on other sites
Well.... yesterday I have tried it couple times again and I have finally managed to get this working.

I tried almost everything, but this one way works for me, I dont know why, but it does.

And by the way, I actually cleared the correct bits, the problem isn't here.

First, I restart my computer. If I don't restart it and clear that bits, my laptop freezes.

Then I open-up AMD overdrive. In the Clock/Voltage tab click "Turbo Core Control" and make sure its enabled.

If I haven't restarted my computer, the "Turbo Core Control" option would be grey and not available to click/activate.

Then I click the green sphere at the top of the AMD OD GUI, then red circle around it appears. After it my clock finally go over the 2,5 GHz.

...but it still randomly drops between 2,4 and 3,5.

If I do all of these steps, I am able to change those bits without any freeze and its finally locked on 3,5. (Its actually 2 cores on 3,2 and 2 cores on 3,5... no idea why as well ->according to AMD OD)

I don't get it, why does it work this way.

Now, with slightly OCed 8970HD, I can finally run BF3 on ultra at 45-65 FPS!! Yay! Other games run much better too of course.

Thanks again @Khenglish for your guide and all the others caring about people like me! :)

Weird. Well I'm glad you got it to work!

Share this post


Link to post
Share on other sites

i really doubt it, i own a GX70 3CC.

im playing neverwinter and graphic setting allow me to choose Amd Radeon Hd8650g(built in) but not my Radeon R9 M290X(stand alone) why?? Or they are actually the same?

Share this post


Link to post
Share on other sites

Hi im really interested in this thread as i am going to buy a gx60 with a10-5750m and r9 m290x. Would it not be the same if i set the power management settings to high performance to lock the cpu at 100%?

Share this post


Link to post
Share on other sites

i have tried this on 8.1 also crashes, has anyone tested dual channel for any performance improvements on this, im currently just running 1 slot of 8gb on gx70

Share this post


Link to post
Share on other sites
Hi im really interested in this thread as i am going to buy a gx60 with a10-5750m and r9 m290x. Would it not be the same if i set the power management settings to high performance to lock the cpu at 100%?

No. That doesn't lock the CPU. That just makes it prefer idling at max clocks instead of idling at minimum clocks. It makes no difference when loading the CPU.

- - - Updated - - -

i have tried this on 8.1 also crashes, has anyone tested dual channel for any performance improvements on this, im currently just running 1 slot of 8gb on gx70

Dual channel has a tremendous impact if you're using the integrated graphics. Around an 80% improvement. It doesn't make much difference if you're using a dGPU though. At best a few %, and usually nothing.

Share this post


Link to post
Share on other sites
No. That doesn't lock the CPU. That just makes it prefer idling at max clocks instead of idling at I

Iminimum clocks. It makes no difference when loading the CPU.

Ok thanks for answering. I am a little unsure if I should buy the gx60 because a lot of people are talking about the cpu bottlenecking the gpu. I have found a machine with an I7 4700MQ and a nvidia gtx860m of course it costs a little more but would it be worth the exstra money. Or is the gx60 good enough to handle games like the gtx860m. I don't mind a little drop in fps but it should at least be 30fps on high. I would really like to hear your opinion on this :-).

Share this post


Link to post
Share on other sites

Poor experience with Watch Dog in GX70. Would like to see if this tweak helps. Thanks!

Share this post


Link to post
Share on other sites
Poor experience with Watch Dog in GX70. Would like to see if this tweak helps. Thanks!
What FPS did you get? A lot of people are also getting poor performance even with intel i7 and nvidia machines, have you tried to update to the latest driver? The game is not optimized very well but hopefully a patch will fix this ^^. Have you tried any other games with it and would you recomend it? i am maybe going to buy it?

Share this post


Link to post
Share on other sites

I wihs it had a different CPU- still this fix may help a lil bit. Which is great!

Share this post


Link to post
Share on other sites

I didn't use FPS tools, but feel a little bit lag on car racing if some are medium.

GX70 got fast GPU not CPU... the A10 5750M ruined the game. However for Titan Fall it works perfect (but this game also run smooth in my Core 2 Duo E6600 with HD 6850 desktop.

No. This game should run far better on i7 and Nvidia Card. Try the new GT60 Dominator Pro.

Check the Watch Dog review below.

MSI GT60 2PE Dominator pro 3K unboxing

What FPS did you get? A lot of people are also getting poor performance even with intel i7 and nvidia machines, have you tried to update to the latest driver? The game is not optimized very well but hopefully a patch will fix this ^^. Have you tried any other games with it and would you recomend it? i am maybe going to buy it?

Share this post


Link to post
Share on other sites

The processor (5750m) is just horrible overall. I wish you could overclock this computer. You can't really run more than one program at a time if you things to run smooth.

Share this post


Link to post
Share on other sites

Is there any posibility to upgrade this cpu on gx70 ?

Sent from my SM-N9005 using Tapatalk

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use. We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.