Jump to content

M18x R2 980m assistance required (8 beeps).


Recommended Posts

Help me Tech Inferno, you're my only hope.


Ok so firstly, apologies for yet another 8 beeps thread. I must have read 100 of them over the last week. I feel like I'm missing something obvious, but I'm totally burned out after days of working on this so would appreciate some outside perspective.


I live in the UK, so I've avoided buying a 980m to upgrade my 660 for years to due the price/import tax etc. I finally found a good priced 980m on Ebay a few weeks ago so I thought why not give my trusty 18x r2 a few extra years of life.


I ordered the 100w heatsink, x bracket etc from Eurocom at the same time and everything arrived on the same day.


Here's what I've done so far in the last 7 days:


-Flashed unlocked A11 BIOS (I rolled back to Dell A11 first)


-Removed  660m and installed 980m


-With BIOS in Legacy, Installed Windows 7 on a new SSD with BIOS set to IGFX


-Tried to switch to PEG but got 8 beeps so reset CMOS battery


-Switched to SG and booted to Windows. 980m detected as default hardware. Installed 980m Driver from Eurocom and restarted. Device manager shows 980m  working normally along with HD Graphics 4000. Tried PEG again but still got 8 beeps


-Reset battery, booted to Windows and disabled the 980m in Device Manager


-Flashed VBIOS from here  (I read that the dell VBIOS doesn't work well so tried Clevo one first, but I've since tried both and a few others)


-Re enabled 980m and restarted Laptop still in Legacy SG.


-Tried to test a game but they only want to use HD Graphics 4000. When I try to open NVIDIA Control Panel and change some settings I get a blue screen and have to restart.


-Tried PEG again, still 8 beeps



I've tried many combinations of drivers, VBIOS and BIOS settings over the last week but the result is mostly the same. I get 8 beeps in PEG. I thought perhaps the seller had sent me a G-sync version as I have read these don't play well with PEG, but I checked the hardware ID (PCI\VEN_10DE&DEV_13D7&SUBSYS_05501028&REV_A1) and what I've read seems to indicate this is the Non G-Sync card.


I got the 980m rather than the 1060 after reading the forums as I saw so many success stories I figured it would be the safer option.


I understand this laptop is basically dead to most of you now, but if any techsperts are around and could give me some other things to try I'd greatly appreciate it.



Thank you,












DDU image.png

Edited by Max2016
Adding some pictures
Link to comment
Share on other sites

Update: I've installed a new SSD with Windows 10. In SG, it has automatically found and installed all the drivers including the Nvidia one, and the 980m shows up with no errors. However, I still get 8 beeps when setting Graphics to PEG, and for some reason when I switch from Legacy to UEFI the Laptop just keeps blue screening before Windows can load. I have to try several times to get back into BIOS so I can change it back to Legacy.


Update 2: I've fixed the Uefi issue by cleaning the SSD and switching it to GPT. Reinstalled Windows and can boot in UEFI now. Even with Legacy ROM & Fast Boot Disabled and PEG always on, system will still not POST in PEG.

Link to comment
Share on other sites

Update 3 Well after a lot of messing around, re seating, re pasting and cleaning (I'm not convinced the card was new like stated when I bought it), I managed to boot in PEG. However I get blue horizontal lines across the screen.


I downloaded the latest Drivers via Windows 10 update and the lines vanish for a minute. They are then replaced with blue squares and the Laptop gets stuck in a boot cycle until I go into Safe Mode and remove them with DDU. The other thing that can happen is the card disables itself in Device Manager (Code 43).


I really am stumped with this one. I've got one more thing to try which is trying it in my friends Alienware 17 this week. Will report back with the results then.

blue lines.jpg

Blue Squares.jpg

Edited by Max2016
Link to comment
Share on other sites

Update 4 Well it's official. All these problems have been caused by a faulty card :logik:

Tried it in another machine and had the exact same problems. Tried flashing the official Dell/Alienware & Clevo VBIOS from Techpowerupwith no improvement. Card is now being returned.


I will update when a new card arrives (and hopefully works).

Edited by Max2016
Link to comment
Share on other sites

  • 2 months later...

Hey. How did you go with this? I have a beautiful Nebula Red R2 sitting in a box in the garage and I'd love to do this same upgrade. It's got dual 675M's in it. 

I have another R2 with dual 780M's but they were pretty easy to install. The 980's seem a little daunting with all these steps but I want to get this girl rolling again.  


Also, where did you get the unlocked BIOS? From here?

Edited by MattyB
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...

Important Information

By using this site, you agree to our Terms of Use. We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.