Jump to content
EwinRacing Flash Series Gaming Chairs

Recommended Posts

I've started wondering if it would be possible to replace the R3 MB to the R4 ver. in my R3. If they are exactly the same in form and wouldn't require any external modification (misaligned usb ports ect). I'm aware that if I did this, I would need to replace the CPU. Is there anything else that would need replacement or would everything I currently have in my R3 (aside from the CPU) be compatible with the R4 MB. One last idea, would this also mean that I would regain 3D and would my Dell 680m be natively compatible?

I'll continue searching the web but have currently only found 2 resources that doesn't tell me much.

Anything else I may have not thought off, please feel free to inform me.

Current System

Win 8.1

M17X R3

Dell 680m

8GB

1TB HDD (2 x 500 Raid 0)

Share this post


Link to post
Share on other sites

Physically, the R4 MB will fit perfectly in a R3 chassis. You will only need to replace the MMC board and the keyboard to the R4 version. No need to replace your CPU as it is forward compatible to the R4 MB. The 680m card is 3D capable only if you have a 3d screen and cable.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Similar Content

    • By Anderitos135
      I have a iBuypower CZ-17 laptop, with a 2012 AMI BIOS that has E1762 as the version, which I believe means I have an MSI G70 motherboard. It has a 675MX GPU, but it's not useable in Windows 10 despite being "seen" in the device manager. I believe an updated, unlocked BIOS would fix my issue and have located the thread on this site with the BIOS I need.

      First of all, am I right? Will this fresh BIOS make my laptop that originally ran Windows 8 work with this old GPU?

      And second, I created this account, will wait 24 hours and made this post. Is that enough to allow me to download the file, or do I need to post elsewhere?

      Thanks!
    • By ajdrenter
      Hello all! I have been researching upgrade paths for my M17x R4 and I have decided on the GTX 1060. Now, I was given this laptop with a dead GPU, and I had an M17x R3 already. So I moved the GTX 560m into the R4 which has worked fine. Now as I understand it a few things are needed for this upgrade including the 120hz panel and the ability to disable the legacy ROM for a pure UEFI boot. I have the 120hz screen, but the 560m uses the GF116 architecture which does not have a vBIOS which supports GOP. So I am thinking the only solution is to buy a cheaper "in-between" card which supports both boot modes, which will allow me to disable the legacy option in setup. Does anyone have any suggestions as to what cheap card to buy as a transitional part? I have been considering a 765m but I am also wondering if there are any other good choices.
    • By depmixels
      hello everyone, I have a MSI GT683R with a dying (pretty much dead actually) GTX560M in it.
       
      I am looking to upgrade it to a new GPU, I have found a AMD Firepro M6100. (I first wanted to upgrade to a GTX970M, but that's too expensive for now... and corona is also making things difficult) I have already ordered a second heatsink to modify because I didn't want to modify the original heatsink it came with.
       
      But, my question is. Does it even work in this system? I have heard of people getting it to work in the barebone variant of this system. But I am not sure if it would work in the 'fully loaded' variant.
       
      Also, my games are mostly RAM/CPU dependent and I am looking for a little extra power in this system. I have found a I7-2860qm and I want to upgrade to 32GB of RAM, is it possible on this system? the sticker says 'max. 16GB of RAM' But I have feeling it says that due to the limitation of the cpu that's already on this system (I7-2630QM, 16GB RAM max.)
    • By Soapy
      I reversed the input polarity on my m15x jack after a botched psu repair. Computer worked fine, but overall power control is messed up. System only boot on both battery and psu, no battery charge, and a very low battery drain (arround 6wh).
       
      I aways had battery issues whith my 8 years old m15x after my original battery died. Bought a new one two years ago, didn't work. Checked on upower, basically no info on manufacturer, power or history. So i refunded and used the system hooked on the psu as usual. In August i bought a new one, worked flawlessly for a day. The next day the battery died from nowere. Checked upower, bus was ok, battery was charging extremely slowly (6wh), history showed subpar disharge before shutting down. I got mad at this point, decided that psu was to blame. Opened it, checked everything, noticed some wear on the male jack. Resoldered it, connected on computer. Nothing happened, so i checked the voltage. That's when i realised that i screwed up big time. I swaped the positive and negative wires. Decided that one mistake was enough, so i sent my m15x to a trusted repair shop (latter found that they just hooked the battery and gave me back as soon as it booted, they didnt even open it). Got my pc a week later, but the battery didn't charge . Worse, it was slowly discharging (same 6wh as before), and it needed both the psu and the battery to turn on. At 65%, it worked as usual for my college semester, but the battery is dead, and so is my computer. I bellieve i burned some voltage controller or something. I'm pretty competent at soldering thing's (evem smd components) when i know what to do, and i can understand simple circuit's, but when i got my hands on the m15x datasheet i got overblown. I cant make heads or tails about it. I aways lurked this forum and i bellieve your guys are the best when it comes to finding creative solutions to technical problems concerning microelectronics. I followed a guide in this forum as a teenager to upgrade this same computer to a gtx680m, overclocked stuff, got custom bios, and had a lot of fun learning. The m15x is a deprecated platform, but it's a part of my history that i dont want to let go.
      So please guys, help me.
       
    • By Edrc
      Hello,
       
      I am new on this forum, so I am sorry if posting at the wrong place. It's been 2 weeks that I am searching how to make my GTX 980M 8GB working Inside my Alienware 17 R1 (June 2014, i7 4710MQ, 60 Herts Display, OPTIMUS and the GTX 880M Inside died.)
      After "quickly" looking some forums, I saw that a 980M would easily fit Inside … but maybe I was wrong.
       
      Hardware wasn't a problem. I've also could install drivers by modding the nvdmi or nvcvi. inf files. The card was recognied BUT :
      the clock speed is locked a 135 or 405 Mherts and fan is not runing when booted up.
      I tried to flash vBios with nvflash and some ROM I found on vBios collection … but no way to get this working properly.
       
      So, i'm coming here. I've seen many people talking about Prema or svl7 or other big boss in the place … but ? how ? where ? when ?
       
      Inside the peripherial manager I have this in remote acces path : PCI\VEN_10DE&DEV_1617&SUBSYS_05AA1028&REV_A1\4&D590A51&0&0008
      So I assume my GTX 980M card ID is 1617 and vendor and PC Model are 05AA 1028.
      But near the "Standard Microsoft Video Card" there is a yellow exclamation point and Inside details it says "this peripherial doesn't work properly" when no Nvidia drivers installed.
      I could find some vBios with 1617 (Asus) but black screen at boot up. Since laptop model where not the same .. probably.
      And I wasn't able to find 1617 with the existing 05AA 1028 … as the GTX 980M was not an option for my model. (AW 17 R1 2014 ,60Herts)
      I tried 353.60, 382.33 and 419.35 drivers. The latest one seems easier to install but longer.
       
      BIOS is A16 from Dell. And I am using Windows 10. Got a Dell 330W brick. 
       
      I saw a guy with the exact model as me, he gets a modded vBios especially for his configuration, then everything worked easily … but can't find the topic again
       
      I guess depending on the card info and the laptop model … a dedicated vBios is required … 
       
      So, If anyone here got some informations or any kind of help for me, it would be very nice.
       
      Thanks for reading and help.  
       
      PS: there are a lot of files, pictures and links that I can't see on this forum .. even after registration …. 
       
×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use. We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.