Jump to content
Niskon

15" Acer Aspire 5742G + GTX660Ti@2Gbps+c-mPCIe1 (PE4C 1.2) + Win8.1 [Niskon]

Recommended Posts

masterblaster 2.0 comment>> This is the first Windows 8.x implementation where a dormant iGPU was activated to enable x1.Opt (x1 pci-e compression) on a 1st gen i-core (dual core) system supplied by the manufacturer with a dGPU only.

First I want to say thank you for Tech Inferno Fan for his huge help the whole project and I want to apologize for my bad english. I'm from Germany and still a student so be surprised :)

A long time ago I saw a video with an graphics card running external connect to an notebook. I always thought about doing this by myself and one day I decided to order an eGPU adapter and the graphics card.

First the specs of my notebook:

Model: Acer Aspire 5742G

CPU: i7-640m (upgraded from an i3-370m) with dormant Intel HD iGPU not connect to LCD

GPU: Nvidia GeForce GT420m dGPU only

RAM: 8GB DDR3

So now we are getting to the things you need:

  • free mPCI slot (unfortunately the Aspire 5742G has only one slot, so you need to remove the Wifi-Card. In my sitution no problem because I'm using lan either way.)
  • PCIe -> mPCIe adapter (PE4L, PE4H or what I used the PE4C)
  • A GPU of your choice (I chose a Nvidia GeForce GTX660Ti)
     
  • A PSU that has enough power (I used an PSU with 550W found in the basement)
     
  • Setup 1.x (buy it from Tech Inferno Fan for 25$) -> it's necessary, without you wouldn't be able to run the eGPU
     
  • A case or something to store you eGPU + GPU (not necessary, but looks tidier)
     
  • Windows 8.x (I wasn't successful with Win 7. If you want to know more about it, you can read more here.)
  • External Display -> internal isn't working because the dGPU is disabled and the iGPU isn't connected to the LCD
     

Some explanations:

The biggest problem about the whole process is that the Aspire 5742G has a iGPU but it's not connect to the LCD and even if you have enabled it via Setup 1.x you are always getting Error 43 in device-manager. As seen on the screen here.

So the point is to enable the iGPU and disable the dGPU under Win8.x to get a working x1.Opt setup. The way of just disabling the dGPU via Setup 1.x is ending up in freezing and you have to restart the notebook. So I tried a lot of things with Tech Inferno Fan. So many things and I was close to just give up all. But then he had the great idea to just disable the PCI port where the dGPU is connected on. And that's the way how it's working :)

Let's get started:

1. You need to buy the Setup 1.x from Tech Inferno Fan. Here you will get more information about it.

2. Install it as mentioned in the email.

3. Then navigate to "C:\eGPU" and run the "eGPU-Setup-mount.bat" batch file to install Setup 1.x. Now you will see a new drive named "DIYEGPUIMG (V:)"

4. Go to "V:\config" and just replace the "startup.bat" with my startup.bat startup.zip. (It's just to make the whole process easier. It's configured by Tech Inferno Fan and optimized by me. So it's easy and fast to boot up.)

5. If you have done this all correctly you should get an option "DIY eGPU Setup 1.30" on startup. (When not make you sure you missed no step or done it wrong.)

6. Select the Setup 1.30 and run the "automated startup" (You are now using the startup.bat you have downlaoded an replaced with the stock.)

7. Some lines will now come up and then you get an message that your eGPU isn't connected. Just power on your eGPU (PSU + PCI adapter. Make sure, the switch shows "ON") and connect the mPCI adapter to your notebook.

8. If done correctly you now should be back in the selection menu where you can select Windows 8.x or the Setup 1.30. Now select Windows 8.x.

9. Windows is booting normal and you should see your desktop. (If not -> make sure you did everything right.)

10. Go to device manager and you will see two new devices. Click on install drivers and wait until it finished. (eGPU driver took about 10 minutes so don't be impatient.)

Important: It can happen that you get an bluescreen while installing the iGPU driver. I don't know why, perhaps because it isn't connected to the LCD. When this happens just start at point 6. and go on.

11. Now download the graphics card driver that is compabtile to your graphics card. Uninstall your old driver and install the new one. (You can do this step before starting with the eGPU but I don't think there is any difference in doing this after.)

12. When you have successfully installed your Nvidia driver now it's getting tricky but still such simple :)

13. Go to device manager and select "devices on connection" (German: "Geräte nach Verbindung") and search where the dGPU is connected on and just disable it. (I got an blackscreen and I needed to restart my laptop via the power button. But it doesn't matter you need to restart your notebook anyway to get fully working x1.Opt Setup.

dasfdafafas.png

14. After restart (just like point 6. you can check the device manager and you should only see the "Intel HD Graphics [iGPU] and your video card that you bought. In my situation the GTX660Ti [eGPU]. (If not -> check the steps above.).

asfsadf.png

15. You should now have a fully working (expect the internal screen isn't working) x1.Opt Setup. You can check this in the Nvidia cobtrol panel by checking if the "High-performance Nvidia processor" is available. Or go to GPU-Z and check it there.

Manage-3D-Settings.png

16. At the end you can run 3dMark06 or other benchmark tools to compare your results with others. Or just play a game and enjoy it :)

Here is my 3dMark06 score. With the same notebook you should get similar results. (+/- depends in you graphics card.)

Something else to say:

There are some downsides of using the eGPU Setup with an Aspire 5742G. I'll list some of my established.

  • Need of removing wifi card
  • You need to plug the eGPU in after running the automated startup. Otherwise you'll running into reboot loop.
  • You are not able to go into sleep mode and wake up successfully (biggest downside for me)
  • You won't get the full graphics power as on an desktop computer

If you have any question or you think I forget something - feel free to ask me. :)

startup.zip

asdasda.png

sad.gif

  • Thumbs Up 8

Share this post


Link to post
Share on other sites

Wow that is one comprehensive review on that PE4C setup I am looking to build as only now I quite understood all that is required to start off with this experiment!

Thanks buddy!

The way I see it I will be doing the same ways that you have demoed and setup.

Thank God the PE4C V2.0 is such a beauty to miss, I will get all things gathered hopefully in the coming months.

Can you do us a favor? Do you mind posting images of your setup mate?

Regards,

Jes

Share this post


Link to post
Share on other sites

Whats your average fps in gta v? or your average fps in any game and on what settings and res..I really want to know since I think 2GBPS will bottleneck..

Share this post


Link to post
Share on other sites

Hi there,

really appreciate your work.. it's a good review and guide.. I'm thinking of doing the same thing on my old laptop.. Acer Aspire 4752G late 2012, processor i5-Sandy bridge 2.4Ghz, ram 4gb, windows 7 ultimate, iGPU Intel Hd 3000 with Optimus enabled Nvidia Geforce 610M.. I don't have any idea if it would work.. maybe you can give me some advises or walkthrough? since this is my 1st time.. i would be thankful for now as I found something good to do with my laptop.. hope it will work.. anyway, thanks again!!! :smug:

Share this post


Link to post
Share on other sites

Hi !

Thanks for the description. People who have 5741G/5742G... etc. Did you modify the BIOS to access some options (disable dGPU) or something like that ? It's not mentioned in this thread.

Thanks

Share this post


Link to post
Share on other sites

Hey guys, I have to apologize for not answering your questions.

I wasn't active in this scene for a while because other things had priority in the past.

Sadly I have to tell you that I switched from my old Aspire 5742G to the new impressive iMac 5k.

Also I couldn't find any pictures of my setup although I thought I took some.

Unfortunately I can't give you any Benchmarks or average fps details of any game.

As the fact that I haven't done anything in this topic for a while I can't give you any advises for your own build.

I still know that i modified my bios to get the i7-640m running. But I think that was only needed because I bought this notebook with an i3-370m which didn't have the Turbo-Boost.

At the end I want to thank you for your good feedback.

If you have any questions feel free to ask me. Hopefully I'll be able to answer them.

Share this post


Link to post
Share on other sites

Hi, you said the display is not connected to the iGPU, I have a 480m and want to upgrade to a i7 720QM without integrated graphics but I heard I will lose display output.

Edited by wall
typo

Share this post


Link to post
Share on other sites

hi guys, I have a 5742G with 540m, windows 7, a BEAST v8.4d and a GTX670.
When I connect everything and I turn on the laptop screen remains dark and the adapter for the GPU turns on a green LED.
Is there an easy way for this to work?
thank you so much 

Share this post


Link to post
Share on other sites
On 28.11.2016 at 10:07 PM, wall said:

Hi, you said the display is not connected to the iGPU, I have a 480m and want to upgrade to a i7 720QM without integrated graphics but I heard I will lose display output.

 

No you will not but you will lose Optimus technologie. In the first Gen. Intel you'll drive better with the i7 640M.

 

On 24.2.2017 at 3:56 PM, walterego221 said:

hi guys, I have a 5742G with 540m, windows 7, a BEAST v8.4d and a GTX670.
When I connect everything and I turn on the laptop screen remains dark and the adapter for the GPU turns on a green LED.
Is there an easy way for this to work?
thank you so much 

 

I did this setup a long time ago so I can't say exactly what's wrong but there must be something wrong with your configuration.

 

 

Sorry for the late replys but I wasn't able to work on this project due to lack of time.

Now I am working on a new project with a Dell ThinkPad T420.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Similar Content

    • By Blocker35
      Hi guys, bit of a rookie to the whole EGPU scene. Currently I have:
       
      - MacBook Pro 2015 13inch (3.1GHz Core i7 16GB RAM)
      - Razer X Core 
      - Apple TB3 to TB2 Adapter
      -  TB2 Cable (Cable Matters)
      - 23inch AOC External Monitor
       
      I am wonder about what graphics card to get to run X-Plane11 with high graphic settings?
      I have purgewrangler set up and ready to use with an AMD graphics card, but am also open to the idea of an Nvidia graphics card.
      Any advice appreciated. I did not buy a Windows PC as I need a Mac for various other things and wanted an all-in-one laptop.
    • By SnipeKing17
      The GPU works, The PSU works, The system works. [individually they all do work]
       
      The system works perfectly fine without the WLAN card.
       
      When i put the system to sleep and hotswap the mPCIe riser and WLAN press something on the keyboard.. Restarts.
      Will shutdown in roughly 27 seconds for those 27 seconds it works just fine like how it normally would on external monitor.
       
      When i shut it down and plug the riser and switch it on, same story. 27 seconds.
       
      I don't even see a error. I get to login screen directly. I used DDU already.
       
      I timed it. no matter what i do if i use the eGPU, External monitor it restarts instead of pause-play. I have 27 seconds.
       
      Need help!
    • By Kel
      I got the exp gdc beast 8.5 got all the connections right... laptop boots up... fans turn on the gpu.... device manager detects gtx 1060 with a “ ! “ in a yellow triangle. Now what to do.... i tried to do the bios mod.... but realised that i have 3.07 version. 
      Questions-
      1 is there any way to get this done without the mod?? 
      2 if mod is the only way... kindly help me with step by step instruction in laymans terms... i m not a techy... so i might not understand technical terms.... altho i am interested... but learning yet. Please help. 
    • By Drozof
      Has any company out there launched a laptop with an external MXM port? 
       
      Just curious since with the boom in the gaming laptop market and some companies launching eGPU thunderbolt enclosures, isnt the MXM faster?
       
      Is it because of licensing issues? or hardware problems?
       
    • By Iwillsolo
      Hello guys ...

      i wanna make sure that everything is going to work fine with my laptop so i got some questions

      First of all my laptop is Lenovo Z51-70
      CPU: I5-5200U 2.2ghz
      iGPU Intel HD 5500
      dGPU:AMD R9 M375
      Ram: 8GB (will raise it to 16GB)
      HDD: 1TB stock one
      SSD: 120GB (for my games and windows only)

      now i investigated  a little about eGPUs and found that i need a M.2 or thunderbolt, i've found that my wifi card use a M.2 a/e key aka ngff, so i will be using the GDC Beast NGFF version

      to the bad part / question part

      What do i need to know other than the stuff above?
      what is the white-listing thing? i found on support forums that my laptop support some wifi cards only and it's bios cann't be modified according to bios modifying forums (not here)
      in same time saw some posts on reddit that says if ur bios have UMA graphic option then you will need to disable PAX / WIRELESS and enable UMA and it will work fine, the question is that true?

      i wasn't able to find anyone who did it on Z51-70 i found only 1 post on reddit for Z41-70 (which after research found that both are using same M.2 a/e key slot and also same bios... but the one who posted only replied that it's recognized with some errors and never replied back with any updates so still not sure about it.....

       
×

Important Information

By using this site, you agree to our Terms of Use. We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.