Jump to content
EwinRacing Flash Series Gaming Chairs
TommySprat

How to remove keys from the backlit keyboard on my P150EM?

Recommended Posts

The regular enter key on my backlit keyboard fails to detect a lot of keypresses. I'd like to take it off and see if i can find a cause.

It's not in the manual and google search only seems to return results on how to remove the entire keyboard. Is it even possible without breaking anything?

Share this post


Link to post
Share on other sites

you have to use a small screwdriver to push the top cover/switch board from the underside of the pc (thru a spot located beside the gpu fan below the first gpu heatpipe and left of the mxm slot ) then remove the screws holding the keyboard in place after which you lift the keyboard up gently and disconnect the flex cable better refer page 37 of the p150em service manual available here :http://forum.techinferno.com/clevo-sager/3837-clevo-service-manuals.html

Share this post


Link to post
Share on other sites
Guest

You can just pop off single keys by lifting them from the top end, just be a bit careful and it will be fine.

Share this post


Link to post
Share on other sites
You can just pop off single keys by lifting them from the top end, just be a bit careful and it will be fine.

Usually the keys are attached in each corner on a laptop, the are attached to a scissor type piece of plastic, that then attaches to the base at 4 points.

2 of the 4 points, usually the bottom of the key closest to you although Prema highlights it might be the TOP so take care) clip DOWN, the top right/left (or bottom as Prema wisely suggests) have a little mini rail inside and the plastic scissor slides in and out when you push the key down. If I try to explain how to install one, hopefully it will give you an idea of how to remove one?

to INSTALL an NEW key, you would

fit the plastic scissor (if it isn't already attached)

hold the scissor in the up position with a bit of bent paper clip and slide the rail on the key, in to the lugs on the scissor (that are held up in the air by the paper clip!

then remove the paperclip (or other item) gently, and ensuring the key is straight and the remaing clips and lugs feel aligned, gently press down, it should clip in to position!

here is an image I nicked off google :) - it highlights the importance that some scissors are the front to back configuration, and the slimmer keys are actually left to right (and some might be right to left or back to front!) - I usually just gently lift up the sides of the key with a spudger - starting at the back (as this is usually the clip side) - if you pull to hard on the slide side, it will just unclip the scissor from the base, so no drama really, just doubles the amount of work to reinstall!

take care not to damage the rubber contact, although I suspect this little bit is what's damaged anyway - it is glued down, if you knock it off, it requires some incredible precison gluing to get it back in position, I recommend using a tiny brush to paint on the glue - do not use to much, and once stuck back down centrally, do NOT press the rubber down or install that key for 24hrs or the whole dam lot will stick down and this is not so easily fixed without damaging the contacts

post-14140-14494995555337_thumb.jpg

  • Thumbs Up 2

Share this post


Link to post
Share on other sites

Thanks for all the helpful replies!

I removed the enter key and looked for something obvious that could cause the problem. I found that the rubber piece itself had to be pressed pretty deep before the key fires, i assume that's what my problem comes down to. I'm used to mechanical keyboards with Cherry MX switches so it's probably just the difference between the keyboards that confuses me.

I didn't see anything special so i took some pictures of it and put the key back on.

post-14253-14494995935938_thumb.jpg

post-14253-14494995936822_thumb.jpg

post-14253-1449499593767_thumb.jpg

post-14253-14494995938446_thumb.jpg

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Similar Content

    • By Qvixot
      Hello everyone! First of all sorry if this isn't the correct forum to post this.
      I bought a laptop few days ago. The laptop is Sager P150EM.
      Cpu:i7 3610qm 
      Gpu: amd hd 7970m
      Ram: 8gb
      Os: windows 8.1 pro
      So my problem is that everytime i install the amd driver after the intel driver my laptop freezes or gets a bsod or something that stops it from working. Any help would be appreciated. I saw somewhere something about vbios does this matter anywhere?
    • By duffman_777
      Managed to find a relatively cheap MSI 1070 on ebay, and after reading a few success stories that 1070's are compatible I decided to pull the trigger. 
       
      Modified the bottom case as per the photo on this FAQ page http://www.eurocom.com/ec/faqs(272)ClevoP150EM_SagerNP9150_XMG_P502_PRO. Things were going well until I went to screw the card down and felt some resistance.
       
      Oops. Looks like that capacitor(?) with the blue on it *just* clashes with the card. Now what's weird is not all P150em motherboards seem to have this component on it - looking at replacements this component is not there. Also looking at the photos from this 1080m P150em mod (https://premamod.wordpress.com/2017/10/10/clevo-pascal-mxm-standard/), this component isn't there either. Does anyone know what this is, and if it can be removed? Or, if this could be taken off and shifted out of the way somehow, or replaced with a smaller equivalent...?
       
      In my disbelief/annoyance/problem solving when trying to push it down, I did notice that the card has a surprising amount of flex in it and it *can* be screwed down almost completely to a level where I feel somewhat comfortable in doing... Though I'd rather not put this strain on the card if there is a way to avoid it.
       
       
       
       
       



    • By Buratos
      Привет. Помогите, мне грустно.
      Существует clevo p150em, недавно обновленный с 7970 до 8970 м (от 150 см)
      Bios, R.2.0 / 1.02.17EC v3b / 1.02.11EC.
      Когда он был установлен 7970 м, в BIOS на линии gpu это было 7970 м. После установки 8970m, NVIDIA пишет вместо 8970m.
      Драйверы на 8970m не установлены, либо синий экран, либо ноутбук замерзает. Windows 10 1713.
      Я пробовал разные версии драйверов, все равно. Что вы посоветуете?
      8970m vbios  VER015.041.000.000.044964 BR44964.009 it s DELL? 
       
      ps. when I bought 7970m for a place of 670m. At 7970m there was also a problem with the drivers, but I somehow skipped it.
    • By GastStraus
      Hi, I started overclocking my laptop. Initially, the graphics card provided 601 MHz at core (900 mV voltage) and 1400 MHz at memory. By moddig the bios through the Kepler Tweaker, it was possible to overclock to 944 MHz at core (925 mV voltage) and 2310 MHz at memory.
      I want to reach 1 GHz by the core, but for this I need to raise the voltage. At a very high voltage, even without load, the fan will start to rustle, so I do not want to raise the voltage much.
      But there is an idiotic problem. When the temperature of 60 degrees is used, the video card discards 25 mV. This is Nvidia`s feature . In the stock, it drops from 925 to 900, now from 950 to 925. I want 950 constantly, but it's impossible to make through Kepler Tweaker. I saw reports that svl7`s BIOS mod does not have this problem, but anyway I can not download it. So may be somebody know how make right vbios mod.
    • By havran
      Hi all,

      Please help me

      I've flashed my Laptop clevo p150em with latest BIOS V 1.02.17 and EC/KBC V 1.02.11.
      Now I want to reflash it again with latest original Eurocom bios

      EC V 1.02.11EC
      BIOS V1.02.17EC v3b GTX9

      but there is a problem. I did everything according to the instructions, but after I ran step2.bat, the flashing process stoped itself and only the cursor was blinking in the lower corner (and nothing happened)

      There is movie link: https://www.dropbox.com/s/0k1tqw3abwzmcpx/racer_p150em.mp4?dl=0

      Generally I am not able to flash any other bios (the result is still the same)

      Does anyone have any idea, how to solve it?

      I also tried the following (unsuccessfully):

      Remove system battery, disconnect adapter.

      Disconnect CMOS battery, hold down Power Button for 45 seconds.

      Thank you in advance for your help
       
      PS: the reason why i want to flash it, is GPU upgrade (from AMD 7970M - bricked, to NVIDIA 970M)

×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use. We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.