Jump to content
Apologies for the spam Read more... ×
Sign in to follow this  
Eviling Dark

M18x R2 GPU update to GTX 880M black screen problem

Recommended Posts

Hello

I bought Dell gtx 880m for my m18x r2.

I thought there would be fewer problems than with gtx 970m.

 

Installed it and the laptop at the start produces 8 sound signals with black screen.

I tried to flash a11 and a12 BIOS and it did not help.

 

Share this post


Link to post
Share on other sites
On 3/13/2017 at 1:23 AM, Eviling Dark said:

Hello

I bought Dell gtx 880m for my m18x r2.

I thought there would be fewer problems than with gtx 970m.

 

Installed it and the laptop at the start produces 8 sound signals with black screen.

I tried to flash a11 and a12 BIOS and it did not help.

 

hold the FN key before powering up the laptop and then turn it on hold the key until the laptop make a restart and you are done. if u installing just one card it has to be install on slot 1. 

 

On 3/13/2017 at 1:23 AM, Eviling Dark said:

 

 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

  • Similar Content

    • By mtvgt
      Hi guys,
      i have m18x R1 model with A05 unlocked bios and i try to connect ati mobility 4870 card/s.
      I read ton of posts but people that seem to have similar problem with different card didn't post any solution. Case is when i connect 4870 i get black screen and 8 beeps.
      When i use only integrated graphics (no cards installed) laptop is starting normally.
      When i use integrated graphics (nvidia card installed as master) laptop is starting normally.
      When i use nvidia card installed as master laptop is starting normally.
      When i use nvidia card installed as master and ati 4870 installed as slave laptop is starting normally but in devices manager i see there is error 10 with ati card.
      When i use ati 4870 card installed as master i get 8 beeps and black screen.
      I tried to google for answers but unfortunatelly didn't find any. Do you know if that old card can work in m18x ? Maybe it's not supported at all? Do you have any ideas what else can i try?
    • By Max2016
      Help me Tech Inferno, you're my only hope.
       
      Ok so firstly, apologies for yet another 8 beeps thread. I must have read 100 of them over the last week. I feel like I'm missing something obvious, but I'm totally burned out after days of working on this so would appreciate some outside perspective.
       
      I live in the UK, so I've avoided buying a 980m to upgrade my 660 for years to due the price/import tax etc. I finally found a good priced 980m on Ebay a few weeks ago so I thought why not give my trusty 18x r2 a few extra years of life.
       
      I ordered the 100w heatsink, x bracket etc from Eurocom at the same time and everything arrived on the same day.
       
      Here's what I've done so far in the last 7 days:
       
      -Flashed unlocked A11 BIOS (I rolled back to Dell A11 first)
       
      -Removed  660m and installed 980m
       
      -With BIOS in Legacy, Installed Windows 7 on a new SSD with BIOS set to IGFX
       
      -Tried to switch to PEG but got 8 beeps so reset CMOS battery
       
      -Switched to SG and booted to Windows. 980m detected as default hardware. Installed 980m Driver from Eurocom and restarted. Device manager shows 980m  working normally along with HD Graphics 4000. Tried PEG again but still got 8 beeps
       
      -Reset battery, booted to Windows and disabled the 980m in Device Manager
       
      -Flashed VBIOS from here  (I read that the dell VBIOS doesn't work well so tried Clevo one first, but I've since tried both and a few others)
       
      -Re enabled 980m and restarted Laptop still in Legacy SG.
       
      -Tried to test a game but they only want to use HD Graphics 4000. When I try to open NVIDIA Control Panel and change some settings I get a blue screen and have to restart.
       
      -Tried PEG again, still 8 beeps
       
       
      I've tried many combinations of drivers, VBIOS and BIOS settings over the last week but the result is mostly the same. I get 8 beeps in PEG. I thought perhaps the seller had sent me a G-sync version as I have read these don't play well with PEG, but I checked the hardware ID (PCI\VEN_10DE&DEV_13D7&SUBSYS_05501028&REV_A1) and what I've read seems to indicate this is the Non G-Sync card.
       
      I got the 980m rather than the 1060 after reading the forums as I saw so many success stories I figured it would be the safer option.
       
      I understand this laptop is basically dead to most of you now, but if any techsperts are around and could give me some other things to try I'd greatly appreciate it.
       
       
      Thank you,
       
      Max










    • By Spokf
      Hello,
      I have a g750js with gtx 870m, I upgrade it to gtx 880m when the laptop boot it's not recognize the gpu and the fan turn at the high speed. 
      The laptop turn with windows 8.1.
      Can someone help me please ?
      Thank's 
      Sorry for m'y poor english.
    • By Losercore13
      I have installed my 980M on myR2, Got the 8 Beeps, I thought with the A12 BIOS and Windows 10 it should have worked. Oh well, going to tear it back down and put the 675M's back in. Ijust got promoted and am downloading the A11 unlocked BIOS . So, Next teardown I am going to be completely ready. I just want to get this in and see if I can get it working before my return window passes. I have posted a few places here, and on Notebook Review on several threads about this stuff, and have received one response. Is this site still active? Do I need a modified driver still, all that stuff looks really old, 2013-2016 type stuff. I need to know about 2018. I have read that Nvidia added support for the maxwell in m18x r2. Am I wrong? Can someone offer advice? I have read that this thing should have been plug and play with windows 10 on Eurocom, Do I just need their driver? PLEASE HELP!!! Thank You!!!
    • By Losercore13
      Is there a way to get a 144 HZ Display for the m18x R2? I was trying to think of a meaningful 5th Post for promotion, so there it is! Haha, but really, is there?
×

Important Information

By using this site, you agree to our Terms of Use. We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.