Jump to content

Force Windows 10 internal output


Recommended Posts



I've currently got my Akitio Thunder 2 + MBPr setup working beautifully with Windows 10 - except for one annoying issue.

Sometimes when I boot up Windows 10, the OS will try to output on the display output of my eGPU (GTX 960) instead of on the internal display.

This means that I can't log into the OS and that I have to force-reboot.


Sometimes I time the bootup correctly, and everything works perfectly, but sometimes it doesn't - which is very annoying.

Do any of you guys know a way to force Windows 10 to use the internal display - always - even if an eGPU is plugged in (basically forced Optimus)?

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...

Important Information

By using this site, you agree to our Terms of Use. We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.