Jump to content

M17x Quirk: Running HD Graphics 4000 below 650MHz base speed

Recommended Posts

This is a weird quirk that has stumped me for a long time and I've found nothing through my own extensive research (thanks Intel for your "confidential" PDF collection!)

System is M17x R4 running A10 BIOS; Similar behavior seen on M14x R2.

Installing RAM faster than original 1600MHz (verified w/ Crucial 1866MHz and Kingston 2133MHz) causes the base speed of the iGPU to idle below the advertised 650MHz. On 3740qm CPU it ran at 350MHz and with 3920xm it runs at 400MHz. It still ramps up as high as 1300MHz as needed for performance but uses a hell of a lot less power at idle - so I really want this behavior! With these power savings, I'm able to run my M17x on battery for nearly 6 hours! Really!

Everything works great if I boot on AC power, even if I then switch to battery, even sleep/hibernate. The issue is that if the system is booted from a cold start or rebooted while on battery, the iGPU does its advertised 650MHz (which I do not want) and draws 2+ watts of power from the battery, even to do nothing. It stays like that until the AC adapter is plugged in, at which time it immediately switches down to 400MHz (verified w/ 2 separate 240w adapters.) With the desired behavior - running at 400MHz - iGPU only draws ~0.1 watts at idle doing nothing. It might sound silly but I really want those two watts of power savings ALL THE TIME, which I lose if I'm running on battery and I have to reboot for whatever reason.

Can anyone explain this behavior? Has anyone else experienced it? It's not a huge issue but it has perplexed me for so long and I cannot find anything on the topic.

I do know that downgrading back to A05 BIOS made my original 3740qm's iGPU run at the lower speed all the time, even when booted on battery, so I'm assuming that would work with this CPU too but I'd like to actually understand what's going on here - and if there's another way to control it. I'd like to be able to force it manually.

I have tried lowering the iGPU clock multiplier in both Intel XTU and in BIOS (via the GT overclocking section) but it gets ignored.


Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...

Important Information

By using this site, you agree to our Terms of Use. We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.