Jump to content

M17x R4 : GNU/Linux


Recommended Posts

  • 3 months later...
  • 1 month later...

But how? I've had audio jack detection issues across multiple kernels / distros since the time of Ubuntu 12.04 LTS (which is just the first one I tried with this M17x R4).

I'm currently dual-booting W8 with Arch running kernel 3.9.1 (from the testing repos) and KDE, to answer the OP, but the issues persist under Linux for me.

Link to comment
Share on other sites

  • 2 weeks later...

Hi all ,

I tried several distro of ubuntu without any success, perhaps tink because the 120hz screen.

Then I tried the Debian 7 x64 , it boot and wifi works good , but the audio is missing, the keyboard is USA in place of the Italian type.

Link to comment
Share on other sites

Well running the latest Arch with the testing repos enabled, audio works properly (under ALSA) by simply plugging into the secondary headphones jack. I've yet to test this with pulseaudio.

What's more troubling is how the 7970m has no s3tc/dxtn support in the radeonsi FOSS driver, and indeed no hardware acceleration at all unless using Glamor. I guess that's supposed to be merged with kernel 3.10 but be dependent on the next Mesa, which isn't going to be ready for about 5 months. I've opened some threads across the Arch and openSUSE forums detailing these issues, and I can point anyone there who is interested. There are some upstream bug reports open as well, by others.

Link to comment
Share on other sites

You'll have to grab the proprietary drivers, which is probably most easily done from their site. As things currently stand, "Nvidia's" FOSS drivers will never get close to what the AMD and Intel stacks offer, especially with acceleration: re-clocking is broken under nouveau.

Link to comment
Share on other sites

  • 3 weeks later...

Using Ubuntu 13.04, 8.04 (for older software) , BT5 (white hat purposes), and ofc win 7 and 8. everything works perfectly, sound, video, you name it.

Only thing I want and I am currently working on is getting the alienFX to work properly on my linux distros.

Other wise everything is perfect

Link to comment
Share on other sites

I'm using Arch Linux. Got the nVidia GTX 680M. Extremely problematic to get the proprietary driver with optimus working without using a hackish bumblee solution.

Got the nvidia graphics sort of working with a "proper" optimus solution by starting the X server, then set the provider output through Intel with xrandr, then setting it back to auto.

The official nvidia website suggests using the modesetting driver instead of Intel, but couldn't get that to work.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...

Important Information

By using this site, you agree to our Terms of Use. We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.