Jump to content
EwinRacing Flash Series Gaming Chairs
Sign in to follow this  
AleksR17x

m17x R4 Creative Recon 3Di

Recommended Posts

Being an Audiophile i had to get all the functions up and running for my Almost new R4

 

How to get updated driver.. and Thx control panel to work under windows 10 64 bit (who has 32 installed on an R4 anyways)

 

I have DDU disabled always, Windows 10 in Test mode.

 

Do this after all the other drivers/apps are updated, NVIDIA, Visual C etc.

 

Fix:

 

1.:ownload the latest driver for the Recon 3Di chip itself. This specific driver package is for a later revision that has another firmware on the effect side so the Control Panel does not work.

But we are not after that here, we need the latest driver so it will work optimally in W10.

http://www.dell.com/support/home/no/no/nobsdt1/Drivers/DriversDetails?driverId=D6NF4

 

2.: Thx Control panel:

Download the standard Audio driver package M17x R4 / M18x R2

https://downloads.dell.com/FOLDER00384156M/2/Audio_Creative_W74_5NJ7K_A01-Setup_ZPE.exe

 

3.: Right click the exe file and extract the contects to a random folder.

Go to Program files\Creative\Sound Blaster Recon3Di\Sound Blaster Recon3Di Control Panel

Copy the contents of this folder over to Program Filesx86\Creative

Make a shortcut to the desktop. Run it, and you have control over all settings :) 

 

(optional) Delete the Newer Recon 3Di control panel folder if you installed that with the newer package that does not recognise the older Chip.

 

 

Share this post


Link to post
Share on other sites

Hello,

 

I followed the instructions and seemed to work because it's reading the headphone jacks. One problem, the control panel will not open when I click the icon.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

  • Similar Content

    • By Guardian241
      Hi,
       
      I've recently got my hands on an M17x R4 Alienware Laptop from 2013 which I love. I've replaced the screen, keyboard, RAM, and hard drive to make it into a fully modern laptop. However, I'm currently waiting on a replacement for the 680m GPU with a 980m from ebay. My question for you all is, do I need to do anything with the BIOS to make this 980m work? Is there a way to prevent the laptop from using Intel HD Graphics with Optimus? I think the Intel HD Graphics on this laptop are currently broken as I see static-looking dots flash on the screen. (See image below for example). My theory is that because Intel HD Graphics with Optimus is still in-use while in-game, the dots are being caused by it.
       
      Thanks for any help in advance.
       
      - M
       

       
       
    • By svl7
      Files contained in this archive:
      FTP-DOS.zip prr2.zip M18x R2 - BIOS A03 'unlocked.zip M18x R2 - BIOS A08 'unlocked.zip M18x_R2_-_BIOS_A08_-_[unlocked]_-_[IRST 11.0.6.1702].zip M18x_R2_BIOS_A03_-_[unlocked] - [IRST 11.6.0.1702].zip M18x_R2_BIOS_A09_-_[unlocked].zip [FPT]-M18x_R2_BIOS_A09_-_[unlocked].zip [FPT]-M18x_R2_BIOS_A10_-_[unlocked]_V2.zip M18x_R2_-_BIOS_A08_-_[unlocked].zip M18x_R2_BIOS_A03_-_[unlocked].zip  
      For information on how to use the files in this archive, see here:
       
       
      My donation link in case you want to buy me a beer
    • By Crustieraxe
      Hello Guys this is my first post here!
       
      So my original post was this:
       
      "I don't even know if any active forum is out there on this laptop and on this issue, but after installing my new DHCG2 LTN173HT02 120hz display, I am unable to boot up on it. I do have a modded bios which the video setting is set to PEG, and just about read every forum about this but have not found a solution. I have tried resetting the bios, made sure the cable is plugged into the Edp port, and have made sure I have an UFEI Windows installation and legacy mode is turned off. I don't know what else to do and if anyone could help it would mean alot to me! "
       
      The reason it was not booting up on a pure UEFI environment is because my 660m did not have the GOP compliant driver vbios. You would need this in order to boot up in a pure UEFI environment which at the time I didn't know, and my fix was to stick to legacy. Any card before the 660m will most likely require this if you need to boot up in a pure UEFI environment. If you do not have this vbios driver while it is set to UEFI and plug in the 120hz lcd, it will beep 8 times and you will be forced to plug back in the 60hz display to change it back to legacy.
       
      This was the vbios that I can say worked for me and had the GOP compliant driver for the 660m
       
      https://www.techpowerup.com/vgabios/144032/144032
       
      ------------------------------------------------------------------
       
      These are the steps to upgrade from a normal 1600x900 60hz display to a 1920x1080 3D 120hz Display which is needed if you want to update your graphics card to a more modern one.
       
      I am making this guide because I felt frustrated that for this awesome computer, there aren't really any post in 2020 to upgrade the LCD panel to the 3D 120hz one. And The older posts I scavaged through really helped me little in doing this upgrade.
       
      Anyways lets begin
       
       
      1) If you have a stock AMD graphics card, and are wanting to install the 120hz display, then your journey ends here and you will have to upgrade to an NVIDIA graphics card to do so. If you have an NVIDIA, you may continue
       
      1a) ( Only if upgrading to pascal graphics card )Your NVIDIA card Needs to have a GOP compliant vbios  or else it will not let you select the UEFI option on the bios. This is needed because you need to set a UEFI environment before upgrading to a 1060/1070 Since these cards don't support legacy mode. This means you will need to flash a vbios onto your card that will allow you to boot on a UEFI Environment. You will need to verify first wether your card has a GOP compliant vbios by searching up your vbios version in GPU-Z. If you have a 660m that doesn't have this, then here is the link to that vbios that does. https://www.techpowerup.com/vgabios/144032/144032 I think that all of the Nvida 6XXm are not GOP driver compliant and need this but do not quote me.
       
      2) On the 60hz display, I would start by making sure that you have windows 10 installed or reinstall with UEFI support as it is needed if you are installing a pascal graphics card. If you have legacy mode enabled, and are not planning to upgrade to a pascal graphics card and keeping your old Nvidia 6XXM, then disregard this and head on to step 5 (although I would recommend to read everything)
       
      3) turn the laptop off and boot into the bios. In order to boot into the bios, spam the F2 key while it is turning on.
       
      4) Once in the bios, go to the Boot menu, and make sure to Disable "Secure Boot", Make sure that importantly if you converted over to a UEFI installation of windows, UEFI mode is chosen (UEFI  Environment will be needed for a pascal graphic card and legacy will not be compatible) then again, if you are on a legacy installation of windows 10, disregard this if you don't want to upgrade to a pascal graphics card.
       
      5) we can now start looking at the 120hz display. I bought mine on ebay with this seller https://www.ebay.com/itm/New-Dell-Alienware-M17X-R4-17-3-FHD-WLED-3D-V-M-LCD-Screen-DP-N-DHCG2-GN36T/273644412867?hash=item3fb67a5fc3:g:9A0AAOSw5AhcP1pw:sc:USPSPriority!32720!US!-1 (Just in case the link goes bad, this was the listing name"Alienware M17X R4 17.3" FHD WLED 3D V M LCD Screen DP/N DHCG2 GN36T"  with the screen model being  LTN173HT02 and Dell part number GN36T )
       
      6) Since my listing came with the video cables, I did not have to go out and look for the video cable. If yours did not come with the cables, You will also NEED to get the video cable it is required. the Dell Part number is N392W. I cannot stress enough This video cable is required and the 60hz's video cable CANNOT be used with the 120hz one or else you will brick your computer from what I read.
       
      7) Once it comes In, we can start to take apart the computer to Install our new display. I watched this video to remove the old 60hz and install the 120hz panel 
       
       
       
      8) Before I would remove the whole 60hz lcd panel, I would first make sure that you can boot on the 120hz panel. Notice that there is one connecter with screws on both sides right next to where the 60hz screen connecter is. Make sure that you put the 120hz one with the connector where screws are. This is known as the Edp port and cannot be confused with the LVDS port. Again, you want to plug the new 120hz display into the EDP port and unplug the 60hz one.
       
      9) If the installation was done correctly, then you should have no problem booting with the screen. if it is giving you 8 beeps, then just plug in the 60hz display, and navigate back to the bios to make sure everything is in order and refer back to steps 2-3. If you happen to be an advanced user like me and went ahead and installed a modded bios, then on the 60hz display make sure that the video setting is set to PEG. I dont think this is necessary to have a modded bios since the bios automatically changes the video setting when the 120hz display is detected and should be a last resort option to install a modded bios. I got my modded A12 bios from a guy in this forum named klem for 10 US dollars thorough paypal. Shoot him a message in the forum below.
       
       
      10) Once the new LCD is tested and you know you can boot up with no problems, go ahead and finish removing the old 60hz LCD and proceed to finish installing the 120hz LCD. And you are done. 
       
      A couple of words from my personal experience: When I installed the 120hz display, and booted up windows on it, and turned the computer off, it refused to turn on for some weird reason. I don't know why it would turn on when the AC and battery where on. regardless of what this was, I fixed it by Reseting the CMOS. If you don't know how to do this, do a quick google search and after turning it on i got 5 beeps which i then turned the computer off, and then turned it back on which the computer just reset itself and when it turned back on I was able to boot up into windows.
       
      This is the forum that I was able to find about upgrading the graphics card to the 1060.
       
      Anyways I hope I at least helped someone transform their computer! In 2020!
       
       
    • By danger007
      Well I am back, sort of.
       
      Reminder of Stats
      *Alienware M17x R4 (bought June 2012) w/ Intel i7 [email protected] (Ivy Bridge) including the igpu Intel 4000 HD series
      8GB Ram, 17 Inch, SoundBlaster software only Recon 3DI, and the normal stuff that comes with it
      *Graphics Card:  Originally shipped 660m, upgraded to 7970m, 7970m died early, with community help moved to MSI 4GB 680M (flashed to Dell thanks to @svl7) and installed I think 314.xx drivers with help from many (sorry can't remember everyone but notable was @J95), was running 7970m in whatever they called their hybrid drivers, the 680m is run in Optimus)
      *OS:  Windows 7 64bit Service Pack 1
      *Storage:  Msata 1tb Samsung 850 Evo, 2 Hitachi 1TB 7200 rpm 2.5" drives (yes I used all 3 GB or will)
       
      So what will you read.  What got me started on this project and then using all the resources on the net, from @J95 and legions of others I owe all credit for the project too.  Please note I take no credit, take no rights, this is simply something to help others out based on working with what has already been laid down for us.   Installing the latest Nvidia 417.67 mobile/notebook drivers for a 680m for Windows 7 Service Pack 1 on Alienware M17x R4
       
      When I got things up and running back in 2016/2017 with the noted people above I saw a new driver and with the STO game having a driver issue I upgraded to it.  Now I didn't notice anything wrong, the game worked and so paid no attention.  When I started to get unable to eject 680m error messages I thought great who got this, ejecting a gpu, wrong.  I then tried the uninstall Intel, Nvidia, use DDU in Safe Mode, disable AV/Firewall, disable driver enforcement, etc then reinstall intel, nvidia (removing certain folders) with the modified inf but now the game said it couldn't find any feature set and wouldn't let me play.  Finally removing the Nvidia drivers allowed at least the iGPU to run the game.  Used Unigine Heaven 4.0 to encounter more errors with Nvidia.
       
      I moved back to my msata install of windows 7 that I haven't had a chance to work on since 2017 (i know pathetic) that only had system drivers, expired Norton, and not yet registered/activation.  Seems fine.  Tried to run Heaven, same error.  Well after 3 days of trying to duplicate what I had been instructed to do, I finally sat down with a nice big bottle of Fiji Water (courtesy of lovely lady at the Oscars in almost every background pic) and decided I was determined to fix things.   I downloaded the 419.67, copied the nv_dispi.inf & nvdmi.inf to get to work.  After reading the content and using comparisons once again from the noted individuals and the legions of other, I had them modified and decided to give it a try on the clean win 7 install from 2 years ago.  After the uninstall, ddu, deleting folders, copying mod. inf to their directory (also included the change to setup.cfg - credit once again goes to individuals like @J95), gyrxiur, DeathAngel , creator of Notepad++, sora and many others) I was able to launch the Heaven 4.0 Benchmark.  So I am assuming that I have the new 419.67 working on my system.  I did a benchmark of the 680m in 419.67 with unigine Heaven 4 to go with the files I am posting.  Please note the bios was provided by I believe @svl7 (sorry if I got wrong person) and no overclocking of it other than what the changed vbios did.
       
      I am attaching below the following:
      Nvidia 419.67 modified inf and config - nvdmi.inf, nv_dispi.inf, setup.cfg (no credit to me all credit belongs to others)
      The Unigine benchmark results (txt file).
       
      Now the shortened legalize warning
      Please remember you are to take all risk when using modified inf files, I take no responsibility (no virus or other dildrus included) if they don't work with your GPU.  The usual.
       
      This was tested and used on Alienware M17x R4 running the last bios they released A12 or A13 and so it the system bios is not modified at all, the card is a MSI 680m 4Gb flashed vbios to Dell 680m 4GB, and installed in Windows 7 64bit Service Pack 1.  Hopefully if you have only a different card you can make any minor adjustments you need to.  
       
      Please let me know how they work.  I will also be reporting back on the reinstall on my other laptop install I use to play Neverwinter/ Star Trek Online - was suppose to be a temp solution till new install was finished, and if they worked on it as well.
      Alienware M17x R4 680m 419.67 Mod Inf and Setup and Heaven 4 Benchmark.zip
    • By Max2016
      Help me Tech Inferno, you're my only hope.
       
      Ok so firstly, apologies for yet another 8 beeps thread. I must have read 100 of them over the last week. I feel like I'm missing something obvious, but I'm totally burned out after days of working on this so would appreciate some outside perspective.
       
      I live in the UK, so I've avoided buying a 980m to upgrade my 660 for years to due the price/import tax etc. I finally found a good priced 980m on Ebay a few weeks ago so I thought why not give my trusty 18x r2 a few extra years of life.
       
      I ordered the 100w heatsink, x bracket etc from Eurocom at the same time and everything arrived on the same day.
       
      Here's what I've done so far in the last 7 days:
       
      -Flashed unlocked A11 BIOS (I rolled back to Dell A11 first)
       
      -Removed  660m and installed 980m
       
      -With BIOS in Legacy, Installed Windows 7 on a new SSD with BIOS set to IGFX
       
      -Tried to switch to PEG but got 8 beeps so reset CMOS battery
       
      -Switched to SG and booted to Windows. 980m detected as default hardware. Installed 980m Driver from Eurocom and restarted. Device manager shows 980m  working normally along with HD Graphics 4000. Tried PEG again but still got 8 beeps
       
      -Reset battery, booted to Windows and disabled the 980m in Device Manager
       
      -Flashed VBIOS from here  (I read that the dell VBIOS doesn't work well so tried Clevo one first, but I've since tried both and a few others)
       
      -Re enabled 980m and restarted Laptop still in Legacy SG.
       
      -Tried to test a game but they only want to use HD Graphics 4000. When I try to open NVIDIA Control Panel and change some settings I get a blue screen and have to restart.
       
      -Tried PEG again, still 8 beeps
       
       
      I've tried many combinations of drivers, VBIOS and BIOS settings over the last week but the result is mostly the same. I get 8 beeps in PEG. I thought perhaps the seller had sent me a G-sync version as I have read these don't play well with PEG, but I checked the hardware ID (PCI\VEN_10DE&DEV_13D7&SUBSYS_05501028&REV_A1) and what I've read seems to indicate this is the Non G-Sync card.
       
      I got the 980m rather than the 1060 after reading the forums as I saw so many success stories I figured it would be the safer option.
       
      I understand this laptop is basically dead to most of you now, but if any techsperts are around and could give me some other things to try I'd greatly appreciate it.
       
       
      Thank you,
       
      Max










×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use. We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.