Jump to content
EwinRacing Flash Series Gaming Chairs
J95

[Alienware - Clevo - MSI] Aftermarket Upgrades Driver Support - Modded INF

Recommended Posts

Please follow the instructions below.

• Specs.

• Device manager ->Display Adapters ->Details ->Device Description ->Hardware Ids, post results (request).

- Extract downloaded driver using 7-Zip/winrar.

- Extracted Nvidia...International\Display.Driver folder\ -> copy/overwrite nvdmi.inf

- Nvidia...International folder\ -> run setup.exe

- Windows 8 - disable driver signing

Command Prompt (Admin) Win key + X Type:

 
bcdedit /set {current} testsigning yes

-> "The operation completed successfully" ->reboot ->Install drivers.

Exit test mode, cmd (admin).

 
bcdedit /set {current} testsigning no

->reboot.

- Use DDU to remove previous drivers/GPU installations (Nvidia & AMD), create restore point then select first uninstall option (safe mode).

GeForce 334.89 WHQL

Modded nvdmi.inf v334.89 AW M17XR2/R3/R4 3D + M18XR1/R2 GTX 680M / 780M

Modded nvdmi.inf v334.89 AW M18XR1/R2 GTX 680M / 780M SLI Enabled

- - - Updated - - -

Quadro Notebook Driver 334.95

PhysX 9.13.1220

- Extract

- Nvidia...International folder\ -> delete the following folders:

Display.NView

Display.Update

Display.Optimus

NVWMI

- Display.Driver copy/overwrite nvdmwi.inf

- Nvidia...International\ -> run setup exe

- Install Physx -> reboot

Fire Strike NVIDIA GeForce GTX 780M video card benchmark result - Intel Core i7-3940XM,Alienware M17xR4

[

nvdmwi.inf_v334.95_AW_M17XR2_R3_R4_3D_M18XR1_R2_GTX_680M_780M.zip

nvdmwi.inf_v334.95_AW_M18XR1_R2_GTX_680M_780M_SLI_Enabled.zip

  • Thumbs Up 9

Share this post


Link to post
Share on other sites
- Download GeForce 334.89 WHQL

- Extract driver 7-Zip/winrar

- Display.Driver folder -> open nvdmi.inf (notepad) Edit -> Replace -> Find What: 05AE Replace With: 0490 -> Hit 'Replace All' -> Save.

- Nvidia 334.89...International folder\ run setup exe.

Repeat using 335.23 instead.

Share this post


Link to post
Share on other sites

Share this post


Link to post
Share on other sites

I have been trying to use these mod ini files for versions 320.49, 335.23, and 337.88 but I'm never able to pass the compatibility check, it is always saying could not find compatible graphics hardware. I am downloading the drivers from NVidia and then using 7zip to extract the download exe to a folder which I then am downloading the modified ini files and putting them in the Display.Driver folder overwriting the file with the larger mod file, then I go up a folder level and am running setup.exe as admin but I'm never getting past this compatibility check. Anyone know what I am missing or failing to do? Thanks for the helps

Share this post


Link to post
Share on other sites

Hi @magusstorm, welcome to T|I.

- Device manager -> Display adapters -> Details -> Hardware Ids. Post result.

- Specs?

Share this post


Link to post
Share on other sites

Hi thanks for responding, my hardware ids are as follows:

PCI\VEN_10DE&DEV_11A0&SUBSYS_04BA1028&REV_A1

PCI\VEN_10DE&DEV_11A0&SUBSYS_04BA1028

PCI\VEN_10DE&DEV_11A0&CC_030000

PCI\VEN_10DE&DEV_11A0&CC_0300

The device instance path is: PCI\VEN_10DE&DEV_11A0&SUBSYS_04BA1028&REV_A1\4&361D66C5&0&0008

my machine is a m17x r3 running Win 7 SP 1 and recently has been reformatted and bios was updated to a12. the gpu I'm installing is a gtx 680m. I have 11A0 strings in my inf files, but none have the 04BA1028 SUBSYS value.

This is what is in my inf file for the 11A0 values:

%NVIDIA_DEV.11A0.0270.1558% = Section135, PCI\VEN_10DE&DEV_11A0&SUBSYS_02701558

%NVIDIA_DEV.11A0.0271.1558% = Section139, PCI\VEN_10DE&DEV_11A0&SUBSYS_02711558

%NVIDIA_DEV.11A0.0371.1558% = Section135, PCI\VEN_10DE&DEV_11A0&SUBSYS_03711558

%NVIDIA_DEV.11A0.0372.1558% = Section139, PCI\VEN_10DE&DEV_11A0&SUBSYS_03721558

%NVIDIA_DEV.11A0.5105.1558% = Section098, PCI\VEN_10DE&DEV_11A0&SUBSYS_51051558

%NVIDIA_DEV.11A0.7102.1558% = Section098, PCI\VEN_10DE&DEV_11A0&SUBSYS_71021558

  • Thumbs Up 1

Share this post


Link to post
Share on other sites

That worked to get the driver installed, but it has a problem showing in device manager:

Windows has stopped this device because it has reported problems. (Code 43)

Share this post


Link to post
Share on other sites

Really sorry, I'm not sure why it is redirecting me to the downloads page, but even clicking on it from the downloads page is just taking me back to the downloads page. I tried to find it thru google and the link I chose took me to a new thread: http://forum.techinferno.com/alienware-m17x-aw-17/2279-%5Bm17x-r3%5D-bios-a12-unlocked-sata-tweak.html

but that link took me to a page saying that the downloads have moved and are now hosted on tech inferno forum pages and the link it provides takes me to the downloads page where I seem to be stuck in a loop

Share this post


Link to post
Share on other sites

OK managed to flash the bios and gained access to a second advanced menu but when I changed SG to PEG and F10 reboot the system came back and lit the screen but it was all black. I heard the windows chimes in the background and knew everything booted fine except the black screen. I had to pull the card out in order to view anything again. I guess this means something happened to the card and it isn't working now :(

Share this post


Link to post
Share on other sites

- Under Programs and Features, uninstall everything Nvidia related.

- BIOS, disable IGP.

- BIOS, set display to PEG.

- Install drivers nvdmi.inf v337.88

Share this post


Link to post
Share on other sites

Could I be missing a step in bios? By disable IGP you mean change the display from SG to PEG and that is it? Whenever I am setting the display to PEG from SG and press F10 to save the pc reboots and when it comes back on the screen lights up but remains all black, I can hear windows boot in the background but I can't actually see anything and I have to unseat the card in order to view anything on screen again.

Share this post


Link to post
Share on other sites

You need to disable the integrated graphics (HD3000) and set display to PEG.

post-3012-14494997774856_thumb.png

post-3012-14494997774094_thumb.png

Share this post


Link to post
Share on other sites

Unfortunately that also caused the black screen with no view and windows booted in the background. When I unseated the card to get back into bios the machine started to beep a series of 6 beeps. I had to put the old video card back in to get past that.

Share this post


Link to post
Share on other sites

With IGP disabled and PEG enabled are you able to see the BIOS screen?

Try cleaning the golden connectors and if needed reseat the card a couple of times, boot into safe mode (F8) and uninstall drivers.

Share this post


Link to post
Share on other sites

No, in every case when I select the PEG instead of SG the screen goes black but not dark for everything. The ROM messages on startup don't show, if I hit F2 during the loading nothing displays, if I just let it boot normal I can hear windows load but cannot see anything. It always takes to unseat the card to get any display back. I've gotten the drivers to load several times but in each case when Device Manager sees the card it sees it with the error 43, and if I force it to be used I end up with the black lit screen

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Similar Content

    • By Onehit
      I've been scouring the internet in search of anything regarding an updated bios for my Clevo P170SM. I have found many mentions of Prema Bios mods on various websites, but good luck trying to find actual download links. They all seem to vanish or have dead links. Wayback Machine doesn't help either and I was only able to find stock Clevo bios as early as 2015 via the WayBack Machine. If anybody has an updates Prema Bios or some other unlocked bios file for the P170SM, that would be fantastic! Otherwise, I might have to consider paying over $100 to Eurocom for their unlocked bios.
    • By Henrik9979
      Okay here is what's going. I have a alienware m18x r1 running an amd 8970m, I wanted to upgrade it to crossfire but I could see a 8970m was more expensive than a r9 m290x
      So I decided to buy a r9 m290x and see if I could make it work in my alienware and also run crossfire.
      Even though many shops refused to sell me one because the didn't think it would work in an alienware m18x r1 only in the r2.
       
      Here is the whole process.
       
      19/08/17 23:15
      No post bios showing when booting, so impossible to enter bios menu, but can boot into windows 10 with no problems.
       
      19/08/17 23:20
      Because I haven't deleted the old AMD 8970m the r9 m290x shows as a 8970m with no problems.
       
      19/08/17 23:34
      First performance test was a success. The r9 m290x changed p-state normally. The gpu fan start spinning normally. But because of no thermal paste, the test lasted 20 seconds because the temperature raised fast.
       
      20/08/17 00:00
      Created a backup of the vbios version
      015.032.000.004.044450
       
      20/08/17 00:10
      Flashed a new clevo vbios version 015.032.000.003.044465
      Caused the card to be corrupted and resulted the 8 beep code.
       
      20/08/17 00:35
      Finally managed to flash the back and return the graphics card to its original state.

      20/08/17 00:50
      Flashed a new dell vbios version 015.046.000.014.045579
      No change in behavior
       
      20/08/17 01:07
      After trying multiple vbios with no luck I finally found one.
      Dell vbios Version 015.041.000.000.044966
      Brings back the post bios screen and I can now enter the bios menu through the r9 m290x.
      Note: This vbios reduce the cards performance from 900 mhz to 850 mhz
       
      20/08/17 01:21
      After more testing I found one that is working with no limits.
      Clevo vbios version
      015.036.000.005.044618
      Brings back the post bios screen and I can now enter the bios menu through the r9 m290x.
      This will be the vbios I will keep at the moment.

      20/08/17 01:56
      I completely uninstalled the previous driver and installed the newest driver. The graphics card is recognized as a 8970m but works normal.

      21/08/17 20:15
      I have inserted my old 8970m in the secondary slot and will start testing crossfire.
       
      21/08/17 21:45
      I have found out that the fan for the secondary fan did not spin. The is a cable that have felt out. I will fix it now.

      21/08/17 22:00
      In my try to test crossfire compatibility, I installed the newest AMD driver 17.7.2 but as soon it installed the driver for the secondary card it caused black screen. Only booting the computer in safe mode brings the screen back.

      21/08/17 23:02
      After many frustrating hours I finally managed to get crossfire working with the r9 m290x as the primary card and my old 8970m as the secondary.
      I have flashed the same vbios on both cards so the r9 m290x shows up I device manager as a 8970m.
       
      I first installed AMD driver version 16.2.1
       
      Then installed AMD driver version 16.6.1 in order to play battlefield

      21/08/17 23:20
      First test run in battlefield 1

      21/08/17 23:40
      Battlefield 1 is flickering bad, this can maybe be solved with a new patch or driver.
      Other games I have tried is working perfect with crossfire on.


      Now what I would like to try is somehow force the r9 m290x driver to be installed and see if it will make it possible to run the latest AMD driver without getting a blackscreen.
       
      I have tried to edit the .inf file like you would do with nvidia but no luck.
      I have also tried to figure out how to edit the device id in the vbios, but I find it too complex.
    • By rsk
      Hello everyone just a little question. 
       
      i've just flash my p751dm2-g with the backed's bios and i gonna overclock it of course but i don't know how to clear cmos on this laptop.
      i have find nothing about it in the manual so i ask here. 
       
      Thanks 
    • By rsk
      Hello everyone I'm new on this forum and i'm new with clevo laptop. 
      I've recently buy a second hand laptop a clevo p751dm2-g with a i7 6700k and a 1070 mxm and unfortunatly the bios is locked i can't overclock my cpu or my ram. :sadge: 
      So i wanted to know if you guys on this forum have alternative solution to oc your cpu and your ram with a locked bios. 
      Thanks 
    • By Klem
      Klem's_vbios_MSI_GTX880M_80.04.EA.00.03_UNLOCKED.rar
      For both, 4Gb and 8Gb card.
      1. Unlocked Nvidia core limit +135 MHz.
      2. Unlocked Power Limit.
      3. Unlocked Power adjustment by software (for example with Nvidia Inspector).
      4. Increased Power Limit and Power Target.
      5. Enabled some additional tweaks.
       
      If you liked my mod, you can buy me some beer:   https://www.buymeacoffee.com/ekushukovZ
×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use. We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.