Jump to content
EwinRacing Flash Series Gaming Chairs

Recommended Posts



I am trying to do the "Ultimate" G73jh upgrade and I have power related issues.


So I have the most "basic" G73jh, with i5-430m and 5870m.

This version is the one with the brown MB, with only 2 memory slots.


What I did:

- Opening the whole laptop

- Swapping 5970m to 7970m

- Blind-Flashing 7970m vBios

- It boot ! But GPU/RAM frequency stay at 450/300 maximum, because of my 120W PSU I think (throttle), So I ordered a 240W One

- Swapping i5-430m to i7-920XM

- It boot but I almost didnt use it because I was affraid of my weak PSU (dont want to burn it !)


Then I received my new PSU, from ebay  ( http://www.ebay.fr/itm/201638674476).


And... Nothing change !! My 7970m is stil throttling. And I cant OC the 920XM, if I go over 70W TDP, the G73 instent shutdown :-/.


I need your help to be sure Its a PSU related issue, and not something else, like my mobo etc. I dont want to buy a 100+€ PSU if this is not the problem.


As my G73 is still out of his case, I manage to solder the PSU wire directly on the MB, and then I measured voltage during full load (prime95).

IDLE 19,4-19,5V     LOADED: 19,3-19,4V

Not that bad !


I am very confused because the PSU seams to work. I have no oscilloscope to watch the signal in real-time...

For sure it is not a real DELL but if voltage is not droping, whats wrong ?


Its very frustrating to know that everything work but can't be "feeded" with Amps !


Any ideas ?


EDIT: All temps are OK ! Furmark : 58° GPU... (because of the low Freq :-/ )

EDIT2: new info: I tried on battery, It is the same, is it a common behavioor ? (My battery is almost dead, only 30% capacity)

EDIT3: Do you know if the "metalic" part of the case (under the keyboard) have somthing to do with the power delivery in the mobo ?

EDIT4: I reassemble the laptop, so no, the metal plane have nothing to do with ground...

Edited by cclecle2000

Share this post

Link to post
Share on other sites

Some News !


I received the DELL 330W power adapter and I manage to "convert" it to G73jh jack.

It work well but didnt solve anything...


BUT ! I flash another vBIOS, a Clevo one (enduro disabled) and now the GPU run at max frequency !

So for the GPU part, its all working well..


Still have problem with CPU, my PC still instant shut down if I go after 70W tdp (while executing prime95)


So I did a lot of test with ThrottleStop, HW64 and Prim95.

What I see is that, when I raise TDP, CPU Frequency raise (wich is the desired behavior) BUT the BCLK become crazy and dont stay at 133MHZ !

It Jump to 150, even 170 wich mean my DDR3 SIMMs are way beyond the stock 666Mhz .

I tryed to disable Turbo Boost in bios but by doing this I cant use throttlestop anymore :-/.

I also tryed differents bios (211,213, modded 213 V5), nothing chage.


If anyone have a G73jh with a 920XM/940XM can do the test... just run P95 and watch frequencies in HW64 and see if mem clock become crazy.

In my setup the computer fail at 750Mhz (wich is high compared to stock 666...)

Share this post

Link to post
Share on other sites


I think HW64 is wrong, its not able to read the CPU multiplier in real time, against it compute a fake BCLK value...

I think that because CPU-z's frequencies are all OK.


So... My 920XM do not want to eat that much power ! Or maybe may MB do not want to feed it.. That would be strange since the 7970m work just fine. I am even able to overclock it (975/1400 from 850/1200, stable 1H FurMark (95° top temp)).


I'll measure the Vcore to see if there is "glitch" or something like that.


Share this post

Link to post
Share on other sites

Hi, I did same upgrade as you with similar problems :-). TnF had on forum attach file named as clevo.zip (pack of clevo 7970m VGA bios). I was able using this VGA modified bios to1.10V overclock my gpu max on 1095/1560.


Share this post

Link to post
Share on other sites

Re-Hi jurom !


As I tell you in the other thread, my main problem now is the MB.

Mine is too weak to power the 920XM at full speed.


And you are right, I did the same mistake with the vbios...

Now I have flashed the right vbios and it work great !


But at 850Mhz it is very close to the tdp limit...

In some games its Ok, but in others I have to underclock (mainly in the last tomb raider).

(Even with the undervolted vbios)


I am thinking about adding a secondary heat-pipe/fan in the dvd trapdoor :).


Thank you anyway.


Edit: with the vbios i use, I have not sound over HDMI and VGA isnt working too. Is it the same for you ?

Edit: At stock clock (850/1200), undervolted vcore (0.975v), I get constant 92° in FurMark after 20 minutes.

Edited by cclecle2000

Share this post

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Similar Content

    • By OnaStack100
      I have a p150sm which has a seemingly dead 780m due to a perpetual error 43 which came after a big BSOD about 6 months ago. I upgraded the laptop to a 980m and modded the inf files. The upgrade was perfectly fine for a week. One day, i left the laptop and something related to sleep or power may have caused the laptop to shut off. Since then, the laptop with the 980m won't boot. I tried many things like resetting cmos, taking out the hardware and putting it back in, and resetting bios, and buying a 230W adapter. Nothing worked. The laptop works fine with the old dead 780m in there, but now when the 980m is in there, holding the power button generates a green light flash and then the power LED goes back to orange. No sounds, maybe one tick, and that's it. What is left to try?
    • By Andrew2009
      Please could you check if it is possible to unlock my A17 BIOS? I have Alienware 17 R5(2013). 120 Ghz 3D. gtx 980 m. I want upgrade to 1070 but I have dark picture. Turns on but does not start with 1070. 980m-All good. What could it be?
    • By IveGotRoot
      I have recently upgraded my laptop(an M6800 firepro 6100) and replaced it with an GTX 980m. Nvidia says that the latest driver(461) supports my card but i can only install up to 388.13 Ive tried to mod it but i can't figure it out. I can run the latest linux driver tho
    • By Qvixot
      Hello everyone! First of all sorry if this isn't the correct forum to post this.
      I bought a laptop few days ago. The laptop is Sager P150EM.
      Cpu:i7 3610qm 
      Gpu: amd hd 7970m
      Ram: 8gb
      Os: windows 8.1 pro
      So my problem is that everytime i install the amd driver after the intel driver my laptop freezes or gets a bsod or something that stops it from working. Any help would be appreciated. I saw somewhere something about vbios does this matter anywhere?
    • By pippocarlot
      Hello everyone! I am looking for an answer to a problem I cannot find a solution to ... I purchased an Amd wx 4150 MXM GPU module su e bay to upgrade my HP 8570W Mobile Workstation which is currently equipped with a Fire Pro M4000. Once the new GPU has been installed, the PC screen no longer turns on but works only with external monitors connected via the docking station. The same happens once the drivers are updated! If I put the old card back on, the integrated monitor starts working again ... How can I fix it?
  • Create New...

Important Information

By using this site, you agree to our Terms of Use. We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.