Jump to content
EwinRacing Flash Series Gaming Chairs
zvasconcelos

eGPU attempting - Dell Xps l502X nVidia 540M; trying to use GTX 970as eGPU

Recommended Posts

Hi, I am trying to run a GTX 970 as eGPU in my Dell XPS L502 and I ampassing through an specific problem.

I'll sum up here what I did until now. For those who don't want to know this and go direct to the issue, my problem is with the PCI Compatcion, and yes, I'd already did the DSDT override.

Well, back to what I already done (any difficulty to understand my text, it's because of my lack of practice in these kind of topics in english).

I bought an EXP GDC Laptop External Independent Video Card Dock w/ PCI-E at DX.com; I am running the DYI eGPU 1.30, everything is installed correctly, etc.


Specs/setup: Gigabyte GTX970 Gaming

1 x EXP GDC PCI-E adapter
1 x Mini PCI-E cable (80cm Length)
1 x ATX PSU power cable (11cm Length)


Dell XPS L502x i7-2670 QM

16 Gb Ram 1333MHz

SSD 480Gb + 750Gb Sata

NVidia 540M 2Gb


Considerations: If I restart/start my laptop with the eGPU On, I'll get black screen. But it works if I turn on the eGPU when it gives the option to select between the DYU and OS to start.


At the DYI eGPU setup screen, I did these steps:

call iport dGPU off
call iport g1 1  
call vidwait 60 10de:11c6
call vidinit -d 10de:11c6
call chainload mbr


But when I am going to do the PCI compaction, it is not working, and I have tried a lot of different configurations. I searched what could I do, and I found the comment from andhie133128 in the page techinferno.com/index.php?/forums/topic/5874-guide-dsdt-override-to-fix-error-12/&page=3 talking about the DSDT override and then loading the DSDT.aml updated file at the DOS in the DYI's setup screen with the command "PT MEM writefromfile 1 0xBAFF2000 DSDT.aml". Why 0xBAFF2000? Its what I have found with the RW-Everything software as my DSDT memory.

 

dsdt.JPG


As told in that post, I'd compacted the .aml with a smaller size than the original (from 36kb to 35kb - it's something =p) and then loaded it at the DOS. Everything worked fine, the " large memory showed up, no error at DOS, everything went well.

 

largememory.JPG


The eGPU is recognized, I am able to stop my dGPU at the DYI setup screen, initialize the eGPU, the large memory is showing in my device manager, I am able to do the DSDT override (note: its easier to compact the file with an older version of the iasl), I'd imported and loaded it at DOS, but the PCI Compaction insists in not work.

 

What I didn't and that may be the problem. I had not installed yet the gtx 970 driver before the PCI Compation and don't know if this have something related to the PCI compaction problem. Why didn't I tried it yet? I am with a huge amount of work now and I am using my laptop everyday and need some GPU to work, then I am keeping my 540M driver and was thinking in uninstall it when the PCI Compation works; or when I get done with my extra work and don't need so much the laptop everyday.

 

One day, in the past (it's not my first time trying to do it), I went able to do the PCI compaction (only one time), and I think I did it when I used a different memory at the "PT MEM writefromfile" command. I think I confused something and used this memory instead: "ACPI -> RSDP -> 0x000F00E0;

 

wrong mem.JPG

 

But few days later I had to format windows OS and lost the configuration.
I had done the same steps that I told to be able to do that. But even with the PCI compaction done that time, I had formated the laptop before setting the eGPU to work 100%...

Why didn't I have tried it again? Same problem, I am using the laptop everyday and in doubt about what can happen if I use this other memory. I don't even know for what this RSDP is used for.

I found this topic from rossysaurus (https://www.techinferno.com/index.php?/forums/topic/6413-17-dell-xps-l702x-gtx9704gbpsc-mpcie2-pe4c-21-win7-rossysaurus/) and I will try the same steps. But in case someone already had the same issues that I'm having, please help me solve this.

 

Share this post


Link to post
Share on other sites

1. Your black bootup screen is due to the BIOS seeing the eGPU. To correct this, hide the eGPU from the bios using the eGPU adapter switches as discussed at https://www.techinferno.com/index.php?/forums/topic/8947-mpcieec-egpu-troubleshooting-steps/

 

2. Your PCI compaction with endpoint=56.25GB is fail probably because you have a non-English v:\config\devcon.txt file (run c:\eGPU\eGPU-setup-mount as admin to view) where the "PCI BUS" entry cannot be identified and skipped, but acts to exclude allocation. Pls remove the non-English PCI Bus section or PM me the file contents so I can identify what needs to be removed.

Share this post


Link to post
Share on other sites

There are some "names" in portuguese. Is just to remove then? Or will need to replace the text in portuguese for something else?

Another doubt: It will need to be done every time that I want to use the egpu?

 

The devcon.txt file is attached.

Thanks for the help.

 

devcon.rar

Share this post


Link to post
Share on other sites
2 hours ago, zvasconcelos said:

There are some "names" in portuguese. Is just to remove then? Or will need to replace the text in portuguese for something else?

Another doubt: It will need to be done every time that I want to use the egpu?

 

The devcon.txt file is attached.

Thanks for the help.

 

devcon.rar

 

Pls remove the following section, then save and re-try PCI compaction:

ACPI\PNP0A08\0
    Name: Complexo da Raiz de PCI Express
    Device is currently using the following resources:
        MEM : 000a0000-000bffff
        MEM : bfa00000-feafffff
        MEM : fed40000-fed44fff
        IO  : 0000-0cf7
        IO  : 0d00-ffff

Share this post


Link to post
Share on other sites

The call PCI worked like a charm!

 

The chainload worked, the laptop started, but then I had an error 43, and I did the steps from this link  that you sent

I had used ddu to uninstall my 540M nvidia driver, then I've downloaded the last GTX970 driver (372.70) and restarted the laptop.

At the start, I am executing the .bat (second option, I guess). The laptop starts with the gtx970 at normal speed, but I got error 43.

 

At the device manager: "Windows stopped this device because found an error (Cod.43).

 

dev.JPG

 

OBs: I am connecting the eGPU adapter at the WWAN port of my Dell, not in the place of the wifi card.

 

The compaction that I used was with endpoint=56.25GB. compacted dGpu to 36 bits  and forced no e to 32.

 

Soon i'll try other compactions.

 

Edited by zvasconcelos

Share this post


Link to post
Share on other sites

Noticed something when I get error 43. If I put in sleep mode and wake back my laptop, go to device manager and " scan for hadware", my dGPU comes back to life and with the (Microsoft Corporation - WDDM v1.2 recognizing it).

 

I tried some different PCI compactions, some got me back to error 12, others to error 43. Still stuck in error 43.

Now the PCI compaction works also without usind the " endpoint=56.25GB ", giving even more compaction options. (But I think I saw somewhere that if you have more than some amount of memory, 4GB or 8Gb, you will need the endpoint 56.25. Am I right?)

 

Someone has any advice? Considering I use a Dell XPS l502x, 16gb, 540M.

What PCI compaction may work better? Iport g1 or g2?

Tried a lot of difference combinations and no one appeared to do something different.

 

The error 43 maybe is happening because of having the mobile NVidia and desktop NVidia drivers loaded simultaneously. Where can I start to look to fix it?

 

I made the "save Dump file" thing, exported via the Rw everything, and then loaded the Dump file. Yet returned to error 43. (I have the images if necessary. I didn't attached them here to try not to make this post even bigger)

 

Note: Using windows 8.1

 

 

 

 

Edited by zvasconcelos

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Similar Content

    • By Tech Inferno Fan
      We've had a stack of recurring questions from with problems getting a mPCIe eGPU working. This includes GPU-Z not reporting no clock details, error 10/43 or even not being detected at all. Overall it's more troublesome getting mPCIe working than say expresscard or Thunderbolt.
       
      Here's some common problems and some troubleshooting steps to correct them.
       
      Getting a black bootup screen, resolving error 10/43 or ACPI_BIOS_ERROR win bootup messages
       
      Here the BIOS doesn't know what to do when it sees an eGPU. So the solution is to not let the BIOS see it. Do that by setting the delays on the eGPU adapter (CTD/PTD - EXP GDC or CLKRUN/PERST# on PE4L/PE4C). Boot with eGPU adapter in the wifi slot into Setup 1.30 or Windows. Is the eGPU detected?
       
      I'll add that should error 43 continue AND you have a NVidia dGPU as well as NVidia eGPU then it's likely because of having the mobile NVidia and desktop NVidia drivers loaded simultaneously. Proceed to uninstall ALL your NVidia drivers, use "DDU" to clean NVidia registry entries and do a 'clean' install of the latest NVidia desktop driver.
       
      mPCIe port that hosted the wifi card disappears when connecting an eGPU in it's place
       
      Use the Setup1.30 PCIe Ports->enable to enable the missing port.
       
      eGPU does not get detected
       
      Overcome mPCIe whitelisting by booting with the wifi card and then hotswapping in the eGPU. That way the BIOS will enable the mPCIe port to work.
       
      1. Boot with wifi card into Windows, sleep system, swap wifi card for mPCIe eGPU adapter and ensure eGPU is powered on, resume system. Do a device manager scan in Windows. Is the eGPU detected?
       
      2. Boot with wifi card into Setup 1.30 *carefully* hotplug the eGPU adapter in place of wifi card. Hit F5 to rescan the PCIe bus. Is the eGPU detected?
       
      If this enables detection then avoid this tedious hotswapping by seeking a unwhitelisted modified BIOS for your system OR test the Setup 1.30's PCI ports->undo_whitesting feature.
       
      eGPU still not detected - set the PSU to be permanently on
       
      The latest EXP GDC and BPlus eGPU adapters try to manage the PSU to only power on after they detect a signal. This can cause a race condition where the eGPU isn't ready to go when the CLKRUN signal is asserted.
       
      Avoid this by jumpering the PSU so it's permanently on rather than being managed. Depending on the PSU you are using refer to the following doco on how to do that:
       
      http://forum.techinferno.com/enclosures-adapters/8441-%5Bguide%5D-switching-atx-psu-using-paperclip-trick-swex.html
      http://forum.techinferno.com/enclosures-adapters/9426-220w-dell-da-2-ac-adapter-discussion.html
       
      eGPU still not detected - a non-standard mPCIe implementation by your vendor?
       
      PERST# mPCIe pin 22 may need to be isolated due to a non-standard implementation by your notebook vendor: http://forum.techinferno.com/enclosures-adapters/10812-pe4x-series-understanding-clkreq-perst-delay.html#post142689
       
      eGPU still not detected - faulty hardware?
       
      If you still don't get detection then test the video card and eGPU adapter in another machine to confirm neither is faulty.
       
      NVidia driver stops responding
       
      EXP GDC, PE4H 2.4 and PE4L 1.5 all use a socketted cable and therefore are not true Gen2 compatible device. This error indicates there was transmissions errors.
       
      The solution is either to get a better Gen2-compliant eGPU adapter such as PE4C V3.0 or PE4L 2.1b (both with soldered cable), or downgrade your link from Gen2 to Gen1 using BIOS options or Setup 1.30
       
      Other troubleshooting help resources?
       
      See DIY eGPU Troubleshooting FAQ.
       
    • By ReverseEffect
      3dMark11 Performance Preset Benchmark: http://www.3dmark.com/3dm11/11262792
       
      Required items:
      1.) Lenovo u310 (I have a Core i3 - Ivy Bridge, 8GB RAM)
      2.) 65CN99WW unwhitelisted.
      3.) eGPU (I used a EVGA GTX 750 Ti from another computer I had).
      4.) EXP GDC mPCIe Edition adapter (got from eBay - banggood seller).
      5.) ATX power supply (I used a 600W PSU from another computer I had).
      6.) USB wireless.
      7.) External monitor, keyboard, and mouse.
       
      Steps:
      1.) Obtain and install a unwhitelisted BIOS. If you are unable to obtain a unwhitelist BIOS, I think it might be possible to bypass it with Tech Inferno Fan's Setup 1.x (may need confirmation as I haven't used it myself yet.)
      2.) Shutdown computer and remove all USB devices, ethernet cables, power cables, card reader cards.
      3.) Remove mPCIe wireless card and detach antennas.
       
       
      4.) Attach EXP GDC external mPCIe cable to the former wireless slot and screw down.
       
       
      5.) Attach HDMI end of the mPCIe cable adapter to the EXP GDC device.
       
       
      6.) Attach graphics card to the EXP GDC device (I moved my laptop off the desk and onto the side shelf to make room on the desk for the monitor/keyboard/mouse).
       
       
      7.) Using the power cable adapters that came with the EXP GDC device, I hooked in my ATX power supply's 20 pin and CPU 4 pin cables. Then hooked the other end (8 pin) into the EXP GDC device. My EVGA 750 Ti also required that I use an additional PCIe power cable (6 pin) in the top of the card.
       
       
       
       
       
      8.) Then I attached my misc devices (HDMI monitor, USB keyboard/mouse/wireless adapter), and hooked in my PSU and powered it on (below is image of final product, also moved HDMI cable out of the way).
       

       
      9.) Power on your computer and let it install the standard VGA drivers and then install your drivers (I didn't have to go in the BIOS for any graphics settings, which it doesn't have anyways, nor did I have to disable iGPU in Device Manager before the card was added).
       
      Extra Info:
      I found that most games will play on med settings with about 45 FPS with this particular card.
      BDO: Upscale on - Anti Aliasing on - SSAO off - med settings.
      Skyrim: Med-High settings.
      Fallout 4: Med settings.
       
      (EDIT 5/19/2016) > Images added.
       
×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use. We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.