Jump to content

Bios reset or recovery possible?


Recommended Posts


I need your help. I deactivated the internal grafic card with the unlocked Bios A05 because I only wanted to use the nVida (got a new monitor and want to connect it there).

Now whenever I start the Laptop it just makes biep noises and nothing happens.

Hard reset did not work. I found a way to recover the bios: All Powerful M14X Bios Recovery M14x

(Its in german but thats no problem for me). When I follow the instructions, the notebook restarts a few times but nothing happens at the end.

I am using the HP format tool for my usb stick (1gb). I tried fat and fat32.

But I don't know what files I have to use to create the bootable stick. I found an archiv with all kinds of boot discs and also usb, it seems to format it correctly, but when trying to recover the bios, the notebook does not load from usb. So I believe I made some kind of mistake.

Can anybody help me getting my alien back to life?

Link to comment
Share on other sites

  • Founder

Sounds like a bad bios flash, hopefully the EC was not corrupted. @svl7 may know how to get you out of this mess but after looking around, I found an M17x/M18x recovery method. I don't have an M14x to test with but you may give the following a try:

Create blind USB:

1. Download M14x bios here: Drivers and Downloads | Dell [united States]

2. Extract the exe file to any directory, locate the file PALB0MEC.fd

3. Place PALB0MEC.fd on a fat 32 formatted USB disk.


1. Unplug your computer, remove the battery.

2. Place USB stick with PALB0MEC.fd file in a USB 2.0 port (M17x/M18x use e-sata so I'm not sure if this is crucial).

3. Press and HOLD the END key and at the same time plug in your power cord.

4. At this point the computer should power itself on as well as the fans. Release the END key.

After several beeps the computer should successfully flash from the USB stick and then reboot. If this doesn't happen, then there may or may not be another solution for you.

Good luck.

Bios flash credits: bar-code & LVNeptune over at NBR.

  • Thumbs Up 2
Link to comment
Share on other sites

Thanks, you saved me :)

The difference between your solution and the german one was the formatting and not using a bootable stick!

I will report this to the german forum, maybe this helps them also.

I did not use the PALB0MEC.fd from your post but the one from the german forum, since this was created for the m14x.

Anyway thank you again :)

Link to comment
Share on other sites

[MENTION=5]Brian K.[/MENTION] : That's exactly the way to recover the latest Insyde BIOS. But it's necessary to rename the mentioned file properly in order to make it work, in this case it would be "PALB0x64.fd". The name of the recovery file may vary, but as far as I know it's the same for the M14x, M17x r3 and M18x BIOS.

  • Thumbs Up 1
Link to comment
Share on other sites

  • 1 year later...


Perhaps you can help me.

I had an Alienware M17x R2 which worked for years until one day the screen didn't work anymore (for no apparent reason).

I did all I could to diagnostic including resetting the screen cable, to no avail.

The computer still did work, with either an external monitor or remotely.

Desperate for a solution I tried to reflash the bios but the reflashing program from dell crashed after a few minutes.

I let the program run for about 30mins but the computer did lots of fan noise and nothing seemed to happen so I ended up unplugging from DC and removing the battery.

Now the program doesn't do anything and I can access the bios.

So I tried the above mentioned solution from Brian.

Problem is, when I press End and p^lug the powerchord nothing happens.

Only when I press the start button do I see my usb stick light flicker (e.g. apparently reading) but nothing elses happens and no beep.

Any idea what I can do or is the notebook dead for good?

Link to comment
Share on other sites

  • 1 year later...
  • 4 months later...
  • 3 years later...

I have been trying to do this for sometime and I have let the computer sit for 15mins after holding END and plugging it in.  I can see it access the usb drive for the first 30secs or so but nothing seems to happen after that.  No beeps, nothing.  I have tried A05 and A08 from Dell's website and both never seem to complete the task.  Any suggestions.  Thank you in advance!!

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...

Important Information

By using this site, you agree to our Terms of Use. We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.