Jump to content
michaelgqld

Alienware 17 R1 (Late 2013) GTX980m Power Limiting

Recommended Posts

Hi everyone. I have had a bit of search around but I have not found anything yet pertaining to my issue. I have an Alienware 17 R1 (Late 2013 model). It originally came with an i7 4900, a GTX780m, 120hz 3D panel with intel graphics disabled. I have just got a Dell GTX980m 8GB (BIOS 84.04.2F.00.79 - Device ID 10DE 13D7-1028 05AE) and put it in and it works fine getting into windows and running 2D. However, when I run any decent 3D the graphics constantly hits power limiter and downclocks to around 800mhz. This is confirmed to be power limit in gpuz perfcap reason and this happens regardless of temperature. Running a Unigine benchmark has actually showed the card's performance to be just lower than the 780m I replaced. Using HWiNFO64 I have found that the GPU is being limited to 80 watts. It briefly goes up to over 100 watts but drops to 80.

Power Supply is 240 watt

This laptop always runs off mains power and the battery only lasts a few seconds regardless of apparent charge.

I should also mention that I have tried,
Setting nvidia control panel power management mode to prefer maximum performance.
Disabling Battery Boost in nvidia geforce experience
Setting windows power options to high performance
I have even installed a fresh windows 10 on a different hard drive and have observed the same result.

Has anyone else done this upgrade and had no issues, are there any known fixes, is this card faulty or just not going to work correctly.

Thanks

Share this post


Link to post
Share on other sites
15 hours ago, michaelgqld said:

Hi everyone. I have had a bit of search around but I have not found anything yet pertaining to my issue. I have an Alienware 17 R1 (Late 2013 model). It originally came with an i7 4900, a GTX780m, 120hz 3D panel with intel graphics disabled. I have just got a Dell GTX980m 8GB (BIOS 84.04.2F.00.79 - Device ID 10DE 13D7-1028 05AE) and put it in and it works fine getting into windows and running 2D. However, when I run any decent 3D the graphics constantly hits power limiter and downclocks to around 800mhz. This is confirmed to be power limit in gpuz perfcap reason and this happens regardless of temperature. Running a Unigine benchmark has actually showed the card's performance to be just lower than the 780m I replaced. Using HWiNFO64 I have found that the GPU is being limited to 80 watts. It briefly goes up to over 100 watts but drops to 80.

Power Supply is 240 watt

This laptop always runs off mains power and the battery only lasts a few seconds regardless of apparent charge.

I should also mention that I have tried,
Setting nvidia control panel power management mode to prefer maximum performance.
Disabling Battery Boost in nvidia geforce experience
Setting windows power options to high performance
I have even installed a fresh windows 10 on a different hard drive and have observed the same result.

Has anyone else done this upgrade and had no issues, are there any known fixes, is this card faulty or just not going to work correctly.

Thanks

Hi!

To solve your issue try flash this vbios.

 

Edited by Klem

Share this post


Link to post
Share on other sites

Thanks for the quick reply. I am unable to download from this site at this point due to not enough posts but I also got the message:

Sorry, there is a problem

This attachment is not available. It may have been removed or the person who shared it may not have permission to share it to this location.

Is that the same bios from techpowerup? https://www.techpowerup.com/vgabios/167297/clevo-gtx980m-8192-141030

Share this post


Link to post
Share on other sites

Still the same issue, limiting at 80watts. Though it scores a bit better in firestrike, probably due to the undervolting allowing it clock higher before hitting limit.  I've even tried underclocking to lower the power draw but still as soon as it hits 80watts, it power throttles.

Share this post


Link to post
Share on other sites

Any other thoughts? Could the laptop maybe be limiting the card and it may need a modded bios? Are there any modded vbios that remove power limiting or maybe have a power slider?  Is there anyone that may be able to look at the standard bios I have? I am quite disappointed and honestly feel ripped off as I spent a fair bit to buy the card but I have basically gained little to no performance. The card performs nothing like reviewed benchmarks and as it seems the card physically works I doubt I can return it.

Share this post


Link to post
Share on other sites
4 hours ago, michaelgqld said:

Any other thoughts? Could the laptop maybe be limiting the card and it may need a modded bios? Are there any modded vbios that remove power limiting or maybe have a power slider?  Is there anyone that may be able to look at the standard bios I have? I am quite disappointed and honestly feel ripped off as I spent a fair bit to buy the card but I have basically gained little to no performance. The card performs nothing like reviewed benchmarks and as it seems the card physically works I doubt I can return it.

You can try flash this vbios:  https://www.techpowerup.com/vgabios/200721/200721

Share this post


Link to post
Share on other sites

OK. That one stops the power limiting and it holds full clocks. But now it crashes with a black screen, audio still plays but I cannot do anything and have to hold power button. Could this be VRM overheating?

Share this post


Link to post
Share on other sites

I have ordered new thermal pads and paste will see how it goes. I'm currently using the undervolted bios because it performs the best with the 80 watt limiting. and is running in the mid to high 60s Celcius with Unigine Heaven 4 Ultra.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Similar Content

    • By jhsd1124013561
      Help! I created a BOS BOOT DISK and use legacy to boot in DOS.   But it is saying that "An operating system wasn't found".   I have extracted all the files (the alienware m18x r2 a11 unlocked bios) into my external hard drive (format: NTFS)
    • By MessiWessi
      Hi,
       
      I bought a alienware m17x r4 a few weeks ago. The problem is: I have noise (distorsion) on the right speaker. Had anybody in past the same problem and is it a known problem regarding this model? I feared at the beginning that the soundblaster is defect but I tested it with headphones and everything is fine. I already ordered a new speaker pair and will install it within the next weeks.
       
      But if you tell me that this problem is known and not resolvable I can save my effort.
    • By MessiWessi
      Hi,
       
      I read a lot of different threads about the maximum possible M17X R2 configuration. But after I was more and more irritated.
       
      What is at the end the best performant GPU solution (with unlocked bios and dirver mod) but WITHOUT manual fan control and such things. Because if I want to sell one day my M17X R2 I don't want to explain and force the buyer to control the GPU fan per hand.  
    • By Psycha
      Hello, I'm on an alienware m17 r4 and am trying mod my vbios for a 970m 3GB msi. I've managed to get the max boost with an increase in voltage, however I believe my voltage settings maybe unstable. When attempting to load programs capable of high gpu usage capabilities, the gpu begins to become pretty unstable. would anyone be able to provide assistance? I have both my edited and original roms as well.
       
      *update
       
      I'm not sure how to delete this thread but disregard this please. I've figured out the issue.
    • By screemex
      Hello, I am looking for a working vbios to 8970m. My problem is that the clocks freez at 450Mhz and the memory at 300Mhz. i heave vbios from http://forum.notebookreview.com/threads/m17x-r2-8970m-crossfire-upgrade.814434/ this guide and heave latest drivers 18.5.1, another driver not help, re-instal windows also not working

×

Important Information

By using this site, you agree to our Terms of Use. We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.